LINUX.ORG.RU

Помогите очень большая проблема!

 ,


0

1

Собираюб систему как конструктор и пытаюсь установить build-essential. У меня debian. Иду по зависимостям и тут у меня ошибка!

root@kali:~/Загрузки# dpkg -i gcc-4.7-base_4.7.2-5_amd64.deb
(Чтение базы данных … на данный момент установлено 113722 файла и каталога.)
Подготовка к распаковке gcc-4.7-base_4.7.2-5_amd64.deb …
Распаковывается gcc-4.7-base:amd64 (4.7.2-5) на замену (4.7.2-5) …
dpkg: зависимости пакетов не позволяют настроить пакет gcc-4.7-base:amd64:
 gcc-5-base:amd64 (5.3.1-5) ломает gcc-4.7-base (<< 4.7.3) и установлен.
  Версия gcc-4.7-base:amd64, которая будет настроена: 4.7.2-5.
 gcc-4.9-base:amd64 (4.9.3-10) ломает gcc-4.7-base (<< 4.7.3) и установлен.
  Версия gcc-4.7-base:amd64, которая будет настроена: 4.7.2-5.
 gcc-4.8-base:amd64 (4.8.5-3) ломает gcc-4.7-base (<< 4.7.3) и установлен.
  Версия gcc-4.7-base:amd64, которая будет настроена: 4.7.2-5.

dpkg: ошибка при обработке пакета gcc-4.7-base:amd64 (--install):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 gcc-4.7-base:amd64

Что делать!Мне кажется это тупик

А sudo apt-get install -f не пробовал?

ozzee ()
Ответ на: комментарий от ozzee

следующий баг

root@kali:~# apt-get install -f Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Исправление зависимостей… Готово Пакеты, которые будут УДАЛЕНЫ: build-essential g++ gcc gcc-4.7 gcc-4.7-base обновлено 0, установлено 0 новых пакетов, для удаления отмечено 5 пакетов, и 0 пакетов не обновлено. не установлено до конца или удалено 6 пакетов. После данной операции, объём занятого дискового пространства уменьшится на 18,6 MB. Хотите продолжить? [Д/н] y (Чтение базы данных … на данный момент установлено 113722 файла и каталога.) Удаляется build-essential (11.5) … Удаляется g++ (4:4.7.2-1) … Удаляется gcc (4:4.7.2-1) … Удаляется gcc-4.7 (4.7.2-5) … Удаляется gcc-4.7-base:amd64 (4.7.2-5) … Настраивается пакет man-db (2.7.5-1) … Updating database of manual pages ... root@kali:~/Загрузки# dpkg -i gcc-4.7-base_4.7.2-5_amd64.deb Выбор ранее не выбранного пакета gcc-4.7-base:amd64. (Чтение базы данных … на данный момент установлено 113588 файлов и каталогов.) Подготовка к распаковке gcc-4.7-base_4.7.2-5_amd64.deb … Распаковывается gcc-4.7-base:amd64 (4.7.2-5) … dpkg: зависимости пакетов не позволяют настроить пакет gcc-4.7-base:amd64: gcc-5-base:amd64 (5.3.1-5) ломает gcc-4.7-base (<< 4.7.3) и установлен. Версия gcc-4.7-base:amd64, которая будет настроена: 4.7.2-5. gcc-4.9-base:amd64 (4.9.3-10) ломает gcc-4.7-base (<< 4.7.3) и установлен. Версия gcc-4.7-base:amd64, которая будет настроена: 4.7.2-5. gcc-4.8-base:amd64 (4.8.5-3) ломает gcc-4.7-base (<< 4.7.3) и установлен. Версия gcc-4.7-base:amd64, которая будет настроена: 4.7.2-5.

dpkg: ошибка при обработке пакета gcc-4.7-base:amd64 (--install): проблемы зависимостей — оставляем не настроенным При обработке следующих пакетов произошли ошибки: gcc-4.7-base:amd64 root@kali:~/Загрузки# dpkg -i gcc-4.7_4.7.2-5_amd64.deb Выбор ранее не выбранного пакета gcc-4.7. (Чтение базы данных … на данный момент установлено 113595 файлов и каталогов.) Подготовка к распаковке gcc-4.7_4.7.2-5_amd64.deb … Распаковывается gcc-4.7 (4.7.2-5) … dpkg: зависимости пакетов не позволяют настроить пакет gcc-4.7: gcc-4.7 зависит от gcc-4.7-base (= 4.7.2-5), однако: Пакет gcc-4.7-base:amd64 пока не настроен. gcc-4.7 зависит от cpp-4.7 (= 4.7.2-5), однако: Пакет cpp-4.7 не установлен. gcc-4.7 зависит от libitm1 (>= 4.7.2-5), однако: Пакет libitm1 не установлен. gcc-4.7 зависит от libmpc2, однако: Пакет libmpc2 не установлен.

dpkg: ошибка при обработке пакета gcc-4.7 (--install): проблемы зависимостей — оставляем не настроенным Обрабатываются триггеры для man-db (2.7.5-1) … При обработке следующих пакетов произошли ошибки: gcc-4.7

mr-proper ()
Ответ на: комментарий от ozzee

Врядли поможет, потому что у него пакеты из тестинга перемешались с олдстаблом.

ionanahin ★★★ ()

У тебя щас кали, в котором перемешаны пакеты разных веток.
Попал ты. Короче, хватит играться с говносборками. Ставь Debian Stable, пакеты устанавливай через apt.

goodbyeXP ()
Ответ на: комментарий от ionanahin

Ооо, ну тут тогда либо переустановка, либо регенерация репозиториев и dist-upgrade.

ozzee ()

Для форматирования кода надо использовать [code], а не [cut]!

beastie ★★★★★ ()
Ответ на: комментарий от ionanahin

root@kali:~/Загрузки# cat /etc/apt/sources.list #

# deb cdrom:[Debian GNU/Linux 2016.1 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160120-18:40]/ kali-rolling contrib main non-free

#deb cdrom:[Debian GNU/Linux 2016.1 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160120-18:40]/ kali-rolling contrib main non-free

mr-proper ()
Ответ на: комментарий от goodbyeXP

Ломает зависимости пакетов а потом битые пакеты ломают всю систему. Хотя в sources.list несколько штук добавлял и потом apt-get update

mr-proper ()
Ответ на: комментарий от ozzee

ОШИБКИ

apt-get install build-essential
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»:
Пакеты, имеющие неудовлетворённые зависимости:
 build-essential : Зависит: libc6-dev но он не будет установлен или
                                   libc-dev
                   Зависит: gcc (>= 4:4.4.3) но он не будет установлен
                   Зависит: g++ (>= 4:4.4.3) но он не будет установлен
 gcc-4.7 : Зависит: cpp-4.7 (= 4.7.2-5) но он не будет установлен
           Зависит: libitm1 (>= 4.7.2-5) но он не будет установлен
           Зависит: libmpc2 но он не будет установлен
           Рекомендует: libc6-dev (>= 2.13-5) но он не будет установлен
 gcc-4.8-base : Ломает: gcc-4.7-base (< 4.7.3) но 4.7.2-5 будет установлен
 gcc-4.9-base : Ломает: gcc-4.7-base (< 4.7.3) но 4.7.2-5 будет установлен
 gcc-5-base : Ломает: gcc-4.7-base (< 4.7.3) но 4.7.2-5 будет установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение).

mr-proper ()
Ответ на: следующий баг от mr-proper

Re: следующий баг

следующий баг

Руки из жопы - это не баг. Ну если только в ДНК

anonymous ()
root@kali:~/Загрузки# apt-get install -f
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
The following additional packages will be installed:
  libmpc2
Пакеты, которые будут УДАЛЕНЫ:
  gcc-4.7 gcc-4.7-base
НОВЫЕ пакеты, которые будут установлены:
  libmpc2
обновлено 0, установлено 1 новых пакетов, для удаления отмечено 2 пакетов, и 1 пакетов не обновлено.
не установлено до конца или удалено 2 пакетов.
Необходимо скачать 40,1 kБ архивов.
После данной операции, объём занятого дискового пространства уменьшится на 18,3 MB.
Хотите продолжить? [Д/н] y
Get:1 http://ftp.ru.debian.org/debian wheezy/main amd64 libmpc2 amd64 0.9-4 [40,1 kB]
Получено 40,1 kБ за 1с (25,3 kБ/c)
(Чтение базы данных … на данный момент установлено 113698 файлов и каталогов.)
Удаляется gcc-4.7 (4.7.2-5) …
Удаляется gcc-4.7-base:amd64 (4.7.2-5) …
Обрабатываются триггеры для man-db (2.7.5-1) …
Выбор ранее не выбранного пакета libmpc2:amd64.
(Чтение базы данных … на данный момент установлено 113588 файлов и каталогов.)
Подготовка к распаковке …/libmpc2_0.9-4_amd64.deb …
Распаковывается libmpc2:amd64 (0.9-4) …
Настраивается пакет libmpc2:amd64 (0.9-4) …
Обрабатываются триггеры для libc-bin (2.21-6) …
root@kali:~/Загрузки# apt-get install build-essential
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 build-essential : Зависит: libc6-dev но он не будет установлен или
                                   libc-dev
                   Зависит: gcc (>= 4:4.4.3) но он не будет установлен
                   Зависит: g++ (>= 4:4.4.3) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

mr-proper ()

Зачем ты вообще вручную пакет ставил командой dpkg?

rumgot ★★★★ ()

dpkg -i gcc-4.7-base_4.7.2-5_amd64.deb

пытаюсь установить build-essential.

он не так ставится, а через апт-гет

darkenshvein ★★★★★ ()

Айда на Slackware, тамошний пакетный менеджер не будет вас ограничивать в реализации нескромных желаний.

bormant ★★★★★ ()

Не пойму, для чего вообще все ставят этот Kali? Все ж пакеты есть в репах дебиана, но нет же, кулхацкеры они такие.

conformist ★★★ ()

У меня debian

Да ладно!?

Что делать!Мне кажется это тупик

Поставить debian, как уже советовали.

grem ★★★★★ ()
Ответ на: комментарий от conformist

вроде как там еще патчи сетевой подсистемы какие-то особые.

Nicholass ★★★ ()

Помогите очень большая проблема!

Где проблема? Я думал у тебя сервер лег. А тут на домашней машине пакетики сломались. В бан тебя за такое название темы.

root@kali
У меня debian.
Что делать!Мне кажется это тупик

Тебе не кажется, ты действительно тупой.

LinuxDebian ★★★ ()
Последнее исправление: LinuxDebian (всего исправлений: 1)
Ответ на: комментарий от LinuxDebian

Тебе не кажется, ты действительно тупой.

Святая вежливость ЛОР-овца.

RedEyedMan4 ★★★★★ ()
Ответ на: комментарий от RedEyedMan4

Вежливость лоровца это морозить полную чушь, и после того, как тебе на это вежливо укажут, обкладывать оппонента и его семью формально не содержащими мата ругательствами, что крышуется местными аутистами модераторами.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.