LINUX.ORG.RU

Epson L210 и debian

 , ,


0

1

есть не удовлетворённые зависимости > lsb при установке deb пакета

sudo dpkg -i epson-inkjet-printer-201207w_1.0.0-1lsb3.2_amd64.deb
Выбор ранее не выбранного пакета epson-inkjet-printer-201207w.
(Чтение базы данных … на данный момент установлено 334567 файлов и каталогов.)
Подготовка к распаковке epson-inkjet-printer-201207w_1.0.0-1lsb3.2_amd64.deb …
Распаковывается epson-inkjet-printer-201207w (1.0.0-1lsb3.2) …
dpkg: зависимости пакетов не позволяют настроить пакет epson-inkjet-printer-201207w:
 epson-inkjet-printer-201207w зависит от lsb (>= 3.2), однако:
  Пакет lsb не установлен.

dpkg: ошибка при обработке пакета epson-inkjet-printer-201207w (--install):
 проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для libc-bin (2.29-10) …
При обработке следующих пакетов произошли ошибки:
 epson-inkjet-printer-201207w

кто что посоветует? lsb-base и lsb-release есть в системе. Я начинающий не судите строго.

Ответ на: комментарий от buratino
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
 aptitude : Зависит: aptitude-common (= 0.8.12-1) но он не будет установлен
            Зависит: libcwidget4 (>= 0.5.18-1) но он не будет установлен
            Зависит: libxapian30 (>= 1.4.12~) но он не будет установлен
            Рекомендует: libparse-debianchangelog-perl но он не будет установлен
 epson-inkjet-printer-201207w : Зависит: lsb (>= 3.2) но он не может быть установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).

нет aptitude

kolobok1978 ()
Ответ на: комментарий от kolobok1978

щас поставлю 10-й дебиан, посмотрю что за зверь. а без него не работает, что ли? а то на мой кэнон тоже есть какие-то драйвера официальные, но они беспонтовые какие-то, нужных настроек нет. безо всяких драйверов оно работает лучше :)

buratino ★★★★★ ()
Ответ на: комментарий от kolobok1978

нет, этот пакет не поставится нормально, 2012-го то года. в debian нет пакета lsb, есть lsb-base и другие, а просто lsb - нет

buratino ★★★★★ ()
Ответ на: комментарий от buratino

на арче проблем не было там rpm пакет собирается, с другими зависимостями. буду так пользоваться пока.

kolobok1978 ()
Ответ на: комментарий от kolobok1978

А чем отличается lsb пакет убунты, от дебиановского кроме названия? Если не работает, то как правило, не хватает библиотек или они не тех версий.

einhander ★★★★★ ()
Ответ на: комментарий от einhander

Вообще Debian удалило поддержку LSВ. Там остались пакеты для поддержки штанов.

lsb-base Linux Standard Base init script functionality
lsb-release  Linux Standard Base version reporting utility
kolobok1978 ()
11 апреля 2021 г.
Ответ на: комментарий от kolobok1978

еще один способ

на EPSON L210 есть драйвера Gutenprint - http://gimp-print.sourceforge.net/p_Supported_Printers.php

можно скачать у них, либо с официального репозитория (одинаковый как для дебиана так и для кали ;) )

$ sudo apt-get install printer-driver-gutenprint

мне помогли их драйвера для EPSON L310

haaron ()
Ответ на: комментарий от kolobok1978

Можно было даже установить пакет-пустышку вместо него, эффект был бы тот же

ZenitharChampion ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.