LINUX.ORG.RU

Подключить Epson L132 в Debian 12

 ,


0

1

Здравствуйте!

Нужно настроить Epson L132 в Debian 12. Скачал драйвер epson-inkjet-printer-201401w_1.0.0-1lsb3.2_amd64.deb. Но при попытке установить вылетает ошибка:

Следующие пакеты имеют неудовлетворённые зависимости:
 epson-inkjet-printer-201401w : Зависит: lsb (>= 3.2) но он не может быть установлен

Выяснил, что LSB отключен в Debian c 2015 года. Что можно сделать в таком случае?

На лор это уже обсуждали:

это не принтер ненормальный, а просто очередной сгусток безблагодатного топлива для биореактора.

Можешь попытаться:

  1. Распаковать пакет, убрать эту зависимость, запаковать обратно.

  2. Поискать другой драйвер из поставляемых вместе с дистрибутивом. Говорят что есть драйвер epson-201401w для этого принтера.

einhander ★★★★★
()
Ответ на: комментарий от einhander

даже если он перепакует дебку, вряд ли пакет 2014 года встанет ровно и заработает
попробовать, конечно же можно/нужно, но…

knigolaz , вот тебе рецепт, написал кто-то из лоровцев
https://dogberrt.livejournal.com/13273.html

d00fy ★★
()
Ответ на: комментарий от knigolaz

epson-201401w искал, пробовал? https://github.com/FishTest/epson-inkjet-printer-201401w

Там по идее то же, что и в дебе, но обвязка должна компилироваться на более свежих линуксах.

einhander ★★★★★
()
Последнее исправление: einhander (всего исправлений: 2)
Ответ на: комментарий от d00fy

Ну у ТСа оно не работает даже так. Говорят что в gutenprint http://gimp-print.sourceforge.net/p_Supported_Printers.php есть поддержка L серии, но не принтера ТСа. А вообще на лоре обсуждали проблемы с эпсонами и проприетарным драйвером, у кого-то получилось Epson L210 и debian (комментарий).

einhander ★★★★★
()
Последнее исправление: einhander (всего исправлений: 2)

Получилось!

Помогла очень эта статья: https://dmr.md/2019/05/12/установка-и-настройка-принт-сервера-cups/

Если кратко, то:

1. Устанавливает CUPS, если он еще не был установлен

sudo apt install cups 
2. Устанавливаем Foomatic. Foomatic – это такая база драйверов для принтеров, существенно расширяющая стандартную базу драйверов CUPS. Без foomatic шансы на то, что вы найдёте нужный драйвер ничтожны.
sudo apt-get install foomatic-db
3. Добавляем новый принтер через http://localhost:631/ -> Администрирование -> Новый принтер и выбираем драйвер.

Конкретно L132 там не было, но был L130 я использовал его и с ним принтер заработал!

knigolaz
() автор топика

У меня есть принтер которому нужный драйвер есть в пакете epson-inkjet-printer-201401w. Для него поправил зависимости в deb-пакете, убрал lsb и добавил lsb-base, заглушку которая устанавливается в Debian по-умолчанию. Теперь пакет с драйвером устанавливается в системе без вопросов и работает без проблем. Принтер Epson L456.

foxy_ant ★★
()