LINUX.ORG.RU

Помогите подключить принтер epson L132

 , ,


0

1

Имеется принтер epson L132. Не знаю как его подключить, в http://localhost:631/ просто нет такой модели. Здесь написано http://www.openprinting.org/printer/Epson/Epson-L132_Series что он отлично поддерживается в CUPS и идёт ссылка на драйвер (http://www.openprinting.org/driver/epson-201401w) но ссылка не рабочая (We're sorry, but the driver ID you provided was not found in our database.).

Ответ на: комментарий от iluha16

В Gentoo есть пакет app-arch/deb2targz с утилитой для конвертации deb в архивы.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Разархивировал. Внутри папки cups, doc, lib, ppds, resource, watermark. А куда их копировать? lib я так понимаю в /usr/lib64/ а вот остальные?

iluha16 ()
Ответ на: комментарий от iluha16

Подумай, посмотри куда в Gentoo нужно всё это разместить, поставь какой-нибудь драйвер для принтера из portage средствами emerge, затем посмотри какие файлы и куда установились, с этим драйвером поступи соответственно. Посмотреть можно либо посредство в /var/db/pkg/<категория>/<атом>/CONTENTS, например /var/db/pkg/app-arch/deb2targz-1-r2/CONTENTS, либо посредством утилиты qlist из пакета app-portage/portage-utils, например qlist deb2targz.

Ну и посмотри зависимости в deb пакете, может ещё что нужно поставить, он должен открываться как архив и так, например в mc.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Скопировал но при попытке распечатать test page в localhost:631 выдаётся ошибка 'filter failed'. Я попытался запусть этот филтер самостоятельно и это странно:

$ ls -lh
total 36K
-rwxr-xr-x 1 root root 33K May  5 09:50 epson_inkjet_printer_filter
$ ./epson_inkjet_printer_filter 
bash: ./epson_inkjet_printer_filter: No such file or directory
$ 

Как это может быть если имя файла точь в точь нажал таб для автодополнения файл всего один в папке.

iluha16 ()
Ответ на: комментарий от iluha16

И ещё:

$ lddtree epson_inkjet_printer_filter 
epson_inkjet_printer_filter => ./epson_inkjet_printer_filter (interpreter => /lib/ld-lsb.so.3)
    libdl.so.2 => /lib32/libdl.so.2
        ld-linux.so.2 => /lib64/ld-linux.so.2
    libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/32/libstdc++.so.6
        libgcc_s.so.1 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/32/libgcc_s.so.1
    libcupsimage.so.2 => /usr/lib32/libcupsimage.so.2
    libcups.so.2 => /usr/lib32/libcups.so.2
        libgnutls.so.28 => /usr/lib32/libgnutls.so.28
            libtasn1.so.6 => /usr/lib32/libtasn1.so.6
            libnettle.so.6 => /usr/lib32/libnettle.so.6
            libhogweed.so.4 => /usr/lib32/libhogweed.so.4
            libgmp.so.10 => /usr/lib32/libgmp.so.10
        libz.so.1 => /lib32/libz.so.1
    libjpeg.so.62 => /usr/lib32/libjpeg.so.62
    libpthread.so.0 => /lib32/libpthread.so.0
    libm.so.6 => /lib32/libm.so.6
    libc.so.6 => /lib32/libc.so.6
$ ldd epson_inkjet_printer_filter 
/usr/bin/ldd: line 117: ./epson_inkjet_printer_filter: No such file or directory
$

lddtree работает с файлом а ldd отказывается. Что тут происходит?

iluha16 ()
Ответ на: комментарий от kostik87

Я установил sys-apps/lsb-release 1.4 но ничего не изменилось.

iluha16 ()
Ответ на: комментарий от iluha16

И что там предлагается изменить ссылки в /lib/. А не рухнет ли у мня вся система из за этого?

iluha16 ()
Ответ на: комментарий от iluha16

Что тут происходит?

А происходит тут дикая смесь lib32 и lib64, которую линкер отказывается считать исполняемым файлом!

sigurd ★★★★ ()
Ответ на: комментарий от iluha16

Там есть архив с исходниками, скачай его и собери.

kostik87 ★★★★★ ()
Ответ на: комментарий от iluha16

Искать драйвер под свою архитектуру - x86_64 или собирать самому. А просто драйвер Epson Stylus photo пробовал указать?

sigurd ★★★★ ()
Ответ на: комментарий от sigurd

Который из них там разные с цифрами. Под amd64 скачал и тоже самое. Где хоть логи какие то посмотреть можно?

iluha16 ()
Ответ на: комментарий от sigurd
# rpm -i epson-inkjet-printer-201401w-1.0.0-1lsb3.2.x86_64.rpm 
warning: epson-inkjet-printer-201401w-1.0.0-1lsb3.2.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 8aa65d56: NOKEY
error: Failed dependencies:
        lsb >= 3.2 is needed by epson-inkjet-printer-201401w-1.0.0-1lsb3.2.x86_64
        /bin/sh is needed by epson-inkjet-printer-201401w-1.0.0-1lsb3.2.x86_64
#

Откуда мне взять lsb 3.2. В /usr/portage/sys-apps/lsb-release/ только версия 1.4. А /bin/sh у меня в системме есть.

iluha16 ()
Ответ на: комментарий от iluha16

Ты это в Gentoo вызываешь? Зачем?

Конвертни в архив tar.gz и распакуй, если в твоей Gentoo менеджер архивов не умеет напрямую распаковывать rpm. В моей умеет.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Так я распаковывал уже все которые там есть и копировал, но всё одно - filter failed.

iluha16 ()
Ответ на: комментарий от iluha16
ln -sf /lib64/ld-linux-x86-64.so.2 /lib64/ld-lsb-x86-64.so.3

Проверил, у меня Gentoo, после этого стал запускаться фильтр.

$ ./epson_inkjet_printer_filter 
Insufficient options.
$ ldd ./epson_inkjet_printer_filter 
	linux-vdso.so.1 (0x00007fff3c3ff000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00007f6b545db000)
	libstdc++.so.6 => /usr/lib/gcc/x86_64-pc-linux-gnu/4.8.3/libstdc++.so.6 (0x00007f6b542d2000)
	libcupsimage.so.2 => /usr/lib64/libcupsimage.so.2 (0x00007f6b540ca000)
	libcups.so.2 => /usr/lib64/libcups.so.2 (0x00007f6b53e50000)
	libjpeg.so.62 => /usr/lib64/libjpeg.so.62 (0x00007f6b53bfb000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f6b539de000)
	libm.so.6 => /lib64/libm.so.6 (0x00007f6b536e1000)
	libc.so.6 => /lib64/libc.so.6 (0x00007f6b53336000)
	/lib64/ld-lsb-x86-64.so.3 (0x00007f6b547df000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f6b5311f000)
	libgnutls.so.28 => /usr/lib64/libgnutls.so.28 (0x00007f6b52e04000)
	libz.so.1 => /lib64/libz.so.1 (0x00007f6b52bee000)
	libtasn1.so.6 => /usr/lib64/libtasn1.so.6 (0x00007f6b529db000)
	libnettle.so.4 => /usr/lib64/libnettle.so.4 (0x00007f6b527a9000)
	libhogweed.so.2 => /usr/lib64/libhogweed.so.2 (0x00007f6b52579000)
	libgmp.so.10 => /usr/lib64/libgmp.so.10 (0x00007f6b52301000)

https://forums.gentoo.org/viewtopic-t-966562-start-0.html

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 3)
Ответ на: комментарий от iluha16

Гугли дальше, у меня нет твоего принтера, смотри логи cups.

Может не хватает прав доступа до устройства принтера, попробуй поставить 666.

Удачи.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от kostik87

Unable to send data to printer.

Это строка из лога cups или ты запустил epson_inkjet_printer_filter в консоли и он выдал это сообщение?

В любом случае нужно через web интерфейс cups назначать принтеру установленный драйвер и пробовать печатать и уже тогда, если печать не идёт, то смотреть логи cups.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Ну и мучение этот CUPS. Установив Windows XP в VirtualBox и открыв доступ к USB порту напечатал всё за 5 минут.

iluha16 ()
Ответ на: комментарий от iluha16

Это не cups мучение, а принтер надо нормальный покупать, т.е. HP, ну естественно из списка поддерживаемых драйвером HPLIP.

kostik87 ★★★★★ ()
Ответ на: комментарий от iluha16

Ну ставь Ubuntu, ставь Deb пакет с драйвером собранным под Ubuntu. Ну либо тоже самое под Redhat.

Ну и проверять поддержку нужно на сайте производителя. Не спорю, что эти ссылки тоже на сайт производителя, но нашёл я их не сразу, если просто сайти на epson.com и посмотреть драйверы для твоего принтера, то там есть драйверы только для Windows. А этот драйвер, насколько понимаю написан полуофициально.

Затем нужно почитать форумы по Linux и выбранному принтеру и его драйверу. Т.к., к примеру, принтеры Canon, хоть и имеют вроде официальный CAPT драйвер, но он очень криво настраивается под Linux.

И вот если на официальном сайте в разделе выбора драйверов есть Linux, на форумах написано что этот принтер настраивается без проблем, а в частности его драйвер, то вот этот и бери.

У HP с драйвером HPLIP как водится почти нет проблем.

Ну и уверен, что это драйвер тоже можно докрутить, тебе не хватает терпения и опыта.

Ну и ты всё же выбрал Gentoo, так что здесь есть свои нюансы. Ищи тему на Gentoo.org по настройке твоего принтера, тем более вроде в той теме, ссылку на которую я привёл, всё заработало.

Удачи.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

cups хоть в gentoo хоть в debian и логично было предположить что драйверы для обоих капсов одинаковы а тут какая то муть нет что бы допилить localhost:631 что бы туда можно загрузить эти фильтры и прочее и создать базу данных всех поддерживаемых принтеров как репозиторий.

iluha16 ()
Ответ на: комментарий от kostik87

да это бесконечная история. Пока железку не купишь, ничего толком не узнаешь.

Я этот принтер хочу под малинкой запустить.

max_lapshin ★★★ ()
Ответ на: комментарий от kostik87

это не принтер ненормальный, а просто очередной сгусток безблагодатного топлива для биореактора.

mos ★★☆☆☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.