LINUX.ORG.RU

Бесконечные зависимости пакетов (Ubuntu 14.04.5 LTS)

 , ,


0

1

При каждом запуске стима вылезает окно терминала:

Steam needs to install these additional packages: libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386 [sudo] password for danil:

Ввожу пароль, далее:

Steam needs to install these additional packages: libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386 [sudo] password for danil: .............................................................................................................................................. Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Некоторые пакеты невозможно установить. Возможно, вы просите невозможного, или же используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости: libc6:i386 : Зависит: libgcc1:i386 но он не будет установлен libgl1-mesa-dri:i386 : Зависит: libdrm-intel1:i386 (>= 2.4.48) но он не будет установлен Зависит: libdrm-nouveau2:i386 (>= 2.4.38) но он не будет установлен Зависит: libdrm-radeon1:i386 (>= 2.4.31) но он не будет установлен Зависит: libdrm2:i386 (>= 2.4.38) но он не будет установлен Зависит: libexpat1:i386 (>= 2.0.1) но он не будет установлен Зависит: libgcc1:i386 (>= 1:4.1.1) но он не будет установлен Зависит: libllvm3.4:i386 но он не будет установлен Зависит: libstdc++6:i386 (>= 4.6) но он не будет установлен Рекомендует: libtxc-dxtn-s2tc0:i386 но он не будет установлен или libtxc-dxtn0:i386 libgl1-mesa-glx:i386 : Зависит: libdrm2:i386 (>= 2.3.1) но он не будет установлен Зависит: libudev1:i386 но он не будет установлен или libudev0:i386 но он не может быть установлен E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты. Press return to continue:

Нажимаю Enter, терминал закрывается и запускается стим. Где-то вычитал, что это лечится установкой вайна. Пробую установить:

danil@DanilPC:~$ sudo apt-get install wine [sudo] password for danil: Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Некоторые пакеты невозможно установить. Возможно, вы просите невозможного, или же используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости: wine : Зависит: wine1.6 но он не будет установлен E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты. danil@DanilPC:~$

При попытке установить wine1.6 - требует wine1.6-i386. При попытке wine1.6-i386:

danil@DanilPC:~$ sudo apt-get install wine1.6-i386 Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Некоторые пакеты невозможно установить. Возможно, вы просите невозможного, или же используете нестабильную версию дистрибутива, где запрошенные вами пакеты ещё не созданы или были удалены из Incoming. Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости: wine1.6-i386:i386 : Зависит: libasound2:i386 (>= 1.0.16) Зависит: libc6:i386 (>= 2.17) но он не будет установлен Зависит: libglib2.0-0:i386 (>= 2.12.0) но он не будет установлен Зависит: libglu1-mesa:i386 но он не будет установлен или libglu1:i386 Зависит: libgphoto2-6:i386 (>= 2.5.2) но он не будет установлен Зависит: libgphoto2-port10:i386 (>= 2.5.2) но он не будет установлен Зависит: libgstreamer-plugins-base0.10-0:i386 (>= 0.10.22) но он не будет установлен Зависит: libgstreamer0.10-0:i386 (>= 0.10.26) но он не будет установлен Зависит: liblcms2-2:i386 (>= 2.2+git20110628) но он не будет установлен Зависит: libldap-2.4-2:i386 (>= 2.4.7) но он не будет установлен Зависит: libmpg123-0:i386 (>= 1.13.7) но он не будет установлен Зависит: libopenal1:i386 (>= 1:1.13) но он не будет установлен Зависит: libopencl-1.1-1:i386 Зависит: libpulse0:i386 (>= 1:0.99.1) но он не будет установлен Зависит: libx11-6:i386 но он не будет установлен Зависит: libxext6:i386 но он не будет установлен Зависит: libxml2:i386 (>= 2.9.0) но он не будет установлен Зависит: ocl-icd-libopencl1:i386 (>= 1.0) но он не будет установлен или libopencl1:i386 Зависит: zlib1g:i386 (>= 1:1.1.4) но он не будет установлен Зависит: libncurses5:i386 но он не будет установлен Рекомендует: libasound2-plugins:i386 но он не будет установлен Рекомендует: libcapi20-3:i386 но он не будет установлен Рекомендует: libcups2:i386 но он не будет установлен Рекомендует: libdbus-1-3:i386 но он не будет установлен Рекомендует: libfontconfig1:i386 но он не будет установлен или libfontconfig:i386 Рекомендует: libfreetype6:i386 но он не будет установлен Рекомендует: libgif4:i386 но он не будет установлен Рекомендует: libgnutls26:i386 но он не будет установлен Рекомендует: libjpeg8:i386 но он не будет установлен Рекомендует: libosmesa6:i386 но он не будет установлен Рекомендует: libp11-kit-gnome-keyring:i386 но он не будет установлен Рекомендует: libpng12-0:i386 но он не будет установлен Рекомендует: libsane:i386 но он не будет установлен Рекомендует: libtiff5:i386 но он не будет установлен Рекомендует: libv4l-0:i386 но он не будет установлен Рекомендует: libxcomposite1:i386 но он не будет установлен Рекомендует: libxcursor1:i386 но он не будет установлен Рекомендует: libxi6:i386 но он не будет установлен Рекомендует: libxinerama1:i386 но он не будет установлен Рекомендует: libxrandr2:i386 но он не будет установлен Рекомендует: libxrender1:i386 но он не будет установлен Рекомендует: libxslt1.1:i386 но он не будет установлен Рекомендует: libxt6:i386 но он не будет установлен Рекомендует: libxxf86vm1:i386 но он не будет установлен Рекомендует: ocl-icd-libopencl1:i386 но он не будет установлен Рекомендует: p11-kit-modules:i386 но он не будет установлен E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты. danil@DanilPC:~$

В общем, не фурычит. Пробовал разные команды, вроде:

sudo aptitude upgrade sudo apt-get upgrade sudo dpkg -l libqt4-core sudo aptitude show libqt4-core sudo aptitude search ~ahold sudo aptitude remove libqt4-core sudo dpkg --add-architecture i386 sudo dpkg --configure -a

Ни одна не помогает. Может, здесь помогут.

aptitude в убунту как бы нет, или сам доустановил?

AnimalNitrate ()

выхлоп сюда

apt-cache policy wine
sudo apt-get -f install
sudo apt-get update

CHIPOK ★★★ ()
Ответ на: комментарий от CHIPOK

danil@DanilPC:~$ apt-cache policy wine wine: Установлен: (отсутствует) Кандидат: 1:1.6.2-0ubuntu4 Таблица версий: 1:1.6.2-0ubuntu4 0 500 http://linux.psu.ru/ubuntu/ trusty/universe amd64 Packages

danil@DanilPC:~$ sudo apt-get -f install Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

greylink ()
Ответ на: комментарий от CHIPOK

часть 1

danil@DanilPC:~$ sudo apt-get update В кэше http://repo.steampowered.com precise InRelease Игн http://linux.psu.ru trusty InRelease Игн http://linux.psu.ru trusty-updates InRelease В кэше http://repo.steampowered.com precise/steam Sources Игн http://linux.psu.ru trusty-backports InRelease Игн http://download.videolan.org InRelease Игн http://linux.psu.ru trusty-security InRelease В кэше http://repo.steampowered.com precise/steam amd64 Packages Игн http://extras.ubuntu.com trusty InRelease Игн http://archive.canonical.com trusty InRelease В кэше http://linux.psu.ru trusty Release.gpg В кэше http://download.videolan.org Release.gpg В кэше http://repo.steampowered.com precise/steam i386 Packages В кэше http://linux.psu.ru trusty-updates Release.gpg В кэше http://linux.psu.ru trusty-backports Release.gpg В кэше http://extras.ubuntu.com trusty Release.gpg В кэше http://archive.canonical.com trusty Release.gpg В кэше http://download.videolan.org Release В кэше http://linux.psu.ru trusty-security Release.gpg В кэше http://ppa.launchpad.net trusty InRelease В кэше http://linux.psu.ru trusty Release В кэше http://extras.ubuntu.com trusty Release В кэше http://archive.canonical.com trusty Release В кэше http://linux.psu.ru trusty-updates Release В кэше http://download.videolan.org Packages В кэше http://ppa.launchpad.net trusty InRelease В кэше http://linux.psu.ru trusty-backports Release В кэше http://linux.psu.ru trusty-security Release В кэше http://extras.ubuntu.com trusty/main Sources В кэше http://archive.canonical.com trusty/partner Sources Игн http://ppa.launchpad.net trusty InRelease В кэше http://linux.psu.ru trusty/main Sources В кэше http://linux.psu.ru trusty/restricted Sources В кэше http://extras.ubuntu.com trusty/main amd64 Packages В кэше http://linux.psu.ru trusty/universe Sources В кэше http://ppa.launchpad.net trusty InRelease В кэше http://archive.canonical.com trusty/partner amd64 Packages В кэше http://linux.psu.ru trusty/multiverse Sources В кэше http://linux.psu.ru trusty/main amd64 Packages В кэше http://extras.ubuntu.com trusty/main i386 Packages В кэше http://ppa.launchpad.net trusty/main amd64 Packages В кэше http://archive.canonical.com trusty/partner i386 Packages В кэше http://linux.psu.ru trusty/restricted amd64 Packages В кэше http://linux.psu.ru trusty/universe amd64 Packages В кэше http://ppa.launchpad.net trusty/main i386 Packages В кэше http://linux.psu.ru trusty/multiverse amd64 Packages В кэше http://archive.canonical.com trusty/partner Translation-en В кэше http://ppa.launchpad.net trusty/main Translation-en В кэше http://linux.psu.ru trusty/main i386 Packages В кэше http://linux.psu.ru trusty/restricted i386 Packages В кэше http://ppa.launchpad.net trusty/main amd64 Packages В кэше http://ppa.launchpad.net trusty/main i386 Packages В кэше http://ppa.launchpad.net trusty/main Translation-en В кэше http://linux.psu.ru trusty/universe i386 Packages В кэше http://linux.psu.ru trusty/multiverse i386 Packages В кэше http://ppa.launchpad.net trusty Release.gpg В кэше http://ppa.launchpad.net trusty/main amd64 Packages В кэше http://ppa.launchpad.net trusty/main i386 Packages Игн http://download.videolan.org Translation-ru_RU В кэше http://ppa.launchpad.net trusty/main Translation-en Игн http://download.videolan.org Translation-ru Игн http://download.videolan.org Translation-en В кэше http://ppa.launchpad.net trusty Release В кэше http://linux.psu.ru trusty-updates/main Sources В кэше http://ppa.launchpad.net trusty/main amd64 Packages В кэше http://linux.psu.ru trusty-updates/restricted Sources В кэше http://linux.psu.ru trusty-updates/universe Sources В кэше http://ppa.launchpad.net trusty/main i386 Packages В кэше http://linux.psu.ru trusty-updates/multiverse Sources В кэше http://linux.psu.ru trusty-updates/main amd64 Packages В кэше http://linux.psu.ru trusty-updates/restricted amd64 Packages Игн http://extras.ubuntu.com trusty/main Translation-ru_RU Игн http://extras.ubuntu.com trusty/main Translation-ru В кэше http://linux.psu.ru trusty-updates/universe amd64 Packages В кэше http://linux.psu.ru trusty-updates/multiverse amd64 Packages В кэше http://linux.psu.ru trusty-updates/main i386 Packages Игн http://extras.ubuntu.com trusty/main Translation-en В кэше http://linux.psu.ru trusty-updates/restricted i386

greylink ()

показывай что у тебя в репах.

bdfy ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.