LINUX.ORG.RU

не удаляются пакеты - нет апдейтов! help!


0

0

После очередного обновления (debian lenny) - обновление происодит о ошибкой: не могут быть удалены,блин, 3 пакета :( как быть? помогите пожалуйста! Извлечение шаблонов из пакетов: 100% Предварительная настройка пакетов ... (Чтение базы данных... на данный момент установлено 123374 файлов и каталогов.) Распаковывается пакет libavutil49 (из файла .../libavutil49_0.svn20080206-8_amd64.deb)... dpkg: не удалось обработать параметр /var/cache/apt/archives/libavutil49_0.svn20080206-8_amd64.deb (--unpack): попытка перезаписать /usr/lib/libavutil.so.49, который уже имеется в пакете libavutilcvs49 Распаковывается пакет libavcodec51 (из файла .../libavcodec51_0.svn20080206-8_amd64.deb)... dpkg: не удалось обработать параметр /var/cache/apt/archives/libavcodec51_0.svn20080206-8_amd64.deb (--unpack): попытка перезаписать /usr/lib/libavcodec.so.51, который уже имеется в пакете libavcodeccvs51 Распаковывается пакет libpostproc51 (из файла .../libpostproc51_0.svn20080206-8_amd64.deb)... dpkg: не удалось обработать параметр /var/cache/apt/archives/libpostproc51_0.svn20080206-8_amd64.deb (--unpack): попытка перезаписать /usr/lib/libpostproc.so.51.1.0, который уже имеется в пакете libpostproccvs51 При обработке следующих пакетов произошли ошибки: /var/cache/apt/archives/libavutil49_0.svn20080206-8_amd64.deb /var/cache/apt/archives/libavcodec51_0.svn20080206-8_amd64.deb /var/cache/apt/archives/libpostproc51_0.svn20080206-8_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1) Не удалось установить пакет. Попытка восстановить: dpkg: зависимости пакетов не позволяют настроить пакет libxine1-ffmpeg: libxine1-ffmpeg зависит от libavcodec51 (>= 0.svn20080206), однако: Пакет libavcodec51 не установлен. libxine1-ffmpeg зависит от libavutil49 (>= 0.svn20080206), однако: Пакет libavutil49 не установлен. libxine1-ffmpeg зависит от libpostproc51 (>= 0.svn20080206), однако: Пакет libpostproc51 не установлен. dpkg: не удалось обработать параметр libxine1-ffmpeg (--configure): проблемы зависимостей -- оставляем не настроенным dpkg: зависимости пакетов не позволяют настроить пакет kaffeine: kaffeine зависит от libxine1-ffmpeg, однако: Пакет libxine1-ffmpeg пока не настроен. dpkg: не удалось обработать параметр kaffeine (--configure): проблемы зависимостей -- оставляем не настроенным dpkg: зависимости пакетов не позволяют настроить пакет xine-ui: xine-ui зависит от libxine1-ffmpeg, однако: Пакет libxine1-ffmpeg пока не настроен. dpkg: не удалось обработать параметр xine-ui (--configure): проблемы зависимостей -- оставляем не настроенным При обработке следующих пакетов произошли ошибки: libxine1-ffmpeg kaffeine xine-ui

Re: не удаляются пакеты - нет апдейтов! help!

aptitude -f install пробывал?

civitano ()

Re: не удаляются пакеты - нет апдейтов! help!

попробуй еще руками удалить проблемные пакеты, например libavutilcvs49 и т.п. У тебя почему то он пытается поставить новые пакеты поверх старых а не заменить их.

Vinick ★★ ()

Re: не удаляются пакеты - нет апдейтов! help!

Конфликт с debian-multimedia. Попробуй удалить пакеты, которые взяты оттуда и на которые ругается через dpkg --purge

gaa ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.