LINUX.ORG.RU

debian testing обновление неудачное

 ,


0

1

Всем привет, есть Debian testing сегодня обновляю и получаю

dpkg: error processing package python-gi (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 101
dpkg: зависимости пакетов не позволяют настроить пакет python-gobject:
 python-gobject зависит от python-gi (>= 3.10.2-1), однако:
  Пакет python-gi пока не настроен.

dpkg: error processing package python-gobject (--configure):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 python-gi
 python-gobject
репозиторий вот этот
deb http://ftp.ua.debian.org/debian/ testing main contrib non-free 
уже делал
apt-get -f install
dpkg --configure -a
никакого положительного эффекта, что можно сделать?

★★★★★

Ответ на: комментарий от RedEyedMan3

Я дико прошу прощения за простыню

aptitude install -f
Следующие частично установленные пакеты будут настроены:
  python-gi python-gobject 
Ни одного пакета не будет установлено, обновлено или удалено.
0 пакетов обновлено, 0 установлено новых, 0 пакетов отмечено для удаления, и 0 пакетов не обновлено.
Необходимо получить 0 B архивов. После распаковки 0 B будет занято.
Настраивается пакет python-gi (3.10.2-1) …    
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
dpkg: error processing package python-gi (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 101
dpkg: зависимости пакетов не позволяют настроить пакет python-gobject:
 python-gobject зависит от python-gi (>= 3.10.2-1), однако:
  Пакет python-gi пока не настроен.

dpkg: error processing package python-gobject (--configure):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 python-gi
 python-gobject
E: Sub-process /usr/bin/dpkg returned an error code (1)
Не удалось установить пакет. Попытка восстановить:
Настраивается пакет python-gi (3.10.2-1) …
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
Sorry: TypeError: compile() expected string without null bytes
dpkg: error processing package python-gi (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 101
dpkg: зависимости пакетов не позволяют настроить пакет python-gobject:
 python-gobject зависит от python-gi (>= 3.10.2-1), однако:
  Пакет python-gi пока не настроен.

dpkg: error processing package python-gobject (--configure):
 проблемы зависимостей — оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 python-gi
 python-gobject

mul4 ★★★★★ ()

чтобы таких косяков не возникало aptitude позволяет делать симуляцию

-s, --simulate

vxzvxz ★★★ ()
Ответ на: комментарий от vxzvxz

Добавлю, что симуляцию может делать и apt-get. Но в данном случае от симуляции никакого толку, ибо при ней всё равно не устанавливаются пакеты, а значит, и не проводится их конфигурация и выполнение post-скриптов.

anonymous ()

Итак сегодня обновился, всё хорошо, исправили баг.

mul4 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.