LINUX.ORG.RU

Синаптик и менеджер обновлений вылетают с ошибкой. Debian.

 , ,


0

2

Ошибка:

E: Значение «testing» недопустимо для APT::Default-Release, так как выпуск недоступен в источниках

Debian testing/sid amd64

/etc/apt/apt.conf

APT::Default-Release "testing";

/etc/apt/preferences

Package: *
Pin: release a=testing
Pin-Priority: 1100

Package: *
Pin: release a=unstable
Pin-Priority: 200

Package: *
Pin: release a=experemental
Pin-Priority: 100

В sorces.list всё прописано как надо.
Ошибка возникает не постоянно, а время от времени.
По команде: aptitude update тоже выдает ту же ошибку, но дальше проверяет как положено и по команде aptitude upgrade всё нормально обновляет.
Причина не гуглится (мной по крайней мере) . В чём же дело?

★★★

Если прописать «jessie», то проблема должна исчезнуть.

Gotf ★★★ ()
Ответ на: комментарий от Gotf

Я думал об этом, но как-то это странно. Спасибо, попробую.

MikeB ★★★ ()
Ответ на: комментарий от Gotf

Это смотря что в сорслисте прописано - у меня релиз прописан как тестинг и дефолт как тестинг, все работает. ТСу, наверно, все-таки лучше показать свой сорслист.

alozovskoy ★★★★★ ()
Ответ на: комментарий от alozovskoy

Гы, у меня прописаны оба и в Default-Release работает любой вариант:

deb [arch=amd64] file:///srv/debian/jessie/ jessie main contrib
deb http://ftp.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.debian.org/debian/ testing main contrib non-free
В preferences у меня пусто, если это имеет значение. Собственно, его и не имеет смысла заполнять, за исключением совсем особых случаев.

Gotf ★★★ ()
Ответ на: комментарий от alozovskoy

Да нет, посмотрел в сорслист, там тоже «testing», а не «jessie». Может и правда всё на jessie поменять. Хотя командами в терминале всё работает же.

MikeB ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.