LINUX.ORG.RU

Репы unstable/experemental/stable на Debian Testing

 


0

1

Запутался, в одном месте пишут прописать настройки в /etc/apt/apt.conf.d/70debconf, в другом /etc/apt/preferences (которого из коробки не существует, а соответственно не понятно, будет ли файл влиять на систему после создания). И потом, боюсь накосячить с расстановкой приоритетов в конфигах. Очень хочется не ошибиться. Еще и запутывают обсуждения на странице вики Дебиана. Нужно чтобы система затрагивала пакеты из unstable/experemental/stable только по командам типа apt-get install package/experemental.
Stable хоть и нужен для установки одного пакета, но мало ли, пусть останется. Попытаюсь сам:
Для начала прописать APT::Default-Release «testing»; в 70debconf? Потом:

Package: *
Pin: release a=experemental
Pin-Priority: 900
Package: *
Pin: release a=unstable
Pin-Priority: 800
Package: *
Pin: release a=stable
Pin-Priority: 700


в /etc/apt/preferences ?
Сильно прошу не пинать. Информации много и запутаться в ней легко.


/etc/apt/preferences записывай, всё работает.

v9lij ★★★★★ ()

Package: *
Pin: release a=experemental

А не боишься? Просто некоторые debian для другого держат.

v9lij ★★★★★ ()

Нет.

/etc/apt/preferences (которого из коробки не существует, а соответственно не понятно, будет ли файл влиять на систему после создания).

Будет влиять. Можно разнести на несколько файлов в директории /etc/apt/preferences.d/.

Package: *
Pin: release a=experemental
Pin-Priority: 900
Package: *
Pin: release a=unstable
Pin-Priority: 800
Package: *
Pin: release a=stable
Pin-Priority: 700

У Вас у самого нестабильного релиза самый большой приоритет! Должно быть наоборот.

Если быть совсем более точным, по умочанию у последней версии пакета из дефолтного релиза приоритет 500, так что достаточно просто понизить приоритет менее стабильных веток.

См. http://jaqque.sbih.org/kplug/apt-pinning.html

AITap ★★★★★ ()

У experemental по умолчанию приоритет 1, если не ошибаюсь.

Для unstable можно написать что-то вроде:

Package: *
Pin: release a=unstable
Pin-Priority: 550

Остальное можно не трогать, у testing приоритет получится выше, чем у stable.

Towelie ()
Ответ на: комментарий от AITap

Package: *
Pin: release a=stable
Pin-Priority: 700

Package: *
Pin: release a=unstable
Pin-Priority: 650

Package: *
Pin: release a=experemental
Pin-Priority: 600


Так должен выглядеть мой preferences файл на Testing Debian?
И чем отличаются:

apt-get install <package>/unstable

от

apt-get -t unstable install <package>

Типа первый вариант попытается установить пакет с использованием зависимостей моего testing, а второй скачает пакет с зависимоятями unstable в данном примере? Переводил через онлайн переводчик.

ziemin
/etc/apt/apt.conf.d/00local - если файл отсутствует, то будет работать после создания?
Создал файл и поместил запись дефолтный релиз=тестинг. Это нормально, что apt-cache policy показывает:

100 /var/lib/dpkg/status
release a=now

и некоторым репам дается приоритет 990 после создания 00local:

500 http://ftp.ru.debian.org/debian/ unstable/non-free Translation-en
500 http://ftp.ru.debian.org/debian/ unstable/main Translation-ru
500 http://ftp.ru.debian.org/debian/ unstable/main Translation-en
500 http://ftp.ru.debian.org/debian/ unstable/contrib Translation-en
500 http://ftp.ru.debian.org/debian/ unstable/non-free i386 Packages
release o=Debian,a=unstable,n=sid,l=Debian,c=non-free
origin ftp://ftp.ru.debian.org
500 http://ftp.ru.debian.org/debian/ unstable/contrib i386 Packages
release o=Debian,a=unstable,n=sid,l=Debian,c=contrib
origin ftp://ftp.ru.debian.org
500 http://ftp.ru.debian.org/debian/ unstable/main i386 Packages
release o=Debian,a=unstable,n=sid,l=Debian,c=main
origin ftp://ftp.ru.debian.org
500 http://ftp.ru.debian.org/debian/ testing-updates/non-free Translation-en
500 http://ftp.ru.debian.org/debian/ testing-updates/main Translation-en
500 http://ftp.ru.debian.org/debian/ testing-updates/contrib Translation-en
500 http://ftp.ru.debian.org/debian/ testing-updates/non-free i386 Packages
release o=Debian,a=testing-updates,n=jessie-updates,l=Debian,c=non-free
origin ftp://ftp.ru.debian.org
500 http://ftp.ru.debian.org/debian/ testing-updates/contrib i386 Packages
release o=Debian,a=testing-updates,n=jessie-updates,l=Debian,c=contrib
origin ftp://ftp.ru.debian.org
500 http://ftp.ru.debian.org/debian/ testing-updates/main i386 Packages
release o=Debian,a=testing-updates,n=jessie-updates,l=Debian,c=main
origin ftp://ftp.ru.debian.org
500 http://security.debian.org/ testing/updates/non-free Translation-en
500 http://security.debian.org/ testing/updates/main Translation-en
500 http://security.debian.org/ testing/updates/contrib Translation-en
990 http://security.debian.org/ testing/updates/non-free i386 Packages
release o=Debian,a=testing,n=jessie,l=Debian-Security,c=non-free
origin security.debian.org
990 http://security.debian.org/ testing/updates/contrib i386 Packages
release o=Debian,a=testing,n=jessie,l=Debian-Security,c=contrib
origin security.debian.org
990 http://security.debian.org/ testing/updates/main i386 Packages
release o=Debian,a=testing,n=jessie,l=Debian-Security,c=main
origin security.debian.org
500 http://ftp.ru.debian.org/debian/ testing/non-free Translation-en
500 http://ftp.ru.debian.org/debian/ testing/main Translation-ru
500 http://ftp.ru.debian.org/debian/ testing/main Translation-en
500 http://ftp.ru.debian.org/debian/ testing/contrib Translation-en
990 http://ftp.ru.debian.org/debian/ testing/non-free i386 Packages
release o=Debian,a=testing,n=jessie,l=Debian,c=non-free
origin ftp://ftp.ru.debian.org
990 http://ftp.ru.debian.org/debian/ testing/contrib i386 Packages
release o=Debian,a=testing,n=jessie,l=Debian,c=contrib
origin ftp://ftp.ru.debian.org
990 http://ftp.ru.debian.org/debian/ testing/main i386 Packages
release o=Debian,a=testing,n=jessie,l=Debian,c=main
origin ftp://ftp.ru.debian.org


Как видно, после создания 00local 500 приоритет помимо тестинга дается и unstable пакетам. Значит файл не влияет или я накосячил?

Towelie
т.е. прописать нужные experemental, unstable, stable репы, а в preferences вписать только:

Package: *
Pin: release a=unstable
Pin-Priority: 550



Прощу прощения, если туплю.

Salko ()
Ответ на: комментарий от Salko

Хз. Я в преференсес не лазил. По-идее эта штука не даёт апту взять и обновится до более новой системы (в смысле всё систему обновить). Репозитории подключай любые.

В любом случае, если конкретное приложение требует библиотек (хоть из прошлого, хоть из будущего) насколько я знаю просто не сделать.

ziemin ★★ ()
Ответ на: комментарий от Towelie

Давайте подведем итог.
В репы добавлены следующие записи:


deb http://ftp.ru.debian.org/debian/ unstable main contrib non-free
deb http://ftp.ru.debian.org/debian/ experimental main contrib non-free
deb http://ftp.ru.debian.org/debian/ stable main contrib non-free


Я создал файл /etc/apt/preferences и записал туда:


Package: *
Pin: release a=unstable
Pin-Priority: 550


Потом создал файл /etc/apt/apt.conf.d/00local и записал:


APT::Default-Release «testing»;


Сделал apt-get update и посмотрел на выхлоп apt-cache policy:


# apt-cache policy
Списки пакетов:
100 /var/lib/dpkg/status
release a=now
500 http://ftp.ru.debian.org/debian/ stable/non-free Translation-en
500 http://ftp.ru.debian.org/debian/ stable/main Translation-ru
500 http://ftp.ru.debian.org/debian/ stable/main Translation-en
500 http://ftp.ru.debian.org/debian/ stable/contrib Translation-en
500 http://ftp.ru.debian.org/debian/ stable/non-free i386 Packages
release v=7.3,o=Debian,a=stable,n=wheezy,l=Debian,c=non-free
origin ftp://ftp.ru.debian.org
500 http://ftp.ru.debian.org/debian/ stable/contrib i386 Packages
release v=7.3,o=Debian,a=stable,n=wheezy,l=Debian,c=contrib
origin ftp://ftp.ru.debian.org
500 http://ftp.ru.debian.org/debian/ stable/main i386 Packages
release v=7.3,o=Debian,a=stable,n=wheezy,l=Debian,c=main
origin ftp://ftp.ru.debian.org
500 http://ftp.ru.debian.org/debian/ experimental/non-free Translation-en
500 http://ftp.ru.debian.org/debian/ experimental/main Translation-en
500 http://ftp.ru.debian.org/debian/ experimental/contrib Translation-en
1 http://ftp.ru.debian.org/debian/ experimental/non-free i386 Packages
release o=Debian,a=experimental,n=experimental,l=Debian,c=non-free
origin ftp://ftp.ru.debian.org
1 http://ftp.ru.debian.org/debian/ experimental/contrib i386 Packages
release o=Debian,a=experimental,n=experimental,l=Debian,c=contrib
origin ftp://ftp.ru.debian.org
1 http://ftp.ru.debian.org/debian/ experimental/main i386 Packages
release o=Debian,a=experimental,n=experimental,l=Debian,c=main
origin ftp://ftp.ru.debian.org
500 http://ftp.ru.debian.org/debian/ unstable/non-free Translation-en
500 http://ftp.ru.debian.org/debian/ unstable/main Translation-ru
500 http://ftp.ru.debian.org/debian/ unstable/main Translation-en
500 http://ftp.ru.debian.org/debian/ unstable/contrib Translation-en
550 http://ftp.ru.debian.org/debian/ unstable/non-free i386 Packages
release o=Debian,a=unstable,n=sid,l=Debian,c=non-free
origin ftp://ftp.ru.debian.org
550 http://ftp.ru.debian.org/debian/ unstable/contrib i386 Packages
release o=Debian,a=unstable,n=sid,l=Debian,c=contrib
origin ftp://ftp.ru.debian.org
550 http://ftp.ru.debian.org/debian/ unstable/main i386 Packages
release o=Debian,a=unstable,n=sid,l=Debian,c=main
origin ftp://ftp.ru.debian.org
500 http://ftp.ru.debian.org/debian/ testing-updates/non-free Translation-en
500 http://ftp.ru.debian.org/debian/ testing-updates/main Translation-en
500 http://ftp.ru.debian.org/debian/ testing-updates/contrib Translation-en
500 http://ftp.ru.debian.org/debian/ testing-updates/non-free i386 Packages
release o=Debian,a=testing-updates,n=jessie-updates,l=Debian,c=non-free
origin ftp://ftp.ru.debian.org
500 http://ftp.ru.debian.org/debian/ testing-updates/contrib i386 Packages
release o=Debian,a=testing-updates,n=jessie-updates,l=Debian,c=contrib
origin ftp://ftp.ru.debian.org
500 http://ftp.ru.debian.org/debian/ testing-updates/main i386 Packages
release o=Debian,a=testing-updates,n=jessie-updates,l=Debian,c=main
origin ftp://ftp.ru.debian.org
500 http://security.debian.org/ testing/updates/non-free Translation-en
500 http://security.debian.org/ testing/updates/main Translation-en
500 http://security.debian.org/ testing/updates/contrib Translation-en
990 http://security.debian.org/ testing/updates/non-free i386 Packages
release o=Debian,a=testing,n=jessie,l=Debian-Security,c=non-free
origin security.debian.org
990 http://security.debian.org/ testing/updates/contrib i386 Packages
release o=Debian,a=testing,n=jessie,l=Debian-Security,c=contrib
origin security.debian.org
990 http://security.debian.org/ testing/updates/main i386 Packages
release o=Debian,a=testing,n=jessie,l=Debian-Security,c=main
origin security.debian.org
500 http://ftp.ru.debian.org/debian/ testing/non-free Translation-en
500 http://ftp.ru.debian.org/debian/ testing/main Translation-ru
500 http://ftp.ru.debian.org/debian/ testing/main Translation-en
500 http://ftp.ru.debian.org/debian/ testing/contrib Translation-en
990 http://ftp.ru.debian.org/debian/ testing/non-free i386 Packages
release o=Debian,a=testing,n=jessie,l=Debian,c=non-free
origin ftp://ftp.ru.debian.org
990 http://ftp.ru.debian.org/debian/ testing/contrib i386 Packages
release o=Debian,a=testing,n=jessie,l=Debian,c=contrib
origin ftp://ftp.ru.debian.org
990 http://ftp.ru.debian.org/debian/ testing/main i386 Packages
release o=Debian,a=testing,n=jessie,l=Debian,c=main
origin ftp://ftp.ru.debian.org


Для наглядности зашел в синаптик и посмотрел, какие пакеты хочет обновить система: http://i.piccy.info/i9/10abc608f213817046ef4e80c95e96b6/1388898931/114399/675...
Вроде все пакеты будет обновлять/стягивать как и нужно, с тестинга. Все правильно?
Одно только не нравиться - выхлоп apt-cache policy. Приоритет 500 дается не только testing.
И потом, для обновления например установленных experimental пакетов нужно будет запускать apt-get update -t experimental?

Salko ()
Ответ на: комментарий от Salko

И потом, для обновления например установленных experimental пакетов нужно будет запускать apt-get update -t experimental?

Вроде нет. Я как-то не обращал внимание, но вроде они вместе со всеми обновляются, только из своих реп.

UPD: только что обновился. Всё нормально обновляется обычными командами. Которые из sid ставил оттуда и обновились.

ziemin ★★ ()
Последнее исправление: ziemin (всего исправлений: 1)
Ответ на: комментарий от ziemin

В моем сообщении выше и судя по скриншоту, я так понимаю все ровно?! За «UPD» отдельное спасибо.

Последний вопрос, секьюрити репы и.т.д. прописывать не надо? Вопрос может и глупый, но мне простительно, только начинаю осваиваться.

Salko ()
Ответ на: комментарий от Salko

По-моему для testinga они значения не имеют. В него и так почти сразу всё попадает. Но хуже не будет. Потом просто убери строчки, на которые при update ругаться будет и всё.

ziemin ★★ ()

А посаны, почему у меня работает без /etc/apt/preferences?

anonymous ()
Ответ на: комментарий от Salko

я пишу не в
/etc/apt/apt.conf.d/00local
а в
/etc/apt/apt.conf.d/default

Я создал файл /etc/apt/preferences и записал туда:

а кроме unstable ты туда что-нибудь записал?

v9lij ★★★★★ ()
Ответ на: комментарий от anonymous

Вот никогда не обращал внимание. Разве что группировал по источникам.

ziemin ★★ ()
Последнее исправление: ziemin (всего исправлений: 2)
Ответ на: комментарий от ziemin

Ну по сути

APT::Default-Release "stable";
эквивалентно
Package: *
Pin: release a=stable
Pin-Priority: 990

Default-Release не дает такой гибкой настройки, как pinning. А так да, одно и то же.

Towelie ()
Ответ на: комментарий от Towelie

такой гибкой настройки

И в чём гибкость? Так я указал дистр и не парюсь. Например вопросов как у ТС'а у меня никогда не возникало. А тут надо сидеть, коэффициенты какие-то расставлять.

Зачем? Кстати вот вывод

$ apt-cache policy virtualbox-4.3 
virtualbox-4.3:
  Установлен: 4.3.6-91406~Debian~wheezy
  Кандидат:   4.3.6-91406~Debian~wheezy
  Таблица версий:
 *** 4.3.6-91406~Debian~wheezy 0
        500 http://download.virtualbox.org/virtualbox/debian/ wheezy/contrib amd64 Packages
        100 /var/lib/dpkg/status

Хотя я ставил из sid. Походу версии одинаковы и поставилась «штатная»

ziemin ★★ ()
Ответ на: комментарий от ziemin

Так я указал дистр и не парюсь

А как быть, если подключить сторонние репозитории? С помощью preferences можно настроить приоритет для каждого источника индивидуально.

Towelie ()
Ответ на: комментарий от v9lij

Towelie
# apt-cache policy virtualbox


virtualbox:
Установлен: (отсутствует)
Кандидат: 4.3.2-dfsg-1
Таблица версий:
4.3.2-dfsg-1 0
990 http://ftp.ru.debian.org/debian/ testing/contrib i386 Packages
550 http://ftp.ru.debian.org/debian/ unstable/contrib i386 Packages
4.1.18-dfsg-2+deb7u1 0
500 http://ftp.ru.debian.org/debian/ stable/main i386 Packages



v9lij
Сейчас попробовал:
(unstable - 450, stable 400)
# apt-cache policy virtualbox


virtualbox:
Установлен: (отсутствует)
Кандидат: 4.3.2-dfsg-1
Таблица версий:
4.3.2-dfsg-1 0
990 http://ftp.ru.debian.org/debian/ testing/contrib i386 Packages
450 http://ftp.ru.debian.org/debian/ unstable/contrib i386 Packages
4.1.18-dfsg-2+deb7u1 0
400 http://ftp.ru.debian.org/debian/ stable/main i386 Packages



Все равно пытается тянуть ядро:
# apt-get install virtualbox


НОВЫЕ пакеты, которые будут установлены:
dkms libcurl3 libgsoap4 libqt4-opengl libvncserver0
linux-image-3.2.0-4-rt-686-pae virtualbox virtualbox-dkms virtualbox-qt
обновлено 0, установлено 9 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 0 B/44,7 MB архивов.

Salko ()
Ответ на: комментарий от Towelie

С помощью preferences можно настроить приоритет для каждого источника индивидуально.

Так это для задротов. Если оно мне понадобится когда-нибудь, я так сделаю.

ziemin ★★ ()
Ответ на: комментарий от Salko

# apt-get install virtualbox

Зря ставишь виртуальный пакет. ИМХО он поломан и всё равно ставит vb-4.3. Проще сразу ставить 4.3.

ziemin ★★ ()
Ответ на: комментарий от Salko

Кстати да, попробуйте virtualbox-4.3, просто virtualbox тянется с debian.org, а 4.3 будет именно с virtualbox.org

Towelie ()
Ответ на: комментарий от ziemin

Зря ставишь виртуальный пакет. ИМХО он поломан и всё равно ставит vb-4.3. Проще сразу ставить 4.3.

Значит в настройках все нормально? Просто если закомментить stable репы, то ядро не тянется. Stable, кстати, последние в sources.list
/etc/apt/apt.conf.d/default:

APT::Default-Release «testing»;

я так понимаю, вместо 00local, default можно задать любое имя?
/etc/apt/preferences

Package: *
Pin: release a=unstable
Pin-Priority: 450

Package: *
Pin: release a=stable
Pin-Priority: 400



Towelie
Там на сайте же нет реп для testing (wheezy самые последние)? Или я туплю. А так, то, что тянется ядро со stable, виноват кто или что?

Salko ()
Ответ на: комментарий от Salko

Да, у них там только один репозиторий.

Возможно, ядро тянется из-за linux-headers. У вас установлены headers для вашего ядра?

Towelie ()
Ответ на: комментарий от Salko

я так понимаю, вместо 00local, default можно задать любое имя?

00 для того, что бы этот файл выполнялся как можно раньше. К обычному пользователю это не относится. Вот если бы у тебя был мощный сервер с тысячами конфигов это имело бы значение.

Вот блин. Пока писал, самому в голову пришла мысль, что это бессмысленно. В общем считай это традицией.

ziemin ★★ ()
Ответ на: комментарий от Towelie

Towelie

$ dpkg -l | grep linux-headers


ii linux-headers-3.12-1-686-pae 3.12.6-2 i386 Header files for Linux 3.12-1-686-pae
ii linux-headers-3.12-1-common 3.12.6-2 i386 Common header files for Linux 3.12-1
ii linux-headers-686-pae 3.12+55 i386 Header files for Linux 686-pae configuration (meta-package)


Так headers для моего (текущего testing) ядра. Причем тут 3.2? Кстати, почему в stable 3.2, когда в testing 3.12?

По поводу реп vbox. Пардон за тупизм, но что прописать для тестинга?
Вижу только:


deb http://download.virtualbox.org/virtualbox/debian saucy contrib
deb http://download.virtualbox.org/virtualbox/debian raring contrib
deb http://download.virtualbox.org/virtualbox/debian quantal contrib
deb http://download.virtualbox.org/virtualbox/debian precise contrib
deb http://download.virtualbox.org/virtualbox/debian lucid contrib non-free
deb http://download.virtualbox.org/virtualbox/debian wheezy contrib
deb http://download.virtualbox.org/virtualbox/debian squeeze contrib non-free



ziemin
Понятно.

Salko ()
Ответ на: комментарий от Salko

Причем тут 3.2?

Попробуйте aptitude why inux-image-3.2.0-4-rt-686-pae

По поводу реп vbox. Пардон за тупизм, но что прописать для тестинга?

wheezy

Towelie ()
Ответ на: комментарий от Towelie

Это я к тому, что vb выпускают свои релизы независимо от дебиана. Виртуальный пакет у ниж традиционно сломан. Так что надо ставить с указанием версии.

Я, если что в реале использую vb и уже напарывался на косяки.

ziemin ★★ ()
Ответ на: комментарий от Towelie

С версиями пакеты с virtualbox.org, без версии - с debian.org, все в порядке

Да ну? В тестинге вроде сломан. У меня не ставитсо. Пишет, что для установки пакета необходимо установить его же. Обновлялся сегодня. На сервере проверять не буду.

upd: сервер, кстати вырублен. А на нём крутится в виртуалке сжатие потока от видеокамер. Мда.

ziemin ★★ ()
Последнее исправление: ziemin (всего исправлений: 2)
Ответ на: комментарий от Towelie

Towelie
$ aptitude why linux-image-3.2.0-4-rt-686-pae


i linux-image-686-pae Зависит linux-image-3.12-1-686-pae
i A linux-image-3.12-1-686-pae Рекомендует firmware-linux-free (>= 3~)
i A firmware-linux-free Предлагает linux-image
pi linux-image-3.2.0-4-rt-686-pae Предоставляют linux-image



$ dpkg -l | grep linux-image


ii linux-image-3.12-1-686-pae 3.12.6-2 i386 Linux 3.12 for modern PCs
ii linux-image-686-pae 3.12+55 i386 Linux for modern PCs (meta-package)


нужно удалить linux-image-686-pae?

Salko ()
Ответ на: комментарий от Towelie

Towelie

Хмм, не помогло.
$ aptitude why linux-image-3.2.0-4-rt-686-pae


i gdm3 Рекомендует xserver-xorg
i A xserver-xorg Зависит xserver-xorg-video-all | xorg-driver-video
p xserver-xorg-video-nvidia-legacy-96xx Предоставляют xorg-driver-video
p xserver-xorg-video-nvidia-legacy-96xx Рекомендует nvidia-legacy-96xx-kernel-dkms (= 96.43.23-8) | nvidia-legacy-96xx-k
ernel-96.43.23
p nvidia-legacy-96xx-kernel-dkms Зависит dkms (>= 2.1.0.0)
p dkms Рекомендует linux-image
pi linux-image-3.2.0-4-rt-686-pae Предоставляют linux-image



$ dpkg -l | grep linux-image


ii linux-image-3.12-1-686-pae 3.12.6-2 i386 Linux 3.12 for modern PCs


хедеры тоже почистил

Salko ()
Ответ на: комментарий от Towelie

aptitude why же почему-то дает результаты.
По идее, должно быть что-то типа:
$ aptitude why linux-image-9.9.7-7-rt-686-pae
E: Пакета с именем «linux-image-9.9.7-7-rt-686-pae» не существует.

Salko ()
Ответ на: комментарий от Towelie

# apt-get install virtualbox-4.3


НОВЫЕ пакеты, которые будут установлены:
cpp-4.6 dkms gcc-4.6 gcc-4.6-base libqt4-opengl libsdl-ttf2.0-0 linux-headers-3.2.0-4-common-rt
linux-headers-3.2.0-4-rt-686-pae linux-headers-686-pae linux-image-3.2.0-4-rt-686-pae linux-kbuild-3.2 virtualbox-4.3
обновлено 0, установлено 12 новых пакетов, для удаления отмечено 0 пакетов, и 11 пакетов не обновлено.
Необходимо скачать 83,2 MB/107 MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 299 MB.


Facepalm.

Salko ()
Ответ на: комментарий от Salko

Попробуйте так:

apt-get install --no-install-recommends virtualbox-4.3

Ну или попробуйте через aptitude

Towelie ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.