LINUX.ORG.RU

Ubuntu 16.04.4 LTS

 , ,


2

2

Вышло накопительное обновление дистрибутива 16.04.4 LTS, в котором включены все последние исправления, в том числе и исправления уязвимостей Spectre и Meldtowm, снижающие производительность. Исправлены ошибки в инсталляторе и загрузчике. Также вышли субрелизы дериативов - Kubuntu, Xubuntu, Lubuntu и другие.

В состав вошли улучшения из 17.10 - ядро 4.13, свежие свободные и проприетарные драйвера, X.org и Mesa. Обновление недоступно для PowerPC 32bit, поскольку в PowerPC поддержка HWE не осуществляется.

Поддержка Ubuntu 16.04 продлится до 2021 года, при этом до 2021 года поддерживаться будут 16.04.0, 16.04.1 и 16.04.5, которая выйдет в августе 2018 года. Данный выпуск будет поддерживаться до августа 2018, после чего нужно будет либо поставить General Kernel /General X.org, либо перейти на HWE из Ubuntu 18.04 Bionic Beawer.

Для перехода с General или старых версий HWE нужно установить пакеты linux-generic-hwe-16.04 xserver-xorg-hwe-16.04 с рекомендациями.

>>> Подробности

★★

Проверено: Shaman007 ()
Ответ на: комментарий от h31

То, что он по умолчанию включен - плата за то, что появляется новое железо

Тогда какой смысл от этого LTS который вовсе никакой не LTS. Проще на новую версию убунты обновиться.

Polugnom ★★★★★ ()
Ответ на: комментарий от Polugnom

Проще на новую версию убунты обновиться.

Ну потому что по мимо ядра с иксами, есть всё остальное. В котором тот ещё трах бабах.

PHP (?) => PHP 7

ffmpeg => Libav => ffmpeg

scanbuttond => scanbd

Продолжать можно долго.

А уж про DE И говорить не стоит. В линуксах всё только так переписывается по многу раз и быстро.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 2)
Ответ на: комментарий от Rinaldus

А как ты относишься к тому, что даже в серверных версиях 18.04 LTS по умолчанию вместо ifupdown для настройки сети будет использоваться systemd-networkd?

Vsevolod-linuxoid ★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от Polugnom

Тогда какой смысл от этого LTS который вовсе никакой не LTS. Проще на новую версию убунты обновиться.

Тут еще одна недоговорка - он включается по умолчанию со второго субрелиза по вышеописанной причине. Есть как минимум три альтерантивных варианта:

  • Самый простой- установка с диска хх.хх.1 или хх.хх.0 и apt-get dist-upgrade. Там по умолчанию будет General на 5 лет.
  • Использование Netboot- там сразу на выбор ядро при загрузке образа, а в экспертном режиме - выбор версии ядра.
  • Установка ручками, как Arch - тут и так все ясно.

А вот каков смысл у Debian, который из уникального дистрибутива превращается в аналог RHEL? Проще взять любой клон - Oracle, Scientific, CentOS, ROSA и др.

Lowes ★★ ()
Последнее исправление: Lowes (всего исправлений: 1)
Ответ на: комментарий от Lowes

А вот каков смысл у Debian, который из уникального дистрибутива превращается в аналог RHEL?

Шта?

(Не говоря уже о том, что превратись Debian в аналог RHEL, Ubuntu последует за ним с лагом в один год.)

anonymous ()

Также вышли субрелизы дериативов - Kubuntu, Xubuntu, Lubuntu и другие.

И зачем нужна 16, менее протестированная версия, если на сайте кубунты у 16 и у 14 версий срок поддержки до одного и того же числа - до апреля 2019 года.

Napilnik ★★★★★ ()
Ответ на: комментарий от Lowes

а какой смысл в убунте которая превращается в аналог дебиана? оно вообще хоть чем-то отличается от дебиана или можно ставить дебиан стейбл и получить то же самое? или действительно сразу рхел ставить и не морочиться?

anonymous ()
Ответ на: комментарий от Polugnom

ну да, ну да.

страница дебиана на дистровотч: https://distrowatch.com/table.php?distribution=debian

страница федоры на дистровотч: https://distrowatch.com/table.php?distribution=fedora

но разница конечно огромная: обои поменяли, и иконки другие.

anonymous ()
Ответ на: комментарий от Rinaldus

Стабильность багов - соглашусь, пожалуй. До сих пор в пакете с dnsmasq не могут починить скрипт, чтобы при перезагрузке демон запускался ПОСЛЕ поднятия сети, а не до... 2 года почти. И это они называют LTS ? в чем support-то?

DummyBoy ()
Ответ на: комментарий от DummyBoy

Да убунточка скатилась с момента внедрения анального системГэ. Сейчас уважение вызывают только Слака и Хромая ось, слава гуглу, хоть додумались оставить апстарт.

menangen ★★★★★ ()
Ответ на: комментарий от DummyBoy

dnsmasq не входит в main и Canonical официально не поддерживается. Официальная поддержка действует только на dnsmasq-base, который не содержит файлов для запуска сервиса.

anonymous ()
Ответ на: комментарий от Polugnom

Смысл в том, что ваш HWE только для десктопных хомячков нужен, которые ни черта ни чего не понимают и пониматьть и знать не желают. Отрыжка относительной популярности десктопной бубунты.

mandala ★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

А как ты относишься к тому, что даже в серверных версиях 18.04 LTS по умолчанию вместо ifupdown для настройки сети будет использоваться systemd-networkd

Это прекрасно! А то обещали единую экосистему настройки и администрирования всего и вся, а по факту в каждом дистре сустемдик вкорячен под особенной травой.

mandala ★★★ ()
Ответ на: комментарий от anonymous

А 3 года поддерживается весь репозиторий, а не его жалкий огрызок, как в Ubuntu.

За десять лет использования Debian я чётко уяснил: нормально поддерживаются лишь более-менее популярные пакеты, остальное хорошо если хоть как-то, но часто заброшено.

anonymous ()
Ответ на: комментарий от Napilnik

И зачем нужна 16, менее протестированная версия, если на сайте кубунты у 16 и у 14 версий срок поддержки до одного и того же числа - до апреля 2019 года.

Ты думаешь после заморозки пакетов в кубунте они тестируются? Нет юный падаван, они ферментируются.

af5 ★★★★★ ()
Ответ на: комментарий от Rinaldus

Очень годная серверная версия, использую на всех своих серверах.

И не задалбывают постоянные обновления, единственное назначение которых — переписать твои конфиги дефолтными? А пермонентное «system needs to be rebooted» даже без установки этих обновлений? Ссаная убунта делает жизнь сисадмина адом. Это первая и последняя убунта на моих серверах. Хорошо время жизни нашего сервиса, который на ней крутится, подходит к концу и можно забыть этот кусок говна навсегда.

anonymous ()
Ответ на: комментарий от anonymous

За десять лет использования Debian я чётко уяснил: нормально поддерживаются лишь более-менее популярные пакеты, остальное хорошо если хоть как-то, но часто заброшено.

Конечно же я поверю тебе на слово. Пакеты, которые заброшены, обрастают RC-багами и не проходят в stable.

anonymous ()
Ответ на: комментарий от anonymous

поддержка LTS 5 лет.

да? 4.4.0-116 сломался пару недель назад, никто чинить не торопится.

ну и о какой «поддержке» можно говорить, если волонтёрский дебиан может поддерживать свои инит-скрипты для сервисов, а коммерческая компания каноникал не может? что они там поддерживают вообще, расскажите нам.

anonymous ()
Ответ на: комментарий от anonymous

Меня апт спрашивает про конфиги. Да, софт обычный и популярный, но может тогда вам стоит пинать сопровождающих ваших пакетов?

system needs to be rebooted

Вангую кто-то срет в dconf.

можно забыть этот кусок говна навсегда

Да, меня тоже уже бесит бубунта, но скорее своим тупым сустемдиком.

mandala ★★★ ()
Ответ на: комментарий от Napilnik

И зачем нужна 16, менее протестированная версия, если на сайте кубунты у 16 и у 14 версий срок поддержки до одного и того же числа - до апреля 2019 года.

Для таких как ты, которые читают жопой: https://www.ubuntu.com/info/release-end-of-life

16.04 поддерживается до 2021 года.

Dimez ★★★★★ ()
Ответ на: комментарий от anonymous

4.4.0-116 сломался пару недель назад, никто чинить не торопится.

Где ссылка на багтрекер? Наоборот, в 4.4.0-116 пофиксили все проблемы и он стабилен :)

Dimez ★★★★★ ()
Ответ на: комментарий от af5

Ты думаешь после заморозки пакетов в кубунте они тестируются?

Мне как бы пофиг, лишь бы в вертухайке иногда можно было что-то протестировать или собрать.

Napilnik ★★★★★ ()
Ответ на: комментарий от Dimez

Для таких как ты, которые читают жопой: https://www.ubuntu.com/info/release-end-of-life

Ты ей думаешь и ей же отвечаешь. Мне нет дела что написано про кубунту на сайте бубунты. Ты бы ещё про кубунту в макдональдсе прочитал и на этом основании предъявы кидал. Как долго поддерживать версию кубунты будут решать в кубунте - захотят и раньше на помойку выкинут.

Napilnik ★★★★★ ()