LINUX.ORG.RU

Вышел Slackware Linux 13.1

 


0

0

Да, время релиза настало, спустя несколько месяцев разработки Патрик Фолькердинг представил версию 13.1

В числе новшеств:

  • Ядро 2.6.33.4
  • Glibc 2.11.1
  • GCC 4.4.4 как компилятор по умолчанию
  • Perl 5.10.1, Python 2.6.4, Ruby 1.9.1-p378, Subversion 1.6.11, git-1.7.1, mercurial-1.5.2
  • KDE SC 4.4.3
  • Обновлены также и Gtk+ приложения: Pidgin-2.7.0, gimp-2.6.8, gkrellm-2.3.4, gxine-0.5.903, xchat-2.8.6, xsane-0.996, pan-0.133.
  • Xfce 4.6.1
  • Добавлена поддержка PolicyKit и ConsoleKit
  • в extra/ обновлена утилита slacktrack для удобства сборки собственных пакетов

Заказать диск Выбрать зеркало и скачать

>>> официальный анонс

★★★★★

Проверено: mono ()

Ответ на: комментарий от Root-msk

Я пользуюсь арчем, потому что он мне удобен. Исчерпывающий ответ?

Профит лично для меня в свежести софта. Можно называть меня цифро/апдейтодрочером, но меня бесит, когда софт месяцами не обновляется. Особенно KDE.

Причём обсуждение всегда не менее чем на 20 страниц

Разборки в стиле:
— $subj — самый Ъ-дистр!
— Нет, мой уютный $distroname круче!
— А я вообще неосилятор и не понял, как ставить иксы в $subj. $subj — г*вно, а его юзеры — красноглазики.

Таким вот образом набирается ~20 страниц.

Не уж так повышает ЧСВ?

Мне — нет. Стадию убунтушника я давно прошёл. И я не понимаю, как тот же арч может тешить ЧСВ, потому что я решительно не вижу в нём ничего трудного. Я поставил его сразу после убунты и никаких вопросов у меня не возникло. С гентой такое не прокатило. Вот у её юзеров есть повод для завышенного ЧСВ. Но на генту просто так не перейдёшь, всё-таки трудновато. А как осилишь — так и поумнеешь, ЧСВ вообще пропадёт.
Про слакварь не знаю, ровно как и не вижу в ней смысла. Ну да ладно, дистр старый, юзеров много, пусть пользуются, я нисколько не возражаю.

KevinDetry ()
Ответ на: комментарий от KevinDetry

>Ну да ладно, дистр старый, юзеров много, пусть пользуются, я нисколько не возражаю.

спасибо :)))

krim ()

Ура! Это то чего я искал.

anonymous ()
Ответ на: комментарий от BSD

>когда я сам на Слаке не один год просидел
Видимо, не дальше хомяка. Загляните в каталог /etc/rc.d - увидите там runlevel скрипты (которых нет в BSD-style) и совместимость с SysV и много чего еще. А потом рассказывайте мне про Ъ BSD-style в Слаке, ага?

yirk ★★★ ()

черт пропустил! всех поздравляю с этим событием, сам обновляться не собираюсь правда

lambrianov ()
Ответ на: комментарий от KevinDetry

>С гентой такое не прокатило. Вот у её юзеров есть повод для завышенного ЧСВ.

нет у юзеров генты повода для завышенного ЧСВ. по крайней мере, это ЧСВ к линуксу отношения не имеет. гента просто учит читать доки.

ass ★★★★ ()
Ответ на: комментарий от KevinDetry

>Про слакварь не знаю, ровно как и не вижу в ней смысла.

«Не читал, но осуждаю». Блин, мальшик, греби уже отсюда в какой-нить тред про арч и там занимайся своими ЧСВ-зашкаливающими песнопениями. Ты здесь не нужен!!

anonymous ()
Ответ на: комментарий от wenzel

> У Debian есть unstable и experimental

// К.О. еще есть testing-proposed-updates


Да, но там в среднем 3,5 пакета. Несущественно.

JackYF ★★★★ ()
Ответ на: комментарий от Xenius

Wi-Fi отключил в биосе сразу после покупки, поэтому не проверял)

Советую ethernet вырубить ибо весь трафик твоего провайдера дублируется еще и для спецслужб. И советую процессор вытащить, так как его устройство неизвестно, а поэтому там вполне могут быть закладки.

Reset ★★★★★ ()

Вот бы еще 32-битные библиотеки в 64-битную систему добавили-вообще б замечательно было.

Slackware_user ★★★★★ ()
Ответ на: комментарий от Slackware_user

> Вот бы еще 32-битные библиотеки в 64-битную систему добавили-вообще

дык вот, особо даже не сложно: http://alien.slackbook.org/dokuwiki/doku.php?id=slackware:multilib

А в основную ветку Патрик, вроде как, не собирается 32-битные либы включать. Чистоту блюдет.

abumbaher ()
Ответ на: комментарий от lawliet

поэтому вопрос - как ощущения от этой процедуры (проблематично, али нет)?

вроде как несколько дискет не считалось ;) но система заработала.. тогда это было так, в качестве интереса и первого знакомства - «напосмотреть». более основательно стал пользоваться с Mandrake 5.3

Sith ★★★★★ ()
Ответ на: комментарий от Reset

> скорее просто ниасилил

С др. стороны, зачем красноглазому «Ъ» 32-битные либы, на 64-битной системе? Чтоб неправославные грязные костыли юзать в виде вайна или каких-нибудь закрытых блобов? Не тру, нет пути.

abumbaher ()
Ответ на: комментарий от KblCb

> только не deb или rpm, ибо с ними уже много лет всё ясно

Простите, что с ними ясно, особенно с rpm? Ясно ли это также большинству пользователей линукс?

anonymous ()
Ответ на: комментарий от Reset

> Советую ethernet вырубить
Ну он вообще-то проводной и я вижу когда провод подсоединен. Иногда я пользуюсь этим интерфейсом, потому не вырубаю.

советую процессор вытащить, так как его устройство неизвестно, а поэтому там вполне могут быть закладки.

Могут конечно, но увы, без него не будет работать. Куплю себе какую-нибудь копилефтную железку на MIPS процессоре как-нибудь

Xenius ★★★★★ ()
Ответ на: комментарий от Root-msk

Вот объясните, в чем профит машинного постинга тупых новостей типа выхода релиза Wine? Т. е. таких, которые нафиг никому не сдались кроме пары вантузятников? Не уж так повышает ЧСВ?

anonymous ()
Ответ на: комментарий от Xenius

Ну он вообще-то проводной

И что? Спецслужбы всё равно всё читают. Говорю же, что провайдерский трафик специально для этого дублируется и проходит через спецфильтры, которые срабатывают по ключевым данным.

Куплю себе какую-нибудь копилефтную железку на MIPS процессоре как-нибудь

А кто гарантирует, что китайцы туда закладок не поставили?

Reset ★★★★★ ()
Ответ на: комментарий от Root-msk

> где по умолчанию ничего нет и ничего не работает?

Профит в том, что буде то и будет работать так, как ты захочешь, а не то и так как захотели разработчики дистра, с тем чтобы ты потом оттуда половину всего выковыривал.

Viglim ()
Ответ на: комментарий от Sith

ну пути у всех свои)
и да [offtop]я как-то к calculate пристрастился и почитать «вкусных» мануалов можно и «покрасноглазить» и proffit получить[/offtop]

lawliet ()
Ответ на: комментарий от lawliet

calculate пилится для конкретного предприятия. их cl утилиты подавляющему большинству юзеров не нужны. какой может быть профит от stage4, который засран ненужным софтом? идеология gentoo наоборот получается.

ass ★★★★ ()
Ответ на: комментарий от Reset

> А кто гарантирует, что китайцы туда закладок не поставили?
Открытые Спецификации. И стоимость. Закладки довольно дорого стоят, чтоб их зря переводить.

провайдерский трафик специально для этого дублируется и проходит через спецфильтры, которые срабатывают по ключевым данным.

У меня Ethernet служит только для связи двух рядом стоящих компов. Причем тут провайдеры?

Xenius ★★★★★ ()
Ответ на: комментарий от Xenius

Открытые Спецификации.

это ничего не значит, на arm тоже вон открыты спецификации, однако все реальные железяки насквозь проприетарные и чтобы там делать серьезные вещи надо использовать blob'ы и подписывать nda

У меня Ethernet служит только для связи двух рядом стоящих компов. Причем тут провайдеры?

ага, а на ЛОРе ты через libastral сидишь

Reset ★★★★★ ()
Ответ на: комментарий от Fracta1L

Стоило только Fracta1L похвалить PCLinuxOs, как этот дистр на distrowatch.com поднялся на три позиции. Чудеса от LOR.

anonymous ()

KevinDetry, складывается такое ощущение что при переходе с венды на Ubuntu ты так же орал что Ubuntu - The Best! Теперь ты «арчевод» и орешь во всеуслышанье что Арч - Ъ а вы все говно. Из-за таких как ты Arch превращается в Срач. Да и еще, гента не даст тебе того чего ты от нее ждешь 2фрактал. Ты просто жырный троль изливающий потоки поноса в каждом дистросраче. Читать то что ты пишешь интересно 2-3 камента - не больше.

Слаководов поздравляю

/// Arch Linux user

partyzan ★★★ ()
Ответ на: комментарий от Slackware_user

можно ставить с 32 битных пакетов ) только */lib часть, вручную, несколько неудобно, но работает

Sylvia ★★★★★ ()
Ответ на: комментарий от anonymous

Простите, что с ними ясно, особенно с rpm? Ясно ли это также большинству пользователей линукс?

Для deb'ов и rpm'ов неоправданно сложные спецификации. Впрочем если вы мне назовёте дистрибутив в котором любое файловое дерево заворачивается в валидный deb или rpm одной командой, то мне даже интересно и я готов забрать свои слова назад.

KblCb ★★★★★ ()
Ответ на: комментарий от Slackware_user

Насколько я понял, этот бред с /usr/lib64 в 64-битной слаке существует для того чтобы ставить 32-битные пакеты из обычной.

KblCb ★★★★★ ()
Ответ на: комментарий от KblCb

да, но вообщем-то это не совсем уж и бред с /lib64
вполне себе один из возможных стандартных вариантов multilib,
вариант с /emul-ia32 хуже

Sylvia ★★★★★ ()
Ответ на: комментарий от UnknownUser

Он ещё в 12ой был точно. Раньше не помню.

KblCb ★★★★★ ()
Ответ на: комментарий от KblCb

ну я видел только 2 версии слаки в своей жизни: 9 и нынче 13 стоит на рабочей машине, так что не берусь утвержать насчет остальных.

хочу сделать пару опытов над ней: установка likewise для авторизации в AD и установка wine с radmin для доступа на рабочий w2k3 сервак, ну или заменить совместимым нативным клиентом, если таковые существуют, ну и естественно установка OOo для работы с доками. хочется устроить хоть локальный вендакапец на работе :)

UnknownUser ()

и, пользуясь случаем, хочу поздравить слакварщиков )) релиз может и минорный, но нужный. уж такого KISS как в слаке вроде больше нигде не видел. более userfriendly видел, но не встречал дистрибутива, следующего KISS столько лет и так настойчиво.

UnknownUser ()
Ответ на: комментарий от Sylvia

Боюсь соврать, но это вроде бы нарушение стандарта иерархии файловой системы. То есть системные библиотеки должны жить в папке /usr/lib (или хотя бы симлинкнуты туда).

KblCb ★★★★★ ()
Ответ на: комментарий от UnknownUser

Мне субъективно показалось что crux брутальнее.

KblCb ★★★★★ ()
Ответ на: комментарий от KblCb

стандарт иерархии ФС что-либо говорит о multilib?

имеют место быть такие варианты

1) /emul-
2) /lib /lib32 /lib64
в качестве /lib обычно выступает 32 битная версия или на чистой 64 битной системе - 64 битная, в целом выбор остается за дистростроителями,
главное не нарушать свой же стандарт, если приняли 32 бита --libdir=/usr/lib значит так собираем все, если --libdir=/usr/lib64 значит не нужно забывать указывать это постоянно для всех пакетов архитектуры

Sylvia ★★★★★ ()
Ответ на: комментарий от UnknownUser

wine с radmin

Юзай версию 3.2, в ней работает всё, кроме чата.

если таковые существуют

Не существует.

Viglim ()
Ответ на: комментарий от Sylvia

из фактических примеров могу привести glibc и gcc сборку, без указания --libdir и LIBDIRSUFFIX

glibc использует /lib на 32 битах, /lib64 на 64
gcc ( 4.4 и 4.5 ) - аналогично glibc
gcc 4.3 использовал /lib (на чистой 32 битной системе) и lib32 и lib64 на 64битной

Sylvia ★★★★★ ()
Ответ на: комментарий от Viglim

насчет версии 3.2 в курсе :) уже юзаю, правда в бубунте на ноуте. погуглил, придется либо вайн накатывать в слаку с радмином, либо поднимать Terminal Server. пойду по пути наименьшего сопротивления.

UnknownUser ()
Ответ на: комментарий от KblCb

ничего не могу сказать. слышал, но только поверхностную информацию, да и самому посмотреть никак не удавалось. заинтересовало, почитаю сегодня, благодарю за пищу для размышлений :)

UnknownUser ()
Ответ на: комментарий от KblCb

lib64 хорош тем, что позволяет ставить пакеты из 32х битного дистрибутива и при этом не требуются костыли типа ia32-libs в которые неизвестно что положили как в бубунтоидах

Reset ★★★★★ ()
Ответ на: комментарий от Reset

в дебиане ушли от этого (squeeze) , пусть несколько и мучительно )

Sylvia ★★★★★ ()
Ответ на: комментарий от KblCb

все правильно, альтернативный бинарный формат,
т.е. подразумевают что в 64 системе должен быть 64 битный /lib и lib32,
в 32 - 32 битный lib и lib64

но законы удобства диктуют несколько иные реалии, возможно в будущем , когда 64 системы станут более «поумолчальны» и придут к тому что написали

Sylvia ★★★★★ ()
Ответ на: комментарий от anonymous

лапа, 4.2, прекрасно и компилится и работает вайн с gcc 4.5.1prerelease

Sylvia ★★★★★ ()
Ответ на: комментарий от Sylvia

я именно по факту что в арче с 4.5.0 не скомпилился, причём на багзиле баг исправили, но новой версии в репах арча так и не было.

anonymous ()
Ответ на: комментарий от anonymous

я специально написала не 4.5, а 4.5.1prerelease, нужно брать с svn, или ждать пока зарелизится 4.5.1 , релизный 4.5.0 ужасен, но вот текущее состояние ветки уже гораздо лучше, из нареканий только то, что он не проходит bootstrap с профилированием... в багзилле как всегда игнорируют..

Sylvia ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.