LINUX.ORG.RU

Slackware upgrade 12.2 -> 13.1


0

1

В дистре только инструкция по апгрейду с предыдущей версии (13.0). А как с 12.2 обновится?

Через интернет обновится можно?

И что там за изменения hda на sda?


>И что там за изменения hda на sda?

facepalm.jpg

шел 2010 год...

Turbid ★★★★★ ()
Ответ на: комментарий от Turbid

Извините, я не понимаю Вашего юмора. По теме что-то можете сказать?

P.S. Извините, если не успеваю за модой. Я не конченый фанатик линукса, не сижу ежедневно на линух форумах и не читаю новости по этой теме. Я простой пользователь. У меня есть дела и поважнее, чем следить за историей линукса. Поставил более года назад слаку 12.2 и с тех пор не парюсь. Просто заметил, что уже 13.1 вышла.

paxac ()
Ответ на: комментарий от paxac

hda и sda это то же самое, но намекает на новое ядро. через интернет обновится можно) инструкция подходит, пробуйте.

Berluskoni ★★ ()
Ответ на: комментарий от Berluskoni

> инструкция подходит, пробуйте.

вы проверяли? ПРосто там написано только обновление с 13.0. Может там какие-то кореные изменения произошли. Просто не хочется ломать то, что работает.

paxac ()
Ответ на: комментарий от Berluskoni

> через интернет обновится можно

в UPGRADE.TXT про это не нашел.

paxac ()
Ответ на: комментарий от paxac

>Извините, я не понимаю Вашего юмора.
Извините,не хотел вас обидеть - веселье не в вашу сторону, а к системе.

По теме что-то можете сказать?


Ну придется переписать в ручную в fstab hda на sda, если это не произойдет автоматически при обновлении. Пусть слакварщики поправят.

Turbid ★★★★★ ()

Патрик сам говорит, что ставить нужно с 0.

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

> Патрик сам говорит, что ставить нужно с 0.

И потерять все настройки (те, которые в /etc). А потом переустанавливать все проги. К сожалению, я сохранил не все tgz'шники. Придется снова качать, ставить,... Зачем мне это нужно.

paxac ()
Ответ на: комментарий от amorpher

> там txz, хотя и tgz вставится

...а ещё tbz и tlz, а может ещё что-то. Не в этом суть. Пожалуйста, отвечайте по теме.

paxac ()
Ответ на: комментарий от paxac

по теме - читай UPGRADE.TXT для 13.0 и 13.1, делай выводы.

vostrik ★★★☆ ()
Ответ на: комментарий от paxac

По теме - ставь вин7 или убунту и не задавай таких вопросов.

amorpher ★★★★★ ()
Ответ на: комментарий от paxac

slapt-get например, но помни

Canonical Slackware users do not use third-party tools for upgrading. They use their brain.

vostrik ★★★☆ ()
Ответ на: комментарий от vostrik

> по теме - читай UPGRADE.TXT для 13.0 и 13.1, делай выводы.

Вы предлагаете обновится до 13.0, а потом до 13.1? Вы не находите это немного глупым. Обновиляются почти все пакеты. Это считай целый DVD надо качать зря.

paxac ()
Ответ на: комментарий от vostrik

> slapt-get например, но помни: Canonical Slackware users do not use third-party tools for upgrading. They use their brain.

Может по этому я slapt-get и не пользуюсь. У меня нездоровое желание всё контроллировать, а всякие автоматичсекие пакет-менеджеры лишают меня удовольствия. Другое дело — простой как 3 рубля tgz/txz.

paxac ()
Ответ на: комментарий от paxac

я предлагаю прочитать, сравнить и сделать выводы. например о том, нужно обновляться сначала до 13.0 а потом до 13.1 или нет.

vostrik ★★★☆ ()
Ответ на: комментарий от amorpher

# ОФФТОП

amorpher, не в обиду, но что вы всё время встреваете не по теме? Сообщения набиваете? Так у вас и так 3 звезды уже. (Поэтому в хороших форумах «звания» и прочие бантики юзерам присваивают путём голосования по совокупности полезности, который юзер внёс в форум. Флудить каждый может.)

paxac ()
Ответ на: комментарий от vostrik

Да что там читать. UPGRADE.TXT почти без изменения копируется из дистра в дистр. А лазить внутрь каждого пакета и смотреть, что изменилось — изврат.

Я просто думал, если есть офиц. руководство по обновлению с прошлой версии, то может есть аналогичное для более старых. В инете я тоже не нашёл. Ладно, останусь на 12.2.

paxac ()
Ответ на: комментарий от paxac

ну так не UPGRADE.TXT единым же. это так, собирательное понятие для всех release notes и ченжлогов. не так их и много. например про sda написано тут и т.д.

vostrik ★★★☆ ()
Ответ на: комментарий от paxac

Почему не по теме? Спрашиваешь - отвечаю. Если ты слаку держишь и такие вопросы задаёшь. Ещё раз повторю - Патрик рекомендует ставить с нуля, в виду несовершенства (отсутствия вменяемой «просто» обновлялки).

Сообщения набиваете? Так у вас и так 3 звезды уже. (Поэтому в хороших форумах «звания» и прочие бантики юзерам присваивают путём голосования по совокупности полезности, который юзер внёс в форум. Флудить каждый может.)


Сообщения я набиваю, а как ещё сообщить-то? Я не телепат, да и ты видимо тоже. О званиях особо не думаю, порой сутками молчу. А если это нехороший форум - зачем спрашиваешь?

amorpher ★★★★★ ()

Если не особо разбираетесь в тонкостях устройства слаки, лучше сидите на 12.2 или переустановите систему 13.1 заново.
Дело в том, что при переходе с 12.2 обновились кеды с 3 ветки на 4, и соответственно вся инфраструктура. Руками все можно починить, но нужно знать что. Автоматически обновиться скорее всего не прокатит.

whoami ()

а если все работает, зачем обновляться?

lambrianov ()

я сегодня обновился с 12.2 до current, прочитай UPGRADE.TXT и CHANGES_AND_HINTS.TXT. После обновления поправь login.defs и усе.

splinter ★★★★★ ()
Ответ на: комментарий от splinter

правда кеды у меня там 4-е стояли. не думаю что это должно создать какие то сильные проблемы, смысл обновления в слаке очень прост. можете поставить из extra программу slackpkg и обновится через неё.

splinter ★★★★★ ()
Ответ на: комментарий от splinter

>После обновления поправь login.defs и усе.

что там править?

paxac ()
Ответ на: комментарий от splinter

я без кедов живу. Кстати, а при обновлении можно указывать, что ставить, а что нет. Там вроде просто делается find по новым пакетам и всё подряд ставится. Нахрена мне всё подряд. Мне бы только обновить уже установленные проги + либы + критически важные пакеты.

paxac ()
Ответ на: комментарий от paxac

после обновления при логине вываливается сообщение о неизвестных опциях, что то связанное с DIALUP и еще какой то опцией сейчас не помню, я просто закомментировал их.

splinter ★★★★★ ()
Ответ на: комментарий от paxac

если указываешь upgradepkg --install-new тогда он устанавливает новые пакеты если просто upgradepkg то обновит существующие.

splinter ★★★★★ ()
Ответ на: комментарий от splinter

если просто upgradepkg то обновит существующие.

Но ведь не так всё просто. Есть же зависимости. Вот стоял у меня пакет «A-1.0». В новой слаке он обновился до «A-2.0», при этом появились новые зависимости (стали нужны новые либы. которые в 12.2 не было, а в 13.1 появились). Как upgradepkg об этом догадается?

Лирический вопрос: почему до сих пор Патрик не включает в txz хотя бы какой-нибудь простой файл со списком зависимостей? В пакетах со repository.slacky.ru давно включается install/slack-required (или как-то так, я точно не помню; вот пример: http://paste.org.ru/?6vjcor); имхо, очень удобно: можно либо быстро вручную проверить (с /var/log/packages), либо написать простенький автоматичсекий проверялщик (я его сделал как филтр для mcview:

$ cat bindings |grep slack-req
# slack-required check
regex/^slack-required$
        View=%view{ascii} ~/.mc/bin/slack-req <%f

$ cat bin/slack-req 
#!/usr/bin/ruby

Dir.chdir('/var/log/packages')

STDIN.each_line { |l|
  l.chomp!
  s = l.sub(/ .*/,'')
  p = Dir["#{s}-*"][0]
  print l
  if p.nil?
    puts ' (*** not installed ***)'
  else
    puts " (#{p})"
  end
}

Просто обидно как-то. Менять слаку ни на что не хочется (привык очень). А вот с зависимостями до сих пор мучаюсь. Установлю прогу, а она баз. «lib-bla-bla.so не найден» или что-то вэтом роде :(((

paxac ()
Ответ на: комментарий от paxac

Знал бы английский, написал бы патрику письмецо с просьбой добавить install/slack-required и install/douninst.sh. Может кто-ниблдуь это сделает за меня?

paxac ()
Ответ на: комментарий от paxac

странно, ты хочешь обновится до 13.1 но при этом обновится так, что бы осталась структура дистрибутива как в 12.2. Я как то не понимаю, если ты хочешь оставить предыдущие настройки то не заменяй *.conf.new, Зависимости можно разрешить с помощью slapt-get, попробуй обновиться через него, или используй ldd. Но все же не так много программ поменялось в 12.2 по 13.1, эта та же самая слака, попробуй обновится для начала в виртуалке, если все будет гуд то потом уже на железке.

splinter ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.