LINUX.ORG.RU

slackware 13.1 — pidgin


0

0

Установил новый pidgin-2.7.0-i486-1.txt с офсайта слаки. При запуске pidgin вылетает с ошибкой

$ pidgin
pidgin: symbol lookup error: /usr/lib/libpurple.so.0: undefined symbol: g_checksum_reset

Как можно вылечить?


несоответствие glib

или glib обновить нужно
или по слакбилду пересобрать пакет пиджина с тем что есть в системе

Sylvia ★★★★★ ()
Ответ на: комментарий от Sylvia

А каким боком тут glib? Вроде там же libpurple. А эта либа идёт вместе с пиджином, в одном пакете.

paxac ()
Ответ на: комментарий от paxac

g_checksum_reset в glib , libpurple как и pidgin слинкована с glib
причем вероятно с более новой чем у вас

Sylvia ★★★★★ ()

Проверил: работает. Видимо и правда надо обновить glib. Попробуй slackpkg.

KblCb ★★★★★ ()
Ответ на: комментарий от paxac
$ ldd /usr/lib/libpurple.so
        linux-gate.so.1 =>  (0xffffe000)
        libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0xb770e000)
        libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0xb76d5000)
        libgstinterfaces-0.10.so.0 => /usr/lib/libgstinterfaces-0.10.so.0 (0xb76c7000)
        libgstreamer-0.10.so.0 => /usr/lib/libgstreamer-0.10.so.0 (0xb7633000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb75f8000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb75f5000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb75f1000)
        librt.so.1 => /lib/librt.so.1 (0xb75e8000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb74af000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb73df000)
        libidn.so.11 => /usr/lib/libidn.so.11 (0xb73ae000)
        libm.so.6 => /lib/libm.so.6 (0xb7388000)
        libutil.so.1 => /lib/libutil.so.1 (0xb7384000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb736b000)
        libnsl.so.1 => /lib/libnsl.so.1 (0xb7352000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xb733b000)
        libc.so.6 => /lib/libc.so.6 (0xb71d7000)
        libdl.so.2 => /lib/libdl.so.2 (0xb71d3000)
        /lib/ld-linux.so.2 (0xb783a000)
        libz.so.1 => /usr/lib/libz.so.1 (0xb71bf000)
KblCb ★★★★★ ()
Ответ на: комментарий от KblCb

Я обновил glibc-solibc (до 2.11). Не помогло. Та же ошибка.

paxac ()
Ответ на: комментарий от Sylvia

Спасибо. пиджин запустился. Но, в отличии от старой версии, не подключается к аське:

Ошибка запроса https://api.oscar.aol.com/aim/startOSCARSession: Не удаётся соединиться с api.oscar.aol.com: SSL-рукопожатие не удалось

В чём может быть дело?


Ух, блин, стока гемора. Лучше бы 2.6 оставил

paxac ()
Ответ на: комментарий от paxac

Ещё раз говорю. Поставь slackpkg, воткни туда url репа слаки 13.1, посмотри какие либы обновились и выборочно (если знаешь что выбирать) или полностью обновись. И да, ничего не поделаешь, это icq. Хотя у меня работает, что намекает на то что openssl наверное тоже стоит обновить.

KblCb ★★★★★ ()
Ответ на: комментарий от KblCb

Всё сделал. Только вот одна проблеимка осталась — при наведении на ник НЕ появляется всплывающего окошко с краткой информацией о контакте.

paxac ()
Ответ на: комментарий от paxac

Посмотри чейнджлог и настройки. Я pidgin'ом пользуюсь только когда в хлам разламываю KDE.

KblCb ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.