LINUX.ORG.RU

Вышел CentOS 5.6

 , ,


0

1

Разработчики рады представить CentOS 5.6 — дистрибутив, основанный на пакетной базе RHEL 5.6.

Изменения:

Начиная с CentOS 5.6, пакет centos-release включает в себя файлы конфигурации, необходимые для доступа к репозиториям debuginfo и vault, которые ранее должны были быть загружены отдельно. Репозиторий CentOS-Debuginfo.repo содержит набор debuginfo-пакетов (среди прочего необходимы для Systemtap), а репозиторий CentOS-Vault.repo содержит предыдущие (и больше не поддерживаемые) корректирующие релизы CentOS 5.

Новые пакеты, которых не было в CentOS 5.5:

  • bind97
  • hplip3
  • php53

Пакеты, которые были обновлены:

  • mod_nss-1.0.8-3.el5
  • python-2.4.3-27.el5_5.3

Анонс
Информация о выпуске
Ссылка на скачивание

>>> Подробности

Ответ на: комментарий от anonymous

>Думать о такой ерунде должен компьютер. Помнить все репозитории, разбираться в этом всём - это задача только компьютерозаменителя, низшего обслуживающего персонала.

Совершенно с вами согласен! Я вообще человек ленивый и предпочитаю удобный десктоп и нормальные шрифты из коробки, без тонн мануалов.

Мыслящий человек должен думать совсем о других вещах, а если вы помогаете компьютеру делать его работу, вместо того, чтобы компьютер помогал вам, поздравляю вас, вы типичное быдло.

Никто не писал рецепт для каждого прохожего, на каждыйдень. Вы далеки от серверов, чего ж критикуете на чужом поле? Я написал, как собирается виртуальный хостинг на центос (и на rhel собственно тоже) на 77% хостингов юзающих эту ось. Если бы вы мыслили, то поняли бы или хотя бы не встревали с глупостями ;)

Aman ()
Ответ на: комментарий от Aman

Какие «левые»? Сам проект centos можно назвать целиком «левым» ;). Есть плохие репы, есть хорошие ). Надо просто разбираться. Например - для openvz подключается оф. реп openvz. Дебиан - собрали сами с нестабильными патчами. Дальше epel - всем известен. rpmforge - беру буквально 1 пакет, но реп старый, известный. php 5.2 - уже писал. php 5.3 - раньше брали из remi, тоже известный реп. И опять - везде есть спеки, для собственной пересборки бинарников.

На самом деле это и есть то самое «ручное управление», о котором так много говорят в нашей стране. Оно требует огромного труда и очень высокой квалификации. Да, результаты на выходе могут быть весьма неплохи, но в подавляющем числе случаев невозможно позволить себе такие затраты. К тому же, возникает зависимость от конкретного специалиста, поскольку сочетание его знаний , навыков и связей становится уникальным и в случае его ухода всё непременно сломается.

Vudod ★★★★★ ()

Решены проблемы, из-за которых при установке с локального накопителя, такого как CD или DVD, выбор extra-репозитория («CentOS extras repository») приводил к сбою в процессе установки.

наконец-то

firstep ()
Ответ на: комментарий от Vudod

) да это знает любой линукс-админ. Как вы все не поймёте - это как раз наименее трудозатратный и удобный для массового администрирования и поддержки рецепт LAMP, требующийся сегодняшнему рынку. На дебиан я ума не приложу, сколько бы сил понадобилось, генту не предлагать, фрибсд - туча времени (+проблемы с оптимайзером). Как всё готово - делаете периодически yum update и всё.

Я как-то одним настроил и ушёл, в штате только винадмин. Показал ему на пальцах - вот «пути» тыцаешь, потом yum update. Работает уже года 3.

Aman ()
Ответ на: комментарий от Aman

> Совершенно с вами согласен! Я вообще человек ленивый и предпочитаю удобный десктоп и нормальные шрифты из коробки, без тонн мануалов.

Так это Debian.

.

А то спросишь у одного центосника, как поставить php, один скажет «ставь из remi», другой «ставь из centos.alt.ru», третий ещё что-нибудь. И обслуживание всего этого по-разному. Обновления, конфликты.

Ну и обновлений, которых в 5.5 не было с 6 января, это тоже так, мелочи.

Поэтому у тех, у кого гонор играет на почве того, что в Debian и Nginx и OpenVZ может даже домохозяйка поставить, начинается, что «openvz не той системы», «nginx должен быть с перламутровыми пуговицами». А Debian универсален.

anonymous ()
Ответ на: комментарий от firstep

> Решены проблемы, из-за которых при установке с локального накопителя, такого как CD или DVD, выбор extra-репозитория («CentOS extras repository») приводил к сбою в процессе установки.

Причём в 5.5 это было прямо текстом написано, что такая проблема есть. Постеснялись бы, что-ли, с таким качеством продукт выпускать.

anonymous ()
Ответ на: комментарий от anonymous

Причём в 5.5 это было прямо текстом написано, что такая проблема есть. Постеснялись бы, что-ли, с таким качеством продукт выпускать.

Зато у них ngnix единственно правильной системы.

Vudod ★★★★★ ()
Ответ на: комментарий от Sky4eg

Ага. Только я уточнил задачу, человека 4 кричали, как два пальца, но рецепта нет. Ещё раз, в который раз - коммерческий хостинг, linux+apache+nginx(>=0.8)+php5.2.17(+zend optimizer 3.3.9)+mysql(с ним вроде нигде нет проблем :) )+openvz stable (последнее на дебиан думаю нельзя).

Вообще знаю только 1 действительно стабильный share хостинг на дебиан. Репы этого товарища мне как-то и советовали (опять же - прищлось ему всё-таки собирать свои пакеты). Но у каждого своя кухня ) и я предпочитаю ядра с патчами Red Hat.

PS Я не фанатик, а очень даже реалист. Если мне покажут, как это делается на дебиан и что это лучше - с большим удовольствием буду юзать его.

Aman ()
Ответ на: комментарий от Aman

> PS Я не фанатик, а очень даже реалист. Если мне покажут, как это делается на дебиан и что это лучше - с большим удовольствием буду юзать его.

Зачем? Сторонние репозитории тоже есть, тот же dotdeb, но ими обычно и не пользуются, только в особых случаях, когда действительно «надо». Нужно php 5.2, лучше становись в дебиане мейнтейнером пакета php-legacy, чтобы вся информация об этом была в едином источнике, а не раскидана по «профессиональным» кучкам.

anonymous ()
Ответ на: комментарий от Aman

постоянно работаю с дебианом, никакого гемора не замечаю. правда, обычно это не ламп, а что-то более серьёзное, типа nginx+tomcat, но суть от этого не меняется.

про сторонние репы в центоси — это как-то смешно :)

anonymous ()
Ответ на: комментарий от anonymous

>А то спросишь у одного центосника, как поставить php, один скажет «ставь из remi», другой «ставь из centos.alt.ru», третий ещё что-нибудь. И обслуживание всего этого по-разному. Обновления, конфликты.

А вы не спрашивайте у «центосников», а спросите у админов. В remi был новый php 5.3 (сейчас с центос 5.6 может и не так актуально), на 5.2 забили с выходом 5.3. В centos.alt.ru - неподписаны пакеты (может изменилось что-то, не смотрел), не юзаю.

Ну и обновлений, которых в 5.5 не было с 6 января, это тоже так, мелочи.

Это ужасно, но пришлось терпеть. Я внимательно отслеживал, что публикуют, вроде за период ничего такого не было (да и команда обещала в случае опасного критикала, всё-таки выпустить апдейт). Ядра я центосовские не юзаю ;).

Поэтому у тех, у кого гонор играет на почве того, что в Debian и Nginx и OpenVZ может даже домохозяйка поставить, начинается, что «openvz не той системы», «nginx должен быть с перламутровыми пуговицами»

Какой ещё гонор ) ? Чисто практические факты, которые я назвал. Нашёл про nginx - не было в lenny поддержки лимитов скоростей и кол-ва соединений. Типо боремся с DDOS. Если для вас это перламутровые пуговицы, я даже не знаю.. Openvz - в дебиан unstable. В stable серьёзные баги всплывают, на которые через 3 месяца реагируют, а вы.

Aman ()
Ответ на: комментарий от Vudod

>Зато у них ngnix единственно правильной системы.

Его там просто нет. Фишка в том - что он, той системы, есть в репе, легко подключаемой.

Aman ()
Ответ на: комментарий от anonymous

А что серьёзного в tomcat? Хотя бы glassfish или jboss ).

про сторонние репы в центоси — это как-то смешно

Вы не поверите, я тоже когда-то так думал. Но задумайтесь, почему вы доверяете официальному дебиан? Это просто кучка недотёп, с проблемами в личной жизни, за бесплатно собирают )). Шучу, но мат в деб. рассылках вроде остаётся? Вы доверяете дебу - потому что его юзает куча людей и если что не так - будет крик (а может и нет). Так же и с репами центос, тем более, как я уже сказал - юзаются известные репы (которые проверяются, тестятся). И оттуда берётся пара пакетов, а не полсистемы. И они юзаются для конкретных продакшн целях, конкретными командами, которые общаются между собой.

Aman ()

Ещё, что немаловажно, был обновлён subversion. Странно, что не упомянули.

cruxish ★★★★ ()
Ответ на: комментарий от Aman

> Вы доверяете дебу - потому что его юзает куча людей и если что не так - будет крик (а может и нет). Так же и с репами центос, тем более, как я уже сказал - юзаются известные репы (которые проверяются, тестятся).

Потому что люди уходят, люди приходят, а Debian остаётся. В сторонних же репах уходят люди - уходит и проект. А в CentOS вообще то права на домен уходят, то обновления.

anonymous ()
Ответ на: комментарий от Aman

Я OpenVZ ни разу не ставил... Только ЛАМП, пхп брал с дотдеба... 135 дней аптайм, проблем пока не вижу... Но возможно если усложнить задачу, то они появятся... Хотя я выбрал дистр по параметрам относительная свежесть пакетов/легкость установки/легкость сопровождения... Для сервера под 1 сайт он справляется хорошо! Не пробовал под шаред. В основном шареды на центосяс судя по данным из сипанели по описанию ядра с суффиксом el

Sky4eg ()
Ответ на: комментарий от anonymous

>Потому что люди уходят, люди приходят

Вы правы. Риск есть. Как и во всём. Я всегда держу у себя сырцы со спеками, если что - пересоберу сам, пока реп жив - просто экономится время.

Aman ()
Ответ на: комментарий от Sky4eg

>В основном шареды на центосяс судя по данным из сипанели по описанию ядра с суффиксом el

Вот-вот. Задумайтесь почему. А я уже не раз ответил. Не из-за трушной энтерпрайзности центос, а просто простые практические вещи. Сипанель кстати ставится только на rhel, centos, freebsd. Так что там без вариантов. Для debian/ubuntu по просьбам обещали запилить, но проект на год и результата вроде пока нет.

135 дней аптайм, проблем пока не вижу...

Не хвастайтесь высокими аптаймами, а то вас обвинят в ядерных дырках ).

Aman ()
Ответ на: комментарий от Aman

Хм... а ведь действительно только под RH подобные ставится cpanel (спасибо за открытые глаза =) ), а с учетом что весомое большинство хостингов используют cpanel, то вывод напрашивается сам собой... *ушел думать*

Sky4eg ()
Ответ на: комментарий от borisych

Поздравляю, но мы сервер запустили 135 дней назад, до этого опыта не было! =)

Sky4eg ()
Ответ на: комментарий от borisych

>16:13:27 up 872 days, 23:02, 6 users, load average: 0.04, 0.03, 0.00

и каким бараном надо быть, чтоб дыры не обновлять.

но да, фанаты красношляпы такие фанаты. я бы сравнил их с абантоидами - марк сказал кнопки влево, значит влево!1

SimonPhoenix ()

У них в рассылке такая перепалка идёт, что они так долго тормозят с релизом.

Вообще обещают 6-ку через 2-3 недели после выхода 5.6 =)

anonymous ()
Ответ на: комментарий от SimonPhoenix

вы идиот. никто ж не сказал, что там лежит. сервер может и не быть в общем доступе, а народ может его хотеть 24/7, не давая рестартануть.

anonymous ()
Ответ на: комментарий от Ramzes001

Ну 10.04 будет пНу 10.04 будет поддерживаться до 2015, по мне так для сервера очень даже...оддерживаться до 2015, по мне так для сервера очень даже...

у RH/CO - 7 лет + 3 года расширенная фаза (y RH)

но по моему в 2011 году сервер с такими характеристиками (Р2-400МГц/256Мб) это немного некрофильно..

как файл-сервер вполне себе, хотя я говорил про ноут ))

Sith ★★★★★ ()
Ответ на: комментарий от Solaris10

>0.04 - это что, нагрузка для сервера

это вменяемое управление сайзингом

borisych ★★★★★ ()
Ответ на: комментарий от anonymous

>вы идиот. никто ж не сказал, что там лежит. сервер может и не быть в общем доступе, а народ может его хотеть 24/7, не давая рестартануть.

сам-то понял что сказал? неужели красношляпники все такие, как и этот бестолковый анон? смех, да и только.

SimonPhoenix ()
Ответ на: комментарий от Sith

Да я понял что про ноут, просто я вообще как пример.(сообщения читаю внимательно)

Я просто вот чего не понимаю: в предыдущей новости 10000 ядерный кластер работал под CO, почему? И во всех подобных новостях, он.

Ramzes001 ★★ ()

Хорошая новость, но...

обои скучные (це)

mir-inoy ★★ ()

долго они этот релиз рожали - ни прошло и полгода. Любопытно, что же их так затормозило ?

argin ★★★★★ ()
Ответ на: комментарий от Aman

4 года хостингу на дебианах. Ничего не падает. ЧЯДНТ?

И объясните, пожалуйста, зачем вам на шареде опенвз; а еще приведите пруфы «нестабильности» дебиановского опенвз (читать - реальные истории повреждения клиентских данных и/или простоя из-за этой «нестабильности»).

leave ★★★★★ ()
Ответ на: комментарий от Aman

Да, искал я как-то collectd для центоса. Нашел, кажется, на rpmforge. Вы меня извините, но я в самых смелых мыслях не могу представить, чем надо было упороться, чтобы в депенды впилить xmms. Первый, да.

leave ★★★★★ ()
Ответ на: комментарий от leave

>искал я как-то collectd для центоса. Нашел, кажется, на rpmforge

Дружище, ищи в следующий раз подобное на RPMSearch и смело ставь пакеты от Fedora 8, например... как yum localinstall... оно ж всё совместимое с федорыными, просто для версии федоры с таким же ядром выбирай и всё....

А вообще CentOS и Fedora - наше всё... остальное вторично и сильно красноглазо...

anonymous ()
Ответ на: комментарий от leave

>4 года хостингу на дебианах. Ничего не падает. ЧЯДНТ?

Я про падать ничего не говорил, наоборот заметил, что знаю 1 шаред на дебиане с отличными аптаймами. Даже при переезде в другой ДЦ, хоть и обещали 2 часа простоя, но его не было. А некоторые по суткам, а то двум держат даунтайм при переездах (известные личности, упоминать не буду). Про дебиан я просто заметил, что дольше делать инфраструктуру, чем на центос. Трудозатратней (сборка, тестирование недостающих пакетов). Если вы уже обкатали платформу, то конечно легче.

И объясните, пожалуйста, зачем вам на шареде опенвз

live migration, удобный бекап, удобно менять железо. Чисто административно. И быстро. Памяти хватает.

а еще приведите пруфы «нестабильности» дебиановского опенвз

openvz stable официально только на ядре 2.6.18. Есть патчи для 2.6.27 и 2.6.32, которые и использованы в дебиан, но официально (по позиции проекта openvz) они development, experemental. Реально я не нарывался, но и не тестировал (немного смотрел 2.6.32 и то на rhel), мне это не нужно. По практике знаю, что и в stable хватает вопросов, чем ещё с unstable ставить опыты.

Aman ()
Ответ на: комментарий от Aman

>openvz stable официально только на ядре 2.6.18.

и при этом прекрасно работает на 26ом чтоли в ленни. 50 впсок крутяться уже овер полгода.

tazhate ★★★★★ ()
Ответ на: комментарий от anonymous

>А вообще CentOS и Fedora - наше всё... остальное вторично и сильно красноглазо...

да уж, дебиан так красноглаз, так красноглаз

tazhate ★★★★★ ()
Ответ на: комментарий от Aman

>PS Я не фанатик, а очень даже реалист. Если мне покажут, как это делается на дебиан и что это лучше - с большим удовольствием буду юзать его.

невозможно крутейшее знание дарую тебе

apt-get install apache2 php5 libapache2-mod-php5 mysql-server nginx

чо те там исчо нада?

далее просто правишь настройки вхостов и вуаля %)

tazhate ★★★★★ ()
Ответ на: комментарий от IT-specialist

смысл им от твоего 10 лвл в 3 на 3?

anonymous ()
Ответ на: комментарий от tazhate

>невозможно крутейшее знание дарую тебе

apt-get install apache2 php5 libapache2-mod-php5 mysql-server nginx
чо те там исчо нада?

php 5.2.17, nginx - в lenny нет поддержки лимитов скоростей и кол-ва соединений. Для нормальных шаров на дебиан все компиляют, apt-get install не хватает, так что не надо.

Aman ()
Ответ на: комментарий от Aman

php 5.2.17 и php 5.3.2 - это две разные вещи, в первом десятилетия отставания от нормальных языков, а во втором - только года. И что делать, если мне вместо этого предложат php 5.2? Почему не 4.4?

nginx - в lenny нет поддержки лимитов скоростей и кол-ва соединений


В backports тоже? У меня и на squeeze и на lenny стоит одинаковая версия, 0.7.x.

Для нормальных шаров на дебиан все компиляют


Когда нужна гибкость, в debian её можно легко получить. В чём проблема. А многих устраивает apt-get install nginx. И да, стабильный релиз уже Squeeze, что вы всё Lenny да Lenny.

kid_lester ()
Ответ на: комментарий от kid_lester

>В backports тоже? У меня и на squeeze и на lenny стоит одинаковая версия, 0.7.x.

Я не знаю. Дело не в версии, а в том, как собрали. Там был какой-то конфликт и собрали без этих опций.

Когда нужна гибкость, в debian её можно легко получить.

Ну классно.

И да, стабильный релиз уже Squeeze, что вы всё Lenny да Lenny.

Во-первых не все ещё проапдейтились и пока в ближайших планах нет, во-вторых разговор задевал времена до сквиза.

Сипанели по деб нет :P

Aman ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.