LINUX.ORG.RU

Доступен CentOS 6.8

 ,


0

1

Представлен релиз дистрибутива CentOS 6.8, основанный на пакетной базе Red Hat Enterprise Linux 6.8. Выпуск поставляется для платформ i386 и x86_64 в виде DVD-сборки, минимального установочного образа (300 Мб) и сокращенного образа для установки по сети — netinstall.iso (200 Мб).

Пакеты SRPMS и debuginfo доступны через vault.centos.org. Пакеты из различных репозиториев RHEL, например, из серверной и из десктоп редакции, объединены в единый репозиторий пакетов и распространяются одним установочным комплектом. Дистрибутив на 100% бинарно совместим с RHEL, внесенные в пакеты изменения как правило сводятся к ребрендингу и замене художественного оформления.

Из изменений, внесенных в CentOS 6.8, можно отметить:

  • Реализация IPsec переведена с Openswan на Libreswan (поддержка добавлена в NetworkManager).
  • В SSSD добавлена поддержка аутентификации через смарткарты для системных входов и привилегированных операций (например, вызов sudo).
  • Максимальный размер файловой системы XFS увеличен со 100 до 300 Тб
  • Прекращена поддержка SSLv2. В OpenLDAP, yum, stunnel, vsftpd, Git и Postfix реализована поддержка TLSv1.2. Во многих пакетах использование TLSv1.2 включено по умолчанию.
  • Во многих приложениях появилась поддержка параметров эллиптических кривых, в том числе в Perl Net:SSLeay и Perl IO::Socket::SSL.
  • В dmidecode добавлена поддержка SMBIOS 3.0.0.
  • В kickstart добавлена поддержка загрузки файлов по HTTPS.
  • Добавлен пакет с системой синхронизации точного времени chrony.
  • Добавлен пакет squid34 с новым выпуском прокси-сервера Squid 3.4.14, который заменил собой пакет squid31.
  • В драйверы для работы под управлением Hyper-V добавлена поддержка хранилищ с 4096-байтовыми секторами, поддержка TRIM, поддержка 2-го поколения виртуальных машин, поддержка протоколов Windows 10 и Windows Server 2016.
  • Libreoffice обновлён до версии 4.3.7.2.
  • Обновлены версии пакетов elfutils, SystemTap, ipmitool, memtest86+, icedtea-web, shadow utils, virt-who, а также различных драйверов.
  • Объявлены устаревшими и могут быть удалены в следующих выпусках драйверы и пакеты: python-qmf, python-qpid, qpid-cpp, qpid-qmf, qpid-tests, qpid-tools, ruby-qpid, saslwrapper, 3w-9xxx, 3w-sas, 3w-xxxx, aic7xxx, i2o, ips, megaraid_mbox, mptbase, mptctl, mptfc, mptlan, mptsas, mptscsih, mptspi, sym53c8xx.
  • Переведены в разряд не поддерживаемых экспериментальные компоненты: openswan, seabios, Btrfs, eCryptfs, mingw, virtio-win, fence-agents, systemtap, matahari и openscap.
  • Изменено содержимое 32 пакетов, среди которых anaconda, dhcp, firefox, gnome-applets, gnome-desktop, httpd, initscripts, ipa, kde-settings, kernel, ntp, thunderbird, xorg-x11-server, yum и zsh.
  • Удалено 30 пакетов, присутствующих в RHEL, среди которых libehca, libservicelog, lsvpd, libvpd, openssl-ibmca, powerpc-utils, ppc64-diag, ppc64-utils, python-rhsm, redhat-*, rhn-*, servicelog, s390utils, yaboot, yum-rhn-plugin.

>>> Подробности

★★★

Проверено: Klymedy ()

Libreoffice обновлён до версии 4.3.7.2.

Новость точно не про Debian?

Promusik ★★★ ()

Переведены в разряд не поддерживаемых экспериментальные компоненты:

Btrfs

А она до сих пор экспериментальная?

unixnik ★★★★ ()

Екриптфс-то за что? Чем она не угодила?

sT331h0rs3 ★★★★★ ()

поддержка протоколов Windows 10 и Windows Server 2016.

Must die.

anonymous ()

Перепись некрофилов ITT. Зачем нужен сабж, если уже давно седьмая версия есть?

border-radius ()
Ответ на: комментарий от border-radius

Наверное, потому, что еще используется 70% rhel 6

int13h ★★★★★ ()
Ответ на: комментарий от Promusik

Это лохматый centos 6. Для любителей новизны давно уже вышла 7 версия.

AVL2 ★★★★★ ()
Ответ на: комментарий от Desmond_Hume

Если в продакшене 6, и многое завязано, например, именно на инит, то переход на 7 версию очень трудозатратен.

sT331h0rs3 ★★★★★ ()
Ответ на: комментарий от Desmond_Hume

На седьмую всех жаба душит перезжать. Ну и реакции всякие физиологические круговых мышц в рядах мэнэджмента зачастую тоже имеют некоторую роль.

pon4ik ★★★★ ()
Ответ на: комментарий от border-radius

Спроси еще зачем нужна пятая, арчешкольник, блин :).

mandala ★★★ ()
Ответ на: комментарий от mandala

Пятая вообще ненужна, так что не спрашиваю. Прогрессофоб, блин.

border-radius ()
Ответ на: комментарий от sT331h0rs3

Если в продакшене 6, и многое завязано, например, именно на инит, то переход на 7 версию очень трудозатратен.

Если это трудозатратно, значит такой «продакшен» создавался и поддерживается студентотой на практике.

Siado ★★★★★ ()
Ответ на: комментарий от border-radius

Это ты свой десктоп можешь хоть ежесекундно обновлять. А в продакшене, когда у тебя всё настроено и отлажено, не просит жрат и поддерживается апстримом - даже думать о каких-то апргрейдах нельзя. Тем более что CentOS 7 слишком другой, и просто так на него не переползёшь.

Sunderland93 ★★★★★ ()
Ответ на: комментарий от border-radius

Скорее перепись школия, требующего чтоб было стильно, модно и молодёжно. И не подозревающего, что некоторым просто работать надо.

Diff ★★★ ()
Последнее исправление: Diff (всего исправлений: 2)
Ответ на: комментарий от Sunderland93

даже думать о каких-то апргрейдах нельзя

Во-о-о-от. Если думать о каких-то апгрейдах нельзя, то на кого рассчитана эта новая старая версия?

Новые проекты начинаются уже на седьмой. Старые остаются на шестой определённой версии, ибо думать о каких-то апгрейдах нельзя и вообще бтрфс отвалится. Зачем вот это вот?

border-radius ()
Последнее исправление: border-radius (всего исправлений: 2)
Ответ на: комментарий от border-radius

Во-о-о-от. Если думать о каких-то апгрейдах нельзя, то на кого рассчитана эта новая старая версия?

Я о переходе на 7 версию говорил. А сабж - лишь плановое обновление.

Sunderland93 ★★★★★ ()
Ответ на: комментарий от Sunderland93

ИМХО, как минимум отвал btrfs и ecryptfs - слишком смело для планового обновления. Ну и да, без сторонних реп всё как-то слишком тухло.

border-radius ()
Ответ на: комментарий от border-radius

Ну насчёт ecryptfs ещё ладно, но Btrfs? В продакшене? В статусе эксперементальной (в сабже)?

Sunderland93 ★★★★★ ()
Ответ на: комментарий от sT331h0rs3

Если в продакшене 6, и многое завязано, например, именно на инит, то переход на 7 версию очень трудозатратен.

systemd-sysv-install

anonymous ()
Ответ на: комментарий от Sunderland93

Нет, я не видел в продакшне серваков с физически размеченными дисками с бтром. Видел XFS и эксты. Но вот монтируемые образы были всякие, в том числе и бтры.

border-radius ()
Ответ на: комментарий от border-radius

Сколько не пробовал приручить в продакшене btrfs - всё всегда с ним было плохо. Всегда наступает момент, когда файловая система превращается в тыкву. Пробовал в куче разных дистрибутивов, с самыми разными версиями ядер - от 2.6.x до 4.4. Судя по ченджлогам в каждой новой версии ядра - BTRFS до стабильного юзабельного состояния нужно ещё года 3, не меньше.

anonymous ()

Последняя нормальная центось

leg0las ★★★★★ ()
Ответ на: комментарий от sT331h0rs3

Не только это, например некоторые приложения официально поддерживают RHEL только до 6 (у нас в конторе например JBoss Fuse) и если придти к вендору с багом, то он скажет тебе «у вас неподдерживаемая ОС, вы ссзб».

Hater ★★ ()
Последнее исправление: Hater (всего исправлений: 1)
Ответ на: комментарий от Sunderland93

А в продакшене, когда у тебя всё настроено и отлажено, не просит жрат и поддерживается апстримом - даже думать о каких-то апргрейдах нельзя.

золотые слова

gray ★★★★★ ()
Ответ на: комментарий от sT331h0rs3

Я, кстати, на виртуалках с 7 регулярно вижу кернел паник там, где 6 просто работает.

Diff ★★★ ()
Ответ на: комментарий от border-radius

как минимум отвал btrfs и ecryptfs - слишком смело для планового обновления

Какой дурак на CentOS стал бы в продакшене это использовать? Ну хватит уже своими школьными мерками весь мир охватывать

anonymous ()

по списку изменений - как будто перепотрошили 6-й центос
в любом стандартном дистрибутиве можно выкидывать десятки пакетов - и никто не заметит

kto_tama ★★★★★ ()
Ответ на: комментарий от Promusik

Новость точно не про Debian?

Это точно не opennet?

fixed!

soko1 ★★★★★ ()
Ответ на: комментарий от sT331h0rs3

К анонсу очередного релиза центось 7 говорилось что выпилили потому что устарело типа

soko1 ★★★★★ ()
Ответ на: комментарий от border-radius

Это как спросить «зачем WinXP, если уже Win10»? Себе на компьютер ты всегда можешь поставить что хочешь и это не займёт много времени, а есть сферы где обновлять то что работает и работает хорошо - дорого и не рационально. Именно поэтому и выбирают CentOS - поставил и можно забыть на 10 лет.

soko1 ★★★★★ ()
Ответ на: комментарий от Desmond_Hume

Для продакшена, речь идёт о том что уже работает в продакшене.

soko1 ★★★★★ ()
Ответ на: комментарий от soko1

Если обновлять дорого и нерационально, для кого эта 6.8? Повторюсь: новые проекты пилят на седьмой, старые остаются там, где были.

border-radius ()
Ответ на: комментарий от leg0las

А что в новой не так (кроме личной неприязни к systemd)?

ЗЫ не ради спора, действительно интересно просто твоё мнение

soko1 ★★★★★ ()
Последнее исправление: soko1 (всего исправлений: 1)
Ответ на: комментарий от border-radius

Если обновлять дорого и нерационально, для кого эта 6.8?

Обновлять дорого и нерационально бегая от старой ветке к новой, а не вообще обновлять. Обновлять всё и всегда нужно, но в продакшене нужно обновлять софт лишь если это секъюрити фиксы, либо очень серьёзные баги, а не выход новой версии, которая конфликтует со старой.

Повторюсь: новые проекты пилят на седьмой, старые остаются там, где были.

Ну так мы о том тебе и говорим :)

soko1 ★★★★★ ()
Ответ на: комментарий от soko1

Если отвал двух ФС - это не конфликт со старой, то что тогда, по-твоему, конфликт?

border-radius ()
Ответ на: комментарий от border-radius

отвал двух ФС

Которые там были экспериментальные и более не будет производиться бекпортирование. Не тупи.

mandala ★★★ ()
Ответ на: комментарий от mandala

Какая разница? Фича была. Теперь её нет. Обновление местные оналитеги преподносят как минорное. Нигде подвоха не наблюдается?

border-radius ()

Python так и остался 2.6.6. Чертовы некрофилы.

anonymous ()
Ответ на: комментарий от border-radius

Экспериментальная фича не рекомендованная для повседневного использования. Т.е. ни кто в здравом уме на 6-ке бтрфс кроме как для тестов не использует.

mandala ★★★ ()
Ответ на: комментарий от soko1

Веселый systemd и веселый nm. крайне угребищное (с точки зрения админства) управление. К счастью, большинство серверов на центосе, что мне приходится админить идут на 6-й версии.

leg0las ★★★★★ ()
Ответ на: комментарий от Diff

Скорее перепись школия, требующего чтоб было стильно, модно и молодёжно. И не подозревающего, что некоторым просто работать надо

Оно и видно, как вы работаете: то ботнет найдут на сотни машин, то компрометация одна за другой. Работайте дальше, некрофилы. Такие профи прям, и у каждого диплом. Только цена копейки таким профи и дипломчикам.

dt45pt ()
Ответ на: комментарий от Diff

Я, кстати, на виртуалках с 7 регулярно вижу кернел паник там, где 6 просто работает.

И таким дают дипломы? Продакшен системы тестить на виртуалке? Там на твоем дипломе нет надписи «Оторожно! Специалист!»?

dt45pt ()
Ответ на: комментарий от soko1

Это как спросить «зачем WinXP, если уже Win10»?

Объясни это банкам, чьи онлайн сервисы связанные с деньгами и кредитными картами не работают, если заходишь из под XP, специалист ты наш.

dt45pt ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.