LINUX.ORG.RU

CentOS 5.5

 , ,


0

0

Минувшей ночью в списке рассылки CentOS-announce было официально объявлено о выходе нового обновления данного дистрибутива — 5.5.

CentOS является бесплатной версией промышленного дистрибутива Red Hat Enterprise Linux (RHEL) и на 100% бинарно совместим с ним. Но в отличие от RHEL, для которого бинарные обновления предоставляются только на время ознакомительного срока либо при наличии контракта на поддержку, CentOS не ограничивает доступ к бинарным обновлениям.

CentOS 5.5 наследует все улучшения, введенные в RHEL 5.5. С их полным списком можно ознакомиться в новости о выходе RHEL 5.5. Кратко напомню наиболее интересные моменты:

  • Улучшенная поддержка оборудования. Обновлены драйвера для ряда проводных (vxge, be2net, enic, qlge, tg3, igb, ixgbe, e1000, netxen, bnx2x, bnx2, bnx2i, r8169) и беспроводных (iwlwifi, rt2x00, ath9k) сетевых карт, контроллеров устройств хранения (qla2xxx, hptiop, lpfc, mpt2sas, mptque, megaraid_sas). Реализована поддержка новых платформ и процессоров. Обновлена ALSA.
  • Улучшения средств виртуализации. Доработана поддержка аппаратных технологий проброса PCI-устройств в гостевые окружения (Intel VT-d и AMD IOMMU). В libvirt реализовано управление доступом гостей к HugeTLBfs.
  • Улучшен инсталлятор (anaconda). Исправлен ряд ошибок, добавлена поддержка новых устройств хранения.
  • Расширена поддержка SystemTap. Добавлены новые трассировочные вызовы (tracepoints), возможен запуск из-под непривилегированного пользовательского аккаунта.
  • Значительно увеличена эффективность планировщика ввода-вывода CFQ.
  • Новая Samba с улучшенной поддержкой новых версий Windows (2008, Vista, 7) и возможностью развертывания кластеров.
  • Добавлены пакеты для PostgreSQL 8.4 и FreeRADIUS 2.

Обновление может быть выполнено следующими командами:

yum clean all
yum update glibc\*
yum update yum\* rpm\* python\*
yum clean all
yum update
shutdown -r now

Несколько технических замечаний по возможным проблемам при установке и обновлении:

  • Если вы используете проприетарный драйвер nvidia, перед обновлением рекомендуется заменить его на nv, а после завершения обновления — переустановить его.
  • Также к проблемам при обновлении на платформе x86_64 может привести наличие установленного VirtualBox 3.1.6.
  • Во время установки с CD/DVD не пытайтесь использовать репозитарий extras.

>>> CentOS 5.5 release notes

★★★★

Проверено: maxcom ()

Отличная новость.
А всё-таки интересно, как полуается бэкпортировать функционал новейших ядер в 2.6.18?

some-body ★★ ()

> Во время установки с CD/DVD не пытайтесь использовать репозитарий extras.

Уже сколько лет одни и те же глюки... Небось еще и русский инсталлятор падает перед установкой?

> Значительно увеличена эффективность планировщика ввода-вывода CFQ.

В ванильном ведре ведь тоже должно быть?

Werehuman ★★ ()
Ответ на: комментарий от Werehuman

>Уже сколько лет одни и те же глюки

ынтерпрайз же

registrant ★★★★★ ()

Обновление может быть выполнено следующими командами:

yum clean all 
yum update glibc\* 
yum update yum\* rpm\* python\* 
yum clean all 
yum update 
shutdown -r now 

Давно не касался rpm-дистрибутивов - этот подходи справедлив для обновления версий всех redhat-based дистрибутивов?

alex-w ★★★★★ ()

Scientific Linux 5.5 давно вышел

Чуть ранее, 13.05.2010 вышел Scientific Linux 5.5 (другая ветвь RHEL), но информацию об этом никто не заметил, так как настоящие учёные не бьют себя копытом в грудь, а тихо сидят на верхней ступеньке стремянки в самом пыльном углу библиотеки и лихорадочно листают первоисточник.

Образы Scientific Linux 5.5 размещены по адресу http://ftp.scientificlinux.org/linux/scientific/5rolling/iso/ Вероятно, чуть позже они будут без помпы и литавроуведомлений перемешены сюда: http://ftp.scientificlinux.org/linux/scientific/55/

Chelovechek ()

отличная новость, жаль, что до 6-ой centOS еще как минимум пол-года/год (roadmap на данный момент не смотрел)

real_maverick ★★★ ()
Ответ на: комментарий от alex-w

>Давно не касался rpm-дистрибутивов - этот подходи справедлив для обновления версий всех redhat-based дистрибутивов?

Для федоры вроде бы preupgrade рекомендуют.

anonymous ()
Ответ на: комментарий от alex-w

> Давно не касался rpm-дистрибутивов - этот подходи справедлив для обновления версий всех redhat-based дистрибутивов?

да в общем-то достаточно yum update (4.x=>5.0=>5.1=>5.2=>5.3=>5.4 без проблем), но подход разумный - можно рекомендовать и для apt-get&deb тоже.

> Если вы используете проприетарный драйвер nvidia, перед обновлением рекомендуется заменить его на nv, а после завершения обновления — переустановить его.


достаточно загрузится с init level 3 и перекомпелировть в консоле модуль, естествено, предварительно скачав его, если удалили старый :)

fi ★★★ ()

>yum clean all
>yum update glibc\*

>yum update yum\* rpm\* python\*

>yum clean all

>yum update


по сравнению с
apt-get dist-upgrade
выглядит как шаманство)

goingUp ★★★★★ ()
Ответ на: комментарий от goingUp

If you are already running CentOS-5.4 or an older CentOS-5 distro, all you need to do is update your machine via yum by running :

'yum update'

anonymous ()

После обновления slapd решил слушать только ldaps:// — в новой версии появились дополнительные параметры в /etc/sysconfig/ldap. В остальном обновил уже две машины без каких-либо проблем.

Praporshik ★★ ()

ждём centos 6 и смело ставим на дескоп.

cetjs2 ★★★★★ ()

В состав дистрибутива RHEL/CentOS 5.5 включен дополнительно к имеющемуся PostgreSQL 8.1.6 новый PostgreSQL 8.4.2.

Решил перейти на PostgreSQL 8.4.2. - щаз:

* php собран с 8.1.6; с 8.4.2 не работает.

* pgadmin3 из epel собран с 8.1.6; с 8.4.2 не работает и т.д.

Все ПО, входящее в состав дистрибутива и использующее PostgreSQL, собрано с 8.1.6 и с 8.4.2 не работает.

Т.е. переходить на PostgreSQL 8.4.2 можно только при условии, что сервер работает только в качестве сервера баз данных, иначе поломаете весь дистрибутив, если решите пересобирать все необходимые пакеты.

Может кому пригодится: HOWTO: Обновление PostgreSQL 8.1 на 8.4 в CentOS 5.5

lystor ★★ ()
Ответ на: комментарий от fi

> достаточно загрузится с init level 3

Вообще то если еще чуть подумать то просто обновление нужно делать сразу в инит3, а в конце да ./NV*run ;)

mx__ ★★★ ()

Отличная новость, довольно оперативно выпустили.

ostin ★★★★★ ()
Ответ на: комментарий от mx__

>Вообще то если еще чуть подумать то просто обновление нужно делать сразу в инит3, а в конце да ./NV*run ;)

А если еще подумать можно использовать интел и не париться с драйвером.

anonymous ()
Ответ на: комментарий от fi

> 4.x=>5.0=>5.1=>5.2=>5.3=>5.4 без проблем

Извини, не верю. Точнее, не верю в то, что «4.x=>5.0 без проблем» с учетом слов из Scientific Linux 5 release notes насчет обновления с 4.x — «yum is known not to work». При этом рекомендуется (и без проблем отрабатывает) обновление анакондой с инсталяционного носителя (либо анакондой же по сети). И само собой, работает обновление yum'ом в пределах мажорной версии

dexpl ★★★★★ ()
Ответ на: комментарий от alex-w

> этот подходи справедлив для обновления версий всех redhat-based дистрибутивов?

В целом, да - yum update, прописывание новых репозиториев, yum update, проверки, reboot. Я так апдейтил федору с 10 до 12

no-dashi ★★★★★ ()

VirtualBox 3.1.6.

Откуда там такой свежак?

aydar ★★★★★ ()
Ответ на: комментарий от no-dashi

>В целом, да - yum update, прописывание новых репозиториев, yum update, проверки, reboot. Я так апдейтил федору с 10 до 12

Переход был 10->12 или 10->11->12? И простым yum update'ом?

alex-w ★★★★★ ()
Ответ на: комментарий от dexpl

> Точнее, не верю в то, что «4.x=>5.0 без проблем»

Да, погорячился. Точнее: действительно делал 4.x=>5.0, но с анакондой, забывать стал.:)

А далее через yum

> Вообще то если еще чуть подумать то просто обновление нужно делать сразу в инит3, а в конце да ./NV*run ;)


Мне совсем не мешало в отдельном konsole - это ж не виндоус! а сам занимался своими делами.


fi ★★★ ()

мерси за новость, обновился всегда питал слабось к красной шапке 4 сервака на ней вертеться

bsd_admin ()
Ответ на: комментарий от goingUp

> по сравнению с apt-get dist-upgrade выглядит как шаманство)

не пробовали с lenny на squeeze обновиться? вполне себе занятное дело на десктопе по моему опыту.

AnViar ()
Ответ на: комментарий от alex-w

> или 10->11->12

Переход 10->12 чисто технически невозможен по некоторым причинам, так что 10->11->12

no-dashi ★★★★★ ()
Ответ на: комментарий от AnViar

Да, можно случайно муху проглотить, или челюсть вывихнуть. :)

jungleace ()
Ответ на: комментарий от no-dashi

> Переход 10->12 чисто технически невозможен

Посредством yum update — может и не возможен (не пробовал; кстати, можно вкратце о причинах?), при помощи preupgrade — вполне, самолично делал. Правда, у меня почти дефолтная инсталляция десятки на домашнем локалхосте была

dexpl ★★★★★ ()

Ну-ка, ну-ка, что там они улучшили с Самбой?
Неужто 4.0 выросла из коротких штанишек и ее включили в дистр, и теперь одной левой можно ваять полноценные вин-домены?

chukcha ★★ ()
Ответ на: комментарий от chukcha

Да - и куда подевался yum-basearchonly ?

Без него вечно норовит установиться всякая срань.

chukcha ★★ ()
Ответ на: комментарий от chukcha

> Да - и куда подевался yum-basearchonly?

Включен в yum, нет?

dexpl ★★★★★ ()
Ответ на: комментарий от chukcha

>Да вот как раз и нету :(

Где именно нету? На последних федорах он как раз уже не нужен кажись.

anonymous ()

не нужен.

Все равно в районе 5.3 в новой глибс сломалась вмварь-сервер.

А кроме как для вмвари оный дистр полный старья не сдался.

AVL2 ★★★★★ ()

> Улучшения средств виртуализации. Доработана поддержка аппаратных технологий проброса PCI-устройств в гостевые окружения (Intel VT-d и AMD IOMMU).

периферийных, а не PCI наверное? PCI уже давно заменена на PCI-Express в качестве основной системной шины. Когда это разрабы железа успели IOMMU добавить? такой момент проспал, теперь и драйвера друг другу в тапки не насрут, и проблем с выделением сплошного куска в раме не будет.

filin ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.