LINUX.ORG.RU

Вышел Red Hat Enterprise Linux 5.5

 , ,


0

0

Компания Red Hat выпустила дистрибутив Red Hat Enterprise Linux 5.5. Это дистрибутив, нацеленный на корпоративное использование, его особенность - наличие коммерческой поддержки. Основные изменения и новшества:

  • Исправлены ошибки в системе инсталляции Anaconda.
  • Расширены средства отладки в системе автоматической установки Kickstart.
  • Добавлена поддержка инсталлятором некоторых устройств (PMC Sierra MaxRAID, Power6 Virtual FC, Brocade Fibre Channel, ServerEngines BladeEngine 2).
  • Улучшения в сфере виртуализации (перераспределение памяти на лету для гостевых окружений KVM, улучшение поддержки прямого проброса PCI-устройств внутрь гостевых окружений KVM и Xen).
  • Поддержка ядром новых платформ Intel Boxboro-EX, Intel Boxboro-MC и новых серий процессоров AMD Magny-Cours и IBM Power7.
  • Реализован механизм для выявления зависших процессов, находящихся в непрерываемом состоянии сна (D-State), что ранее приводило к невозможности корректной остановки системы.
  • Все модули s390 для Linux ядра в составе RHEL 5 теперь снабжены цифровой подписью.
  • Добавлена поддержка нового оборудования и обновлены следующие драйверы: управляющие процессоры HP iLO/iLO2 (hpilo), SMBus-контроллеры SB900 (i2c), Mellanox ConnectX HCA InfiniBand (mlx4), значительно улучшена поддержка HD Audio (ALSA).
  • Улучшена поддержка сетевых устройств и устройств хранения: Solarflare, Neterion X3100 10GbE, ServerEngines BladeEngine2 10Gbps, Cisco 10G Ethernet, QLogic 10 Gigabit PCI-E ethernet, QLogic Fibre Channel HBA, Broadcom Tigon3 ethernet, Intel Gigabit Ethernet, Intel 10 Gigabit PCI Express, Intel PRO/1000, NetXen Multi port (1/10) Gigabit Network, Broadcom Everest, Broadcom NetXtreme II, RealTek 8169 ethernet, QLogic Fibre Channel Host Bus, HighPoint RocketRAID 3xxx/4xxx, Emulex Fibre Channel Host Bus, LSI SAS-2, LSI Fusion MPT, LSI MegaRAID SAS.
  • Улучшения работы планировщика CFQ в плане производительности (автоматическое выявление и объединение близких очередей).
  • Новая опция монтирования GFS2 разделов «errors=», которая позволяет игнорировать ошибки ввода/вывода или вызывать панику.
  • Улучшена поддержка CIFS.
  • Поддержка ядром новых трассировочных вызовов SystemTap (аналог DTrace для Solaris).
  • Valgrind обновлён до версии 3.5.0, обновления OpenOffice.org (добавлена поддержка формата Microsoft Office 2007 OOXML), Metacity, Samba (добавлена возможность развертывания кластерных конфигураций, позволяющих организовать работу нагруженных файловых серверов распределенных на несколько машин, и улучшена совместимость с ОС Windows 2008, Windows 2008 R2 server, Windows Vista и Windows 7).
  • В дистрибутив включен пакет с FreeRADIUS 2.0. FreeRADIUS 1.x по прежнему остается базовым RADIUS-сервером

Источник

>>> Подробности



Проверено: hibou ()

День мегарелизов на ЛОРе. Ну почему, почему сегодня не пятница?

Insomnium ★★★★ ()

Ну что-же. Ждём CentOS. И получаем самый стабильный, самый юзабельный, самый энтерпрайзный, самый негиковский, самый приспособленный для простого использования дистриб. Хвала RedHat.

HoBu4eK ()
Ответ на: комментарий от Insomnium

До пятницы еще что-нибудь выйдет, тогда и отметив за всё сразу.

да, ждем'с centos55, хотя 5.4 я ставил еще из оригинального rhel

fi ★★★ ()
Ответ на: комментарий от HoBu4eK

С самым кривым пакетным манагером в истории. %)

Сделайте yum install krb5-devel на x86_64 и посмотрите на результат.

different ()
Ответ на: комментарий от HighwayStar

его можно легально использовать не покупая поддержку? как sles

HighwayStar ★★★★★ ()
Ответ на: комментарий от Dimez

> Можно.

А смысл? Или у них бинарные апдейты уже раздаются всем жедающим и не входят в техподдержку? Если нужен бесплатный редхат (ИМХО), стоит посмотреть CentOS или другие клоны.

sabbakka ★★ ()
Ответ на: комментарий от markevichus

Точно не знаю, ни разу не использовал (там, где rhel не купленный, сразу до соответствующей версии centos обновлял), но вроде как да.

Dimez ★★★★★ ()
Ответ на: комментарий от sabbakka

ставишь сейчас, 60 дней получаешь обновления, затем переходишь на centos 5.5 - тому времени они уже выпустят.

Впрочем я как сидел на 5.4, так и буду, пока centos 5.5 готовят - у меня все работает и так :)

fi ★★★ ()
Ответ на: комментарий от fi

Ну и какой в том смысл? Не проще ли сразу CentOS поставить, когда выпустят?

sabbakka ★★ ()
Ответ на: комментарий от anonymous

Окей, возьмем xulrunner на безиксовой машине.

Получаем:

xulrunner i386 1.9.0.18-1.el5_4

xulrunner x86_64 1.9.0.18-1.el5_4

И за одно все его зависимости, тоже в двух вариантах. Т.е. срач в системе. А все потому, что yum не научили разделять репы на архитектуры.

different ()
Ответ на: комментарий от different
Installed:
  krb5-devel.i386 0:1.6.1-36.el5_4.1                                          krb5-devel.x86_64 0:1.6.1-36.el5_4.1                                         

Dependency Installed:
  e2fsprogs-devel.x86_64 0:1.39-23.el5 keyutils-libs-devel.x86_64 0:1.2-1.el5 libselinux-devel.x86_64 0:1.33.4-5.5.el5 libsepol-devel.x86_64 0:1.15.2-2.el5

Complete!
# uname -srm
Linux 2.6.18-164.15.1.el5 x86_64

и?

kostian ★★★★☆ ()
Ответ на: комментарий от Dimez

Читал, не надо понтов.

Это не решение, а воркэраунд. А если пакетов 10? А если 50?

different ()
Ответ на: комментарий от different

>Это не решение, а воркэраунд. А если пакетов 10? А если 50?
написать скрипт или плакать и требовать гуй.

dimon555 ★★★★★ ()
Ответ на: комментарий от dimon555

написать скрипт или плакать и требовать гуй.

А он уже написан:

$ yum info yum-basearchonly
Loaded plugins: rhnplugin, security
Available Packages
Name       : yum-basearchonly
Arch       : noarch
Version    : 1.1.10
Release    : 9.el5
Size       : 9.7 k
Repo       : rhel-x86_64-server-5.4.z
Summary    : Yum plugin to let Yum install only basearch packages.
License    : GPL
Description: this plugin makes Yum only install basearch packages on multiarch systems.
           : If you type 'yum install foo' on a x68_64 system, only 'foo-x.y.x86_46.rpm' is installed.
           : If you want to install the foo-x.y.i386.rpm, you have to type 'yum install foo.i386'.
           : The plugin only works with 'yum install'.

mv ★★★★★ ()
Ответ на: комментарий от dimon555

Dimez! Молодец. А то я уж сам хотел молодняк мордой потыкать :)

А если пакетов 10? А если 50?

Что занчит 50 ? Ты их как будешь в строку инсталл то писать ? тоже через
гуй ? А если это камень в сторону зависимостей то можешь не писать
при ххх.i386 токо 386 притянутся !

mx_ ()
Ответ на: комментарий от Dimez

>>http://www.redhat.com

По ссылке не ходил :) но на сколько я знаю, редхат уже лет 5 как не выкладывает iso-шки со своим линуксом в открытый доступ.

bigfrogg ()
Ответ на: комментарий от different

> Сделайте yum install krb5-devel на x86_64 и посмотрите на результат.
Сделал, могу показать выхлоп, всё штатно без подвохов. Что необычного я должен увидеть?

Lumi ★★★★★ ()
Ответ на: комментарий от different

> Это не решение, а воркэраунд. А если пакетов 10? А если 50?
Тебе это чем-то мешает?

Lumi ★★★★★ ()
Ответ на: комментарий от Lumi

Что необычного я должен увидеть?

Наверное, очередного манонечитателя. Но, разве, это что-то необычное на ЛОРе?..

mv ★★★★★ ()
Ответ на: комментарий от mv

Вдруг красная пелена в моих глазах заслоняет жестокую правду жизни. Так и умру непосвещённым.

Lumi ★★★★★ ()
Ответ на: комментарий от bigfrogg

Выкладывает. Надо только сделать 2 вещи:
1) зарегистрироваться в rhn
2) активировать подписку на rhel.

Dimez ★★★★★ ()
Ответ на: комментарий от Dimez

Костыль. Почему в debian/gentoo/arch я могу сказать например «apt-get install gcc make openssl openssl-devel krb5-devel libc-client libc-client-devel libastral-devel», а в centos приходиться извращаться и скриптовать очевидную задачу? Это теперь считается нормальным?

А он уже написан:

Отлично, но в базовой поствке его нет и в системе срач.

требовать гуй

Зачем?

Тебе это чем-то мешает?

Мешает. Либо необходимостью совершать лишние телодвижения (установка доп. пакетов, скриптование), либо срачем в системе.

Я _знаю_ как этого избежать, вопрос сейчас НЕ ОБ ЭТОМ. Еще все умеют ядро пересобирать, дык давайте будем ядра кривые поставлять? Для примера.

different ()
Ответ на: комментарий от sabbakka

> Не проще ли сразу CentOS поставить, когда выпустят?

Ну когда я ставил 5.4, CentOS еще не было, а работать надо. С 5.3 возится уже не хотелось - комп был совсем свежий, да и виртуализация требовалась.

fi ★★★ ()
Ответ на: комментарий от different

> Костыль. Почему в debian/gentoo/arch я могу сказать например «apt-get install gcc make openssl openssl-devel krb5-devel libc-client libc-client-devel libastral-devel»,

ой не надо!!! до сих с содроганием вспоминаю 64 debian и 32-битные приложения, в то время когда в rh просто ставились по две рпм под 32 и 64.

fi ★★★ ()
Ответ на: комментарий от different

> Это не решение, а воркэраунд. А если пакетов 10? А если 50?

А может не надро звиздеть? В федоре yum, если не указана архитектура, выбирает пакет, совпадающий с архитектурой системы.

no-dashi ★★★★★ ()
Ответ на: комментарий от no-dashi

В федоре - возможно.

В CentOS к установке библиотек и devel-пакетов предлагаются пакеты для обеих архитектур, что я продемонстрировал выше.

different ()
Ответ на: комментарий от different

И за одно все его зависимости, тоже в двух вариантах. Т.е. срач в системе. А все потому, что yum не научили разделять репы на архитектуры.

# yum install krb5-devel
[..]
==============================================================================================================================
 Package                              Arch                    Version                          Repository                Size
==============================================================================================================================
Installing:
 krb5-devel                           x86_64                  1.7.1-6.fc12                     updates                  1.1 M
Installing for dependencies:
 keyutils-libs-devel                  x86_64                  1.2-6.fc12                       fedora                    29 k
 libcom_err-devel                     x86_64                  1.41.9-7.fc12                    updates                   35 k
 libselinux-devel                     x86_64                  2.0.90-5.fc12                    updates                  134 k
 libsepol-devel                       x86_64                  2.0.41-3.fc12                    updates                   64 k

Transaction Summary
==============================================================================================================================
Install       5 Package(s)
Upgrade       0 Package(s)

Total download size: 1.3 M
Installed size: 2.4 M
Is this ok [y/N]:

# uname -r
2.6.32.10-90.fc12.x86_64

Не центось, но тем не менее. Худеем, товарищ.

anonymous ()
Ответ на: комментарий от different

и это правильно :)

так было задумано, это удобно, это работает.

fi ★★★ ()
Ответ на: комментарий от different

> В CentOS к установке библиотек и devel-пакетов предлагаются пакеты для обеих архитектур, что я продемонстрировал выше.
И что не так?
Ты прямо глаза всем открыл. Как до тебя жили, не представляю даже.

Lumi ★★★★★ ()
Ответ на: комментарий от no-dashi

А может не надро звиздеть? В федоре yum, если не указана архитектура, выбирает пакет, совпадающий с архитектурой системы.

Это относительно недавно так стало. Собственно, basearch сейчас и не нужен... ;)

mv ★★★★★ ()
Ответ на: комментарий от different

Это вроде называется Multilib, причем очень грамотно реализованный. Суть в том, что при можно спокойно ставить i386 rpmки без проблем с зависимостями.

Все очень просто - на RHEL/Centos/Fedora ты легко можешь продключить тот-же yum i386 репозиторий с Wine и простой коммандой yum install wine установить его и все что он для себя требует.

codoranro ()

Красиво. Радует улучшение совместимости.

Jayrome ★★★★★ ()
Ответ на: комментарий от codoranro

Это я знаю и это нормально.

Не вполне нормальным мне кажется то, что _по_умолчанию_ ставятся пакеты чужой архитектуры. Впрочем.. на вкус и цвет пакетные манагеры разные, ок.

different ()
Ответ на: комментарий от different

Не вполне нормальным мне кажется то, что _по_умолчанию_ ставятся пакеты чужой архитектуры.

А это не чужая архитектура.

mv ★★★★★ ()

А в нём всё ещё нужно лазить по варезникам^W поисковикам rpm-ов, чтобы поставить довольно известные программы? А то, помню, достался мне сервер с центосом - жуть, даже rpm-ок для xapian-а нет. То ли дело дебиан - там почти всё есть.

anonymous ()
Ответ на: комментарий от anonymous

То ли дело дебиан - там почти всё есть.

Кроме поддержки 24x7 ;) А ещё любят ничего не делающие функции в программах убирать.

mv ★★★★★ ()
Ответ на: комментарий от anonymous

> А в нём всё ещё нужно лазить по варезникам^W поисковикам rpm-ов, чтобы поставить довольно известные программы? А то, помню, достался мне сервер с центосом - жуть, даже rpm-ок для xapian-а нет. То ли дело дебиан - там почти всё есть.

Товарисч. Зайди на http://xapian.org/download и просветись, прежде чем троллить.

Dimez ★★★★★ ()

Исправлены ошибки в системе инсталляции Anaconda.

Круто, млин. Столько лет системе, а они это гавно до сих пор дофиксить не могут.

Sekai ()
Ответ на: комментарий от mv

>Кроме поддержки 24x7 ;) А ещё любят ничего не делающие функции в программах убирать.

То-то в postfix в дебиане есть mysql и pgsql, а в центосе нет:)

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.