LINUX.ORG.RU

Вышел Wine 1.1.42

 


0

0

Основные изменения:

  • Реализована поддержка смешанных (32/64-бит) инсталляторов
  • Добавлена поддержка TIFF в WinCodecs
  • Улучшения в поддержке Internet Explorer
  • Улучшения в поддержке Direct3D (реализованы такие функции как D3DXCreateEffectCompiler, D3DXLoadVolumeFromMemory и т.д.)
  • Улучшения связанные с MSI
  • Исправлены ошибки при запуске/установке/работе таких программ, как: Lord of the Rings Online, Civilization 4, Atlantica и многих других

>>> Подробности

★★★★★

Проверено: mono ()

Ответ на: комментарий от AlexM

>Насколько мне говорили, это такой наколенный p2p, в который популярно складывать разное, м-м-м, всякое. Истинному любителю няшных мультфильмов без неё не жить.

что, выкладывают больше, чем на торрентах?

registrant ★★★★★ ()
Ответ на: комментарий от AlexM

>Ну, намедни у бухгалтера развалилась винда, после чего вожди решили полностью её под линукс пересадить. Собственно, почти получилось (ну, с купленным Wine@Etersoft), но вот банк-клиент сходу не завёлся.

а мы поставили виртуалку для 1с интернет-банка и такском-спринтера с рефрентом. Довольнг удобно, поскольку можно обращаться с разных мест.

AVL2 ★★★★★ ()
Ответ на: комментарий от registrant

>что, выкладывают больше, чем на торрентах?

легко. ты же видел, что это выбор японских анимешников, так что представление этих мультиуов может быть куда более полным, чем в торрентах.

AVL2 ★★★★★ ()
Ответ на: комментарий от registrant

>не имеющая свободных аналогов программа, как ... 7-зип?

4.2 7зип свободен (lgpl) и доступен для никсов нативно. Для Ъ на основе 7zip сделали консольный lzma с привычными ключами

annulen ★★★★★ ()
Ответ на: комментарий от rom-hvichia

Ну, полный комплект на 1 с половиной гигабайт мне пришлось качать с перерывами три дня, так что тут только торрент.

Гигабайт???!!! Да еще на CD-образе???!!!

Где ты вообще такое чудо нашел?

Wine занимает 8.7 Мб: http://wine.budgetdedicated.com/archive/index.html

То есть, то, что ты скачал весит примерно в 200 раз больше.

Nxx ★★★★★ ()
Ответ на: комментарий от annulen

>Для Ъ на основе 7zip сделали консольный lzma с привычными ключами

да, я пользуюсь lzma, а вот томми гоняет вендовую версию

registrant ★★★★★ ()
Ответ на: комментарий от Phantom_Harlock

> Официальный пакет кстати метров 30 что-ли весит в общей сложности, а то и меньше. Не помню уже размер дебов.

8.7 Мб

Nxx ★★★★★ ()
Ответ на: комментарий от Nxx

ну тем более. Такое даже сидя на GPRS не так уж напряжно скачать. если тариф нормальный.

Phantom_Harlock ()

> Добавлена поддержка TIFF в WinCodecs

Теперь в лайтруме заработает импорт? :)

AP ★★★★★ ()
Ответ на: комментарий от tommy

>это только в линукс что-бы поставить одну программу надо иногда обновить дистр со стабильного на непонятно на что, или же поломать стабильность в существующем скачав либы хрен знает откуда

ты вменяем?

annulen ★★★★★ ()

почитал топик, понял что виндузятников тут чуть менее, чем половина. «пак вайна с торрента» - этапять, адназначна.

те, кто говорят что вайн не нужен - есть некоторые виноли проги, ради которых держать винду не очень целесообразно. это раз. во вторых, порты некоторых прог под линукс создают именно с затычками для вайна. не Ъ конечно, но лучше чем ничего, это два. А в третьих - вайн нужен хотя бы для галочки, что есть пускалка виндовых прог (касается новичков). правда не тех, которые качают пак вайна с торрента, а нормальных.

з.ы. писал как-то тут про баг вина с HoMM 3, оепзплось это баг (или фича) чегобывыподумали? правильно, ядра, просто он вылез именно в вайне. посему жду 2.6.34:)

leg0las ★★★★★ ()
Ответ на: комментарий от Gary

>> Любопытствую у населения: а Цивилизация под вайном использует нативный питон, или таки его тоже эмулирует?

А что, Цивилизация под виндой использует системный питон или запускает свой парсер?

А хрен его знает, там никаких логов при установке нет, посему и любопытствую.

ZhAN ★★ ()

Костыль не нужен. Пора ходить самостоятельно, больной, иначе потеряете ноги, а затем и жизнь.

GluckMan ★★★ ()
Ответ на: комментарий от Zhbert

Абсолютно согласен. А Wine- штука очень полезная.

Viort ()
Ответ на: комментарий от annulen

>если у тебя такие кривые руки, не надо за других говорить. нужный софт всегда можно установить

враньё и хамство, сектантское. так как было то написано

«это только в линукс что-бы поставить одну программу надо иногда обновить дистр со стабильного на непонятно на что, или же поломать стабильность в существующем скачав либы хрен знает откуда»

tommy ★★★★★ ()
Ответ на: комментарий от Hokum

> Например, сейчас все переходят на ГОСТ-криптографию

А что, разве в «браузерном HTTPS» ГОСТ не реализуем? В OpenSSL-же вроде как есть? Правда интересно.

AlexM ★★★★★ ()
Ответ на: комментарий от tommy

а ты в винде тоже пользуешься только тем, что входит в систему в зверской сборке? тогда не говори, что репов не хватает

annulen ★★★★★ ()
Ответ на: комментарий от tommy

Начнём с того, что «скачать либы хрен знает откуда» в Windows - гораздо более популярное занятие. Цельные сайты (dll.ru, dll-files.com и иже с ними) на это специализируются. Да и понятие DLL-хэлл не для линукса придумали.

Более того, принятая в Виндоус модель инсталляции софта и библиотек к нему запросто реализуется и в Линуксе. Есть даже цельные дистрибутивы, построенные на такой идеологии (правда, в качестве образца для подражания они чаще берут MacOS X). Только вот, странность, дистрибутивы эти оказываются, по факту, отнюдь не самыми популярными. Может быть, серьёзность проблемы Вами сильно преувеличивается? А то получится как с тем Амароком, сколько было воплей, что разработчики козлы, рулят не туда, куда надо, а вскрытие показало, что как был он самым популярным, так и остался, а все претенденты - далеко позади...

AlexM ★★★★★ ()
Ответ на: комментарий от leg0las

> писал как-то тут про баг вина с HoMM 3

К-к-какой баг? У меня сын ставил с диска, всё игралось просто со свистом. Правда, у меня и ядро не самое новое :)

AlexM ★★★★★ ()

Парус 7.40 (Украинский)

... так и не работает.

http://forum.runtu.org/index.php/topic,6731.0.html

Чудо произойдет лишь в двух случаях: - или разработчики Паруса учтут пожелания клиентов с Linux на борту; - или wine таки научится идеально копировать винду.

Абзац ********* (03.04.2010 23:11:11)

anonymous ()
Ответ на: комментарий от AlexM

есть программа. требует тулкит 1 или тулкит 2 или тулкит 3. а так как разработчикам на пользователей наплевать то они используют новейшие возможности этих тулкитов. соответственно для пользования этой программы нужно ломать дистр, так как это не только wxvidgets, но и Qt и GTK+ на котором работает и DE.

и это в линукс постоянно. куда не ткнёшься - требует что-то системное обновить из библиотек.

в венде может быть кому то и надо найти какую то либу. хотя насколько помню такое не требуется. но что-бы поставить DC++ и eMule клиент не надо обновлять стабильный дистр, или даже не стабильный а простой, на непоянтно что. там просто поставил и используй.

tommy ★★★★★ ()
Ответ на: комментарий от AlexM

Amarok - чудесный пример. Для его обновления как раз и надо обновлять дистр. иногда со сменой KDE3 на KDE4. так же и с Ktorrent

но нет, вы продолжаете спорить хотя своими примерами только мои слова и подтверждаете.

tommy ★★★★★ ()
Ответ на: комментарий от AlexM

> А то получится как с тем Амароком, сколько было воплей, что разработчики козлы, рулят не туда, куда надо, а вскрытие показало, что как был он самым популярным

linux использует очень небольшое число пользователей. если среди них большинство пользователей амарока это видимо говорит о том что это те пользователи которые готовы тепреть такое положение дел с плеерами и они нетребовательный и следуют за модой и гламуром (миллионы американцев в погоне за модой сейчас закупаются айпадами в эти минуты). более требовательные используют более функциональные плееры (и вообще плееры а не менеджеры коллекций коим является амарок и его клоны)

не принимайте виртуальный мир пользователей linux за реальность. 1% пользователей примерно есть. но сколько из них постоянных пользователей, а сколько пользователей просто пробующих linux в данный момент времени. число пользователей интернета - велико. соответственно какой то процент будет пробовать использовать linux всегда. но это не пользователи linux. это засветившиеся в статистике пробующие linuxпользователи.

tommy ★★★★★ ()
Ответ на: комментарий от tommy

> более требовательные используют более функциональные плееры (и вообще плееры а не менеджеры коллекций коим является амарок и его клоны)

А какие же функции нужны от «просто плеера» кроме play/pause?

sv75 ★★★★★ ()
Ответ на: комментарий от sv75

возможность проигрывать то что есть из музыкальных данных. а не только mp3 и порезанные на треки flac. возможность использовать плеер просто открыв в нём нужные файлы и альбомы а не добавляя их в некие коллекции записываемые в SQL а осознанно добавив их в плейлист.

возможность использования плагинов, такие как плагины ресемплирования так как при работе в 24 бит карты имеют параметры лучше чем при 16, даже референсные.

полезно иметь в плеере возможность перекодировать в другой формат (например на мобильный aac/mp3). но необязательно иначе там и прожигалка дисков появляется и тп.

tommy ★★★★★ ()
Ответ на: комментарий от tommy

> не принимайте виртуальный мир пользователей linux за реальность. 1% пользователей примерно есть. но сколько из них постоянных пользователей, а сколько пользователей просто пробующих linux в данный момент времени

Не трать силы на проповеди перед этой жалкой кучкой отщепенцев. Всё равно их больше, чем ты можешь убедить :D

tailgunner ★★★★★ ()
Ответ на: комментарий от tommy

> миллионы американцев в погоне за модой сейчас закупаются айпадами в эти минуты

какбэ опросы уже показали, что пользователям айпад пофиг

AP ★★★★★ ()
Ответ на: комментарий от AP

>какбэ опросы уже показали, что пользователям айпад пофиг

после этого забыв обо всяких опросах, нужности-ненужности, направились стоять в очереди за новинкой.

tommy ★★★★★ ()
Ответ на: комментарий от AlexM

Аппаратно ГОСТ реализован в устройствах на базе смарт-карт, которые зачастую толком не работают в Линуксе (Feitian не ccid ридер, насколько мне известно)

Hokum ☆☆☆☆ ()
Ответ на: комментарий от tommy

С технологической точки зрения в винде точно так же.

есть программа. требует тулкит 1 или тулкит 2 или тулкит 3. а так как разработчикам на пользователей наплевать то они используют новейшие возможности этих тулкитов. соответственно для пользования этой программы нужно ломать дистр

Ответ: нет. Любой требуемый софт можно поставить, как в и Windows и MacOSX, в отдельный каталог, с полностью независимым набором библиотек. Есть и пакетные менеджеры, построенные вокруг этой идеи. Из последних анонсировавшихся здесь - это Nix, http://nixos.org/nix/. Так что, было бы желание. И, да, такая схема, разумеется, имеет собственные недостатки, которые напрочь отсутствуют у пакетных менеджеров с традиционной для linux/bsd схемой.

Но, замечу, актуальность этой проблемы, измеренная в количестве пользователей, проголосовавших ногами за тот или иной вариант, стремится к 0.

AlexM ★★★★★ ()
Ответ на: комментарий от tommy

> но нет, вы продолжаете спорить хотя своими примерами только мои слова и подтверждаете.

В огороде бузина. Пример с Амароком был, э-э-э, аналогией. Если Вы сразу эту аналогию не уловили, поясню подробнее.

Дело в том, что устами наших уважаемых активистов-гномолюбов Амарок-2 был низведён до состояния говна. И то не так, и это не так, и вообще, УГ. Однако, как показало вскрытие^W голосование на ЛОРе, несмотря на все эти яростно бичуемые недостатки, у Амарок-а по-прежнему чуть ни в два раза больше активных пользователей, чем у ближайшего преследователя. Таким образом, можно сделать вывод, что проблемы, очерченные уважаемыми гномолюбами, несомненно, существуют, но вот их актуальность для большинства пользователей сильно преувеличена.

Примерно такая же ситуация с пакетными менеджерами. Проблема бинарной совместимости между разными линуксами несомненно существует, но важность этой проблемы несравнимо ниже других проблем и достоинств этой операционной системы.

AlexM ★★★★★ ()
Ответ на: комментарий от sv75

> А какие же функции нужны от «просто плеера» кроме play/pause?

lyrics и шире, контекст? Мне тут в пятницу аж на википедию пришлось лезть за Mary Hamilton. С удивлением узнал, что и в этой трагедии не обошлось без русского следа.

AlexM ★★★★★ ()
Ответ на: комментарий от AlexM

>Проблема бинарной совместимости между разными линуксами несомненно существует

бинарная совместимость тут не причём. часто в линукс опенсоурс программы пишутся ни для кого. но вот скачать сейчас оперу - просто выбери x86 или x64. и до этого любая опера работала с любым Qt (3/4). программы надо писать так что-бы ими можно было пользоваться и другим.

достоинств этой операционной системы.

это вообще не причём

tommy ★★★★★ ()
Ответ на: комментарий от tommy

> часто в линукс опенсоурс программы пишутся ни для кого... программы надо писать так что-бы ими можно было пользоваться и другим.

Программы пишутся для удовлетворения прежде всего *своих* потребностей. Если Вам не нравится или не подходит данная программа, найдите лучше или напишите свою. Если Вас не устраивает ситуация, когда, по большому счёту, никто никому ничего не должен - Вы, вероятно, ошиблись дверью.

AlexM ★★★★★ ()
Ответ на: комментарий от AlexM

а в венде и опенсоурс и бесплатные программы с закрытым кодом - просто работают. повторю: там не надо для установки DC++, торрент и eMule клиентов ломать дистр.

думаю это ты ошибся дверью. линукс для стабильной и комфортной работы а не для красноглазия. поэтому часть программ были и будут люди использовать в Wine.

tommy ★★★★★ ()
Ответ на: комментарий от tommy

> поэтому часть программ были и будут люди использовать в Wine

Кстати, неприятный для некоторых факт - посмотрите на процент использующих uTorrent на раздаче любого дистрибутива, от Ubuntu до Gentoo... Как сейчас модно говорить, символизирует.

tx ()
Ответ на: комментарий от tx

проблемы отдельно взятых хомячков ничего не символизируют,примерно также как голосование и Songbird.

a_no_no ()
Ответ на: комментарий от tommy

> а в венде и опенсоурс и бесплатные программы с закрытым кодом - просто работают.

Ну дак и пользуйтесь, кто-то мешает? :)

думаю это ты ошибся дверью. линукс для стабильной и комфортной работы

Хы. Хы-хы. Ну и покажите мне тех, кто *должен* Вам эти комфорт и сухость обеспечить. И, главное, попробуйте объяснить, почему они *должны* тратить свою жизнь на такого, как Вы :)

AlexM ★★★★★ ()
Ответ на: комментарий от tx

Хых... А чо, гентушнеги качают свою генту из-под венды? Хе-хе, я всегда подозревал, что они недалеко от латентных виндоузятников - любителей фряхи ушли :)

AlexM ★★★★★ ()
Ответ на: А не надо от amorpher

Re: А не надо

> А не надо

сайтики, порталы, магазины под это дело делать

Вообще-то, речь не о том, чтобы делать их «под это дело», а проверять, как они на этом деле работают. Делать, естес-сно, надо под стандарты w3c.

Сайт, предназначенный для массового посещения в обязательном порядке должен быть проверен по крайней мере на трёх наиболее популярных семействах браузеров. А сейчас - пожалуй, что и пяти (в связи с появлением Хрома и Сафари). А в каждом семействе - ещё по несколько версий. Это я свой редко посещаемый хомяк могу себе позволить проверить под FF, а на остальное забить.

hobbit ★★★★★ ()
Ответ на: комментарий от tx

> Кстати, неприятный для некоторых факт - посмотрите на процент использующих uTorrent на раздаче любого дистрибутива, от Ubuntu до Gentoo...

Интересно, чем их ktorrent не устроил.

hobbit ★★★★★ ()
Ответ на: комментарий от NekoExMachina

>Как правильный FreeBSD'шник, обновился и проверил запускаемость Путти. Все работает!

O_o скомпилить не осилил?

annulen ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.