LINUX.ORG.RU

Wine 4.17

 


1

1

Стал доступен релиз для разработчиков Wine 4.17. В нём исправлено 14 ошибок и внесено 274 изменения.

Основные изменения:

  • обновлён движок Mono;
  • добавлена поддержка сжатых текстур в формате DXTn;
  • предложена начальная версия runtime-библиотеки Windows Script;
  • поддержка обработки уведомлений о смене устройств через API XRandR;
  • поддержка генерации ключей RSA;
  • для архитектуры ARM64 реализована поддержка бесшовных прокси для интерфейсов объектов

Исправлены ошибки, связанные с работой приложений:

  • Vampire the Masquerade;
  • iCloud;
  • AppCAD;
  • Civilization 4;
  • Royal Quest;
  • Shed installer

>>> Подробности

★★★★★

Проверено: cetjs2 ()

кек, у ректал целая простыня про нескучные темы, а вайн - мининовостью...

anonymous ()

В оригинале новости, половины пунктов нет. Авторы новостей на Опеннете сами дописывают пункты, беря то, что их заинтересовало в ChangeLog.

С Опеннета спёр новость, не правда ли?

anonymous ()

Civilization 4, хм, давно уже с play4linux играл в нее, все нормально было.

One ★★★ ()
Ответ на: комментарий от ZweiStein

16бит достаточно на десктопе! 32бит бездумная растрата ресурсов.

anonymous ()

А кто нибудь когда нибудь видел приложение, запущенное в арм-версии вайна? Ну, кроме встроенного сапёра.

kirill_rrr ★★★★★ ()
Ответ на: комментарий от kirill_rrr

Встречный вопрос: кто-нибудь когда-нибудь видел ARM-версию Wine?

Korchevatel ()
Ответ на: комментарий от ZweiStein

Доля десктопов больше чем у ляликса.

anonymous ()

что там с х64, всё такая же жопа?

utanho ()
Ответ на: комментарий от utanho

Скорее всего да, ведь такой архитектуры не существует

bender ★★★★★ ()
Ответ на: комментарий от utanho

А по существу есть что сказать?

Что пробовал — всё работало. Кроме Proteo Wizard. Но выборка нерепрезентативная — в основном, консольные числодробильные приложения, много консольного же .Net, немного GUI на WinAPI, немного DRM с активацией по интернету.

question4 ★★★★★ ()
Ответ на: комментарий от anonymous

В оригинале новости, половины пунктов нет

4.2

intelfx ★★★★★ ()

Когда будет в Альт Линуксе?

anonymous ()

14 ошибок и внесено 274 изменения

когда уже запилят поддержку usb?

amd_amd ★★ ()
Ответ на: комментарий от anonymous

в альтлинуксе есть POL, значит уже есть...

anonymous ()
Ответ на: комментарий от amd_amd

ты перепутал темы - тема с ректалосью соседняя

anonymous ()
Ответ на: комментарий от anonymous

ничего я не перепутал - виндовый софт запущеный в вине не видет usb устройств, а хотелось бы...

amd_amd ★★ ()
Последнее исправление: amd_amd (всего исправлений: 1)

Когда-то пользовался, а сейчас нет необходимости. А так хорошая программа

stafik1993 ()
Ответ на: комментарий от amd_amd

ну, кое что он видит!

например абдуринку через USB-ttl :)

anonymous ()
Ответ на: комментарий от Korchevatel

Я видел. У меня даже часть её пакетов в репе есть. А главный прикол в том, что только часть.

kirill_rrr ★★★★★ ()
Последнее исправление: kirill_rrr (всего исправлений: 1)
Ответ на: комментарий от amd_amd

А что именно вы хотите видеть на usb? мышки, клавиатуры, диски, принтеры и сканеры уже давно запилены.

kirill_rrr ★★★★★ ()
Ответ на: комментарий от utanho

ты это счас про поддержку виндовых x64 приложений или просто недавно услышал про зависимость от 32-битных либ из мультилиба у самого вайна?

anonymous ()
Ответ на: комментарий от utanho

что там с х64, всё такая же жопа?

А что с ней не так?

Kron4ek ★★★ ()
Ответ на: комментарий от kirill_rrr

что именно вы хотите видеть на usb
мышки, клавиатуры, диски, принтеры и сканеры

софт хочу видеть - программулины всякие! к примеру mapcheker утилита для обновления гарминовских карт - хоть убейся не видит usb устройств... или всем известный rufus - то же не видит флешек... опять же утилиты для восстановления флешек все под винду - запускаются в wine, но самих флешек не видят...

amd_amd ★★ ()
Ответ на: комментарий от amd_amd

утилиты для восстановления флешек

счас бы низкоуровневое форматирование через такую прослойку проворачивать

anonymous ()
Ответ на: комментарий от anonymous

Там вообще-то утилиты работающие напрямую с контроллером флэшки по проприетарному протоколу, а не «низкоуровневое форматирование».

anonymous ()

Исправлены ошибки, связанные с работой приложений:

  • Vampire the Masquerade;

    Она ж и так идеально работала. Что там было исправлять?..

anonymous ()
Ответ на: комментарий от amd_amd

Страшно подумать, как это на самом деле работает и что для поддержки произвольных юсб-устройств надо вкорячить в ядро.

kirill_rrr ★★★★★ ()
Ответ на: комментарий от anonymous

О! Где выв идели идеально работающий маскарад, одну из 3-х самых забагованых игр всех времён и народов?

kirill_rrr ★★★★★ ()

если оно не может epic game ,то остаюсь на винде

dodgers ()
Ответ на: комментарий от dodgers

не может epic game

и что это? дотка? контра? майнкрафт? сапер?

anonymous ()
Ответ на: комментарий от dodgers

если оно не может epic game

Может, по крайней мере, некоторые игры работают. Недавно Borderlands 3 кто-то запускал.

Kron4ek ★★★ ()
Последнее исправление: Kron4ek (всего исправлений: 1)
Ответ на: комментарий от LINUX-ORG-RU

не обновлялись бинарные сборки под винду с прошлого марта.

под линуксом для всего выше Hello World довольно неудобно собирать библиотеки.

Slackware_user ★★★★★ ()
Ответ на: комментарий от eternal_sorrow

чтобы без проблем собирать свой и не очень софт под форточки не грузясь в винду.

Slackware_user ★★★★★ ()
Ответ на: комментарий от Kron4ek

спс, просто не понял о чем тот принципиальный пациент вообще толдычил

anonymous ()
Ответ на: комментарий от kirill_rrr

На лоре(и в некоторых других комьюнити нефанатов) «идеально работает» == «не работает».

anonymous ()

Ну, что там, интерфейс к Diablo 1 починили, или всё также чёрный экран?

Office97 c access'ом уже работает, или всё также с ошибкой на этапе установки?

record ★★★★★ ()
Последнее исправление: record (всего исправлений: 2)
Ответ на: комментарий от record

Сомневаюсь, что 22-х летний софт у них в приоритете уже.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.