LINUX.ORG.RU

LXQt переходит на Qt5

 , , ,


0

3

LXQt, форк LXDE, использующий Razor-qt и Hawaii, плавно переходит на Qt5. Главная цель перехода с Qt4 на Qt5 - обеспечение возможность работы и совместимости с Wayland. Для сборки LXQt с поддержкой Qt5 необходимо производить сборку с флагом "-DUSE_QT5=ON". В скором будущем ожидается выход версии 0.8, которая еще будет поддерживать Qt4, но после этого выпуска все силы разработчиков будут сосредоточены на Qt5.

>>> Подробности

★★★★★

Проверено: DoctorSinus ()

Ответ на: комментарий от RevenantX

с удовольствием переползу с lxde на lxqt когда станет стабильным

int13h ★★★★★ ()

Я, как большой фанат KDE, люто одобряю все что связано с Qt.

anonymous ()
Ответ на: комментарий от int13h

Я подтверждаю твою новость - отличная новость!

anonymous ()

Пропал lxde. Закапывайте.

AVL2 ★★★★★ ()

они задолбали уже. вместо того, чтобы превращать нормальное DE в чудовищное говнище на Qt, лучше бы перевели обычное LXDE на GTK3, чтобы совместимость с Wayland была в нормальной версии.
собираются же сделать эту ветку основной? ну и пошли они на..., кому тогда этот высер нужен будет? верим и надеемся, что Xfce портируют на GTK3 (всмысле, закончат, там вроде часть уже на нем), чтобы осталось хоть одно легковесное DE.

Lincor ()
Ответ на: комментарий от AVL2

нет. За последние два года, imho, там все на месте - нет динамики развития. Пусть и в угоду ресурсопотребления (сейчас у меня lxde занимает ~50 МБ), но развитие нужно. А то, что основой берут QT5 есть позитивная новость. Вот сижу и мечтаю о настоящем смартфоне, где будут работать чистый GNU/Linux + QT, без тормозной жабы =)

int13h ★★★★★ ()
Последнее исправление: int13h (всего исправлений: 1)

Не успели ещё стабильную версию на qt4 выпустить, уже на qt5 перепрыгнули. Разве так дела делаются.

kinik ★★☆ ()

Ну когда уже в Qt5 починят хоткеи в русской раскладке?... А так неплохая новость. Но перелазить с gtk2 lxde я пока смысла не вижу.

Falcon-peregrinus ★★★★★ ()

Значит ли это, что в Gentoo его не будет, или он будет доступен только с подключенным оверлеем qt?

alextk ()
Ответ на: комментарий от Falcon-peregrinus

между GTK2 и GTK3 различий ОСОБЫХ нет. кстати, GTK3 едва ли толще, оттуда, например, выпилили ненужные устаревшие рисовальные API, оставили только Cairo.

GTK3 - это продолжение GTK2, оба хороши. Qt5 - это продолжение Qt4, оба убогое говно.

Lincor ()
Ответ на: комментарий от AVL2

Пропал lxde. Закапывайте.

Пропал AVL2. Закапывайте.

anonymous ()

2 int13h, Falcon-peregrinus: насчет жручести - это правда. по поводу тормозов загнул, да. но все равно что то, что другое для мобильных устройств подходит плохо. туда надо GTK+ или чего-то еще легче.

Lincor ()
Ответ на: комментарий от int13h

Вот сижу и мечтаю о настоящем смартфоне, где будут работать чистый GNU/Linux + QT, без тормозной жабы =)

опять? Его уже закопали даже вместе с кутопией...

AVL2 ★★★★★ ()
Ответ на: комментарий от AVL2

Не вводите в заблуждение. Jolla же. int13h, беги покупать. И рут, и Wayland, и Qt из коробки.

Adonai ★★★ ()
Ответ на: комментарий от int13h

нет. За последние два года, imho, там все на месте - нет динамики развития. Пусть и в угоду ресурсопотребления (сейчас у меня lxde занимает ~50 МБ), но развитие нужно.

Какое развитие? Что такого нового появилось в ДЕ за последние 20 лет?

Это просто рабочий стол и запуск приложений. Все остальное дурь и лишнее.

Юникод нужен, потому что языки разные - он есть, переключатель раскладок - есть, окна и десктопы есть. Минимум памяти под эти задачи - есть.

Все остальное лишнее. Зачем, например, файловый менеджер делают в ДЕ? Он же все равно у всех стопицотый по счету и все равно кривой и никакой, даже до эксплорера не дотягивает...

AVL2 ★★★★★ ()
Ответ на: комментарий от Lincor

Lincor (01.07.2014 16:58:25) Qt-хейтер

Зачем заходить в каждую тему про KDE и Qt и писать, насколько всё плохо? Если не нравится - ну не нужно пользоваться, зачем себя заставлять.

Adonai ★★★ ()
Ответ на: комментарий от Lincor

нормальное DE в чудовищное говнище на Qt

Толсто, педрила. :D

anonymous ()
Ответ на: комментарий от alextk

Ну пока они на qt5 не перешли, так что еще как минимум следующая версия будет в генту как и текущая. А там, может, qt5 в дерево впилим. Или будет в оверлее жить, как сейчас лайв версия, пока qt5 до дерева не дойдет.

wayland_systemd ()
Ответ на: комментарий от anonymous

педрила

ты меня со своими друзьями-кедерастами перепутал.

Lincor ()
Ответ на: комментарий от int13h

где будут работать чистый GNU/Linux + QT, без тормозной жабы

Trolltech Greenphone. А вообще QML гораздо более ресурсоёмкий, нежели Qt Widgets.

EXL ★★★★★ ()
Ответ на: комментарий от Lincor

Вроде по бенчмаркам третий гтк тормознее Qt был

wingear ★★★★ ()

А что там в качестве WM? Не опенбокс же на qt переписали (:

NeverLoved ★★★★★ ()
Ответ на: комментарий от Lincor

для мобильных устройств … надо GTK+

У тебя так много свободного пространства на мобилке?

anonymous ()

Я вижу, процеcc перехода разработчикам понравилcя. Лишь бы переходить. Потом можно на Motif, потом опять на GTK.

shimon ★★★★★ ()
Ответ на: комментарий от anonymous

GTK3 в два раза меньше Qt. я гарантирую это, посмотри сам размер пакетов в своем дистре.

Lincor ()
Ответ на: комментарий от Lincor

Потому-что в Qt есть много упрощающих жизнь разработчику модулей. Которые можно не подключать и занимать они будут только место на HDD. А GTKшные приложения обычно эти модули либо велосипедят, либо используют сторонние библиотеки, которые в купе с GTK+ дадут размер Qt.

RevenantX ★★★★ ()
Ответ на: комментарий от Lincor

ты меня со своими друзьями-кедерастами перепутал.

Да нет, я никого ни с кем не путаю, педрила.

anonymous ()
Ответ на: комментарий от RevenantX

4.2. в Qt только вебкит отдельно, остальное все в одной библиотеке.

и вообще, это не Unix-way, все в одной библиотеке, даже если модулями. что от Qt хотят большинство приложений? GUI. а что она дает им? да, GUI, и еще 100500 разных свистелок и перделок. Qt - это комбайн в стиле оффтопика, поэтому и наиболее похожее на оффтопик DE создается на нем.

Lincor ()
Ответ на: комментарий от RevenantX

Ерунда. В любом случае для программ QT характерно обжорство (скайп, влс и тд). У меня есть комп с семёркой, 425 оператива. QT на нём нет и не будет. GTK+ программы кушают значительно меньше просто по количеству свободной памяти видно.

anonymous ()
Ответ на: комментарий от Lincor

Лол. Это ты 4.2. Я делал программы на Qt. И в проджект файле ты выбираешь какие модули подключить. А вот список модулей

[archie@workarch /]$ ls /usr/lib | grep 'Qt5.*\.so$'
libQt5CLucene.so
libQt5Concurrent.so
libQt5Core.so
libQt5DBus.so
libQt5Declarative.so
libQt5DesignerComponents.so
libQt5Designer.so
libQt5Gui.so
libQt5Help.so
libQt5Network.so
libQt5OpenGL.so
libQt5Positioning.so
libQt5PrintSupport.so
libQt5Qml.so
libQt5QuickParticles.so
libQt5Quick.so
libQt5QuickTest.so
libQt5QuickWidgets.so
libQt5Script.so
libQt5ScriptTools.so
libQt5Sensors.so
libQt5Sql.so
libQt5Test.so
libQt5WebKit.so
libQt5WebKitWidgets.so
libQt5Widgets.so
libQt5XmlPatterns.so
libQt5Xml.so

RevenantX ★★★★ ()
Последнее исправление: RevenantX (всего исправлений: 1)
Ответ на: комментарий от RevenantX

ах, в Qt5 подробили. тем не менее, что делает в графической библиотеке SQL, Network, D-Bus и Xml? да и там еще дофига лишнего.

ну-ка сравни мне, к примеру, размер QtCore+QtSQL и GTK3+SQLite.

Lincor ()
Ответ на: комментарий от Lincor

хотя стоп, QtCore по функциональности полной GTK+ не проигрывает? только честно. а иначе - еще плюсуй другие компоненты.

Lincor ()
Ответ на: комментарий от Lincor

GTK3 - это продолжение GTK2, оба хороши. Qt5 - это продолжение Qt4, оба убогое говно.

Сколько лет ты занимаешься разработкой с использованием Qt?

totik ()
Ответ на: комментарий от totik

даже не пробовал. я бы никогда такое говно юзать не стал. еще и плюсы, фу. вся моя критика со стороны пользователя-непрограммиста.

Lincor ()
Ответ на: комментарий от AVL2

Jolla жыва. Но смартфоны в текущем виде не нужны. Как и интернет-планшеты и прочие цацки для гиков.

Deleted ()
Ответ на: комментарий от Lincor

ах, в Qt5 подробили

В Qt4 то же самое, наркоман.

Pavval ★★★★★ ()
Ответ на: комментарий от Lincor

GTK3 в два раза меньше Qt. я гарантирую это, посмотри сам размер пакетов в своем дистре.

Порнуха заняла весь диск и вдруг стало важно?

Pavval ★★★★★ ()
Ответ на: комментарий от Pavval

кедерасты такие кедерасты. речь шла о мобильных устройствах. и посмотри пост, на который я отвечал.

Lincor ()
Ответ на: комментарий от kinik

Не успели ещё стабильную версию на qt4 выпустить, уже на qt5 перепрыгнули. Разве так дела делаются.

Ну а смысл при разработке ориентироваться на тухлятину?

Manhunt ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.