LINUX.ORG.RU

Релиз ROSA Desktop Fresh R6 LXQt

 ,


0

3

Спустя несколько месяцев после выхода ROSA Desktop Fresh R6 KDE, разработчики рады представить редакцию Desktop Fresh R6, с легковесным рабочим окружением, в роли которого на сей раз выступает LXQt. Вплоть до версии Fresh R5 в качестве рабочего стола использовался LXDE, основанный на использовании библиотек GTK+2. Однако последний крупный релиз серии 2.x стека GTK+ состоялся четыре года назад. В настоящее время ветка 2.x еще поддерживается в плане исправления ошибок, но основная разработка ведется в ветке 3.x. Однако переход с GTK+2 на GTK+3 — занятие не очень прямолинейное, а результат перехода нравится не всем. Среди недовольных оказались и разработчики LXDE, поэкспериментировавшие с новым GTK и решившие посмотреть в сторону альтернативы в лице Qt. В 2013 году большинство разработчиков LXDE объединились с коллегами из проекта Razor-qt для работы над совместным проектом, получившим имя LXQt. Основанный на GTK+2 «старый» LXDE при этом вовсе не умер и продолжает поддерживаться группой энтузиастов, но по темпам развития сильно отстает от своей новой альтернативы — например, между LXDE-редакциями ROSA Desktop Fresh R4 и Fresh R5 практически не было различий непосредственно в компонентах LXDE. А поскольку дистрибутив все-таки называется «Fresh», то было решено попробовать новое рабочее окружение.

И вот, после нескольких месяцев полировки и обкатки нескольких версий LXQt, мы готовы предложить вам редакцию нашего дистрибутива на основе этого перспективного окружения. Релиз основан на LXQt 0.10.0 — последней на данный момент версии окружения рабочего стола, собранной с использованием библиотек Qt5. По возможности, мы отбирали для включения в образ приложения, также использующие Qt5. Набор таких приложений включает в себя:

  • менеджер файлов PCManFM-Qt;
  • эмулятор терминала qterminal;
  • просмотрщик изображений lximage-qt;
  • почтовый клиент Trojita;
  • просмотрщик PDF qpdfview;
  • аудиопроигрыватель qmmp;
  • текстовый редактор juffed;
  • менеджер буфера обмена qlipper.

Qt5-программ на все случаи жизни пока что не хватает, поэтому в Desktop Fresh R6 LXQt входят и несколько Gtk-приложений. В первую очередь это офисный пакет LibreOffice и веб-браузер Firefox. Было решено не заменять их полуфункциональными альтернативами исходя только из используемых библиотек, хотя энтузиасты могут попробовать и otter-browser — браузер на основе Qt5, имеющий целью воспроизвести внешний вид Opera 12.x.

Также у LXQt есть собственная панель управления (аналог KDE System Settings, также известного как «Параметры системы»), в который органично вписались специфичные инструменты РОСЫ — в частности, программа установки и удаления программ.

В Desktop Fresh R6 LXQt используется дисплейный менеджер SDDM, являющийся также рекомендуемым менеджером для Plasma 5 — так что с большой вероятностью в будущем вы увидите его и в релизах РОСЫ на основе KDE. Также это первый релиз РОСЫ с новым ядром по умолчанию — мы переехали на использование LTS-ветки 4.1 в качестве основной для наших настольных систем.

>>> Подробности

★★★★★

Проверено: fallout4all ()

Хороший качественный российский дистрибутив. Давно пользуюсь.

Anonim999 ()
Ответ на: комментарий от Anonim999

Все что основано на федоре и редхатах не может быть хорошим, качественным тем более, по крайней мере для десктопа.

uin ★★ ()
Ответ на: комментарий от uin

Этот дистрибутив не имеет отношения к Fedora или Red Hat-у. Это оригинальная разработка-форк Мандривы. На Red Hat Enterprise Linux у них другие продукты.

anonymous ()
Ответ на: комментарий от anonymous

Так Mandriva это изначально редхатовская ветка и основана на редхат. Все производные соответственно тоже.

Promusik ★★★★★ ()
Ответ на: комментарий от uin

Все что основано на федоре и редхатах не может быть хорошим, качественным тем более, по крайней мере для десктопа.

Крайне безответственное высказывание, которое ничем не обосновано. А на чём может, на Убунту что ли? Не смеши.

Anonim999 ()
Ответ на: комментарий от Anonim999

Ну начнем с того что оно до_сих_пор хочет отдельный пароль для администратора. Про пакетный менеджер я вообще даже молчу, хотя пакетные менеджеры вообще для десктопа зло.
Дебианы/убунту конечно адов глюкодром но они хотя бы пытаются что то придумывать что бы с их дистрибутивами было работать проще и легче, и вообще что бы почти как у белых людей.

uin ★★ ()
Ответ на: комментарий от uin

Ну начнем с того что оно до_сих_пор хочет отдельный пароль для администратора.

И на этом закончим. Между sudo и su, я выбираю su, ибо считаю это безопаснее. Впрочем не только я так считаю. На таких серьёзных дистрибутивах как Дебиан, CentOS и т.п., тоже используется su.

А что касаемо качества и т.п., я писал выше. И могу только добавить: «Ребята из Роса! Спасибо за ваш дистрибутив, который качественнее и стабильнее всех этих хвалёных *бунту».

Anonim999 ()
Ответ на: комментарий от uin

пакетные менеджеры вообще для десктопа зло

А что, простите, на десктопе быть должно? Установка нажатием нескольких «далее» софта, который или не обновляется сам, или обновляется как-то по своему? Ты троллишь? Именно отсутствие пакетного менеджера - главная проблема, которая не позволяет использовать на десктопе Windows.

Дебианы/убунту конечно адов глюкодром

Дебиан - глюкодром? Тестинг - может быть, и то вряд ли. А стейбл работает прекрасно.

stav_artefakt ★★ ()
Ответ на: комментарий от uin

Все что основано на федоре и редхатах не может быть хорошим, качественным тем более, по крайней мере для десктопа.

Исправил. Не благодари.

Ну начнем с того что оно до_сих_пор хочет отдельный пароль для администратора.

Не смеши...Попробуй еще раз.

Дебианы конечно адов глюкодром

Пруф в студию....

убунту конечно адов глюкодром

С этим соглашусь...

Odalist ★★★★★ ()
Ответ на: комментарий от Anonim999

Хороший качественный российский дистрибутив.

+1

Odalist ★★★★★ ()
Ответ на: комментарий от stav_artefakt

А что, простите, на десктопе быть должно?

Да хоть что, лишь бы нормально работать с приложением без головняков и гемора, а то установил приложение - оно скачало ворох зависимостей на 50mb, потыкался, понял что не то - удалил, зависимости остались, полез удалять зависимости а оно тебе внезапно заявляет что удалит еще вот это и вот этоб приложения которые раньше без этой либы обходились.
Или например устанавливались куча каких то пакетов, и вдруг какой то пакет сообщает что он либо не настроился либо не может быть установлен или хрен знает что еще. Или устанавливал пакеты система вдруг выкинула из сессии, пакеты недоустановились, зависимости установившихся неудовлетворились и в новой сессии творится уже адовый звиздец.

Для разработки пакетный менеджер конечно предпочтительнее, намного удобней либы необходимые для сборки какого то прожекта выкачивать пекетником, но как обычный юзер я желаю видеть упакованное приложение в котором для его работы все уже имеется, и которое я спокойно могу распокавать себе в хомяк и запускать. Где это видано вообще чтобы для установки пользовательской апликухи требовались рут права?

или не обновляется сам, или обновляется как-то по своему?

Это намного лучше чем протухшие версии софта в репах.

uin ★★ ()
Ответ на: комментарий от uin

но как обычный юзер я желаю видеть упакованное приложение в котором для его работы все уже имеется, и которое я спокойно могу распокавать себе в хомяк и запускать. Где это видано вообще чтобы для установки пользовательской апликухи требовались рут права?

Пользуйтесь Windows, и будет вам счастье.

Odalist ★★★★★ ()
Последнее исправление: Odalist (всего исправлений: 1)
Ответ на: комментарий от uin

Все что основано на федоре и редхатах не может быть хорошим, качественным тем более, по крайней мере для десктопа.

РОСА это самостоятельный дистрибутив, продолживший развитие ныне покойной Mandrivы.

filosof ()

Все mandriva-based дистрибутивы, которые я видел, обладали собственным
графическим менеджером настроек, совершенно избыточым, на мой взгляд.

Вот, вижу

Также у LXQt есть собственная панель управления... в который органично вписались специфичные инструменты РОСЫ

Все ли уже наконец слили воедино?

Deleted ()
Ответ на: комментарий от uin

В настройках системы можно отключить запрос пароля и ставить программы просто так. Причем из готового каталога, а не бегая по интернетам в поисках.

anonymous ()
Ответ на: комментарий от anonymous

Куда ставить? Ничего не понял, в корень можно ставить без прав рута?

не бегая по интернетам в поисках.

А никто не говорит бегать по интернетам, есть же магазин-галерея приложений, причем их теперь чуть ли не в каждом дистре своя. К тому же бегать все равно приходится и добавлять сторонние репозитории на то и на сё, причем в этих сторонних репозиториях окажется либа более новой версии чем есть в основном, умный манагер её обновит и что нибудь сломает либо начнет работать через жопу. Так что манагер пакетов в этом плане не то что ничем не лучше а даже еще хуже делает.

uin ★★ ()
Последнее исправление: uin (всего исправлений: 2)
Ответ на: комментарий от uin

Ставить программы через Установка и удаление программ. Корень? Ставится в линуксах обычно в /usr/bin/ или /opt/ вроде же.

anonymous ()
Ответ на: комментарий от uin

Да хоть и в корень. В Росе можно полностью отключить запрос пароля для чего душе угодно. Хоть для всего. Системные настройки >>> Настройка аутентификации.

anonymous ()
Ответ на: комментарий от uin

А в Федоре 23 вообще по умолчанию нет запроса пароля при установке программ через Центр приложений;)

anonymous ()
Ответ на: комментарий от uin

К тому же бегать все равно приходится и добавлять сторонние репозитории на то и на сё,

Это вы про Убунту? В Роса нет необходимости в сторонних репозиториях. Даже если какого-то приложения нет, то на форуме Роса есть тема, где можно попросить его собрать или обновить. Если знания позволяют, то можете сами собрать или обновить в ABF

Anonim999 ()
Ответ на: комментарий от Anonim999

В Роса нет необходимости в сторонних репозиториях.

Ну ох-ть вообще, и как же быть? Первым делом что я сделаю как только установлю десктоп - это поставлю браузер (в моем случае это QupZilla) http://mirror.rosalab.ru/rosa/rosa2014.1/repository/i586/main/release/
Мало того что его нет в репозиториях, так еще и сторонний прицепить нельзя?

На гайку вон скачал пакет или архив http://www.qupzilla.com/download#haiku да и установил или распаковал куда тебе там нужно.

uin ★★ ()
Ответ на: комментарий от uin

но как обычный юзер я желаю видеть упакованное приложение в котором для его работы все уже имеется

Собирай статик либ и будет счастье, но контроль безопасности таких приложений, когда версии собранных либ никак и никем не контролируются, это ад. Поэтому ни одного стоящего дистрибутива с такой политикой ты не найдешь.

Где это видано вообще чтобы для установки пользовательской апликухи требовались рут права?

Монтировать /home с noexec уже не в моде? Где это видано, чтоб пользователю разрешалось запускать что-то, кроме уже установленного в ОС? Вам на офтопик или надкусанный офтопик.

anonymous ()
Ответ на: комментарий от stav_artefakt

А что, простите, на десктопе быть должно?

Астра жеж

gray ★★★★★ ()
Ответ на: комментарий от anonymous

Где это видано, чтоб пользователю разрешалось запускать что-то, кроме уже установленного в ОС?

А в чем проблема как бы? Пусть пользователь в пределах своего хомяка делает что пожелает. Приложение это такой же контент в конце концов как изображения, музыка и видео.

uin ★★ ()

Посмотрел в виртуалочке, на редкость годно, lxqt уже можно юзать.

enso ★★★★ ()

Уже говорили «не нужно»?

redixin ★★★★ ()
Ответ на: комментарий от uin

Самое смешное, что те, кто говорят, что какноникал делает больше для людей, чем редхат забывают, что avahi, networkmanager и т.д. пилят редхатовцы

mystery ★★ ()

Российское ПО как-то не внушает доверия. Буду пользываться отечественным софтом только если совсем ничего не будет, и то при этом десять раз подумаю можно ли как-то обойтись без него.

anonymous ()
Ответ на: комментарий от anonymous

То есть любое другое внушает доверие кроме российского? Интересно, почему?

anonymous ()
Ответ на: комментарий от anonymous

А чего там российского? Название и хостинг реп дистрибутива?

EXL ★★★★★ ()
Ответ на: комментарий от mystery

Да, молодцы. Ты перечислил всё, что я выпиливаю сразу после установки.

anonymous ()
Ответ на: комментарий от mystery

Забывают про GTK и GNOME, форком которого является Unity.

EXL ★★★★★ ()
Ответ на: комментарий от anonymous

Любые другие разработки пусть и имеют зонды, следят за пользователями и отправлят данныые спецслужбам, но они в любом случае далеко и мы неподсудны иностранным судам, по крайней мере пока человек находится в России. А в России если за тобой могут следить, то ничем хорошим это не закончиться.

anonymous ()
Ответ на: комментарий от Odalist

А товарищ uin всё верно говорит, между прочим.

Существующие пакетные менеджеры - адская система, не помогающая, а наоборот, препятствующая. Причем бегания по интернету в поисках «более-менее свежего ppa с $x», в стиле поиска по помойкам нужного setup.exe в винде, никто не отменял.

Вот вам пример. Накатил я не так давно последний выпуск Linux Mint, которая, напомню, рекламируется как «лучше Ubuntu», Linux Mint 17.3. Далее возникают, казалось бы, простые задачи:

  1. Захотел я по идейным соображениям вычистить flash из системы.
    system ~ # aptitude search flash | grep '^i'
    i A adobe-flashplugin               - Adobe Flash Player plugin                 
    i A libhal1-flash                   - Compatibility library to allow playback of
    

    Делаю aptitude remove adobe-flashplugin, и что бы вы думали?

    system ~ # aptitude remove adobe-flashplugin
    The following packages will be REMOVED:  
      adobe-flashplugin 
    0 packages upgraded, 0 newly installed, 1 to remove and 3 not upgraded.
    Need to get 0 B of archives. After unpacking 32,1 MB will be freed.
    The following packages have unmet dependencies:
     mint-meta-codecs : Depends: adobe-flashplugin but it is not going to be installed.
    The following actions will resolve these dependencies:
    
         Remove the following packages:
    1)     mint-meta-codecs            
    
    Accept this solution? [Y/n/q/?] 
    
    Ну вы поняли, да? Иными словами, мне предлагается остаться без возможности воспроизведения mp3, mkv, ...
    system ~ # aptitude show mint-meta-codecs | grep Description
    Description: All the packages required for multimedia support in Linux Mint.
    
    А когда я применил механизм Apt-Pining, менеджер пакетов банально отказался оперировать с ними, ссылаясь на «невозможность разрешить зависимости».

  2. Далее. Захотел я заменить mate-screensaver на что-то другое, к примеру, xscreensaver. И таки шо?
    Depends: dbus-x11, mate-desktop-common
    В этот раз мне [безальтернативно] предлагается снести половину MATE (если не весь).
  3. Война с пакетным менеджером продолжается. Задача: необходимо разобрать на кадры .mkv файл. Что первым приходит на ум? Правильно, ffmpeg.
    system ~ # ffmpeg
    ffmpeg: command not found
    
    И в репозитариях пакета тоже нет. А всё потому, что разработчики и мейнтейнеры из-за каких-то драм в своих мейл-листах приняли решение выкинуть ffmpeg из дистрибутива, закрыть глаза вообще на то, что он существует. Вместо этого мне предлагается ковырять что-то под названием libav. Отлично, спасибо. Теперь мне нужно идти искать в гугле Оффициальный Сайт, качать tarball'ы, компилировать в /opt/. Какое удобство установки, у-у-у!

И пожалуйста, не надо в этот раз отмахиваться фразочками про «виндузятские методы» и «виндузятский подход».

У меня ведь простой вопрос: почему этот ваш Linux диктует мне, какой софт использовать, а какой не использовать? Почему я не могу, например, свободно даунгрейднуться до Gnome 2 или KDE3, заменить systemd? Ах да, это потому что там Зависимости™.

anonymous ()
Ответ на: комментарий от uin

Да хоть что, лишь бы нормально работать с приложением без головняков и гемора, а то установил приложение - оно скачало ворох зависимостей на 50mb

А лучше чтобы каждое приложение эти 50Mb тащило с собой?

полез удалять зависимости а оно тебе внезапно заявляет что удалит еще вот это и вот этоб приложения которые раньше без этой либы обходились

Список шагов как это повторить или ложь.

Где это видано вообще чтобы для установки пользовательской апликухи требовались рут права?

В системах где не бывает вирусов.

slovazap ★★★★★ ()
Ответ на: комментарий от anonymous

Это если есть за что, а так, наоборот, можно использовать как алиби. И, кстати, для проживающих за границей всякие спецслужбы вроде омереканских на суды обычно не заморачиваются.

И вообще, если ты пользуешься интернетом российских провайдеров то для тебя всё остальное вроде того какой дистр или программа только ложная иллюзия «безопасности».

anonymous ()
Ответ на: комментарий от uin

Какая установка софта без прав рута, это что вам винда чтоли или Мак. Так работайте на вынде если паролей боитесь. Жесткача вам надо для начала: начать со сборки Гентушки с Иксами все как положенно ДМом поднять Openbox или DWM, а дальше видно будет. И будет вам счастье никакой пароль Тута вас точно не испугает особенно после сборки ядра и нормальной прокрутки видео дров поднятие Иксов.

Vint_243 ()
Ответ на: комментарий от anonymous

надеюсь тебя таки схватят за жопку

anonymous ()

Уж лучше Леннард, чем эта п Сара

anonymous ()
Ответ на: комментарий от anonymous

Уж лучше Леннард П., чем эта п. Сара

anonymous ()
Ответ на: комментарий от anonymous

Вот вам пример. Накатил я не так давно последний выпуск Linux Mint,

А вы не подумали, что это проблема в Linux Mint?

почему этот ваш Linux диктует мне, какой софт использовать, а какой не использовать?

Ненужно обобщать. Ставьте Arch Linux. Будете иметь полный контроль того, что будет установлено.

Почему я не могу, например, свободно даунгрейднуться до Gnome 2

Ну он как бы уже не поддерживается. Ну ставьте Debian 6. Будете иметь Gnome 2.

или KDE3

Тоже самое. Ставьте Trinity DE. Будете иметь сладости KDE3.

заменить systemd?

Этого тоже нету в Linux Mint.

Ах да, это потому что там Зависимости™

А где вы видели софт без зависимостей?

Odalist ★★★★★ ()
Ответ на: комментарий от anonymous

mint-meta-codecs
meta

Это метапакет, шорткат для установки всего набора кодеков (всех пакетов) в данном случае. Очевидно, что удаление одного из кодеков делает набор неполным, поэтому и метапакет уходит. Где тут у тебя забирают mp3?

Апдейт

Доки например: https://help.ubuntu.com/community/MetaPackages

mutley ()
Последнее исправление: mutley (всего исправлений: 1)
Ответ на: комментарий от slovazap

А лучше чтобы каждое приложение эти 50Mb тащило с собой?

А что такого то? У музыкального плеера свои либы из пакета ffmpeg например, у видеоплеера свои, но это те либы работу которых автор этого плеера тестировал и гарантирует. Это жалкие крохи же, комбайнеры вроде VLC и ffmpeg и так же в себе их несут, просто единым монолитным бинарником и что то у линуксойдов недоумения не вызывает что зачем это в /usr/lib/ лежат libavc56 libfaac56 etc, в то время как ffmpeg бинарник весит 12мб и в нем те же самые либы встроены.

Список шагов как это повторить или ложь.

Вот там выше анон расписал что и почем.

В системах где не бывает вирусов.

И пользователей. А насчет безопасности - разворачивание пакетов в те же самые локации где установлены основные компоненты системы (иногда перезатирая или обновляя какие то ее компоненты приложениями из сторонних репозиториев) безопасности ниразу не добавляет, а даже совсем наоборот.

uin ★★ ()
Ответ на: комментарий от Odalist

А вы не подумали, что это проблема в Linux Mint?

Вероятно. Но приличных ему альтернатив не так и много.

Ставьте Arch Linux. Будете иметь полный контроль того, что будет установлено.

Арч предполагает ещё больше возни с системой. У меня как бы задача обратная — от этого уйти…

уже не поддерживается

И из этого следует, что никто его уже не может установить?

Ну ставьте Debian 6. Будете иметь Gnome 2.

Ну нет, ставить старые дистрибутивы — не решение. Поддерждка этого выпуска Дебиана, например, кончается уже в феврале 2016. Что делать дальше?

Тоже самое. Ставьте Trinity DE. Будете иметь сладости KDE3.

Не-а. Это не аутентичный KDE.

Этого тоже нету в Linux Mint.

И много где ещё, где это стратегическое решение приняла группа мейнтейнеров.

А где вы видели софт без зависимостей?

Почему-то сами-знаете-какой ОС это не мешает.

anonymous ()
Ответ на: комментарий от mutley

метапакет

Удаляешь --purge либреофис из дебиана, он пишет что удалит gnome-desktop, а потом autoremove радостно сообщает что все пакеты из gnome-desktop больше не нужны.

uin ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.