LINUX.ORG.RU

Вышел ROSA Desktop Fresh R2

 ,


0

2

Компания «РОСА» выпускает новый релиз своего дистрибутива для Linux-сообщества ROSA Desktop Fresh R2.
ROSA Desktop Fresh R2 — плановый апдейт-релиз платформы ROSA Fresh. Линейка «R» предназначается для технически грамотных пользователей, желающих получить свежие версии ПО, имеющих достаточно новое оборудование и не предъявляющих повышенных требований к стабильности системы. Это семейство дистрибутивов развивается как силами специалистов компании «РОСА», так и силами сообщества. Релиз включает в себя все исправления, улучшения и дополнения, которые произошли с даты предыдущего релиза R1.
Данная версия ROSA Desktop Fresh R2 включает в качестве основного окружения рабочего стола KDE4. В ближайшее время будут представлены редакции системы с обновленным рабочим столом GNOME и LXDE.
Те, кто уже использует ROSA Desktop Fresh 2012 R1, получат обновление до ROSA Desktop Fresh R2 через штатную систему обновлений.

Изменения в технической части по сравнению с прошлым релизом:
Улучшения в инсталяторе:

  • При наличии сети раскладка, язык и временная зона выбираются через GeoIP
  • Улучшена поддержка btrfs
  • Доработана русская локализация

Окружение рабочего стола:
Основное окружение рабочего стола KDE обновлено до версии 4.11.3. Помимо обновления, исправлено несколько ошибок (в том числе, и проблемы upstream) и регрессий. Исправлен ряд ошибок локализации. Phonon обновлен до версии 4.7.0

Обновления прикладного ПО

Популярные пользовательские приложения обновлены до своих последних версий:

  • LibreOffice - 4.1.3 c исправленными ошибками зависаний в KDE4 (при использовании режима интеграции) и поддержкой Python 3
  • Clementine - 1.2 с добавлением поддержки ВКонтакте
  • Firefox - 25.0.1
  • Thunderbird - 24.1.1

Системная часть

  • Ядро системы обновлено до версии 3.10.19 c патчами исправления MEI-зависания процессоров Intel и улучшенным определением мониторов X-Server 1.14.4
  • Обновлены видеодрайверы Intel до версии 2.99.905, NVIDIA - 325.15 и NVIDIA304 (для карт < 8xxx) - 304.88, AMD Catalyst (fglrx) - 13.8
  • Mesa 9.2
  • FFmpeg 2.1 с добавлением поддержки кодека Atrac3+
  • GCC 4.7 с наработками Linaro (4.8 доступен в отдельном репозитории)
  • NetworkManager 0.9.8.2
  • Cups 1.7.0
  • Системные репозитории подключены сразу после установки, пользователь может сразу получать обновления системы
  • Для облегчения тестирования пакетов созданы testing-репозитории, подключаемые, но игнорируемые по умолчанию
  • В образы системы для архитектуры x86-64 добавлены 32-битные репозитории main и non-free для установки таких программ, как skype, wine, teamviewer, steam и других, не имеющих 64-битных сборок
  • Draksec (инструмент гибкого управления доступа к функциям администрирования) теперь поддерживает настройку принтеров и сканеров
  • Шифрование паролей пользователей переведено на алгоритм sha512
  • Grub2 в EFI-режиме теперь находит и прописывает Windows разделы
  • Добавлена базовая поддержка EFI при установке. grub2 и efibootmanager позволяют установить систему на EFI машины, но пока не в автоматическом режиме.

Systemd

  • systemd обновлен до версии 204
  • Произведена миграция на systemd следующих подсистем:
    • Управление локалями и раскладками. Теперь их можно настроить как через localectl, так и через старый инструментарий drakkeyborad и draklocale
    • Управление временными зонами возможно как через drakclock, так и через timedatectl
  • Добавлен собственный генератор подключения EFI разделов, не требующий обязательного наличия efivars
  • Продолжается перевод устаревших скриптов init.d на сервисы systemd

Установочные образы системы можно скачать по ссылке
Сообщения об ошибках принимаются в багзилле
Просмотреть информацию о релизе и список известных на момент выпуска ошибок можно здесь

Разработчики компании «РОСА» готовы подробно ответить на вопросы на форуме

>>> Источник



Проверено: leave ()

FFmpeg 2.1 с добавлением поддержки кодека Atrac3+

Atrac3+ используется, например, в PSP-игрушках. И если ffmpeg собран с поддержкой Atrac3+, то в последнем релизе PPSSPP (эмулятор PSP) в играх есть фоновая музыка (иначе только звук). Не знаю только, уже взяли патч для Atrac3+ в транк ffmpeg или ещё рассматривают его. Maxim Polijakowski автор патча.

Pulfer ()

Софт старее, чем в опенсусе 13.1.

kinik ★★☆ ()

А вашим дистрибутивом правда кто-то пользуется? Ни в коем случае не хочу обидеть, но учитывая общее отношение к малоизвестным дистрибутивам... Я не в курсе, может есть киллер-фичи какие?

evilmanul ()

Что изменилось, кроме надрачивания версий пакетов?

voodoo_doll ()

Я прямо вижу, как это набиралось

Линейка «R» - кривое^W^W предназначается для технически грамотных пользователей, сырое^W желающих получить свежие версии ПО, прожорливое падучее гов^W^W^W имеющих достаточно новое оборудование и не предъявляющих повышенных требований к стабильности системы.

thesis ★★★★★ ()
Ответ на: комментарий от evilmanul

В чём это выражается? И где кеды собраны плохо?

можно просто пользоваться, в убунте

pear-user ()
Ответ на: комментарий от pear-user

Чем кеды кубунты некошерны? Пользуюсь пока-что, и горя не знаю.

evilmanul ()
Ответ на: комментарий от evilmanul

Если бы не неприлично мелкий репозиторий - был бы отличный дистр. Но т.к. он таки мелкий - близко к состоянию ненужно.

templarrr ★★★★★ ()
Ответ на: комментарий от evilmanul

А вашим дистрибутивом правда кто-то пользуется?

Я, например.

может есть киллер-фичи какие?

Наследие Мандривы.

redgremlin ★★★★★ ()
Ответ на: комментарий от evilmanul

И где кеды собраны плохо?

Почти везде. Качественно собираются в ROSA, Mageia и OpenSUSE. Ну и ещё в покойном Pardus когда-то.

Pulfer ()

NVIDIA304 (для карт < 8xxx) - 304.88

urpmq -S dkms-nvidia-long-lived
dkms-nvidia-long-lived : NVIDIA kernel module for GeForce 6 and later cards ( 304.64-9 )
dkms-nvidia-long-lived : NVIDIA kernel module for GeForce 6 and later cards ( 304.108-4 )

Точно 304.88 ?

redgremlin ★★★★★ ()
Ответ на: комментарий от evilmanul

Тем, что во всякие кубунты багфиксы приходят из апстрима с огромной задержкой. Например, в нормальных дистрибутивах KDE-баг https://bugs.kde.org/show_bug.cgi?id=254430 был закрыт полгода назад, а в кубунты фикс только с обновлением 4.11.3 пришёл. Особенно тяжело придётся в отсталых дистрибутивах с переходом на Phonon 4.7.0. В апстриме KDE сейчас в звуковой подсистеме полно регрессий. Вплоть до того, что Phonon перестаёт веб-камеры распознавать (из-за коммита http://quickgit.kde.org/?p=kde-runtime.git&a=commitdiff&h=9c061a16753... ).

Pulfer ()
Ответ на: комментарий от kinik

Софт старее, чем в опенсусе 13.1.

Суся при своём выходе щеголяет пустыми репозиториями, которые наполняются примерно к выходу следующей версии.

Vudod ★★★★★ ()
Ответ на: комментарий от Vudod

Практически всё нужное есть, а чего нет можно и самому собрать же.

kinik ★★☆ ()

Только Ubuntu! Остальные дистры должны умереть на декстопе. Во имя лучшего будущего.

И это кстати не троллинг, лучше бы авторы «росы» писали платные программы по модели open core или например business source. Зарабатывали бы больше денег, а мы бы получали больше софта, а не перепаковки того же самого.

I-Love-Microsoft ★★★★★ ()
Ответ на: комментарий от evilmanul

Чем кеды кубунты некошерны? Пользуюсь пока-что, и горя не знаю.

Тем же, чем и в дебиане, альте, федоре и десятках других дистрибутивов — они там ненастроены.

Aceler ★★★★★ ()
Ответ на: комментарий от kinik

Практически всё нужное есть, а чего нет можно и самому собрать же.

Понятия о нужности у всех разные. Вам нужны последних версий плазма, плеер и дрова на видюху, а мне pyopencl, Lazarus и Scilab. В популярных дистрибутивах типа Ubuntu, Debian, Gentoo/Calculate, Fedora это есть, пусть не самых последних версий. В сусе только сервис сборки для начинающих радиолюбителей.

Vudod ★★★★★ ()
Ответ на: комментарий от Aceler

Тем же, чем и в дебиане, альте, федоре и десятках других дистрибутивов — они там ненастроены.

В Альте были хорошие третьекеды, кстати, с удовольствием вспоминаю 4.1.

Vudod ★★★★★ ()

Линейка «R» предназначается для технически грамотных пользователей, желающих получить свежие версии ПО, имеющих достаточно новое оборудование и не предъявляющих повышенных требований к стабильности системы.

Linux Athlon-X3-450 3.12.2-1-ARCH #1 SMP PREEMPT Fri Nov 29 21:14:15 CET 2013 x86_64 GNU/Linux
drfaust ★★★★★ ()
Последнее исправление: drfaust (всего исправлений: 1)
Ответ на: комментарий от redgremlin

Наследие Мандривы.

Какие киллер-фичи были у Мандривы?

sluggard ★★★★★ ()
Ответ на: комментарий от redgremlin

В дебиане неплохие кеды. Только староваты.

Которые старые, те может неплохие, про них не знаю. Смотрю сейчас, как собираются кеды в sid (4.11.3 + phonon 4.7.0). Сходу можно сказать, что есть проблемы с громкостью системных уведомлений, когда используется PulseAudio. Хотя даже Федора уже решила у себя эту проблему (патчем из Магеи: http://pkgs.fedoraproject.org/cgit/kde-runtime.git/commit/?id=b2ddda1c6b07dde... ).

Pulfer ()

В ближайшее время будут представлены редакции системы с обновленным рабочим столом GNOME и LXDE.

А Gnome так и остался бетой?

Aceler ★★★★★ ()
Ответ на: комментарий от Pulfer

кеды в sid

Ну, дебиан ­— это не то место, где все ломанулись исправлять баги в сиде за год до заморозки. Скорее в апстриме баг повесят, тем более, что в следующем дебиане будет 4.12 наверняка.

redgremlin ★★★★★ ()

И ещё вопрос на засыпку как на счёт версии для ARM?

Aceler ★★★★★ ()
Ответ на: комментарий от Aceler

А Gnome так и остался бетой

Gnome сильно «допилен» по сравнению с апстримом. Правда, из-за этого он будет в релизе 3.8, а не 3.10.

Pulfer ()
Ответ на: комментарий от evilmanul

Киллер-фича: отличная сборка. Кеды, системд, все не просто запихнуто в дистр, а обработано напильником с наложением собственных патчей. В результате, система выглядит целостно.

anonymous ()
Ответ на: комментарий от Pulfer

Нет, у вас Gnome Fresh R1 имеет статус бета. R2 наконец будет работать?

3.10 это хорошо.

Aceler ★★★★★ ()
Ответ на: комментарий от sluggard

urpm*, draktools, хорошая поддержка оборудования, в том числе через мышеклики (включил принтер -> «здрастье, у вас новый принтер, дрова ставить будем?» -> ok -> «дрова поставил, тута ещё фирмварь нужна для полного счастья, качнуть?» -> ok -> «Усё работает, насяльника, могу пробную страницу напечатать, если не веришь»). Ну и про нормальные кеды уже сказали.

redgremlin ★★★★★ ()
Ответ на: комментарий от redgremlin

Ну, дебиан ­— это не то место, где все ломанулись исправлять баги в сиде за год до заморозки

Посмотрел ещё kde-workspace 4.8.4 в wheezy - фикс для одного из самых печальных KDE-багов (#254430) там не бэкпортирован. Т.е. человек ставит систему, настраивает оформление на свой вкус, потом идёт настраивать автоматический логин в KDM, и настроенное до этого оформление при этом частично слетает из-за повреждения kdeglobals. И будет слетать каждый раз, когда запускается KCM KDM. Хотя видно и ряд бэкпортированных патчей, так что некоторая поддержка и забота действительно есть.

Pulfer ()
Ответ на: комментарий от redgremlin

Юзеру Суси глянуть на РОСУ советуешь, или нет смысла? P.S. Спасибо большое РОСЕ за вклад в разработку KDE!

sluggard ★★★★★ ()
Ответ на: комментарий от Aceler

Нет, у вас Gnome Fresh R1 имеет статус бета. R2 наконец будет работать?

Ну, на мой взгляд в Gnome 3 в принципе нельзя работать, я минут 10 терпел, а потом вырубил и снёс виртуалку с ним :-D

Но конкретно Gnome 3.8 в R2 коллеги считают очень хорошо собранным, как раз с упором на стабильность работы (там даже утечки памяти отлавливали и чинили, если мне память не изменяет). Хорошо бы мейнтейнер Gnome зашёл на ЛОР, увидел эту тему и сам в комментах поотвечал про Gnome...

Pulfer ()
Ответ на: комментарий от Pulfer

человек ставит систему, настраивает оформление на свой вкус, потом идёт настраивать автоматический логин в KDM

У меня не было шансов встретить этот баг — я всегда сначала включаю автологин, доставляю всякое нужное, после чего перезагружаюсь (хотя бы ради firmware-linux-nonfree) и тогда уже настраиваю всё сразу.

redgremlin ★★★★★ ()

При наличии сети раскладка, язык и временная зона выбираются через GeoIP

Без возможности дальнейшего изменения пользователем?

Системные репозитории подключены сразу после установки, пользователь может сразу получать обновления системы

А раньше было не так? О_о

sT331h0rs3 ★★★★★ ()
Ответ на: комментарий от sluggard

Я сусю с 12.3 не трогал, так что на заклад биться не стану. Но Drak мне нравится больше YaST, он, по крайней мере, не считает себя умнее админа и настройка через гуй и через конфиги друг с другом не конфликтуют по большей части.

redgremlin ★★★★★ ()
Ответ на: комментарий от redgremlin

В Сусе Яст уже не портит конфиги ведь, какие там конфликты?

sluggard ★★★★★ ()
Ответ на: комментарий от Pulfer

Качественно собираются в ROSA, Mageia и OpenSUSE

Компилятор соплями девственниц поливают?

overmind88 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.