LINUX.ORG.RU

Audacious 3.0

 ,


0

0

Вышла новая версия аудиоплеера Audacious. Главным изменением в этом выпуске является полная поддержка тулкита GTK+ 3.0, который теперь используется по умолчанию.
Это повлекло за собой отказ от ряда неподдерживаемых плагинов, несовместимых с GTK+ 3.0, в их числе alarm, evdev-plug, ladspa, lirc, paranormal, projectm-1.0, spectrum, streambrowser.

В подсистему плагинов были внесены изменения, упрощающие использование параллельной обработки в несколько потоков, что должно положительно сказаться на производительности.

Среди других изменений:

  • устранена задержка при переключении между плейлистами в случае, когда их открыто много;
  • MP3-декодер теперь использует системную библиотеку libmpg123 вместо встроенной;
  • при скрытии меню, доступ к его пунктам можно получить по нажатию правой кнопки мыши на элементах управления;
  • среди глобальных горячих клавиш теперь можно настроить переключение режимов повторения и перемешивания;
  • поддерживается отображение обложек альбомов, встроенных в файлы формата Ogg Vorbis;
  • скрипт ./configure теперь определяет OSSv4 и автоматически включает соответствующий плагин;
  • используется новый FFmpeg API для операций ввода-вывода, необходимый для проигрывания файлов форматов WMA, ALAC и некоторых других.

>>> Подробности

Ответ на: комментарий от maniacscientist

Ты меня спрашиваешь? Я им не пользуюсь, ставил только на посмотреть.

petyanamlt ★★★★ ()
Ответ на: комментарий от daemonpnz

> До говядинки с qmmp не дотягивате оно пока.

А я юзаю как раз его и что-то не чувствую себя в чём-то ущемлённым. Да, у меня ~3000 треков в плэйлисте, я не использую всякие библиотеки музыки и пр, и меня это вполне устраивает.

Sadler ★★★ ()
Ответ на: комментарий от daemonpnz

+1. да, парадокс, но Вакер за полгода написал плеер фичастее и удобнее плеера с более чем 10тилетней историей.

anonymous ()

Оно метки расставлять и сохранять в подходящий контейнер умеет? Иначе в топку.

FeyFre ★★★★ ()
Ответ на: комментарий от maniacscientist

Извращенцы знают толк в запуске 2 канальной музыки на 5.1 канальную систему, да...

bhfq ★★★★★ ()

Недавно ушёл с него. Пока не жалею.

Linez ()
Ответ на: комментарий от Polugnom

>>Это тот, который аля Winamp?

На сколько я знаю, он уже давно не аля винамп. Где тут можно увидеть винамп? http://audacious-media-player.org/local-images/audacious-2.5a2-3.png

Одно из его преимуществ, в том, что он всяким может быть: http://audacious-media-player.org/screenshots даже почти точной копией DeaDBeeF. Но я с него свалил на Clementine ибо сабж пошёл не по тому пути развития, что я ожидал.

vilisvir ★★★★★ ()

отказ от ряда неподдерживаемых плагинов, несовместимых с GTK+ 3.0... lirc

обновляться не буду - закопать.

drfaust ★★★★★ ()

Для аудио Дедбиф и ничего больше.

anonymous ()
Ответ на: комментарий от rafister

> juk лучший. для меня.

Не играет AAC, MP4, WMA и прочую дрянь, а иногда надо.

А так да, Juk рулит.

anonymous ()

Audacious 3.0

Блин - спутал с Audacity... (аж млин обрадовалсо)

плееров и так «как грязи» , а вот нормальных редакторов аудио/видео - днем с огнем фиг найдешь.. (хотя аудио то есть - только пилят медленно, а вот с видео - боОльшой вопрос)..

вообщем - не нужен....

uin ★★★ ()
Ответ на: комментарий от darkshvein

> Знакомое лицо. :D

концептуальный маскот Ubuntu 24.04

uin ★★★ ()

> скрипт ./configure теперь определяет OSSv4 и автоматически включает соответствующий плагин;

Хоть кто-то ещё помнит, что не ALSA единым...

anonymous ()
Ответ на: комментарий от Deleted

Интересно получается: от плагинов на gtk2 они избавились, но в то же время оставили обратную совместимость...

Может, когда-нибудь проверю. Неохота сейчас пробовать. У меня с обновлением audacious'а иногда проблемки бывают: то какая-то из версий сегфолтится периодически, то какая-то из версий со звуком выкрутасы выделывает, то - загружает файлы оооочень медленно...

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от darkshvein

Вот единственный вменяемый плеер обновился наконец и стал невменяемым :) Библиотека libmowgli у них хорошая. И да, отсутствие сборки под оффтопки для gtk-приложения — это грустно.

buddhist ★★★★★ ()

гтк3 не нужен

anonymous ()

Надеюсь, в ебилде запилят юзфлаг -gtk3

stormblastt ★★★ ()

Это повлекло за собой отказ от ряда неподдерживаемых плагинов, несовместимых с GTK+ 3.0, в их числе alarm, evdev-plug...

Офигенские новости. Я только из-за первых двух плагинов скучал по Audacious (больше по второму, он хавал все кнопки с пульта), а теперь вовсе забуду. Да здравствует Amarok!

spoilt ★★★ ()
Ответ на: комментарий от spoilt

>Офигенские новости. Я только из-за первых двух плагинов скучал по Audacious (больше по второму, он хавал все кнопки с пульта), а теперь вовсе забуду. Да здравствует Amarok!

Я думаю, Вам стоит дождаться 3.1. К тому моменту уже все плагины должны работать.

vilisvir ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.