LINUX.ORG.RU

Релиз видеоредактора Shotcut 18.08

 , ,


2

1

Представлен релиз видеоредактора Shotcut 18.08, который развивается автором проекта MLT и использует данный фреймворк для организации редактирования видео. Поддержка форматов видео и звука реализована через FFmpeg. Возможно использование плагинов с реализацией видео и аудио эффектов, совместимых с Frei0r и LADSPA. Из особенностей Shotcut можно отметить возможность многотрекового редактирования с компоновкой видео из фрагментов в различных исходных форматах, без необходимости их предварительного импорта или перекодирования. Имеются встроенные средства для создания скринкастов, обработки изображения с web-камеры и приёма потокового видео. Для интерфейса программы используется тулкит Qt5. Программа написана на C++ и выходит под свободной лицензией GPLv3.

Изменения:

  • Добавлен тайм-код для панели «Задания», чтобы упрощать локализацию проблемы при ошибках экспорта видео;
  • Добавлен новый видео-фильтр, Unpremultiply Alpha;
  • Исправлены ошибки, приводившие к аварийному завершению работы программы в версии 18.05;
  • Теперь во время предварительного просмотра нет искажения звука;

>>> Подробности

Ответ на: комментарий от BceM_IIpuBeT

Кстати, не знаешь что за мода такая — раскрашивать приложения в цвет высохшего говна? Вот что у меня Ардор в галерее, что новые кденлайф, гимп и вот это поделие туда же...

deep-purple ★★★★★ ()
Ответ на: комментарий от deep-purple

Цвет фона

Цвет и яркость фона оказывают сильное воздействие на восприятие изображения - они являются частью условий просмотра. Поэтому в случае, если изображение подвергается редактированию в программе, фон должен оказывать минимальное влияние на результат. Поэтому его делают максимально нейтральным.

BigSerpent ★★ ()
Ответ на: комментарий от anonymous

Это не так просто. Из того что удалось найти, в среднем одно и тоже. Даже тулкит теперь одинаковый. Два одинаковых фронтенда к ффмпег... на одном тулките. Подход похож. Нафига?

petrosha ★★★★★ ()
Ответ на: комментарий от deep-purple

Вот что у меня Ардор в галерее, что новые кденлайф, гимп и вот это поделие туда же...

Во-первых, Ardour изначально тёмный.

Во-вторых, у всех перечисленных тобой программ оформление настраивается простым переключением тем.

Проблема в чём? Ты ж вроде не безрукий.

AP ★★★★★ ()
Последнее исправление: AP (всего исправлений: 1)
Ответ на: комментарий от petrosha

Опеншот, ЕМНИП, на питоне, а тут кресты. Это, конечно, несущественно для большинства пользователей, но большинству пользователей и тулкит безразличен. :)

hobbit ★★★★★ ()
Ответ на: комментарий от AP

Не, это я просто вбросил слегка. И смысл тут есть. Проблема в том, что не важно какие они, тёмные или светлые, например тот же ардор (допустим тот что у меня) не умеет в системную тему. Вместо этого предлагается пердолинг внутри приложения, хотя в ДЕ/ВМ уже настроено. Плюс никто не отменял переключение темы из системы, чего программа опять не подхватит и снова пердолинг.

deep-purple ★★★★★ ()
Ответ на: комментарий от hobbit

вторую

Да хоть сотую. Я поставлю qT только при условии, что весь тулкито-зависимый софт у меня в системе будет на qT. А этого не будет никогда.

Касательно этой программы, она мне и так не нужна. Но учитывая, что она на qT, она не нужна даже гипотетически, при нужде я лучше поищу альтернативы на GTK.

eternal_sorrow ★★★★★ ()
Ответ на: комментарий от eternal_sorrow

Но учитывая, что она на qT, она не нужна даже гипотетически, при нужде я лучше поищу альтернативы на GTK.

А если (опять-таки гипотетически) не найдёшь? (Не говоря уж о том, что GTK - это аналог только части Qt, могут потребоваться и другие либы).

Я поставлю qT только при условии, что весь тулкито-зависимый софт у меня в системе будет на qT

Это уже какой-то нездоровый фанатизм. А ведь есть ещё и wxWigdets, программы на нём ты тоже принципиально не будешь ставить? fltk там всякие...

Кстати, есть большая вероятность, что линуксовый бинарник Qt, вроде этого поставится и под Gentoo, если понять, что ему надо. (По ссылке 64-разрядный бинарник, если нужен 32-разрядный, надо взять версию постарше, например, 5.4). Хотя я под гентой Qt всё равно собрал из emerge, но это было давно.

hobbit ★★★★★ ()