LINUX.ORG.RU

Релиз Joomla! 2.5

 , ,


0

1

Вышла новая версия свободной CMS Joomla!. В ней содержится более двадцати новых возможностей, исправления более, чем 350 ошибок, 4 исправления, касающиеся системы безопасности.

Ключевые особенности данного обновления:

  • Расширенный поиск, работающий быстрее;
  • Автоматическое уведомление веб-мастера об обновлениях движка и расширений;
  • Поддержка работы с несколькими базами данных и совместимость с Microsoft SQL Server;
  • Улучшенная пакетная обработка данных.

Подробнее про улучшения и исправления можно прочитать здесь

>>> Подробности

Ответ на: комментарий от deb

в php, что-ли, начисто нет orm или подобного?

Есть. На пример http://www.doctrine-project.org/blog/doctrine2-preview-release.

эти же кариозные монстры намертво прибиты к mysql, в самых лучших случаях можно только надеяться на postgresql

Это уже пробле^Wжелание разработчиков cms поддерживать 1 (максимум 2) базы данных.

anthill ()
Ответ на: комментарий от anthill

Это уже пробле^Wжелание разработчиков cms поддерживать 1 (максимум 2) базы данных.

Т.е. orm есть, но модель использования php, где велосипед едет на велосипеде, и велосипедом погоняет, это не используется? Я так и думал.

А потом спрашивают, почему от PHP, как от чумы шарахаются.

deb ()
Ответ на: комментарий от MSEstMozg

они это с самого начала доказывают, пока доказали, что для бложиков подходит )

Оно уже не требует кучи гигагерц и гигабайт, чтобы не тормозить на банальном блоге из трёх страниц?

deb ()
Ответ на: комментарий от MSEstMozg

Ага, универсальная система. посмотрел зависимости - mysql и никак иначе. Универсальность из всех щелей. В категориях Windows, конечно.

deb ()
Ответ на: комментарий от anonymous

Все-таки в дерьме что-то есть,

миллионы мух не могут ошибаться

MSEstMozg ()
Ответ на: комментарий от deb

вроде нет.

жрёт, конечно, излишне, но уже не так критично. чтобы беспокоило их наличие на нищебродской впс-ке

MSEstMozg ()
Ответ на: комментарий от MSEstMozg

если надо, то было ишшо что-то типа flatpress и блоголёт, хз, поддерживаются/развиваются ли сейчас

Приложения без хорошей поддержки - время на ветер. В репозитории дебиана нет - значит уже настораживает.

А на rails или django, или вообще на ruby или python есть cms, чтобы для самого неподготовленного пользователя?

deb ()
Ответ на: комментарий от deb

А на rails или django, или вообще на ruby или python есть cms, чтобы для самого неподготовленного пользователя?

актуальную ситуацию не ведаю, но на rails что-то весьма красивое со стороны админки точно было. За архитектуру/код не знаю.

MSEstMozg ()
Ответ на: комментарий от deb

на rails2 я бы мог её и себе взять, на всякоразные случаи :)

deb ()
Ответ на: комментарий от northerner

Хорошая цмс для делания сайтов Joomla style ™, шаг влево шаг вправо и ты вгонокоде поуши

уж лучше друпал

umren ★★★★★ ()
Ответ на: комментарий от northerner

а кто такие дизайнеры в твоем понимании что они отправляют в корзину друпал? мне казалось они там ваяют в своем фотошопе тихо мирно и о друпала вордпрессах и джумхал не слышали?

umren ★★★★★ ()
Ответ на: комментарий от deb

в чем профит ставить цмску из репозитория? вся прелесть это в ней это 1 архив - там пхп pdo http://php.net/manual/en/book.pdo.php своеобразный унифицированный интерфейс в пхп к бд (изкаропки), друпал его юзает с 7 версии, что там наделали в дебиане я не вкурсе просто

umren ★★★★★ ()
Ответ на: комментарий от deb

самому недавно понадобилось побыдлкодить под цмс, выбрал друпал, крутится на эскулитэ нормально вполне

umren ★★★★★ ()
Ответ на: комментарий от umren

в чем профит ставить цмску из репозитория?

Сделать один раз и забыть. Мне это вообще совершенно не надо - если сразу не запустится, значит не судьба.

Ну и обновления безопасности какие-никакие. Автообновление баз всяких при обновлениях. И так далее.

deb ()
Ответ на: комментарий от umren

самому недавно понадобилось побыдлкодить под цмс, выбрал друпал, крутится на эскулитэ нормально вполне

Под третьей? А то я как-то поставил apt-get install phpbb3. Там на выбор была куча баз, в том числе sqlite 2 :)

deb ()
Ответ на: комментарий от deb

ну дык, скачай архив, распакуй, кинь в папку htdocs (или как там у вас в дебиане) запусти - работает - профит? тут репозиторий нафиг не нужен, кроме того такой подход не работает и для других языков, джангу - надо обновлять до последней версии руками, руби - rbenv или rvm ставить и отдельную версию руби держать, не надо молиться на апт гет

umren ★★★★★ ()
Ответ на: комментарий от umren

redmine у меня из репозитория, джанга из репозитория, и я не волнуюсь особо. гемы - через rubygems, если нужны отдельные окружения, я проще сделаю контейнер, который потом можно запросто удалить.

deb ()
Ответ на: комментарий от deb

мейнтейнеры - особенно в дебиане это отдельный слой глюков который кроет изначальные глюки, поэтому я им не особо доверяю :) можно легко дистро специфичные баги ловить

umren ★★★★★ ()

Да уж, нельзя экспериментировать в родной системе.

Попробовал refinerycms через gem, не очень понравилось. потом началась свистопляска с удалениями, добавлениями и прочим, но что бы я не пробовал и какую версию, никакой возможности ещё раз запустить refinery у меня нет :(

Была бы Windows - переустановил бы к такой-то матери.

Вот за это я ОЧЕНЬ не люблю хоть что-то, что стоит не под контролем пакетного менеджера - может возникнуть сложность вернуть «как было».

Добавили бы уже rails3 и refinerycms в Debian, вот это было бы хорошо.

deb ()
Ответ на: комментарий от deb

Preparing your application using the refinerycms generator..
Running: cd «/srv/cms/refinery» && «/usr/bin/ruby1.9.1» -S bundle exec rails generate refinerycms
/srv/cms/refinery/config/application.rb:10:in `<module:Refinery>': Application is not a class (TypeError)
from /srv/cms/refinery/config/application.rb:9:in `<top (required)>'
from /var/lib/gems/1.9.1/gems/railties-3.0.11/lib/rails/commands.rb:15:in `require'
from /var/lib/gems/1.9.1/gems/railties-3.0.11/lib/rails/commands.rb:15:in `<top (required)>'
from script/rails:6:in `require'
from script/rails:6:in `<main>'

Failed to generate application.
Message: Could not run the refinerycms generator successfully.
Exiting...


вот что эта шайтан-машина хочет?

deb ()
Ответ на: комментарий от deb

а, это же рельсы! надо было название поменять...

deb ()

Не. Ерунда опять какая-то.

Сколько я не пытался понять что Joomla, что Drupal, что вот эту CMS - вообще не могу понять принципов, как ей пользоваться.

Мне нужна совершенно банальная вещь - несколько страничек, на которые можно менять текст визуально, и добавлять картинки. Можно, в крайнем случае, даже меню не делать, я его сам сделаю.

deb ()
Ответ на: комментарий от pinkpiton

У меня таких велосипедов ещё 10 лет было написано с десяток. И на пыхе, и не на пыхе. Они решают одну проблему, а создают 10 потенциальных.

deb ()
Ответ на: комментарий от deb

Что ты новость то не прочитал, теперь и SQL Server можно прикрутить, можно mSQL прикрутить к жумле.

doomgl ()
Ответ на: комментарий от pkurg

твой идеал?

На друпале ничего не делаю, и в будующем, надеюсь, ничего делать не буду. Просто после того, как я сделал сайт на жумле у меня на неё рвотный рефлекс и паника, а после двоих на Друпале масса приятных впечатлений. То что у него тяжелый код во всех пониманиях — другой вопрос. Все ждут чуда от 8-ой версии.

sphericalhorse ★★★★ ()
Ответ на: комментарий от anonymous

Назови хоть один популярный сайт на жумле?
Несколько набиреться.

На Друпале:
— Убунта;
— Белый дом;
— некоторые медийные компании (кажись некоторые сайты MTV) и компании автопроизводителей;
— htmlbook.ru;
— ещё недавно был itc.ua. // 10 000 уников в день

Это только то, что вспомнилось с ходу.

Про Вордпресс я уже молчу. Я знаю несколько жумламенов и все они делают г*вно. Жумла не такая сложная и пропогандируется всякими там Денисками, поэтому и набрала 2% быдла.

sphericalhorse ★★★★ ()
Ответ на: комментарий от sphericalhorse

поэтому и набрала 2% быдла.
быдла.

Довольно опрометчиво.

doomgl ()
Ответ на: комментарий от deb

rbenv ставь, там можно отдельный пекедж гемов под каждый проект выкатывать, именно в таких случаях он решает все проблемы, глобально гемами ваще башлять низзя - DEPENDENCY HELL начинается

umren ★★★★★ ()
Ответ на: комментарий от deb

1.9.1 руби версия это унстейбл которая нерекомендуется сейчас ни рельсами ни всем остальным, вот ты и попал в жопу дебиановскую :)

umren ★★★★★ ()
Ответ на: комментарий от sphericalhorse

яваскрипт такой яваскрипт :D хотя там есть неплохой фреймворк zappa.js вроде, на coffeescript - намного приятнее (сам недавно выучил coffeescript)

umren ★★★★★ ()
Ответ на: комментарий от umren

на coffeescript - намного приятнее (сам недавно выучил coffeescript)

Я почемуто ещё его не признаю, хотя jade и stylus обажаю.

неплохой фреймворк

Имхо годных фреймворков нет. Мы сейчас пишем свой с крутой архитектурой и коллбеками, но он на ранней стадии и главный лидер и архитектор сейчас от разработки отбился.

sphericalhorse ★★★★ ()
Ответ на: комментарий от sphericalhorse

годных, вылизанных и зрелых - нет, нода слишком молода.. пару лет еще надо :)

поэтому не я тороплюсь в node.js вцелом бежать ;)

мне кажется он больше для приложений в реальном времени подходит или сервисов с подобным функционалом

umren ★★★★★ ()

не нужно, закопать обратно

q11q11 ★★★★★ ()
Ответ на: комментарий от northerner

Что за бред

Что за бред Вы несете милейший, WP хоть и специализируется на блогах, но он позволяет делать сайты любого уровня. Если Вы со мной не согласны, то вы не знаете его АПИ

spiritkhl ()
Ответ на: комментарий от Ginki

Джумла нужна для сайтостроителей.

Тут их половина.

doomgl ()
Ответ на: комментарий от deb

1.9.2 и 1.9.3

1.9.1 не рекомендуется никакими фреймворками, у тя отсюда и глюки

под твои задачи не совсем понимаю зачем тебе нужна CMS, попробуй генераторы статических сайтов

1) http://middlemanapp.com/ - ruby 2) http://jekyllrb.com/ - ruby 3) https://github.com/hyde/hyde - python 4) https://github.com/bevry/docpad - node.js

umren ★★★★★ ()

Joomla кусок быдлокода, закопать.

qbbr ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.