LINUX.ORG.RU

Вышел nvidia-drivers 334.16

 , ,


0

1

Данная ветка находится в стадии бета-тестирования, основные изменения:

  • Устранена ошибка, которая могла приводить к тому, что nvidia-settings некорректно высчитывала таблицы коррекции цвета при настройке бегунков цветокоррекции.
  • Обновлена панель управления nvidia-settings, чтобы разрешить дисплеям использовать RandR и ID имена при осуществлении запросов, направленных к определенным дисплеям.
  • Устранена ошибка, которая мешала корректной работе выпадающих меню в панели управления nvidia-settings в более старых версиях GTK+ (например, 2.10.x).
  • Обновлена панель управления nvidia-settings чтобы обеспечивать пояснительный текст для кодов профилей приложения и вариантов подходящих имен кодов во время настройки профилей приложения.
  • Обновлена Панель управления nvidia-settings, чтобы наполнить выпадающее меню стерео режимов, когда только эти режимы доступны.
  • Устранена ошибка, которая могла приводить к сбоям в работе приложений, использующих расширение OpenGL ARB_query_buffer_object в Xinerama.
  • Устранена ошибка, которая приводила к неверным сообщениям в панели управления nvidia-settings о HDMI режимах с высокой частотой пикселизации (как, например, при 4К разрешении), как о dual-link подключениях.
  • Устранена ошибка, которая могла приводить к плохой синхронизации стерео в крупных установках из нескольких мониторов, использующих 3D Vision, из-за плохого аппаратного подтверждения на некоторых мониторах.
  • Устранена ошибка, которая мешала корректному восстановлению DisplayPort 1.2 дисплеев после VT-переключения.
  • Изменено имя директории proc в /proc/driver/nvidia/gpus/ с расположением шины GPU, отображаемое в формате «domain:bus:device.function».
  • В 64-битные пакеты драйверов добавлены 64-bit EGL и OpenGL ES библиотеки.
  • Изменен формат поля «Расположение шины», отображаемого в файлах /proc/driver/nvidia/gpus/0..N/information с «domain:bus.device.function» на «domain:bus:device.function», чтобы соответствовать формату lspci.
  • Устранена ошибка в расширении GLX_EXT_buffer_age, когда некорректные сроки выдавались до тех пор, пока не подключалась тройная буферизация.
  • Обновлен NVIDIA X драйвер для загрузки модуля ядра NVIDIA X, используя `nvidia-modprobe`, а невспомогательную функцию XFree86 DDX xf86LoadKernelModule().
  • Изменено поведение драйвера по умолчанию, чтоб прекратить удаление расширений RandR 1.2, соответствующих неиспользуемым DisplayPort 1.2 устройствам. Их удаление может помешать работе некоторых приложений. Добавлена новая опция, DeleteUnusedDP12Displays, которая может быть использована, чтобы вновь включить это поведение. Эту опцию можно включить, запустив
    sudo nvidia-xconfig --delete-unused-dp12-displays
  • Улучшена поддержка переменных среды __GL_SYNC_DISPLAY_DEVICE и VDPAU_NVIDIA_SYNC_DISPLAY_DEVICE в определенных конфигурациях. Эти переменные среды теперь распознают все имена поддерживаемых дисплеев. Смотрите более подробно «Приложение С. Имена дисплеев» и «Приложение G. Поддержка VDPAU» в текстовом документе README.
  • Улучшена производительность X драйвера при обработке больших чисел распределения поверхности.
  • Устранена ошибка, которая приводила к тому, что PBO-загрузки кубических поверхностей карты извлекали неверные данные.
  • Устранена ошибка в nvidia-installer, которая приводила к ложным сообщениям об ошибке при отказе от установки моделей ядра NVIDIA или исходных файлов для модулей ядра.
  • Добавлена экспериментальная поддержка ARGB GLX изображений, когда Xinerama и Composite включены на X.Org xserver 1.15 в одно и то же время.

>>> Подробности

★★★★★

Проверено: Shaman007 ()

Бетка, да, но впечатлило количество изменений, так что модераторы - если будете подтверждать, то подтвердите как мини-новость.

В генте уже есть ебилд, уже с -r2.

leg0las ★★★★★ ()
Последнее исправление: leg0las (всего исправлений: 1)

Вяленд на нем еще не запускается?

FFSinit ★★ ()

xf86LoadKernelModule()

Ох уж этот юниксвейный xorg.

anonymous ()
Ответ на: комментарий от rskeyf

лузеры-нищеброды, проснувшиеся уже когда поезд ушёл?

anonymous ()

Блин, только перелез на радеон из-за OpenGL ES, как вышел драйвер для нвидии с его поддержкой..

Lindows ()

Шёл 2014 год, поддержки Optimus так и нет. Слоупоки из NVidia, такие слоупоки ...

anonymous ()
Ответ на: комментарий от anonymous

да уроды они! Интересно когда этот оптимус заработает все таки.

anonymous ()
Ответ на: комментарий от fallout4all

Виктор Бенедиктович

Что это за хрен?

anonymous ()
Ответ на: комментарий от rskeyf

на линуксе, кроме этого блоба, никто не предоставляет opengl 4.4 с достаточной производительностью и минимумом багов

x4DA ★★★★★ ()
Последнее исправление: x4DA (всего исправлений: 1)
  • В 64-битные пакеты драйверов добавлены 64-bit EGL и OpenGL ES библиотеки.

Оно по-прежнему работает только в X'ах?

carasin ★★★★★ ()
Ответ на: комментарий от carasin

Это может быть началом поддержки например вяленого или мира.

leg0las ★★★★★ ()
Ответ на: комментарий от leg0las

Когда в предыдущей ветке появилось EGL/GLES, сообщалось что оно на тот момент было только 32-битным и не работало без X'ов. Т.е. ни о каком Wayland'е и близко речи не было (к тому же, Wayland'у надо ещё какое-то одно нестандартное расширение). Вот я и интересуюсь, отвязали ли его от X'ов.

carasin ★★★★★ ()
Ответ на: комментарий от leg0las

Это может быть началом поддержки

Пример Optimus показывает, что начальная поддержка от компании NVidia может так навсегда и остаться лишь начальной.

anonymous ()
Ответ на: комментарий от Lindows

только перелез на радеон

Мох — это судьба.

anonymous ()
Ответ на: комментарий от x4DA

opengl 4.4

Нинужно, тк для туксрейсера достаточно 2.0, поэтому все должны покупать радеон и ставить швабодку.

anonymous ()
Ответ на: комментарий от anonymous

все должны покупать радеон и ставить швабодку

Там щас 3.3, многовато для туксрейсера.

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

Там щас 3.3

Разработчики в свободное время пилят в пику кукурузным циферкам блоба. На самом деле нинужно.

anonymous ()
Ответ на: комментарий от Behem0th

Да и вообще, разница между 3.3 и 4.4 всего 25%, на глаз не заметно, не стоит тревожить пукан зондами из-за такого.

anonymous ()
Ответ на: комментарий от anonymous

А есть под линукс что нибудь что требовало бы OpenGL выше чем 3.3? Самое требовательное что приходит на ум это unigine'овские Heaven, Valley Oilrush и недавнее Метро последний свет. И все они прекрасно идут на 3.3, Из => 4.0 требуется максимум GL_ARB_tessellation_shader чтоб тесселяцию включить, но и без нее прожить можно.

Behem0th ★★★★★ ()
Ответ на: комментарий от Behem0th

Опять бенчмарки, дрочение на циферки на блобе? Какая разница, сколько fps? Тем более cерьёзным людям некуда спешить.

anonymous ()
Ответ на: комментарий от Behem0th

Ну и как я уже говорил, достаточно 2.0, без ненужных бенчмарков, тем более ограничиваясь только проверенными стабильными версиями мы ограждаем себя от того разрывания пуканов, что ежедневно испытывают на себе пользователи блоба.

anonymous ()
Ответ на: комментарий от anonymous

Шел 2014 год. Вот уже 4 года у меня на ноутбуке работает оптимус.

LightDiver ★★★★★ ()
Ответ на: комментарий от anonymous

Я про то и говорю что пока под линукс есть 3,5 программы требующих OpenGL 3.3.

Behem0th ★★★★★ ()

как вы вообще рискуете пользоваться этим глюкодромом на вашиз вафельницах?%) хотя для бетки вроде норм

der_looser ★★ ()
Последнее исправление: der_looser (всего исправлений: 1)
Ответ на: комментарий от Behem0th

Правильно, так устроен рынок, сначала предприниматели вкладываются в проект, тратятся на его адаптацию под платформу, только после этого платформа начинает создавать базовую инфраструктуру для них. Никто не смотрит на наличие этой инфраструктуры, тк нинужно.

Линус не спроста начал писать ядро, после того, как оракл и редхэт ваысказали свою поддержку и вывели на рынок продукты для линукса.

Пусть пердоли с блобами соснут как обычно, все компании высказали поддержку и выбор для себя свободных драйверов, а не замшелых блобов, писаных индусами приписаными к какой-то там нвиде и пр.

anonymous ()
Ответ на: комментарий от LightDiver

Вот уже 4 года у меня на ноутбуке работает оптимус

Виндузятник. Да и у видеокарт, те amd, никакого оптимуса нет.

anonymous ()

В 64-битные пакеты драйверов добавлены 64-bit EGL и OpenGL ES библиотеки.

Что это значит?

uin ★★ ()
Ответ на: комментарий от uin

Блобопердоли пытаются догнать открытые драйвера, азазаз.

anonymous ()
Ответ на: комментарий от anonymous

Причем тут слоупоки? Мне стало давно очевидно, что плевали они на поддержку оптимус на линуксе.

amazpyel ★★★ ()
Ответ на: комментарий от amazpyel

Причем тут слоупоки? Мне стало давно очевидно, что плевали они на поддержку оптимус на линуксе.

виноваты доисторические x-ы

pear-user ()
Ответ на: комментарий от der_looser

блоб просто работает, в отличи от.
так что не сливайся ты уж так откровенно

megabaks ★★★★ ()
Ответ на: комментарий от anonymous

>> Вот уже 4 года у меня на ноутбуке работает оптимус

> Виндузятник.

Optimus работает в Linux, пишу с него.

> Да и у видеокарт, те amd, никакого оптимуса нет.

У них PowerXPress.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

С оптимуса ? Нормальной поддержки оптимуса нет. Я знаю что вы мне ответите. Отвечу сразу: «Шо то костыль, шо то костыль».

BWAne ()
Ответ на: комментарий от Behem0th

Последний свет

Метро последний свет
последний свет

Больше никогда так не делай, пожалуйста.

anonymous ()
Ответ на: Последний свет от anonymous

последний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний светпоследний свет

А что не так то?

Behem0th ★★★★★ ()

Не нужно, у меня всё равно видюха древняя как говно динозавра (с 304 дровами летает, а новее - чао).

Hertz ★★★★★ ()
Ответ на: комментарий от intelfx

Линукс версия требует 4ю версию? Или опционально тягает пару расширений? Есть у него какой нибудь триал на попробовать?

Behem0th ★★★★★ ()
Ответ на: комментарий от LightDiver

Шел 2014 год. Вот уже 4 года у меня на ноутбуке работает оптимус.

Так таки прямо 4 года?

Не надо кривляться и прикидываться мальчиком-дурачком, у меня тоже работает Optimus через bumblebee/primus - но это неофициальная поддержка, то бишь в случае не поддержки конкретной модели ноутбука, остаёшься без Optimus, либо с частичной поддержкой. Реализация в bumblebee не оптимальна, я думаю что NVidia способна сделать более производительную реализацию. В Steam у части игр проблемы с запуском через optirun и/или primusrun.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.