LINUX.ORG.RU

Релиз драйвера NVIDIA 325.15

 , ,


0

0

5-го августа состоялся очередной релиз проприетарного драйвера для видеокарт NVIDIA. Список изменений:

  • Добавлена поддержка GPU GRID K340, GRID K350, NVS 315, Quadro K500M
  • Исправлен баг в nvidia-settings, приводящий к появлению ложных сообщений о несоответствии устройств вывода при смене такового во время работающего SLI.
  • Устранено мерцание дисплея, возникающее при некоторых случаях смены масштабирования.
  • Исправлена дубликация некоторых элементов UI в nvidia-settings при смене VT на мультимониторных конфигурациях.
  • Метод прерываний PCI-E изменён с virtual-wire на MSI (если это приводит к невозможности загрузить драйвер, это изменение можно отменить через параметр «NVreg_EnableMSI=0» для модуля nvidia).
  • Удалена поддержка ядер серии 2.4, с этой версии требуется ядро 2.6.9 или новее.
  • Исправлен баг с созданием режима RandR с тем же именем, что и предыдущий, даже если таковой был удалён.
  • Исправлена ошибка игнорирования nvidia-settings цветов некоторых элементов UI в GTK-темах.
  • Исправлена ошибка, вследствие которой информация о коррекции цветов записывалась в файл .nvidia-settings-rc даже если в nvidia-settings была выключена опция «Include X Display Names in the Config File».
  • Исправлено сбрасывание некоторых настроек nvidia-settings при пересканировании дисплеев.
  • Исправлено падение некоторых OpenGL-приложений, использующих Frame Buffer Objects.
  • Устранена утечка памяти при выгрузке libGL до уничтожения всех GLX-контекстов.
  • Исправлена ошибка применения цветовой коррекции не к тому дисплею в мультимониторных конфигурациях, когда один из дисплеев был отключён и подключен вновь.
  • Исправлен баг с выводом ложных сообщений о потере NV-GLX расширений при выполнении непрямого рендеринга от клиента GLX с библиотеками NVIDIA OpenGL на не-NVIDIA GLX-сервер.
  • Улучшена производительность отрисовки сложных градиентов.
  • Добавлена поддержка конфигурирования SLI Mosaic и Base Mosaic в nvidia-settings.
  • Изменения в исталляторе, позволяющие опознать альтернативные (не из .run-файла) методы установки.
  • Исправлена группа багов в RandR.
  • И многое другое.

Также, несколько ранее вышла новая версия библиотеки VDPAU от NVIDIA: libvdpau 0.7, с поддержкой DRI_PRIME.

>>> Подробности

На opennet пишут, что теперь официально поддерживаются ядра 3.10+, но в чейнджлоге про это ничего нет.

it-nativa ()
Ответ на: комментарий от it-nativa

Присоединяюсь к вопросу. Вчера весь вечер пробовал патчить эту пакость на 3.10.

LightDiver ★★★★★ ()

почему блоб amd так не пилят ?

smilessss ★★★★★ ()
Ответ на: комментарий от smilessss

Может, потому что у NVIDIA есть решения для кластеров и профессиональных рабочих станций под Linux, а у АМД ничего этого нет?

it-nativa ()
Ответ на: комментарий от it-nativa

не знаю
после того, как мою карту внесли в легаси список я юзаю открытый драйвер
благо он уже куда лучше блоба

smilessss ★★★★★ ()
Ответ на: комментарий от smilessss

он уже куда лучше блоба

Для легаси-карт и тех, кто не играет в игры - да, лучше )

it-nativa ()

Хорошая новость. Думал может сразу обновить ядро, накатив патчей, но лучше подожду поддержки 3.10 из чейнджлога.

a1batross ★★★★★ ()

они так быстро пилят свои драйвера, что я скоро увижу версию 12309.

Anvladislavmf ★★ ()
Ответ на: комментарий от anonymous

Значит, они просто не заинтересованы в Linux. Их можно понять: финансовые ресурсы у них скудноватые, основная прибыль от консольщиков и виндузятников. Зачем им Linux?

it-nativa ()
Ответ на: комментарий от it-nativa

Время идёт, аналитики не меняются.

anonymous ()
Ответ на: комментарий от LightDiver

Чего там патчить-то? Там делов-то на две минуты.

carasin ★★★★★ ()

Про Optimus опять ни слова. Закрадывается мысль: а так ли он востребован? Растолкуйте кто пользуется, пожалуйста.

neutralfan ()
Ответ на: комментарий от carasin

Чего там патчить-то? Там делов-то на две минуты.

Ага, две минуты хотя бы найти патч, еще две минуты понять как бы его поправить под нужные версии, а то он под устаревшие, которых в портажах давно нет, еще пол часа - перебрать варианты версий патчей, драйверов и ядер.

LightDiver ★★★★★ ()
Ответ на: комментарий от carasin

325.08 точно работает с несложным патчем.

Ноу скрин фаунд и все тут.

LightDiver ★★★★★ ()
Ответ на: комментарий от LightDiver

Вот ты шлимазл ) я за две минуты вышел на форум devtalk.nvidia.com, а там патчи под все нужные версии ядер и дров. Скилл гугления прокачай, что ли )

it-nativa ()
Ответ на: комментарий от smilessss

почему блоб amd так не пилят ?

В бета версии (которая вышла первого числа), кстати, заявлена поддержка 3.10

X-Pilot ★★★★★ ()
Ответ на: комментарий от it-nativa

uname -a Linux system 3.10.5-custom #1 SMP PREEMPT Tue Aug 6 09:16:28 EEST 2013 i686 i686 i386 GNU/Linux nvidia-settings -v

nvidia-settings: version 325.15 (buildmeister@swio-display-x64-rhel04-07)

Allemon ()
Ответ на: комментарий от smilessss

В чём-то лучше. Но аппаратное декодирование хромает(и оно есть только в настабильной версии драйвера). И FPS в играх ниже в полтора-два раза по сравнению с блобом. Если этого не замечать - то да, в целом открытый драйвер лучше.

lucentcode ★★★★★ ()
Ответ на: комментарий от lucentcode

Но аппаратное декодирование хромает

в блобе VDPAU вообще нет, постоянный тириг в флеш видео,тормоза в 2d

smilessss ★★★★★ ()
Ответ на: комментарий от smilessss

в блобе VDPAU вообще нет

Зачем ты пишешь очевидное враньё?

И тиринга во флэше я ни разу не видел, как и тормозов 2D.

it-nativa ()
Ответ на: комментарий от smilessss

Три эталонных 4.2 в одном коротеньком предложении. У тебя талант!

Polugnom ★★★★★ ()
Ответ на: комментарий от it-nativa

у меня было так , поэтому и перешёл на открытый
в легаси версии по по крайней мере
как оно там в последних я не знаю

smilessss ★★★★★ ()
Ответ на: комментарий от Polugnom

это всего лишь описание ситуации, которая была у меня с блобом

smilessss ★★★★★ ()
Ответ на: комментарий от anima_hellsing

Есть разница в производительности по сравнению со шмелем ?

BWAne ()
Ответ на: комментарий от smilessss

Всё у него есть, а тиринг поправится compton или другим wm с композитингом.

ritsufag ★★★★★ ()

Удалена поддержка ядер серии 2.4, с этой версии требуется ядро 2.6.9 или новее.

slowpoke.jpg

reserved ()
Ответ на: комментарий от BWAne

Визуально прироста или падения производительности по сравнению с 319.32 не наблюдаю.

anima_hellsing ()
Ответ на: комментарий от BWAne

Присоединяюсь к вопросу: шмель больше не нужен?!

Twissel ★★★★★ ()

Надо же, драйвер вышел, кто бы сомневался.

snaf ★★★★★ ()

На Gentoo наконец-то собралось с ядром 3.10.5. До этого версия 325.08 вылетала с ошибкой.

Feonis ★★ ()

Кому нужны эти кривые костыли — ведь Бог подарил нам качественную продукцию AMD.

anonymous ()
Ответ на: комментарий от smilessss

в блобе VDPAU вообще нет, постоянный тириг в флеш видео,тормоза в 2d

УМВР, может у тебя недохром где все эти прелести не работают? VDPAU в gnome-mplayer 100% работает

pear-user ()
Ответ на: комментарий от neutralfan

Гадость этот оптимус. Купил с ним ноутбук сдуру, в итоге отдал брату. И перекрестился.

mbwa ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.