LINUX.ORG.RU
ФорумTalks

Уба-аааа-антууууу-уууууу (Усталым голосом)


0

0

Решил я что пора обновиться до Рыси.

Запустил update-manager -d, все хорошо, он мне написал, что можно обновиться...
Скачались пакеты, началась установка. Компьютер весело шуршал винтом, прогресс бар тихонько полз, ничего не предвещало беды...

Внезапно пропало окошко менеджера обновлений, прямо совсем, взяло и пропало, ничего не сказало...
Я посмотрел список процессов, обнаружил там периодически появляющийся dpkg - думаю ладно, значит ставится, буду ждать....

Прошло часа 2, я опять посмотрел список процессов, dpkg уже не было, зато был lucid, который кушал 97% процессора и, судя по всему, отдавать его не собирался.

Пришлось его грохнуть. Попробовал запустить update-manager -d, он мне нагло заявил, что не знает как обновить lucid до karmik (именно так, не наоборот). O.o

Ну, ничего, не сдаваться!.... написал в консоли sudo apt-get dist-upgrade. Оно пошуршало винтом, сказало, что n пакетов оно удалит, m пакетов обновит и т.п., после еще некоторого шуршания выяснилось, что продолжать нельзя, т.к. есть конфликты - в разных пакетах одинаковые файлы.

Ладно, ничего и хуже бывало... Выяснил, что проблема из-за поставленного с LP gnome-shell, снес его.
Процесс возобновился. Обновления поставились. Ничего не предвещало беды....

Перезагрузил комп, обрадовался что grub теперь на русском. Молодцы!
Дальше русского граба не пошло. Ядро немного подумав выдавало что корневого раздела нишиша нет, вот вам замечательная busybox консоль.
Написав в ней ls /dev я выяснил, что файлов для дисковых устройств нет вообще, нет винтов, флешки, двд-шника.

Ладно, ничего, бывало такое. Три кнопки, «е» в грабе, редактирование строки, /dev/sda10 вместо uuid - не помогло.
Грррр..... А если sdb10? - фигвам...
Оказывается в initramfs нет никаких модулей для моего чипсета. Всегда после апдейтов для новых ядер собирались нормальные initramfs'ы, а в этот раз система решила что нефиг много модулей пихать, надо место экономить...

Беру диск с 8.04. Загрузка, chroot, правлю конфиг, указываю чтобы было включено максимум модулей, update-initramfs.
Теперь грузится, урааааааааааааааа..... Ой... не, не грузится, пишут, что невозможно смонтировать /proc/bus/usb, вот вам уважаемый пользователь консоль, когда наиграетесь, нажмите ctrl-d.

Ладно, ничего... Редактирую fstab, комментирую нужную строчку. Ctrl-d, продолжает грузиться... недолго.
Хы не стартуют, говорят, что дров нету. Как нету? До обновления были нвидевские, закрытые.
Ну ничего, за одно попробую эту, как ее там... «ноувеау», о!
Тем более что она аж в initramfs включена вместе с перделкой plymouth, которая почему-то совсем не пердит, а вроде бы должна показывать что-то красивое при загрузке.

Редактирую xorg.conf, прописываю что надо - шишЪ.
Ядреный модуль есть, а драйвера для Хов нет.
Ладно, ничего, ставлю дрова, стартую X - опять шишЪ.
Запускаю gdm, он мне пишет, что непорядок с видео, трали-вали, что делать спрашивает...
Нажал создать новую конфигурацию - заработало, правда не понятно на каком драйвере. В конфиге прописано «nvidia», но он просто отсутствует.


А, ну да... это же еще не релиз, т.е. усе починят....

Вообще надо для спасательных целей включать какой-нибудь особый, толстый initramfs с небольшой системой, работающий из памяти. Чтобы можно было сходить в нет, скачать что надо или просто обновиться или поставить несколько пакетов...
Что бы я делал если бы не нашел диск с 8.04?.....

---upd--- Еще из наблюдений. Пропала вторая панель в гноме (трей, часы и еще всякая мелочь). Гном ругается на глюки DockBar, говорит, что апплет завершился и предлагает убрать его с панели, но апплет работает...

В нете читал, что в правой части окна обещают вундер-кнопку. Как ее включить?

★★★★

Не было печали — апдейтов накачали

Теперь и в убанте!

xorik ★★★★★ ()

Безумству храбрых поём мы песню, гыгыгы.

Hoodoo ★★★★★ ()

Ну... это не интересно, я вот сижу на 10.04 со времен 8.10, у меня 6 винтов в рейд-0(350гб*8) и ничего, бывает весело, да )

Но самое главное это:

то же еще не релиз, т.е. усе починят...

=)

Правда вот интересно, при апдейте с 9.10 до релиза 10.04 будет ли автоматом ставиться нуво, при условии, что проприетарный блоб уже стоит, как это ,собственно, сейчас? Если так, то будет еще веселее =)

Lindows ()

Обновляю убунту еще с беты 9.04, были пляски с переустановкой пакетов в востановочом режиме, но в целом ничего серьезного, типичное УМВР. И это при том, что у меня подключено куча ланчпадовских реп и дикая путаница в пакетах.

Magi-max ()

>Ядро немного подумав выдавало что корневого раздела нишиша нет, вот вам замечательная busybox консоль.

Написав в ней ls /dev я выяснил, что файлов для дисковых устройств нет вообще, нет винтов, флешки, двд-шника.


В убунте это более-менее нормально и даже ожидаемо.
А вот в Red Hat Enterprise Linux — уже перебор (из серии «бойцы вспоминали минувшие дни»). Причем там busybox и bash надо вручную в initrd вкорячивать.

nnz ★★★★ ()

После того как посмотрел 10.04 b2 пришел к выводу, что убунту не нужна, а до этого релиза притензий к ней не было - пользовал 2 с лишним года. Правка конфигов и привет, мертвые иксы, дальше восстановление системы.
Но это было потом. До этого была установка с нуля, убило. Вот наффига столько по зависимостям утягивать (притом зависимости явно убунтовские). Дебиан при аналогичной установке встал так, как его просили - без излишеств. А тут... Почему lxde тянет lxmusic И почему я lxmusic не могу удалить не грохнув lxde Это так, если идти цивилизованным путем, а не растоптать зависимости ногами.
Нет, все, точно не нужна - закопать. Установка с LIVE CD с гномом, тоже, тихий ужус и шок. Такого наворотили что мои немногочисленные волосы встают дыбом. Мне собсно интересно кому сказать спасибо, заветам Марка или новой телке в руководстве?

aksi2000 ()

Не, конечно везде бывают косяки, но чтобы такие... чтобы так много.
Ладно бы по мелочи, апплет перестал работать и т.п.
Так ведь не грузится... Какая же это ОС для домохозяек, если надо лезть в конфиги загрузившись с диска, надо ведб знать в какие и что в них писать...
Кажется именно так Canonical позиционирует свою ОС, как ОС для всех, без спец. подготовки, так сказать.

---
Последний раз когда я так весело провел день была попытка первый раз поставить хакинтош, а именно какого то тигра, при том там были косяки (уже не помню что именно, с ядром, дровами, железом...) и я из двух сборок делал одну, копируя ядра и kext'ы... :)

ls-h ★★★★ ()
Ответ на: комментарий от Lindows

> Если так, то будет еще веселее =)
Я и с теплым ламповым кактусом огреб странных багов по самое «не хочу». Куда уж веселее.

P.S. Бес попутал^W^W Решился недавно обновиться - уяснил на всю жизнь, что беты убунты круче любого bleeding edge.

metar ★★★ ()

ССЗБ

Коли баги репортить не собираешься зачем ставил? Что циферки побольше нравятся? подожди 3 недели и ставь 10.10 :)

amorpher ★★★★★ ()

Включил новую тему. Вундер-кнопки нету, смотрится противно.
Сижу тошнюсь...

ls-h ★★★★ ()
Ответ на: ССЗБ от amorpher

Как бы до релиза дней 15 (или около того), и _такие_ быги должнеы быть пофикшены.

ls-h ★★★★ ()
Ответ на: комментарий от ls-h

>Кажется именно так Canonical позиционирует свою ОС, как ОС для всех, без спец. подготовки, так сказать.
Эй, домохозяйка, а какого ты хрена бету ставишь? Шла бы дальше обед готовить.

anotheranonymous ()

Аааа.... аааа... вместо synaptic'а теперь какая-то фиговина.

ls-h ★★★★ ()
Ответ на: комментарий от ls-h

>и _такие_ быги должнеы быть пофикшены

Отправь своё резюме Марку (или кто там сейчас) на рассмотрение.

amorpher ★★★★★ ()
Ответ на: комментарий от ls-h

>Баги _страшные_ такие в бете уже не должны быть...
Как знать. В каноникал не боги сидят, чтобы предвидеть все и вся.

anotheranonymous ()
Ответ на: комментарий от metar

>беты убунты круче любого bleeding edge.

Ну как повезет.. )

Хотя, внезапно был удивлен, когда после обновления (причем на двух разных машинах) с b1 до b2, был удален компиз, а метасити не запускался автоматически.

Lindows ()
Ответ на: комментарий от darkshvein

Да в курсе, месье любит на кактусы садиться же сказал _какие_ это баги, таких даже в альфе быть не должно.

ls-h ★★★★ ()
Ответ на: комментарий от ls-h

>Да в курсе, месье любит на кактусы садиться же сказал _какие_ это баги, таких даже в альфе быть не должно.
Почитай с какой феерией винда обновляется с релиза на релиз и успокойся. А линуксу, который конструктор еще тот, такими болезнями еще долго страдать.

anotheranonymous ()
Ответ на: комментарий от ls-h

баги бывают везде. инфа 100%. а вот тех, кто их не репортает надобно карать раскаленной арматурой. дабы не ныли на лоре, а в ланчпад репортали все, что заметили. а вот чо кому должно - это будет решать космонавт или кто там всем рулит, а не гражданин негодовамши, который лор и убунтовский багтрекер путает, ага.

Unclown ()
Ответ на: комментарий от anotheranonymous

Ну, мне обновления линуха все равно больше виндовых нравятся.
Еще не было случая, чтобы пришлось линух переустанавливать, а вот винду...

ls-h ★★★★ ()
Ответ на: комментарий от ls-h

>Еще не было случая, чтобы пришлось линух переустанавливать, а вот винду...
Ну то-то и оно.

anotheranonymous ()
Ответ на: комментарий от michwill

Да, с 9.04 до 9.10 у меня гладко прошло, без косяков.

ls-h ★★★★ ()
Ответ на: комментарий от Camel_Toe

Потому что ты хреновый сказочник. Зависимости в убунту и в дебиане аналогичны.

Ладно, в squeeze действительно так, а вот lenny вроде мне этот пакет и не ставил вовсе, ща переключусь на другой комп проверю

aksi2000 ()

> Пришлось его грохнуть.

сам себе злобный буратина. теперь тебе проще с нуля переставить чем ковырять то что получилось.

isden ★★★★★ ()
Ответ на: комментарий от michwill

> Дык а что ж.. Апгрейд в убунте хоть когда-то без глюков работал?

прикинь, я провел десяток апгрейдов на разных машинках, часто на дев.версию, и НИРАЗУ не было проблем.

isden ★★★★★ ()

ССЗБ такой ССЗБ.

Или пользуйся стабильной версией или перейди на pclinuxos.это - действительно стабильный и безрелизный дистр.

cetjs2 ★★★★★ ()

Решил я что пора обновиться до Рыси.

Пришлось его грохнуть.

и т.д.

этот тред просто сборник ССЗБ!

Alsvartr ★★★★★ ()
Ответ на: комментарий от aksi2000

Тут нужно смотреть в настройки менеджера пакетов, синаптик, например, или аптитуда тащут рекомендуемые пакеты по умолчанию.

Я тоже как-то удивлялся, отчего дебиан при установке гимпа тащит половину гнома. Но во всяком случае сноситься всё должно без проблем.

Camel_Toe ()

Сегодня перешел на бету, никаких косяков не заметил. Был косяк после бета 1 -> бета 2. Никаких замечаний нету. Все работает.

Zodd ★★★★★ ()

Многабукафф... Убунта этого не достойна...

Eddy_Em ☆☆☆☆☆ ()
Ответ на: УВРИ ЧЯДН? от ponchik

У меня сначала люто глючил plymouth, не хотел грузить зашифрованый хомяк, сейчас 10.04 великолепна=) Никаких нареканий, плазма не падает(c)

Borman3000 ()
Ответ на: комментарий от ls-h

> А ты не думаешь, что такая ситуация должна быть предусмотрена?

ога, ручками разгребать. как правило, должно хватить проверки *.list и выполнении aptitude dist-upgrade.

isden ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.