LINUX.ORG.RU

В MacOS 10.15 скриптовые языки объявлены deprecated

 , , ,


0

1

Из https://developer.apple.com/documentation/macos_release_notes/macos_10_15_bet...

Scripting language runtimes such as Python, Ruby, and Perl are included in macOS for compatibility with legacy software. Future versions of macOS won’t include scripting language runtimes by default, and might require you to install additional packages. If your software depends on scripting languages, it’s recommended that you bundle the runtime within the app. (49764202)

А как там, вменяемый (не маргинальный для пары пользователей) десктопный дистр Linux можно без Python, Perl и Ruby использовать?

★★★★★

А нафига в нормальной системе скриптовые языки по-дефолту? Все мало мальски сложное должно быть нативное, а для остального достаточно bash и компании.

quwy ()

А как там, вменяемый (не маргинальный для пары пользователей) десктопный дистр Linux можно без Python, Perl и Ruby использовать?

А смысл? Даже в винде я юзал cmd и wsh.

subwoofer ★★★★★ ()

Ты видимо, либо не знаешь, либо специально тралируешь?

itn ★★ ()
Ответ на: комментарий от quwy

Все мало мальски сложное должно быть нативное, а для остального достаточно bash и компании.

А если там какой-нибудь конфигуратор с гуем - зачем он нужен непременно на нативном языке? А на bash писать что-то сложнее наколеночных скриптов... ну это занятие специфическое.

seiken ★★★★★ ()
Ответ на: комментарий от quwy

Что бы не таскать за наколеночными скриптами интерпретатор (который ещё и ставить надо), и не пердолиться со всякими калечными bash-ами и, не к ночи будь помянут, cmd

MrClon ★★★★★ ()

А почему они тогда против JS не протестуют ? Или против Electron'а ? С такими темпами, они, видимо, всё кроме swift'а в итоге объявят устаревшим.

DawnCaster ()
Ответ на: комментарий от seiken

А если там какой-нибудь конфигуратор с гуем

Не вижу никаких проблем делать такое нативным.

Да и никто из рук ничего не вырывает. Написано же, если очень надо, то или тяните минимальный рантайм с собой, или добавляйте зависимость.

Современные оси и так разжирели до неприличия, почему бы не сделать опциональным то, без чего вполне можно прожить?

quwy ()
Ответ на: комментарий от DawnCaster

А почему они тогда против JS не протестуют?

А js-cli сильно популярен на гейосах или онтопиках? Он вообще в стандартную поставку хоть одного дистра входит? Я консольные js-скрипты только на винде в свободном выпасе видел пару раз за двадцать лет.

Или против Electron'а?

А это и есть типичный бандл. Снаружи он нативный, а что там внутри, авторов ос не волнует.

quwy ()

Пофиг. Всё равно, хочешь дата-сцаентистом прикинуться - надо R рукаме ставить

TooPar ()

десктопный дистр Linux

а разве есть такие?

chenbr0 ()

эм, ну редхат то выпилил питон, все утерлись. правда забавно, что анаконда все равно на питоне

chenbr0 ()

В MacOS 10.15 скриптовые языки объявлены deprecated

А чего ещё ждать от корпорастов? Поиграли в швабодку и хватит.

Скриптовые языки по умолчанию открыты - странно что их до этого ставили в эту обоссанную проприетарь.

Вот жаба это да, в ней сырцы можно ныкать в байт-код, поэтому копирасты с ней бороться не будут.

Novator ★★★★ ()

То есть тебя не заботит, что macOS frameworks are now thinned for the x86-64 architecture. Apps that execute i386 code now fail with the EBADARCH error code. The remaining stub frameworks are nonfunctional and exist only for compatibility purposes. (51236070). Пистон и прочее то я поставлю ручками, а вот 32 бит уже хрен.

Lordwind ★★★★★ ()

В macOS вроде как был второй Python и обновлять его на третий никто не стал. Выкинуть проще.

Справедливо и для Ruby, Perl кмк.

EXL ★★★★★ ()
Ответ на: комментарий от chenbr0

эм, ну редхат то выпилил питон, все утерлись. правда забавно, что анаконда все равно на питоне

Они не выпилили, а «зафиксировались» на определённой версии Python, сделали её системной и убрали из userland’а. У них же тот же yum и dnf на python в большей части написаны.

Спороное решение, согласен.

EXL ★★★★★ ()
Ответ на: комментарий от Lordwind

Мне интересно куда они совместимость подевают. Ну да ладно, с макосью только страдать. Даже современная винда куда удобнее.

Про интерпретаторы пофигу. Кому надо ставят, кому не надо не знают.

a1batross ★★★★★ ()
Ответ на: комментарий от Novator

Вот жаба это да, в ней сырцы можно ныкать в байт-код, поэтому копирасты с ней бороться не будут.

А что, Java у нас была в стандартной поставке macOS?

странно что их до этого ставили в эту обоссанную проприетарь.

https://opensource.apple.com/

EXL ★★★★★ ()

Это не вся система, а только /bin, но так для прикидки насколько всё плохо.
/bin -> /usr/bin
file /bin/* | grep -c ELF
2745
file /bin/* | grep -c symbolic\ link
957
file /bin/* | grep -c shell
419
file /bin/* | grep -c Perl
259
file /bin/* | grep -c python
157

imul ★★★★★ ()

Good luck with that

в их libc есть замечательная функция, которая за каким-то хером вызывает /usr/bin/perl с хардкоднутым скриптом. Насколько знаю, до сих пор не выкинули.

shimon ★★★★★ ()
Ответ на: комментарий от Novator

JVM из дефолтной поставки выкинули ещё во времена 10.7. :)

mono ★★★★★ ()
Ответ на: комментарий от cvs-255

Почти всегда для софта на python/ruby приходилось ставить современные рантаймы, вместо использования дефолтного.

С bash тоже самое.

mono ★★★★★ ()
Ответ на: комментарий от EXL

А что, Java у нас была в стандартной поставке macOS?

Была, но давно)

mono ★★★★★ ()

Зачем там по дефолту outdated-версии интерпретаторов, если есть nix?

theNamelessOne ★★★★★ ()

И это правильно! Пусть Homebrew переписывают на Swift, и дело с концом!

menangen ★★★★★ ()

А как там, вменяемый (не маргинальный для пары пользователей) десктопный дистр Linux можно без Python, Perl и Ruby использовать?

Конечно, Slackware можно,- и всегда было можно - использовать. А других дистров, которые бы немаргинально работали для более чем пары пользователей, тупо и нет.

sin ()
Ответ на: комментарий от mono

?

У меня в дебиане как стоит python2.7 и python3.7, так их и использую.

cvs-255 ★★★★★ ()
Ответ на: комментарий от chenbr0

Как выпилил? Они же ansible делают, а она требует предустановленного питона на клиентской стороне.

te111011010 ()

А как там, вменяемый (не маргинальный для пары пользователей) десктопный дистр Linux можно без Python, Perl и Ruby использовать?

Ты реально придурок? Да? Ищешь любую новость, связанную с виндой или маком и превращаешь её во вброс, типа какое дерьмо ваш линукс? Ну иди тогда отсюда, что ты тут забыл среди говноедов?

te111011010 ()

by default

А они там были разве?

Всегда использовал стандартный Brew.

Mirage1_ ()
Ответ на: комментарий от chenbr0

Чтоьы шутка быдоа смешной, она должна быть основана на правде, либо быть абсурдной. А твоя просто тупая. Ubuntu и openSUSE идеально выточеные десктопные дистры, и если не они, то десктопных операционных систем не существует в природе.

WitcherGeralt ★★ ()
Ответ на: комментарий от ozz_is_here_again

Я лишь сказал, руководствуясь его логикой. Он намекнул, что линукс — говно, а я ответил: «так что же ты сидишь среди говноедов?».

te111011010 ()
Ответ на: комментарий от ozz_is_here_again

А как можно трактовать этот вброс:

А как там, вменяемый (не маргинальный для пары пользователей) десктопный дистр Linux можно без Python, Perl и Ruby использовать?

По-моему, очевидно, что он хотел сказать: «Линукс — говно, потому что из него нельзя выкинуть perl и python, а macos — не говно, потому что можно». Иначе к чему это вообще было? У линукса свои неотъемлемые системные компоненты, у macos — свои.

te111011010 ()

Просто еще один шаг к слиянию с телофонами. Ничего, макофилам не привыкать, проглотят.

unanimous ★★★★★ ()
Ответ на: комментарий от WitcherGeralt

Чтоьы шутка быдоа смешной, она должна быть основана на правде, либо быть абсурдной. А твоя просто тупая. Ubuntu и openSUSE идеально выточеные десктопные дистры

А вот ты реально смешно сказал 🤣

fornlr ★★★★★ ()
Ответ на: комментарий от WitcherGeralt

если твои опечатки связать с тем, что у тебя перекаченные пальцы - это будет смешно?

эм, дистры, которые выдают черный экран после ребута и установки видеодрайверов это идеально выточенные? изменение расположения конфигов иксов после каждой мажорной версии?по мне фряха и то более готова.

chenbr0 ()
Ответ на: комментарий от chenbr0

Наоборот, экран телефона слишком большой, а пальцы слишком короткие, чтобы набирать в альбомной ориентации, вот в портретном одной рукой такое и получается.

WitcherGeralt ★★ ()
Ответ на: комментарий от Mirage1_

А они там были разве?

Да. И они кстати тормозили прогресс. Например, инструменты в WebAssembly SDK завязаны на древний Python 2, а не на Python 3, потому что в macOS именно он by default.

EXL ★★★★★ ()
Закрыто добавление комментариев для недавно зарегистрированных пользователей (со score < 50)