LINUX.ORG.RU

Проблема с APT в Ubuntu

 ,


0

1

Доброго времени суток. Возникла проблема с менеджером пакетов в Ubuntu. Установил пакет libnotify-bin из файла. И теперь при попытке установить что-либо выдает Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»: Пакеты, имеющие неудовлетворённые зависимости: libnotify-bin : Зависит: libnotify1 (>= 0.4.5) но он не может быть установлен Зависит: libnotify1-gtk2.10 но он не может быть установлен python-dev : Зависит: python2.7-dev (>= 2.7.3) но он не будет установлен E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt-get -f install», не указывая имени пакета, (или найдите другое решение) А в свою очередь apt-get -f install выдает dpkg: зависимости пакетов не позволяют настроить пакет libnotify-bin: libnotify-bin зависит от libnotify1 (>= 0.4.5), однако: Пакет libnotify1 не установлен. libnotify-bin зависит от libnotify1-gtk2.10, однако: Пакет libnotify1-gtk2.10 не установлен. dpkg: не удалось обработать параметр libnotify-bin (--configure): проблемы зависимостей — оставляем не настроенным Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа. При обработке следующих пакетов произошли ошибки: libnotify-bin E: Sub-process /usr/bin/dpkg returned an error code (1) Как исправит? Помогите пожалкуйстаю Заранее спасибо

Как исправит?

Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install»

Ещё вопросы?

GotF ★★★★★ ()

Установил пакет libnotify-bin из файла

Какого файла?

kitar ★★★★★ ()
Ответ на: комментарий от GotF

Говорю же он выдает dpkg: зависимости пакетов не позволяют настроить пакет libnotify- bin: libnotify-bin зависит от libnotify1 (>= 0.4.5), однако: Пакет libnotify1 не установлен. libnotify-bin зависит от libnotify1-gtk2.10, однако: Пакет libnotify1- gtk2.10 не установлен. dpkg: не удалось обработать параметр libnotify-bin (-- configure): проблемы зависимостей — оставляем не настроенным Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа. При обработке следующих пакетов произошли ошибки: libnotify-bin E: Sub-process / usr/bin/dpkg returned an error code (1)

skeeph ()
Ответ на: комментарий от skeeph

Ну блин, ты осиль форматирование, а то у тебя там сам чёрт не разберёт. Сделай

dpkg --purge libnotify-bin

И что, его нет в репозиториях?

GotF ★★★★★ ()

Установил пакет libnotify-bin из файла.

Зря.
apt-get install libnotify-bin

Как исправит?

dpkg -P --force-all libnotify-bin

AITap ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.