LINUX.ORG.RU

Сообщения sholmes

 

Fedora 35 grub2-install /dev/sda

Поставил сабж на отдельную партицию (/dev/sda6), в процессе установки ругнулось, что невозможно установить загрузчик. Установил без него. Зачрутился в свежеустановленную систему, делаю

root@localhost-live /]# grub2-install /dev/sda

Installing for i386-pc platform.

grub2-install: warning: ../grub-core/partmap/msdos.c:403:your core.img is unusually large.

It won’t fit in the embedding area.

grub2-install: warning: Embedding is not possible.

GRUB can only be installed in this setup by using blocklists.

However, blocklists are UNRELIABLE and their use is discouraged..

grub2-install: error: will not proceed with blocklists.

Пробовал по разному с разными ключами, не получается. Как поставить?

 , , ,

sholmes ()

Bluetooth-адаптер не видит устройства на Ubuntu 21.04

Доброго времени суток! На последней Убунте не работает мой usb-свисток. в системе он определяется как:

~$ sudo lsusb Bus 003 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

но при попытке просканировать устройства через blueman или встроенную утилиту kde ничего не находит. hcitool пишет:

Scanning … Inquiry failed: Connection timed out

Можно ли что-то с этим сделать? Раньше стояла 16.04, в ней работало

 ,

sholmes ()

Ubuntu и проприетарный nvidia-драйвер

Стоит Ubuntu 16.04.7 LTS, решил накатить проприетарный драйвер для старой карточки 340.107, сделал:

sudo apt-get install nvidia-340 nvidia-settings

Затем sudo nvidia-xconfig, перезагружаюсь, вижу загрузочный экран системы, логотип nvidia, после чего иксы не грузятся, черный экран и периодически моргает монитор. Ядро версии 4.4.0-201-generic, пробовал загружаться с предыдущим 4.4.0-45, тоже самое. Удалил xorg.conf не помогло. Можно ли заставить работать?

 ,

sholmes ()

Помогите ШГ!

Собрал Gentoo, накатил infinality, сглаживание win7. Вроде лучше стало, но при запуске некоторых программ и открытии окон ругается:

Fontconfig warning: "/etc/fonts/infinality/styles.conf.avail/win7/41-repl-os-win.conf", line 148: Having multiple values in isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/infinality/styles.conf.avail/win7/41-repl-os-win.conf", line 160: Having multiple values in isn't supported and may not work as expected

доустанавливал media-fonts/corefonts с верданой, это проблему не решило. fc-cache продолжает ругаться

Fontconfig warning: «/etc/fonts/infinality/styles.conf.avail/win7/41-repl-os-win.conf», line 148: Having multiple values in isn’t supported and may not work as expected Fontconfig warning: «/etc/fonts/infinality/styles.conf.avail/win7/41-repl-os-win.conf», line 160: Having multiple values in isn’t supported and may not work as expected

Gparted, например, показывает вот такой ШГ:

http://images.vfl.ru/ii/1594483686/0f1952f8/31050880.png

как это исправить?

 ,

sholmes ()

plasma wayland

Подскажите, как на Gentoo заставить работать wayland-сессию с плазмой? Plasma последняя, systemd, установлен sddm, при выборе в дисплей-менеджере сессии plasma (wayland) (wayland) ничего не загружается и выбрасывает назад на экран входа. Из терминала тоже не запускает. Лог https://paste.ee/p/plLyB

 , , ,

sholmes ()

Не запускается Lazarus

Добрый день, при попытка загрузить от пользователя выбивает ошибку

Unable to create file «/etc/lazarus/editormacroscript.xml».

Нажмите ‘OK’, чтобы игнорировать и подвергнуться риску повреждения данных. Нажмите ‘Прервать’ для закрытия программы.

ОК/Прервать закрывать программу. От рута работает. Ставил через emerge. Как можно побороть?

 , , ,

sholmes ()

Смонтировать корень /dev/mmcblk0p1 в /cdrom

Имеется 4 малинка, загрузчик uefi, в качестве системы взял ванильный Debian 10.2 arm64. Установка запускается, доходит до момента определения cdrom’а, а как дальше его ткнуть в корень карты памяти чтобы оно оттуда копировало файлы? Для 3 малинки совет с монтированием был писать в инталляторе:

-t vfat -o rw /dev/mmcblk0p1

у меня не работает:

CD-ROM mount failed: device:-t vfat -o rw /dev/mmcblk0p1 fstype=iso9660 CDROM-detect failed: unmounting CD just to be sure (process:1403): mount: mounting /dev/mmcblk0p1 on /cdrom failed: No such file or directory WARNING **: Configuring ‘cdrom-device’ failed with error code 1 WARNING **: Menu item ‘cdrom-detect’ failed

помогите решить, плиз!

 , , , ,

sholmes ()

Образ диска как гостевая ОС

Всем привет, всех с наступающим! Научите как правильно смонтировать img-образы arm-системы в qemu на малинке как гостевую ос? Это вообще возможно? Есть большая sdшка с рабочей убунтой, не хотелось бы форматировать карточку чтобы пощупать другую систему

 , , , ,

sholmes ()

pulsaudio заикается звук через hdmi

Купил новый raspberry pi 4, накатил на него ubuntu 19.10.1 arm64, полёт нормальный, но есть проблема со звуком: если подключить малинку через hdmi к телеку постоянно пропадает звук в самых разных программах (vlc, в браузере, при прослушивании музыка). Проблема наблюдается если в pavucontrol выбран stereo output, при переключении на mono звук идёт без заиканий и проблем. Помогите, плиз, настроить, офф.форум молчит(

 , , , ,

sholmes ()

Deadbeef 1.8.1 не читает треки из cue

Обновился, новая версия не видит треки из cue-списка, лось играет просто одним большим файлом. В старых версиях такого не было

 , ,

sholmes ()

Посмотреть значение ЖК-фильтра

Имеется старый монитор с не оч.хорошей подсветкой, стандартные ЖК-фильтры из комплекта freetype на нём отдают желтизной и давят на глаза. На днях запустил на нём Devuan 9 и увидел, что по-дефолту у них используется не плохой фильтр, цвет фона близок к белому и от подсветки не устают глаза. Фильтр на дебиане включен стандартный, но значение src/base/ftlcdfil.h похоже не 0x08 0x4D 0x56 0x4D 0x08, а какое-то другое. Собственно вопрос, а как его можно узнать чтобы сконпелять у себя freetype с такими же параметрами?

 , , ,

sholmes ()

grub и несколько систем linux

На диске 4 раздела:

Устр-во    Загрузочный начало Конец Секторы Размер Идентификатор Тип
/dev/sda1  *                  63  83891429  83891367    40G             7 HPFS/N                                            T
/dev/sda2               83891491 454832127 370940637 176,9G             5 Расшир                                            е
/dev/sda3              454834176 488396675  33562500    16G            83 Linux
/dev/sda5               83891493 438054911 354163419 168,9G             7 HPFS/N                                            T
/dev/sda6              438056960 454832127  16775168     8G            83 Linux

на /dev/sda3 стоит Слакварь, на sda6 поставил Debian 10. Grub в дебиане не устанавливал. Добавил параметр с загрузкой дебиана в grub.cfg

menuentry "Debian GNU/Linux (10)" --class gnu-linux --class gnu --class os $men$
        insmod part_msdos
        linux /boot/vmlinuz-4.19.0-5-amd64 root=/dev/sda6 ro quiet
        initrd /boot/initrd.img-4.19.0-5-amd64
}

но при попытке загрузиться получаю Ошибка: файл «/boot/vmlinuz-4.19.0-5-amd64» не найден. Cначала Вам нужно загрузить ядро. На диске ядро и vmlinuz-4.19.0-5-amd64 естественно есть. Пробовал запускать update-grub:

Найден Windows 7 (loader) на /dev/sda1
Найден Slackware Linux (Slackware 14.2) на /dev/sda3
Найден Debian GNU/Linux (10) на /dev/sda6
/usr/sbin/grub-probe: ошибка: неизвестная файловая система.

файловая система естественно ext4. Что за ерунда такая, почему дебиан не запускается?

 , ,

sholmes ()

Noapic проблема с загрузкой

Имеется старенькая машина на am2-сокете. Дистрибутивы с ядрами новее 4.4 не грузятся ссылаясь на kernel panic io apic предлагая его отключить. В биосе эта хреновина не выключается добавил в параметр загрузки noapic. Проблема в том, что тогда вылетает звук, звуковая карта не найдена и всякие разные глюки вроде того, что комп нельзя нормально выключить, зависает при system halt. Если к noapic добавить acpi=off, звук тогда есть, но глюки остаются: монитор переключается на 60 герц (элт), выключается тоже через раз. Можно ли как-то или настроить загрузку с этим apic'ом или починить звук и выключение?

 , , ,

sholmes ()

Slackware автоматическая сборка нового ядра

Доброго дня, может у кого-нибудь есть уже готовый bash-скрипт для автоматической сборки и обновления ядра linux который можно запихнуть в cron? Т.е при запуске проверяет на kernel.org новую версию, качает исходник, распаковывает, конпеляет, опакечивает всё в txz, устанавливает, обновляет grub.cfg. Знаю, что можно самому написать, но может такой велосипед уже у кого-то есть?

 , ,

sholmes ()

Android x86 geforce

Всем привет, можно ли завести нормально сабж на старой жифорс 8600 gts? Все версии и сборки которые пробовал зависают в окне первичной настройки, google-приложения падают, система постоянно уходит в ребут. Когда-то была мать со встроенной графикой на g33, оно работало отлично, но, к сожалению, жележо rip. Поддержка nvidia на уровне софта вроде там есть, странно, что такую древную карточку и не могут сделать.

 ,

sholmes ()

Как добавить новый патч diif?

Написал патч (новый mkspecs), положил его в исходники, а как дальше правильно вызвать diff чтобы он создал этот патч который будет добавляться собственно в распакованные исходники при вызове patch?

 ,

sholmes ()

cmake configure

Добрый день, столкнулся с такой проблемой:

CMake Error at CMakeLists.txt:6 (message):
  CMakeOptions.txt not found! Run configure first.

а как это запустить, не пойму?

 

sholmes ()

Создать множество папок с файлами

Подкиньте скрипт для автоматизации процесса: множество файлов (порядка 200), нужно создать для каждого файла папку с именем как у файла до дефиса с названием версии, перекинуть в эту папку сам файл, а так же создать внутри ещё два файла: имя.SlackBuild с содержанием по-определённому шаблону + пустой slack-desc.

 , , , ,

sholmes ()

cmake libdir на slackware64

Подскажите, как на Слаке научить cmake устанавливать библиотеки в правильное место /usr/local/lib64, в соответствии с $PKG_CONFIG_PATH вместо /usr/local/lib? Столкнулся с программой которая ни в какую не хочет это понимать, параметр LIB_SUFFIX разработчики естесно не включили в проект...

 , , ,

sholmes ()

xterm copy/paste

Интересует, можно ли в сабже вместо ctrl+shift+c/v сделать просто ctrl+c/v? Тупо через .Xresources не работает, наверное нужно что-то менять в коде? Может кто-то делал, киньте, плз, патч!

 , , ,

sholmes ()

RSS подписка на новые темы