LINUX.ORG.RU

Помогите ШГ!

 ,


0

1

Собрал Gentoo, накатил infinality, сглаживание win7. Вроде лучше стало, но при запуске некоторых программ и открытии окон ругается:

Fontconfig warning: "/etc/fonts/infinality/styles.conf.avail/win7/41-repl-os-win.conf", line 148: Having multiple values in isn't supported and may not work as expected
Fontconfig warning: "/etc/fonts/infinality/styles.conf.avail/win7/41-repl-os-win.conf", line 160: Having multiple values in isn't supported and may not work as expected

доустанавливал media-fonts/corefonts с верданой, это проблему не решило. fc-cache продолжает ругаться

Fontconfig warning: «/etc/fonts/infinality/styles.conf.avail/win7/41-repl-os-win.conf», line 148: Having multiple values in isn’t supported and may not work as expected Fontconfig warning: «/etc/fonts/infinality/styles.conf.avail/win7/41-repl-os-win.conf», line 160: Having multiple values in isn’t supported and may not work as expected

Gparted, например, показывает вот такой ШГ:

http://images.vfl.ru/ii/1594483686/0f1952f8/31050880.png

как это исправить?

Ответ на: комментарий от sholmes

ты бы дефолт сначала попытался настроить, чем ставить давно сдохший проект

anonymous ()
Ответ на: комментарий от sholmes

Уже тысячу раз обсосали эту тему, но все равно есть такие вот… Непросвященные. Если у тебя плохой моник с низкой плотностью пикселей, что бы ты там не предпринимал, волшебной кнопки «сделать шрифты нормальными» нет. Все будет или а) мыльно, б) местами тонко/не видно. Нужно нормальное отображение шрифтов - ищи нормальный моник с небольшой диагональю/большим разрешением. Благо сейчас это стоит дешево и есть везде.

anonymous ()
Ответ на: комментарий от anonymous

Да нормально оно работает и сглаживает у меня. Но тот же Gparted из-за этой ошибки показывает сломанные шрифты, такая же ерунда при открытии файла в огнелисе. Вот ещё скрин. В консоле или браузере нормально, а в окне диалога поломано http://images.vfl.ru/ii/1594484774/78ac5fd0/31051058.png

а если поставить вердану на которую ссылает конфиг вообще всё ещё хуже ломается

sholmes ()
Последнее исправление: sholmes (всего исправлений: 1)
Ответ на: комментарий от sholmes

Инфиналити проект древний и мёртвый, думаю никто тут им уже не пользуется, ломать себе шрифты чтобы тебе помочь тоже никто не будет. Так что разбираться портянках скриптов от инфиналити и смотреть что за multiple values там у тебя not supported никто кроме тебя не будет. Возможно кстати что твой fontconfig уже не поддерживает те параметры с которыми играется infinality.

Так что тебе не зря советуют выбросить древний и неподдерживаемый больше костыль, если ты сам его чинить и сопровождать не в состоянии.

Jameson ★★★★★ ()

Если из-за монитора не удаётся настроить сглаживание или ещё как-то улучшить имеющиеся шрифты, то самый простой вариант это просто поменять шрифт на тот, что будет хорошо смотреться на таком мониторе. Хватит насиловать себе мозги, набери в гугловском поске картинок pixel fonts rus и посмотри какие крутые варианты есть, их и поставь.

anonymous ()
Ответ на: комментарий от sholmes

Ссылается на шрифт Verdana, которого нет

Плевать на verdana, у тебя несколько шрифтов указано в секциях test (146–147 и 158–159). Разбей на отдельные match

XMs ★★★★★ ()

Помогите ШГ!

Как помочь ШГ?

mord0d ★★★★★ ()
Ответ на: комментарий от XMs

Интересный вопрос. gparted шг, в диалоге с открытием или сохранением файлов в firefox тоже. Но я проверил equery, у них нету gtk-флага

sholmes ()
Последнее исправление: sholmes (всего исправлений: 1)
Ответ на: комментарий от sholmes

Флага нет, но сами они используют GTK. Стоит собрать Qt (и, если используешь KDE, собственно, KDE) с флагом gtk и потом настроить отображение

XMs ★★★★★ ()
Ответ на: комментарий от XMs

В qtcore нету флага gtk, в plasma-meta он есть. Я ещё подумал, что может неподдерживаемый шрифт в этих приложениях можно изменить на другой, который работает. Но где это переключить пока не нашёл

sholmes ()
Ответ на: комментарий от sholmes

Мне неизвестно, можно ли это сделать путём редактирования конфигов, я просто в параметрах системы (KDE) всё выставил

XMs ★★★★★ ()
Ответ на: комментарий от XMs

А где в параметрах KDE настройки gtk? У меня таких нет. И подозреваю, что если собирать без соответствующего флага их и не будет

sholmes ()
Ответ на: комментарий от sholmes

И подозреваю, что если собирать без соответствующего флага их и не будет

Разумеется. Поэтому надо сперва пересобрать

XMs ★★★★★ ()

установи lxappearance, включи в нём сглаживания, хинтинг, на вкладке Font

spawn_sp ★★★ ()
Ответ на: комментарий от sholmes

А, не посмотрел скриншот. У тебя нет движка для отрисовки GTK-приложений в соответствии с настройками. Можешь поставить kde-plasma/breeze-gtk, но скорее всего придётся пересобрать всё остальное

XMs ★★★★★ ()
Ответ на: комментарий от XMs

Поставил его. Но не помогло. Печально, что придётся пересобирать всё с флагом gtk. Ставил Генту именно чтобы избавится от него и работать со своими флагами

sholmes ()
Ответ на: комментарий от sholmes

Я бы тоже с радостью выпилил GTK, но пока часть ключевых приложений его использует, приходится добавлять поддержку в окружение. При этом у меня глобально -gtk, разумеется

XMs ★★★★★ ()
Ответ на: комментарий от sholmes

Ну и включи это флаг только для тех приложений вид которых тебе важен. Глобально включать вовсе не обязательно.

Jameson ★★★★★ ()
Ответ на: комментарий от sholmes

походу плазма ещё какими то своими конфигураторами переопределяет эти конфы, ну и флаг конечно как уж написали

spawn_sp ★★★ ()
Ответ на: комментарий от XMs

Интересно: я -gtk флаг глобально выпилил, мир пересобрал, а изменений никаких не вижу. В настройках плазмы тоже никаких опций связанных с gtk не появилось. Получается, что не в этом флаге дело или я чего-то не так понимаю?

sholmes ()
Последнее исправление: sholmes (всего исправлений: 1)
Ответ на: комментарий от sholmes

Надо не глобально выпиливать, а локально включать для пакета plasma-meta (если через мета-пакеты ставишь). Тогда он потянет зависимостью kde-plasma/kde-gtk-config и всё остальное. Этого должно хватить (сам когда-то давно настроил, и сейчас уже не помню, что и как, поэтому могу ошибаться)

XMs ★★★★★ ()
Ответ на: комментарий от sholmes

Действительно, почему-то не показывается. Тогда можешь просто $XDG_CONFIG_HOME/gtk-3.0/settings.ini ($HOME/.config/gtk-3.0/settings.ini) поправить

XMs ★★★★★ ()
Ответ на: комментарий от XMs

Есть. Ну вот я поставил Breeze-Dark и шрифты лучше от этого не стали. Похоже это не в флагах всё-таки дело

sholmes ()
Последнее исправление: sholmes (всего исправлений: 2)

что у тебя в /etc/fonts/conf.d ?

anonymous ()

Помогите ШГ!

как это исправить?

Никак. Задолбали блин, сколько десятилетий одна и та же тема? «Привыкайте жрать фекалии!», — предлагаю сделать это девизом для линя.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.