LINUX.ORG.RU

Сообщения menefis

 

wine64 и photoshop

Готовлю новый ноут к передаче его новому владельцу. Выбирал сам с жестким ограничением по бюджету, ессесно без предустановленного оффтопа. Накатил LMDE, все завелось, все супер.

Остался один пункт - Photoshop. Пытаюсь приготовить для него wine, но нихрена не получается. До этого дел с ним не имел и вообще считаю его жутким костылем, но необходимость заставила разобраться.

Накатил wine-development из реп, 1.7.че-то там (14 вроде), с ним приплыл wine64 и тут начинаются грабли. Кучи гайдов в инете писаны дибилами для дибилов, тупо копипаста одного и того же (установите то, установите это, запустите это, профит).

Вопросы:

  1. Хочу накатить CS6, насколько я знаю он только 32 бит. Можно его накатить в wine64?
  2. Есть годные маны по wine с описанием общих принципов его приготовления? Ибо большинство winetricks не канает для wine64, хочу понять как готовить вручную.
  3. Конкретно сейчас застрял на установке vcrun2005. Скачал с сайта мелкомягких вручную под x64. Тупо не запускается. winetricks пытается накатить x32 и ругается на архитектуру.

з.ы. ставить wine32 не хочется ибо тянется overдохрена по зависимостям. Советчики типа «ставь wine32, места чтоль жалко?» без аргументированного отрицательного ответа на п.1 идут лесом.

 ,

menefis ()

Колитесь, чей канал?

линк.

Кто занимается просвещением юных, неокрепших умов в области linux в свободное от работы время?

 ,

menefis ()

Непонятки с зависимостями

Доброго всем дня!

Решил обновить свою гентушечку спустя примерно год с последнего обновления. Наткнулся на непонятный момент такого рода: при обновлении мира, emerge говорит что php-5.5.28 в стабильной ветке, но ему требуется apache-2.4, обе версии которого в портаже замаскированы.

Вопрос: это нормально и у всех так или я где-то нарукожопил?

З.Ы. Такая же петрушка с php-5.6, в дереве есть стабильные версии, однако им так же требуется apache-2.4

 , , , ,

menefis ()

Не полностью выключается ноут

В общем проблема в следующем: при обычном выключении ноута (из XFCE, через oblogout из опенбокса, systemctl halt) ноут как положено выключается, все индикаторы гаснут, экран гаснет, никаких признаков жизнедеятельности. НО при включении следующим вечером заряд батареи уменьшается на 8-10%.

Саморазряд исключен, возраст батареи тож не в счет. Ноут новый, брал в конце февраля, держит 8-9 часов при обычном web-серфе. Thinkpad S540 если имеет значение. На моем 6 летнем сдохшем asus'е за такой же интервал батарея разряжалась максимум на 1%.

Методом тыка обнаружил, если выключить ноут тупо удерживая кнопку, то следующим вечером заряд остается таким же.

Гуглинг привел на убунту-форум с похожими симптомами, вроде как проблема была в tlp, удалением tlp проблема не решилась, зато решилась обычным делом убунтят - переустановкой системы. Переустанавливать не хочется, хочется разобраться в причинах проблемы. Подскажите куда копать? На ум ничего не приходит, конфиги tlp перелопатил вдоль и поперек, но ничего подозрительного...

 , , ,

menefis ()

Разный Power_On_Hours на дисках в RAID1

Имеется RAID1, состоит из 2-х дисков, диски одинаковые покупались одновременно, ставились тоже одновременно. Работают в домашнем сервачке 24/7.

На днях полетел один диск не из этого рейда и я бросился проверять smart показатели на остальных дисках. Вот что меня удивило:

# cat /proc/mdstat 
Personalities : [raid1] 
md1 : active raid1 sdd1[0] sde1[1]
      1953511376 blocks super 1.2 [2/2] [UU]
      
unused devices: <none>
# smartctl -A /dev/sdd | grep Power\_On
  9 Power_On_Hours          0x0032   085   085   000    Old_age   Always       -       11364
# smartctl -A /dev/sde | grep Power\_On
  9 Power_On_Hours          0x0032   091   091   000    Old_age   Always       -       6592
Такое в принципе возможно?

К слову полетевший диск на другом компе определяется, smart показатели в норме, проверка пройдена, самодиагностика без ошибок, но по ощущениям подтупливает при просмотре.

# smartctl -A /dev/sdd
smartctl 6.2 2013-07-26 r3841 [x86_64-linux-3.14.1-1-ARCH] (local build)
Copyright (C) 2002-13, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF READ SMART DATA SECTION ===
SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x002f   200   200   051    Pre-fail  Always       -       0
  3 Spin_Up_Time            0x0027   180   179   021    Pre-fail  Always       -       5958
  4 Start_Stop_Count        0x0032   100   100   000    Old_age   Always       -       209
  5 Reallocated_Sector_Ct   0x0033   200   200   140    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x002e   200   200   000    Old_age   Always       -       0
  9 Power_On_Hours          0x0032   051   051   000    Old_age   Always       -       36408
 10 Spin_Retry_Count        0x0032   100   100   000    Old_age   Always       -       0
 11 Calibration_Retry_Count 0x0032   100   100   000    Old_age   Always       -       0
 12 Power_Cycle_Count       0x0032   100   100   000    Old_age   Always       -       150
192 Power-Off_Retract_Count 0x0032   200   200   000    Old_age   Always       -       48
193 Load_Cycle_Count        0x0032   168   168   000    Old_age   Always       -       98830
194 Temperature_Celsius     0x0022   121   102   000    Old_age   Always       -       29
196 Reallocated_Event_Count 0x0032   200   200   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0032   200   200   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0030   200   200   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x0032   200   200   000    Old_age   Always       -       2
200 Multi_Zone_Error_Rate   0x0008   200   200   000    Old_age   Offline      -       0

Я вот думаю может маман на сервачке чудит?

 ,

menefis ()

Ошибка при установке fuse-sshfs из yum

Помогите плиз разобраться с yum.

Пытаюсь поставить fuse-sshfs в центось 6.4. При установке по зависимостям вытягивает fuse, вот с ним и начинается непонятное

[root@vps /]# yum install fuse
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package fuse.i686 0:2.8.3-4.el6 will be installed
--> Processing Dependency: kernel >= 2.6.14 for package: fuse-2.8.3-4.el6.i686
--> Finished Dependency Resolution
Error: Package: fuse-2.8.3-4.el6.i686 (base)
           Requires: kernel >= 2.6.14
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

вроде как пишет что требуется ядро >= 2.6.14

ну так у меня

[root@vps /]# uname -r
2.6.32-042stab079.6
что этой собаке надо? --skip-broken не хочу, не правильно это думаю, через rpm тож не хочу ибо еще больше неосилятор в нем...

 ,

menefis ()

Настройка DNS

Есть своя локалка 192.168.1.0, она болтается за роутером 192.168.1.1. На нем настроен инет через VPN провайдера и все хорошо.

Есть рабочая сеть, к которой тоже надо подключаться через PPTP. На ноуте настраиваю pptpclient, к сети подключаюсь, получаю ip 10.10.76.100, шлюз 10.10.76.1. За этим шлюзом рабочая сеть 192.168.76.0 с маской 255.255.252.0. Прописываю маршрут до этой сети, все замечательно ходит-пингуется... НО!! чтобы обращаться к компам рабочей сети по имени, мне нужно использовать ДНС рабочей сети. Прописывать его в resolv.conf не хочется, т.к. соединение не постоянное.

Вопрос: можно ли как-нибудь настроить так, чтобы при обращении по имени компа с суфиксом (comp11.sharaga.ru) запрос отправлялся к днс рабочей сети 192.168.78.20?

З.Ы. Просьба сильно не пинать, поиском пользоваться умею, но что-то не могу подобрать ключевых слов.

 ,

menefis ()

RSS подписка на новые темы