LINUX.ORG.RU

Сообщения DenisPA

 

intel hm65 и sata 3

Есть ноут с intel hm65 некий Lenovo z570, вот задумался выкинуть сидюк (возьму юсбшку на всякий случай), а в месно него влепить еще один ссд. В даташите ноута сказато, что там SATA2 (под винчестер), но вот только dmesg и даташит intel с ними не согласны — говорят SATA3. Вот я и думаю стоит рисковать и переплачивать за шахту HDC-27 или таки взять HDC-25. Или они его могли урезать... Чем бы его посмотреть?

dmesg | grep SATA
[    0.792666] ata1: SATA max UDMA/133 cmd 0x40b8 ctl 0x40cc bmdma 0x4090 irq 19
[    0.792671] ata2: SATA max UDMA/133 cmd 0x40b0 ctl 0x40c8 bmdma 0x4098 irq 19
[    0.793501] ata3: SATA max UDMA/133 cmd 0x40a8 ctl 0x40c4 bmdma 0x4070 irq 19
[    0.793505] ata4: SATA max UDMA/133 cmd 0x40a0 ctl 0x40c0 bmdma 0x4078 irq 19
[    1.123569] ata4: SATA link down (SStatus 0 SControl 300)
[    1.276356] ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    2.152834] ata2.00: SATA link down (SStatus 4 SControl 0)
[    2.152849] ata2.01: SATA link down (SStatus 0 SControl 300)
[    2.297599] ata1.00: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    2.297612] ata1.01: SATA link down (SStatus 4 SControl 0)
[ 2687.358519] ata4: SATA link down (SStatus 0 SControl 300)
[ 2687.511585] ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[ 2688.388035] ata2.00: SATA link down (SStatus 4 SControl 0)
[ 2688.388049] ata2.01: SATA link down (SStatus 0 SControl 300)
[ 2688.532763] ata1.00: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[ 2688.532776] ata1.01: SATA link down (SStatus 4 SControl 0)

lspci -vvv
00:1f.2 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller (rev 05) (prog-if 8f [Master SecP SecO PriP PriO])
	Subsystem: Lenovo Device 3975
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin B routed to IRQ 19
	Region 0: I/O ports at 40b8 [size=8]
	Region 1: I/O ports at 40cc [size=4]
	Region 2: I/O ports at 40b0 [size=8]
	Region 3: I/O ports at 40c8 [size=4]
	Region 4: I/O ports at 4090 [size=16]
	Region 5: I/O ports at 4080 [size=16]
	Capabilities: [70] Power Management version 3
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [b0] PCI Advanced Features
		AFCap: TP+ FLR+
		AFCtrl: FLR-
		AFStatus: TP-
	Kernel driver in use: ata_piix

00:1f.5 IDE interface: Intel Corporation 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller (rev 05) (prog-if 85 [Master SecO PriO])
	Subsystem: Lenovo Device 3975
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin B routed to IRQ 19
	Region 0: I/O ports at 40a8 [size=8]
	Region 1: I/O ports at 40c4 [size=4]
	Region 2: I/O ports at 40a0 [size=8]
	Region 3: I/O ports at 40c0 [size=4]
	Region 4: I/O ports at 4070 [size=16]
	Region 5: I/O ports at 4060 [size=16]
	Capabilities: [70] Power Management version 3
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [b0] PCI Advanced Features
		AFCap: TP+ FLR+
		AFCtrl: FLR-
		AFStatus: TP-
	Kernel driver in use: ata_piix

 , , ,

DenisPA ()

Optimus + lenovo z570

Не могу понять работать ли оптимус... (Все делаю на только что утановленной ОС...)
Lenovo z570

Linux 4.2.0-42-generic #49~14.04.1-Ubuntu SMP Wed Jun 29 20:22:11 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 630M] (rev ff)


После установки шмеля
optirun glxgears
[ERROR]Cannot access secondary GPU - error: [XORG] (EE) intel(0): [drm] failed to set drm interface version: Permission denied [13].
[ERROR]Aborting because fallback start is disabled.

Погуглил и «исправил»
I got around this by appending "Screen" section to
/etc/bumblebee/xorg.conf.nvidia and force it to use the
"DiscreteNvidia" device as defined at the top of this
config file:

Section "Screen"
    Identifier "Default Screen"
    Device "DiscreteNvidia"
EndSection


Только вот glxgears в обоих режимах дает однаковые фпс (хотя в интеле проскакиваю и более высокие) около 60-80.
К тому же
optirun nvidia-settings
** (nvidia-settings:3077): WARNING **: PRIME: Failed to execute child process "/usr/bin/prime-supported" (No such file or directory)
** Message: PRIME: is it supported? no

что наводит на мысль что нвидия вообже не запускается... Но в blender 3d рендаринг куба на видеокарте происходит в 2 раза быстрее чем на процессоре (хоть немного подлагивает интерфейс)...

Вообщем у кого-то получилась запустить nvidia-prime (меня вполне устраивает перезагрузка при переключении). А то для меня ни один из методов «гугла» не сработал — результат черный экран даже в консоль зайти не всегда можно...

 , , , ,

DenisPA ()

STARTX + steam

Что-то не могу нормально запустить counter strike source в отдельной сесии.
startx ./css — :1
Сама ксс загружается по средине экрана c расширением где-то 800 на 600, причем видно, что в самой игрушке установлено 1440 на 900 и оно прямо в ходе работы преобразовыватеся в 800 на 600 походу тупо скейлом какимто (фпс из 120 стает 20).

(В нутри скрипта steam steam://rungameid/240)

Linux 4.4.0-22-generic #39-Ubuntu SMP Thu May 5 16:53:32 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

 , , ,

DenisPA ()

QMainWindow + Android

Попытался скомпилить небольшую прожку под андроид 4.1.1 на Qt 5.6. Проблема: как только я пытаюсь динамически добавить на форму виджет, форма расширяется и залазит под «панель управления» планшета. Установка максимального значения формы по высоте не дает никакого эффекта. Расширение происходит не в одну операцию, и где-то через четверть - пол секунды после отображения.

 ,

DenisPA ()

data -> sd

Оказывается 1Гб на дату это мало захотелось расширить без всяких прог за счет второго раздела на второй сдшке:

1. mount -t ext4 /dev/block/mmcblk1p2 /mnt/tmpdata
2. cp -Rv /data/* /mnt/tmpdata/

И вот думаю как же теперь записать то, что я хочу в fstab если он выглядит вот так:
vold.fstab

## Vold 2.0 Generic fstab
## - San Mehat (san@android.com)
## 

#######################
## Regular device mount
##
## Format: dev_mount <label> <mount_point> <part> <sysfs_path1...> 
## label        - Label for the volume
## mount_point  - Where the volume will be mounted
## part         - Partition # (1 based), or 'auto' for first usable partition.
## <sysfs_path> - List of sysfs paths to source devices
######################

## Example of a standard sdcard mount for the emulator / Dream
# Mounts the first usable partition of the specified device
dev_mount sdcard /storage/sdcard0 emmc@fat /devices/platform/goldfish_mmc.0 /devices/platform/mtk-msdc.0/mmc_host
dev_mount sdcard2 /storage/sdcard1 auto /devices/platform/goldfish_mmc.1 /devices/platform/mtk-msdc.1/mmc_host
## Example of a dual card setup
# dev_mount left_sdcard  /mnt/sdcard1  auto /devices/platform/goldfish_mmc.0 /devices/platform/mtk-sd.0/mmc_host/mmc0
# dev_mount right_sdcard /mnt/sdcard2  auto /devices/platform/goldfish_mmc.1 /devices/platform/mtk-sd.2/mmc_host/mmc2

## Example of specifying a specific partition for mounts
# dev_mount sdcard /mnt/sdcard 2 /devices/platform/goldfish_mmc.0 /devices/platform/msm_sdcc.2/mmc_host/mmc1

# usb otg disk

vold.fstab.nand

## Vold 2.0 Generic fstab
## - San Mehat (san@android.com)
## 

#######################
## Regular device mount
##
## Format: dev_mount <label> <mount_point> <part> <sysfs_path1...> 
## label        - Label for the volume
## mount_point  - Where the volume will be mounted
## part         - Partition # (1 based), or 'auto' for first usable partition.
## <sysfs_path> - List of sysfs paths to source devices
######################

## Example of a standard sdcard mount for the emulator / Dream
# Mounts the first usable partition of the specified device
dev_mount sdcard /storage/sdcard0 auto /devices/platform/goldfish_mmc.0 /devices/platform/mtk-msdc.1/mmc_host

## Example of a dual card setup
# dev_mount left_sdcard  /mnt/sdcard1  auto /devices/platform/goldfish_mmc.0 /devices/platform/mtk-sd.0/mmc_host/mmc0
# dev_mount right_sdcard /mnt/sdcard2  auto /devices/platform/goldfish_mmc.1 /devices/platform/mtk-sd.2/mmc_host/mmc2

## Example of specifying a specific partition for mounts
# dev_mount sdcard /mnt/sdcard 2 /devices/platform/goldfish_mmc.0 /devices/platform/msm_sdcc.2/mmc_host/mmc1


Пытался докинуть это в конец vold.fstab
dev_mount data /data 2 /devices/platform/goldfish_mmc.1 /devices/platform/mtk-msdc.1/mmc_host

никакого эффекта

 , , ,

DenisPA ()

DriverManager_DBus

Как запретить автозапуск после логина DriverManager_DBus не сломав и не удалив его? Тормозит загрузку...

 

DenisPA ()

LO Base

Захотелось упорядочить инфу (изображения до 2Мб), как инструмент взял Libre Office Base, хотя никогда им не пользовался. В итоге где-то на 10й записи получаю:

SQL Status: S1000
Error code: 40

S1000 General error java.lang.NullPointerException in statement
[INSERT INTO "b" ( "x1","x2","x3","x4","x5","x6","x7")
VALUES ( ?,?,?,?,?,?,?)]


Нет, я понимаю, что это жирновато будет, просто для теста их туда начал пихать такие - интересно было посмотреть за ресурсам...

Вопрос №1: если я сделаю, допустим изображения по 50-100 Кб на какой сотне я получу тоже? Или это только с большими файлам проблемы?

Вопрос №2: оно там все так глючит? Может лучше самому написать морду над mysql (или чем-то еще)?

П.С.: Пробовал и самый последний 5.0.2...
П.П.С.: ссылки на файлы как-то не хочется делать.

 , ,

DenisPA ()

DMA только на словах?

Почему копирование файлов загружает проц под завязку, оба ядра, в моем случае?

Я конечно гуглил на эту тему но не одного внятного ответа не нашел, правда были некоторы посты где говорили что под линуксом это так и есть, но без каких либо аргументов. Интересно я думал это проблема моего старого корыта, а нет, на 8ми поточном i7 оно тоже забирает все 13%.

Linux 3.16.0-48-generic #64~14.04.1-Ubuntu SMP Thu Aug 20 23:03:57 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

AMD Athlon(tm) II X2 265 Processor
DIMM DDR3 Synchronous 1333 MHz (0,8 ns)
970 Extreme4

Например 42Гб одним файлом из WDC WD5000AADS-0 на ST500LM012 HN-M5 (ФС ехт4)

 Model=ST500LM012 HN-M500MBB, FwRev=2AR10001, SerialNo=S2U3J9EC419059
 Config={ Fixed }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
 BuffType=unknown, BuffSize=8192kB, MaxMultSect=16, MultSect=off
 (maybe): CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=976773168
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5 
 AdvancedPM=yes: unknown setting WriteCache=enabled
 Drive conforms to: unknown:  ATA/ATAPI-0,1,2,3,4,5,6,7

 Model=WDC WD5000AADS-00M2B0, FwRev=01.00A01, SerialNo=WD-WCAV5M828782
 Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=50
 BuffType=unknown, BuffSize=unknown, MaxMultSect=16, MultSect=off
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=976773168
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio3 pio4 
 DMA modes:  mdma0 mdma1 mdma2 
 UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
 AdvancedPM=no WriteCache=enabled
 Drive conforms to: Unspecified:  ATA/ATAPI-1,2,3,4,5,6,7

[    1.685281] ata1: SATA max UDMA/133 abar m1024@0xfe40b000 port 0xfe40b100 irq 19
[    1.685283] ata2: SATA max UDMA/133 abar m1024@0xfe40b000 port 0xfe40b180 irq 19
[    1.685285] ata3: SATA max UDMA/133 abar m1024@0xfe40b000 port 0xfe40b200 irq 19
[    1.685287] ata4: SATA max UDMA/133 abar m1024@0xfe40b000 port 0xfe40b280 irq 19
[    1.685289] ata5: SATA max UDMA/133 abar m1024@0xfe40b000 port 0xfe40b300 irq 19
[    1.685290] ata6: SATA max UDMA/133 abar m1024@0xfe40b000 port 0xfe40b380 irq 19
[    2.179569] ata5.00: ATAPI: HL-DT-ST DVDRAM GH22NS50, TN02, max UDMA/100
[    2.183386] ata5.00: configured for UDMA/100
[    2.186138] ata2.00: ATA-8: WDC WD5000AADS-00M2B0, 01.00A01, max UDMA/133
[    2.186841] ata3.00: ATA-8: ST500LM012 HN-M500MBB, 2AR10001, max UDMA/100
[    2.187835] ata2.00: configured for UDMA/133
[    2.192544] ata1.00: ATA-8: KINGSTON SV300S37A60G, 505ABBF0, max UDMA/133
[    2.193183] ata3.00: configured for UDMA/100
[    2.202437] ata1.00: configured for UDMA/133
[ 9370.942786] ata5.00: configured for UDMA/100
[ 9370.958691] ata1.00: configured for UDMA/133
[ 9371.489050] ata3.00: configured for UDMA/100
[ 9380.104469] ata2.00: configured for UDMA/133
[13035.250645] ata5.00: configured for UDMA/100
[13035.266017] ata1.00: configured for UDMA/133
[13035.772476] ata3.00: configured for UDMA/100
[13044.504955] ata2.00: configured for UDMA/133

 ,

DenisPA ()

Adobe Flash

http://get.adobe.com/ru/flashplayer/

ПРИМЕЧАНИЕ. Adobe Flash Player 11.2 будет последней
версией, поддерживающей Linux в качестве платформы.
Adobe будет продолжать обеспечивать ретроподдержку
безопасности Flash Player 11.2 для Linux.

Нечаянно заметил... Это что ютубокапец ? :) Как там опесорсный клон (как его там) уже юзабелен?

 , , ,

DenisPA ()

ASRock 970 Extreme4 (lm-sensors)

Не могу заставить работать сенсоры... Посмотрите пожалуйста эту мегатонну логов (тот модуль, что просила прога, загружен...):

3.16.0-24-generic

sensors-detect
# sensors-detect revision 6170 (2013-05-20 21:25:22 +0200)
# Board: ASRock 970 Extreme4

This program will help you determine which kernel modules you need
to load to use lm_sensors most effectively. It is generally safe
and recommended to accept the default answers to all questions,
unless you know what you're doing.

Some south bridges, CPUs or memory controllers contain embedded sensors.
Do you want to scan for them? This is totally safe. (YES/no): 
Module cpuid loaded successfully.
Silicon Integrated Systems SIS5595...                       No
VIA VT82C686 Integrated Sensors...                          No
VIA VT8231 Integrated Sensors...                            No
AMD K8 thermal sensors...                                   No
AMD Family 10h thermal sensors...                           Success!
    (driver `k10temp')
AMD Family 11h thermal sensors...                           No
AMD Family 12h and 14h thermal sensors...                   No
AMD Family 15h thermal sensors...                           No
AMD Family 15h power sensors...                             No
AMD Family 16h power sensors...                             No
Intel digital thermal sensor...                             No
Intel AMB FB-DIMM thermal sensor...                         No
VIA C7 thermal sensor...                                    No
VIA Nano thermal sensor...                                  No

Some Super I/O chips contain embedded sensors. We have to write to
standard I/O ports to probe them. This is usually safe.
Do you want to scan for Super I/O sensors? (YES/no): 
Probing for Super-I/O at 0x2e/0x2f
Trying family `National Semiconductor/ITE'...               No
Trying family `SMSC'...                                     No
Trying family `VIA/Winbond/Nuvoton/Fintek'...               Yes
Found `Nuvoton NCT5577D/NCT6776F Super IO Sensors'          Success!
    (address 0x290, driver `nct6775')
Probing for Super-I/O at 0x4e/0x4f
Trying family `National Semiconductor/ITE'...               No
Trying family `SMSC'...                                     No
Trying family `VIA/Winbond/Nuvoton/Fintek'...               No
Trying family `ITE'...                                      No

Some systems (mainly servers) implement IPMI, a set of common interfaces
through which system health data may be retrieved, amongst other things.
We first try to get the information from SMBIOS. If we don't find it
there, we have to read from arbitrary I/O ports to probe for such
interfaces. This is normally safe. Do you want to scan for IPMI
interfaces? (YES/no): 
Probing for `IPMI BMC KCS' at 0xca0...                      No
Probing for `IPMI BMC SMIC' at 0xca8...                     No

Some hardware monitoring chips are accessible through the ISA I/O ports.
We have to write to arbitrary I/O ports to probe them. This is usually
safe though. Yes, you do have ISA I/O ports even if you do not have any
ISA slots! Do you want to scan the ISA I/O ports? (yes/NO): yes
Probing for `National Semiconductor LM78' at 0x290...       No
Probing for `National Semiconductor LM79' at 0x290...       No
Probing for `Winbond W83781D' at 0x290...                   No
Probing for `Winbond W83782D' at 0x290...                   No

Lastly, we can probe the I2C/SMBus adapters for connected hardware
monitoring devices. This is the most risky part, and while it works
reasonably well on most systems, it has been reported to cause trouble
on some systems.
Do you want to probe the I2C/SMBus adapters now? (YES/no): 
Using driver `i2c-piix4' for device 0000:00:14.0: ATI Technologies Inc SB600/SB700/SB800 SMBus
Module i2c-dev loaded successfully.

Next adapter: NVIDIA i2c adapter 0 at 1:00.0 (i2c-0)
Do you want to scan it? (yes/NO/selectively): 

Next adapter: NVIDIA i2c adapter 1 at 1:00.0 (i2c-1)
Do you want to scan it? (yes/NO/selectively): 

Next adapter: NVIDIA i2c adapter 9 at 1:00.0 (i2c-2)
Do you want to scan it? (yes/NO/selectively): 

Now follows a summary of the probes I have just done.
Just press ENTER to continue: 

Driver `nct6775':
  * ISA bus, address 0x290
    Chip `Nuvoton NCT5577D/NCT6776F Super IO Sensors' (confidence: 9)

Driver `k10temp' (autoloaded):
  * Chip `AMD Family 10h thermal sensors' (confidence: 9)

To load everything that is needed, add this to /etc/modules:
#----cut here----
# Chip drivers
nct6775
#----cut here----
If you have some drivers built into your kernel, the list above will
contain too many modules. Skip the appropriate ones!

Do you want to add these lines automatically to /etc/modules? (yes/NO)

Unloading i2c-dev... OK
Unloading cpuid... OK

root@:~# sensors
nct6776-isa-0290
Adapter: ISA adapter
Vcore:          +1.01 V  (min =  +0.00 V, max =  +1.74 V)
in1:            +1.87 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
AVCC:           +3.36 V  (min =  +2.98 V, max =  +3.63 V)
+3.3V:          +3.36 V  (min =  +2.98 V, max =  +3.63 V)
in4:            +0.02 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in5:            +1.72 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in6:            +0.02 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
3VSB:           +3.46 V  (min =  +2.98 V, max =  +3.63 V)
Vbat:           +3.34 V  (min =  +2.70 V, max =  +3.63 V)
fan1:             0 RPM  (min =    0 RPM)
fan2:             0 RPM  (min =    0 RPM)
fan3:             0 RPM  (min =    0 RPM)
fan4:             0 RPM  (min =    0 RPM)
fan5:             0 RPM  (min =    0 RPM)
SYSTIN:         +37.0°C  (high =  +0.0°C, hyst =  +0.0°C)  ALARM  sensor = thermistor
CPUTIN:         +33.0°C  (high = +80.0°C, hyst = +75.0°C)  sensor = thermistor
AUXTIN:        +127.5°C  (high = +114.0°C, hyst = +114.0°C)  ALARM  sensor = thermistor
PCH_CHIP_TEMP:   +0.0°C  
PCH_CPU_TEMP:    +0.0°C  
PCH_MCH_TEMP:    +0.0°C  
intrusion0:    ALARM
intrusion1:    ALARM
beep_enable:   disabled

k10temp-pci-00c3
Adapter: PCI adapter
temp1:        +24.5°C  (high = +70.0°C)

 , ,

DenisPA ()

Частота проца

Я что-то не могу найти где можно посмотреть частоту проца... Есть проц AMD Athlon(tm) II X2 265, частота 3 795МГц но почему-то cat /proc/cpuinfo показывает 3300 пиковую (ровно как и KInfoCenter)... Оно что не из BIOS, а из какой-то статической таблички частоты берет что ли? Где можно посмотреть реальные значения (к примеру забацать свой cpuz).

cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_cur_freq тоже самое... (ну конечно в герцах)

dmesg | grep MHz
[    0.004000] tsc: Detected 3795.212 MHz processor
[    0.446896] hpet0: 3 comparators, 32-bit 14.318180 MHz counter
[    2.086175] tsc: Refined TSC clocksource calibration: 3795.180 MHz

Ядро то знает... Откуда?

 , ,

DenisPA ()

locale kubuntu

Kubunut 14.04.1 неприятно удивила багом в локалях.

Собственно апдейт ничего не ломает, а вот если устанавливать на чистую получается следующее:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_UA.UTF-8
LANGUAGE=en:ru:uk:en
LC_CTYPE="en_UA.UTF-8"
LC_NUMERIC=en_UA.UTF-8
LC_TIME=en_UA.UTF-8
LC_COLLATE="en_UA.UTF-8"
LC_MONETARY=en_UA.UTF-8
LC_MESSAGES="en_UA.UTF-8"
LC_PAPER=en_UA.UTF-8
LC_NAME=en_UA.UTF-8
LC_ADDRESS=en_UA.UTF-8
LC_TELEPHONE=en_UA.UTF-8
LC_MEASUREMENT=en_UA.UTF-8
LC_IDENTIFICATION=en_UA.UTF-8
LC_ALL=

А хотелось бы:

LANG=en_US.UTF-8
LANGUAGE=en_US
LC_CTYPE=en_US.UTF-8
LC_NUMERIC=uk_UA.UTF-8
LC_TIME=uk_UA.UTF-8
LC_COLLATE=en_US.UTF-8
LC_MONETARY=uk_UA.UTF-8
LC_MESSAGES=en_US.UTF-8
LC_PAPER=uk_UA.UTF-8
LC_NAME=uk_UA.UTF-8
LC_ADDRESS=uk_UA.UTF-8
LC_TELEPHONE=uk_UA.UTF-8
LC_MEASUREMENT=uk_UA.UTF-8
LC_IDENTIFICATION=uk_UA.UTF-8
LC_ALL=

Но после добавления этого в /etc/default/locale

locale: Ðевозможно ÑÑÑановиÑÑ LC_ALL в Ð»Ð¾ÐºÐ°Ð»Ñ Ð¿Ð¾ ÑмолÑаниÑ.: ÐÐµÑ Ñакого Ñайла или каÑалога
LANG=en_UA.UTF-8
LANGUAGE=en:ru:uk:en
LC_CTYPE=en_US.UTF-8
LC_NUMERIC=en_UA.UTF-8
LC_TIME=en_UA.UTF-8
LC_COLLATE=en_US.UTF-8
LC_MONETARY=en_UA.UTF-8
LC_MESSAGES=en_US.UTF-8
LC_PAPER=en_UA.UTF-8
LC_NAME=en_UA.UTF-8
LC_ADDRESS=en_UA.UTF-8
LC_TELEPHONE=en_UA.UTF-8
LC_MEASUREMENT=en_UA.UTF-8
LC_IDENTIFICATION=en_UA.UTF-8
LC_ALL=

И самое досадное то, что многие проги (та же konsole) по умолчанию используют ISO-8859-1 что просто недопустимо... В настройках konsole есть регулятор, но я оставил как «детектор»...

Собственно хочется иметь в полностью английской ОС нормальную поддержку кирилицы... Сейчас творится бред каждая софтина на свое усмотрение кодирует имена...

П.С.: по приколу сделал cp uk_UA en_UA не помогло

 , ,

DenisPA ()

ASRock Audio


lspci -knn | grep «Audio» -A2
00:14.2 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) [1002:4383] (rev 40)
Subsystem: ASRock Incorporation Device [1849:7892]
Kernel driver in use: snd_hda_intel
--
01:00.1 Audio device [0403]: NVIDIA Corporation GF108 High Definition Audio Controller [10de:0bea] (rev a1)
Subsystem: NVIDIA Corporation Device [10de:0825]
Kernel driver in use: snd_hda_intel



Проблема: звук постоянно и произвольно меняет уровень, работать не возможно, но если упадет на 0 то уже (сам) не включается.

1. Замена пульсы на алса помогает, но, если включить и наушники и колонки то при проигрывании из колонок доносятся щелчки...

2. Сейчас cтоит пульса, захожу в alsamixer там таже хрень (Surround, Center, LFE, Side) рывками подымаются на 100% и опускаются. Вижет КДЕ показывает что звука нет...

3. Поставил Kubunut 14.04 и установил весь нужный софт, аудио настройки не трогал вообще, то есть все дефолтное... Жду ваших советов.

 , , ,

DenisPA ()

Вирус под линукс? :)

Вот сейчас наблюдаю как флэшплееры ютуба и других сайтов спокойно управляют звуком моей системы, какого хрена не понятно, но они его произвольно уменьшают и глушат. Происходит это в произвольные отрезки времени но довольно часто чтобы задолбатся его накручивать.

 ,

DenisPA ()

splash screen

Можно ли под андроидом 4 заменить анимацию загрузки на текст?

 ,

DenisPA ()

Xubuntu + Qt

Решил попробовать xfce, поставил qt-sdk из репозиториев, но оно както жутко глючит:
1. дебанг работает раз через раз (несколько раз gdb убивал менеджер потому что тот якобы не отвечал)
2. Cтоковой creator настолько глючен, что даже при нажатии на вкладке «development», на стартовой странице, открывается 4 шт пустых форм, которые можно закрыть только закрыв сам creator (в 3.0.1 этот глюк отсутствует).
3. И нигде не работает справка по F1 на элементе кода, а та что есть кажется тоже не полная.

Может что-то нужно до установить?

 ,

DenisPA ()

cups rss

не могу понять как это настроить, после заполнения формы я получаю:

Name	                   Events	         Queue Name
{notify_recipient_name}    {notify_events}	 Epson_Stylus_S22
как к нему теперь получить доступ? Пробовал

http://127.0.0.1:631/rss/epson.rss

http://localhost:631/rss/epson.rss

feed://127.0.0.1:631/rss/epson.rss

Имя этой очереди epson.rss

DenisPA ()

MTS

Купил новый фотик и поснимал на него видео. Теперь вот не могу найти чем его проиграть. В итоге через раз с повисаниями и лагами его воспроизводит Dragon Palyer все остальные (VLC, SMPalyer) просто «слайд-шоу». Неужели мое железо такое неактуальное :) ?

CPU:
AMD Athlon(tm) II X2 265 Processor
GPU:
NVIDIA Corporation GF108 [GeForce GT 440] (rev a1)
RAM:
8Gb
OS:
3.11.0-13-generic x86_64 x86_64 x86_64 GNU/Linux (Ubuntu)
ffmpeg -i 00009.MTS
ffmpeg version 0.8.9-6:0.8.9-0ubuntu0.13.10.1, Copyright (c) 2000-2013 the Libav developers
  built on Nov  9 2013 19:09:46 with gcc 4.8.1
*** THIS PROGRAM IS DEPRECATED ***
This program is only provided for compatibility and will be removed in a future release. Please use avconv instead.
Input #0, mpegts, from '00009.MTS':
  Duration: 00:00:35.03, start: 1.000011, bitrate: 26371 kb/s
  Program 1 
    Stream #0.0[0x1011]: Video: h264 (High), yuv420p, 1920x1080 [PAR 1:1 DAR 16:9], 50 fps, 50 tbr, 90k tbn, 100 tbc
    Stream #0.1[0x1100]: Audio: ac3, 48000 Hz, stereo, s16, 256 kb/s
    Stream #0.2[0x1200]: Data: [144][0][0][0] / 0x0090
At least one output file must be specified

Файлы микроскопические от 50 до 500Мб

DenisPA ()

Дефрагментация ext2/3

Собственно прошу помочь найти, так как нет времени перерывать кучу постов с темами «нужно не нужно» это... Есть файлы которые должны (обязательно) хранится без фрагментации, используется ext3 (можно переформатировать в 2) и только в эти.

П.С.: Честно говоря удивлен, что они сами не записались по человечески 5файлов всего 125М, а раздел на 11Г.

DenisPA ()

GRUB4DOS

А какой офф сайт у этой штуки (GRUB4DOS)?
Нашел это http://code.google.com/p/grub4dos-chenall/
и это http://sourceforge.net/projects/grub4dos/

DenisPA ()

RSS подписка на новые темы