LINUX.ORG.RU

locale kubuntu

 , ,


1

2

Kubunut 14.04.1 неприятно удивила багом в локалях.

Собственно апдейт ничего не ломает, а вот если устанавливать на чистую получается следующее:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_UA.UTF-8
LANGUAGE=en:ru:uk:en
LC_CTYPE="en_UA.UTF-8"
LC_NUMERIC=en_UA.UTF-8
LC_TIME=en_UA.UTF-8
LC_COLLATE="en_UA.UTF-8"
LC_MONETARY=en_UA.UTF-8
LC_MESSAGES="en_UA.UTF-8"
LC_PAPER=en_UA.UTF-8
LC_NAME=en_UA.UTF-8
LC_ADDRESS=en_UA.UTF-8
LC_TELEPHONE=en_UA.UTF-8
LC_MEASUREMENT=en_UA.UTF-8
LC_IDENTIFICATION=en_UA.UTF-8
LC_ALL=

А хотелось бы:

LANG=en_US.UTF-8
LANGUAGE=en_US
LC_CTYPE=en_US.UTF-8
LC_NUMERIC=uk_UA.UTF-8
LC_TIME=uk_UA.UTF-8
LC_COLLATE=en_US.UTF-8
LC_MONETARY=uk_UA.UTF-8
LC_MESSAGES=en_US.UTF-8
LC_PAPER=uk_UA.UTF-8
LC_NAME=uk_UA.UTF-8
LC_ADDRESS=uk_UA.UTF-8
LC_TELEPHONE=uk_UA.UTF-8
LC_MEASUREMENT=uk_UA.UTF-8
LC_IDENTIFICATION=uk_UA.UTF-8
LC_ALL=

Но после добавления этого в /etc/default/locale

locale: Ðевозможно ÑÑÑановиÑÑ LC_ALL в Ð»Ð¾ÐºÐ°Ð»Ñ Ð¿Ð¾ ÑмолÑаниÑ.: ÐÐµÑ Ñакого Ñайла или каÑалога
LANG=en_UA.UTF-8
LANGUAGE=en:ru:uk:en
LC_CTYPE=en_US.UTF-8
LC_NUMERIC=en_UA.UTF-8
LC_TIME=en_UA.UTF-8
LC_COLLATE=en_US.UTF-8
LC_MONETARY=en_UA.UTF-8
LC_MESSAGES=en_US.UTF-8
LC_PAPER=en_UA.UTF-8
LC_NAME=en_UA.UTF-8
LC_ADDRESS=en_UA.UTF-8
LC_TELEPHONE=en_UA.UTF-8
LC_MEASUREMENT=en_UA.UTF-8
LC_IDENTIFICATION=en_UA.UTF-8
LC_ALL=

И самое досадное то, что многие проги (та же konsole) по умолчанию используют ISO-8859-1 что просто недопустимо... В настройках konsole есть регулятор, но я оставил как «детектор»...

Собственно хочется иметь в полностью английской ОС нормальную поддержку кирилицы... Сейчас творится бред каждая софтина на свое усмотрение кодирует имена...

П.С.: по приколу сделал cp uk_UA en_UA не помогло

Ответ на: комментарий от amorpher

Что за странная реакция? Ну тебе в полностю русской хочется видеть латинские буковки? А мне наоборот...

А зачем тебе кеды если ты /etc/default/locale лезешь?

Если бы я знал где это можно установить в КДЕ я бы не лез в глобалку... В КДЕ в settings/locale/country я выставил местоположение...

Вопрос какого хрена УТФ не по деволту???

DenisPA ★★ ()
Ответ на: комментарий от DenisPA

сравни:

$ cat /etc/default/locale
LANG=«ru_RU.UTF-8»
LANGUAGE=«ru_RU:ru»
LC_NUMERIC=«ru_RU.UTF-8»
LC_TIME=«ru_RU.UTF-8»
LC_MONETARY=«ru_RU.UTF-8»
LC_PAPER=«ru_RU.UTF-8»
LC_IDENTIFICATION=«ru_RU.UTF-8»
LC_NAME=«ru_RU.UTF-8»
LC_ADDRESS=«ru_RU.UTF-8»
LC_TELEPHONE=«ru_RU.UTF-8»
LC_MEASUREMENT=«ru_RU.UTF-8»

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

Я не понимаю, о чем вы говорите!

Во первых, эта проблема появилась в 14.04.1 до этого все было адекватно - местоположение влияло только на время и деньги.

Во вторых, в local заявлено UTF-8, а на самом деле половина софта включая КДЕшный дефолт узают кодировку на свой вкус!

Ну и на конец: я не сомневаюсь что штатная ситуация ру_Ру из коробки работает без проблем...

Так зачам вы сюда написали? Сказать что у вас ру_Ру. Сказать что английский не нужен? Или просто трололо?

DenisPA ★★ ()
Последнее исправление: DenisPA (всего исправлений: 1)
Ответ на: комментарий от amorpher

А ну да en_UA в принципе не существует. Это явно баг.

DenisPA ★★ ()
Ответ на: комментарий от DenisPA

Так зачам вы сюда написали?

у меня тоже 14.04.1 и всё ровно
что за вопли? может это тебе не надо было топик создавать? или вспомнить, что было сделано и привело к такому состоянию?
думаю 14.04.1 не мы вдвоём пользуемся

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

что за вопли?

Видимо жара на мозг действует...

у меня тоже 14.04.1 и всё ровно

я не сомневаюсь что штатная ситуация ру_Ру из коробки работает без проблем...

или вспомнить, что было сделано и привело к такому состоянию

Установил чистую ОС. Выбрал страну (для времени и денег). Получил не то что-раньше...

DenisPA ★★ ()
Ответ на: комментарий от amorpher

Вот сейчас вернул назад США, везде стала УТФ8...
Хотя календарь не сбился, а должен был... Ладо может подскажите где в кде конфигах лежит локаль для текущего профиля. Я руками укажу там что нужно....

DenisPA ★★ ()
Ответ на: комментарий от DenisPA

Не скажу, украинской локалью не пользовался никогда, но вывод locale странный, откуда там en_UA.UTF-8? Странно просто. Есть ru_UA. И " не забудь.

$ locale
LANG=ru_RU.UTF-8
LANGUAGE=
LC_CTYPE=«ru_RU.UTF-8»
LC_NUMERIC=ru_RU.UTF-8
LC_TIME=ru_RU.UTF-8
LC_COLLATE=«ru_RU.UTF-8»
LC_MONETARY=ru_RU.UTF-8
LC_MESSAGES=«ru_RU.UTF-8»
LC_PAPER=ru_RU.UTF-8
LC_NAME=ru_RU.UTF-8
LC_ADDRESS=ru_RU.UTF-8
LC_TELEPHONE=ru_RU.UTF-8
LC_MEASUREMENT=ru_RU.UTF-8
LC_IDENTIFICATION=ru_RU.UTF-8

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

Да спасибо, нашел .kde/env/setlocale.sh

Видимо баг в утилите что его генерирует...

DenisPA ★★ ()
Последнее исправление: DenisPA (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.