LINUX.ORG.RU

Slackware Linux 15.0 Beta

 ,


3

4

Патрик Фолькердинг объявил, что разрабатываемая ветвь Slackware Linux, известная как «current», достигла статуса «бета»:

Я осмелюсь назвать это бета-версией, хотя до сих пор нет исправления для проблемы с нераспознанными инструкциями (illegal instruction) у 32-битной MariaDB. Но это должно быть исправлено в ближайшее время. С GCC 10.3 не было замечено никаких регрессий сборки. Пожалуйста, сообщайте о любых новых (или старых) проблемах на форуме LinuxQuestions в разделе Slackware. Наслаждайтесь!

Последние записи в журнале изменений указывают на различные обновления:

  • обновление ядра до Linux 5.10.29 (по умолчанию; более новое ядро 5.11.13 доступно в репозитории «testing»);
  • GCC 10.3.0;
  • несколько исправлений безопасности для dnsmasq и irssi;
  • все пакеты KDE были недавно обновлены, поэтому KDE Plasma теперь имеет версию 5.21.4, а приложения KDE — 5.81.0;
  • Thunderbird также был обновлен из-за недавних проблем с безопасностью.

Как всегда, Slackware не предоставляет никаких официальных тестовых образов, но пользователи, заинтересованные в установке и тестировании дистрибутива, могут загрузить неофициальный установочный DVD от Эрика Хамелеерса или установочный мини-CD, собранный из дерева «current» Slackware и обновляемый ежедневно:

Образ установочного мини-CD также доступен для архитектуры i386.

>>> Список изменений

anonymous

Проверено: Shaman007 ()

Хороший дистрибутив, пользовался довольно долго. Мне интересно, со времён релиза 14.2 огромная куча слакбилдов уже стала abandonware, а их сопроводители уже давно вышли на пенсию. Кто будет это подгонять под актуальные версии в 15.0? Может это уже делается для -current? Без актуальных слакбилдов релиз бесполезен совершенно.

lagavulin16 ()
Ответ на: комментарий от zabbal

А с чего ты решил, что не актуально? Обновления выходят, релиз скоро, бета вон на днях вышла. В current софт вообще многий свежее стабильного дебиана, но деб что-то в маргинальщину не записывают

Dog ()
Ответ на: комментарий от nioelumiijke

Systemd нету, и утята пищат без мамки. Разруливать зависимости многим очень сложно, также жирные пакеты с -dev заголовками, статичными либами многим не сдались на серверах, например, и на домашних компах тоже часто оверхед

menangen ★★★★★ ()
Ответ на: комментарий от nioelumiijke

Gnome 3, Systemd, Wayland, Pulseaudio, RPM и прочих современных болезней пингвина, которые не дают ему стать полноценным конкурентом Windows. Патрик не дает своему дистрибутиву скатиться на дно.

anonymous ()
Ответ на: комментарий от Dog

В общем, сравнительно свежий софт там, многое свежее, чем в stable Дебиана

Нет, многое свежее, чем в Debian unstable (Sid)

glibc:

Debian Buster - 2.28
Debian Bullseye - 2.31
Debian Sid - 2.31
Slackaware Current - 2.33

plasma-desktop:

Debian Buster - 5.14.5
Debian Bullseye - 5.20.5
Debian Sid - 5.20.5
Debian Experimental - 5.21.4
Slackware Current - -5.21.4
anonymous ()
Ответ на: комментарий от menangen

у меня там несколько проблем:

что то там с docker(я не сильно разбирался)(жаль, но я чет там тупил просто),

с virtualbox(с этими драйверами чтото там)(не нужно мне)

с vscode(не устанавливались дополнения)(удалил).

собственно , в остальном меня очень устраивает.

nioelumiijke ()
Ответ на: комментарий от anonymous

нафига вам этот релиз, когда вы все поголовно на «current»

стабильный дефолт где все «просто работает» жы :) курент он все же про недоверчиво вложить персты в ранупотыкать палкой в кровоточащие края прогресса

slackwarrior ★★★★★ ()
Последнее исправление: slackwarrior (всего исправлений: 1)
Ответ на: комментарий от slackwarrior

Ага, был такой чекбокс в инсталлере, меня это всегда радовало).
Я с того момента на ogg/flac и подсел, сейчас вообще не одного mp3 нет в моей библиотеке ∆_∆

qbbr ★★★★ ()
Ответ на: комментарий от kostyarin_

Теорему Ферма наконец доказали. Ферма больше не может троллить математиков с того света, и математика как наука больше не нужна.

Даже более того, теперь «доказали», что математика - расистская наука, унижающая не могущих осилить её негров)))

anonymous ()
Ответ на: комментарий от anonymous

Даже более того, теперь «доказали», что математика - расистская наука, унижающая не могущих осилить её негров)))

Во-во. Это расизм. Такой же как и шахматы. Известно, что арийское население осело в своё время в Индии, где и изобрело шахматы, чтобы троллить местных черномазых.

kostyarin_ ★★ ()
Ответ на: комментарий от Dog

Прикольно. А под досом разве можно было 2 программы параллельно запускать?

А сами как думаете? Постой пример: переключалка раскладок клавиатуры, она запущена? Ответ: да. Вирус[ы] работают? Ответ: ещё как работают. :) И т.д и т.п. Помниться какой-то проигрыватель из каробки в бэграунд умел сваливать. Вообще говоря написать софтину которая свалит в фон и будет на каком-то прерывание болтаться, не такая сложная задача. Другой вопрос, что кто-то может вперед влезть и до до вас очередь не дойдет ;) Как пример: игори.

anc ★★★★★ ()
Ответ на: комментарий от perl5_guy

Начал давным давно знакомиться с Linux с Slackware.
В те времена лишь с помощью нее можно было собрать компактное ядро.
Нареканий не было.

Чем она хороша /вопрос без всяких намеков/?
Какой дистрибутив посоветуете для разработки /GNOME, KDE, … меня мало интересуют/?

Vladimirmir ()
Ответ на: комментарий от Dog

Я кстати про игори не случайно написал. Написал я себе как-то будильник, он спикером пищал, норм работал... какое-то время... и вот очередную ночь хреначу в какую-то игрулину... вощем будильника не сработала... ;)

anc ★★★★★ ()
Ответ на: комментарий от Vladimirmir

Она максимально юниксовая. Простая как полено - всё (ну почти) через текстовые файлы настраивается, нет всякой новомодной хрени. Иногда это осложняет жизнь, но в подавляющем большинстве случаев наоборот упрощает. Так же круто что из коробки есть практически всё что мне надо. Бесит что в той же убунте надо ставить, скажем vim (хотя может я путаю, но gvim 458% из коробки не установлен). Ну и Slackware Linux Essentials 2005 года выпуска по сей день актуален процентов на 90. Это подкупает. Так же справедливо, что если вы знаете Slackware - то знаете GNU/Linux. Отличный дистр для изучения прыщемиров.

perl5_guy ★★★ ()

Поверьте кто-нибудь grub-install
https://www.linuxquestions.org/questions/slackware-14/how-install-slackware-o...
-> https://www.linuxquestions.org/questions/slackware-14/grub-error-in-latest-sl...

- у меня так и не получилось grub поставить, при uefi и uefi-csm, но я до этого lilo пользовался и на legacy. Догадываюсь что дело в kernel-huge, но симлинку в /boot на generic создавать пробовал, как и _/usr/share/mkinitrd/mkinitrd_command_generator.sh_ запускать, не знаю конечно, последнее надо или нет

NK ★★★★★ ()
Последнее исправление: NK (всего исправлений: 2)
Ответ на: комментарий от perl5_guy

В убунте мп3 нужно ставить, когда музло послушать ;) но ящитаю это полумеры — нужно еще удалять, когда плеер закрывается.

slackwarrior ★★★★★ ()
Последнее исправление: slackwarrior (всего исправлений: 1)
Ответ на: комментарий от Dog

Уже после выхода из игры, или потому, что она запущенна была?

Потому что она запущена была. Обработку прерывания на себя переопределяла без передачи управления предку.

Если второй вариант, то не так страшно, хоть не проспал)

От це факт, шо було то було, не проспал ;)

anc ★★★★★ ()
Последнее исправление: anc (всего исправлений: 1)
Ответ на: комментарий от NK

В слаке на машине с UEFI тебе вообще нафиг не нужен никакой загрузчик. Т.е. совсем. ни efi, ни обычный, никакой. Стоковое слакино ядро - валидный EFI бинарник, который может прямо загружаться самим UEFI без всяких прокладок типа груба или лило. initrd и аргументы ядра прописываются в параметр efiboot.

Stanson ★★★★★ ()
Последнее исправление: Stanson (всего исправлений: 1)
Ответ на: комментарий от slackwarrior

с lilo тоже проблема есть, увы( У меня с картинкой он не получается на машине под uefi-csm

# cat /etc/lilo.conf | grep "bitmap ="
  bitmap = /boot/slack.bmp
# lilo
Warning: LBA32 addressing assumed
Warning: Video adapter does not support VESA BIOS extensions needed for
  display of 256 colors.  Boot loader will fall back to TEXT only operation.
Added slack15  *
2 warnings were issued.

vga варианты разные пробовал - не помогло, зато без картинки норм все

# liloconfig
...
# cat /etc/lilo.conf | grep "bitmap ="
# lilo
Warning: LBA32 addressing assumed
Added read-only  *
Added slack15
One warning was issued.
NK ★★★★★ ()
Ответ на: комментарий от NK

Video adapter does not support VESA BIOS extensions needed for display of 256 colors.

Тут вариантов больше одного.
1) uefi-scm действительно не содержит VBE для 256-цветного и выше режима. Тут уж ничего не поделаешь...
2) VBE не видны LILO из-за загруженного видеодрайвера. Тут можно погрузиться с фреймбуфером или нативной текстовой консолью, чтобы проверить предположение.

Смотреть можно на вывод
# lilo -T video
# hwinfo --framebuffer
# hwinfo --log fb.log --framebuffer; less fb.log

bormant ★★★★★ ()
Ответ на: комментарий от bormant

железо новое, но на 5.10 нормально работает, amdgpu если что, давайте посмотрим

вывод lilo -T video такой же, как и в tty1, так и в KDE5 (Xorg/SDDM)

NK ★★★★★ ()
Последнее исправление: NK (всего исправлений: 1)
Ответ на: комментарий от NK

давайте посмотрим

Так там особо и не на что:

=== vbe get info: ok (time 0.000s, eax 0x4f, err = 0x0)
=== vbe info
version = 3.0, oem version = 17.10
memory = 49152k
oem name [0xc01c8] = "AMD ATOMBIOS"
vendor name [0xc00eb] = "(C) 1988-2018, Advanced Micro Devices, Inc."
product name [0xc007f] = "RENOIR"
product revision [0xc4918] = "01.00"
28 video modes:
=== vbe mode info [0x0110]: failed (time 0.000s, eax 0x34f, err = 0x0)
=== emulation log 2 (no i/o) ===
=== vbe mode info [0x0111]: failed (time 0.000s, eax 0x34f, err = 0x0)
=== emulation log 3 (no i/o) ===
=== vbe mode info [0x0121]: failed (time 0.000s, eax 0x34f, err = 0x0)
=== emulation log 4 (no i/o) ===
...

И так для всех 28 режимов.
С незагруженным amdgpu такая же картина? Просто когда работает LILO из бутсектора, про amdgpu, да и про ядро тоже, речь еще не идет.
Как вариант можно в lilo.conf поставить vga=ask, позвать lilo, перезагрузиться и посмотреть, что сам загрузчик увидит (но по личному опыту он сам способен увидеть только более-менее распространенные VBE режимы).

bormant ★★★★★ ()
Ответ на: комментарий от bormant

Сделал «в лоб», удалил все xf86-video-* пакеты, перезагрузился, с bitmap позвал lilo - Warning тот же

При vga=ask он мне выдал режимы, как и при scan, и с какого-то даже запустил ядро, а именно 311. Но пробовал в lilo.conf: vga=311 прописывать, при bitmap/bmp-* - Warning не изменяется, как и результат

NK ★★★★★ ()