LINUX.ORG.RU

Fedora 26 и Russian Fedora Remix 26

 , ,


1

3

11 июля состоялся выход Fedora 26 и Russian Fedora Remix 26.

Основные изменения в Fedora 26:

  • Anaconda получила расширенные возможности для системных администраторов.
  • SSSD-кэш включён по умолчанию.

Обновления ПО:

  • Gnome 3.24,
  • Mate 1.18,
  • Linux 4.11,
  • Firefox 54,
  • GO 1.8,
  • glibc 2.25,
  • Cinnamon 3.4,
  • Flashback 3.24,
  • KDE 5.9.

Russian Fedora — дистрибутив, основанный на Fedora с проприетарными компонентами.

Основные изменения Russian Fedora 26:

  • Freetype пересобран с subpixel rendering.
  • Fontconfig содержит патчи Ubuntu для LCD-мониторов.
  • В образы Workstation по умолчанию для GNOME Shell (не для GTK) используется тема Korora из одноименного проекта. Также опционально добавлены темы Adapta и EvoPop для GTK и иконки EvoPop. Все отключается и включается в gnome-tweak-tool.
  • В KDE добавлен LibreOffice вместо офиса KDE, а также изменена загрузочная тема Плимута на breeze.
  • Доступна поддержка Flash.
  • В репозитории доступен клиент для WhatsApp и Wire, а также Skype 4.3, Viber и Telegram.
  • В Live-образы в выключенном состоянии добавлены официальные репозитории с Google Chrome, Yandex Browser, MEGAsync, Skype, Slack, VirtualBox, Cloud Mail.ru, VK мессенджер и Yandex Disk.
  • Chromium пересобран с поддержкой кодеков.
  • Taglib собран с патчем ruxmms, для поддержки тегов в кодировке win1251.
  • Telepathy Gabble собран с патчем, позволяющим подключение к Jabber-серверу Cisco.
  • В репозитории доступен клиент s3fs-fuse и distributed key/value storage Elliptics.
  • Доступен новый Live-образ LXQt.
  • Для Live-образов доступна опция загрузки образа в память (rd.live.ram).
  • На все Live-образы добавлен по умолчанию Telegram.

>>> Подробности



Проверено: Shaman007 ()
Ответ на: комментарий от Lowes

Ну да, добавили еще один левый репозиторий драйверов Nvidia... В чем его отличие от RPMFusion - непонятно.

Он всегда был на самом деле. Всего лишь иная реализация от другого мейнтейнера. Кому-то нравится этот, кому-то RPMFusion, а кто-то и вообще на свободных сидит.

xvitaly ()
Ответ на: комментарий от lagavulin16

Скорее всего для обновления списка пакетов, так как по умолчанию при ручном запуске dnf он его обновляет. Где-то отключается, возможно даже просто как сервис.

grem ★★★★★ ()
Ответ на: комментарий от grem

Скорее всего для обновления списка пакетов, так как по умолчанию при ручном запуске dnf он его обновляет. Где-то отключается, возможно даже просто как сервис.

Это сервис и systemd-таймер. Отключается достаточно просто.

xvitaly ()
Ответ на: комментарий от xvitaly

Он всегда был на самом деле. Всего лишь иная реализация от другого мейнтейнера. Кому-то нравится этот, кому-то RPMFusion, а кто-то и вообще на свободных сидит.

Ну ежели его возьмут в апстрим, Copr или RFR -тогда и обратим внимания.

Lowes ()
Ответ на: комментарий от Lowes

Ну ежели его возьмут в апстрим, Copr или RFR -тогда и обратим внимания.

В апстрим проприетарщину никогда не возьмут, а в RPMFusion уже есть пакет с драйверами NVIDIA со своими мейнтейнерами.

На мой взгляд, пакет из RPMFusion лучше, т.к. использует akmods для сборки модулей ядра, которые легко удаляются вместе с соответствующими ядрами по зависимостям.

xvitaly ()
Ответ на: комментарий от xvitaly

Потому что Федора --- это не самодостаточный дистрибутив, чтобы работать, а тестовый полигон. У нас тут были любители Федоры, но довольно быстро выяснилось, что предсказуемое поведение свойственно только старым, уже неподдерживаемым выпускам. В результате один из них сидел то ли на 7, то ли на 9 версии в 2011, а два других в 2013 всё ещё использовали Федору 13 и 15.

Vudod ★★★★★ ()
Ответ на: комментарий от Vudod

Потому что Федора --- это не самодостаточный дистрибутив, чтобы работать, а тестовый полигон.

Debian Testing как бы тоже, тут причины несколько иные...

У нас тут были любители Федоры, но довольно быстро выяснилось, что предсказуемое поведение свойственно только старым, уже неподдерживаемым выпускам. В результате один из них сидел то ли на 7, то ли на 9 версии в 2011, а два других в 2013 всё ещё использовали Федору 13 и 15.

Нет, просто есть пакеты, на которые просто забили болт и они кочуют из релиза в релиз, несмотря на то, что апстрим обновился. Отсюда и стабильность сильно упала. Даже был помню срач, когда собирались закрывать KDE-спин.

Lowes ()
Ответ на: комментарий от anonymous

RFR это для тех у кого руки не оттуда растут. Ставь обычную федору, а всё остальное доустанавливай с левых репозиториев. Хотя, если тебе это надо просто для того чтобы поиграться, то ты не туда попал.

serhey ()
Ответ на: комментарий от Lowes

Debian Testing как бы тоже, тут причины несколько иные...

Как бы он и называется тестингом. Но ведь Федора --- не тестинг, а скорее аналог Сида. Тестинг более годное и готовое для употребления поделие.

Нет, просто есть пакеты, на которые просто забили болт и они кочуют из релиза в релиз, несмотря на то, что апстрим обновился.

Нельзя сказать, что в Дебиане такого не бывает совсем, но всё же там перед выпуском проводятся проверка и чистка. Т.е. если пакет устарел более чем на 2 года, он может попасть лишь в случае, если констатируется отсутствие существенных проблем при проверке.

И вообще-то я не про старые пакеты, а как раз про новые: получить новое ядро и неработающий OpenGL или снести себе работоспособную и настроенную версию LibreOffice и заменить на версию для тестировщиков --- в Федоре обычное дело в рамках планового обновления. В Дебиане/Убунте тоже есть backports ядер и не только, но он никогда не становится вариантом по умолчанию.

Vudod ★★★★★ ()
Последнее исправление: Vudod (всего исправлений: 2)
Ответ на: комментарий от Vudod

Потому что Федора --- это не самодостаточный дистрибутив, чтобы работать, а тестовый полигон.

Использую Fedora на всех компах (рабочих и домашних) с 2007 года.

Непредсказуемое поведение при работе системы возникает только у тех кто непредсказуемым образом умудряется испортить себе свою же жизнь. После чего возникает много криков про то как «аа!!! обновление перезатерло мои конфиги, которые я конечно же решил положить в /usr, потому что не знаю как работает пакетный менеджер» и всё такое прочее.

alpha ★★★★★ ()
Ответ на: комментарий от Vudod

Потому что Федора --- это не самодостаточный дистрибутив. В результате один из них сидел то ли на 7, то ли на 9 версии в 2011, а два других в 2013 всё ещё использовали Федору 13 и 15.

Тебе к Петрасяну на пол ставки надо.

anonymous ()
Ответ на: комментарий от alpha

Использую Fedora на всех компах (рабочих и домашних) с 2007 года.

Ничего себе, вот это выдержка, а я в начале 2011 устал от постоянного пердолинга, хотя познакомился с ней чуть раньше.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от Vudod

Но ведь Федора --- не тестинг, а скорее аналог Сида. Тестинг более годное и готовое для употребления поделие.

Нет, скорее тестинг, поскольку после сида есть тестинг, а тут уже сразу финальный RHEL.

но всё же там перед выпуском проводятся проверка и чистка. Т.е. если пакет устарел более чем на 2 года, он может попасть лишь в случае, если констатируется отсутствие существенных проблем при проверке.

Это если пакет устарел вместе с апстримом. А если апстрим не устарел, а уже эти два года обновился? Там такого как-раз и нет. А у Fedora существуют оные пакеты.

И вообще-то я не про старые пакеты, а как раз про новые: получить новое ядро и неработающий OpenGL или снести себе работоспособную и настроенную версию LibreOffice и заменить на версию для тестировщиков --- в Федоре обычное дело в рамках планового обновления. В Дебиане/Убунте тоже есть backports ядер и не только, но он никогда не становится вариантом по умолчанию.

Ядра и в Ubuntu с Debian свежие приходят, и в Live-болванке можно запросто установить свежее ядро, которое через полгода бросят.

Lowes ()
Ответ на: комментарий от Vudod

В Дебиане/Убунте тоже есть backports ядер и не только, но он никогда не становится вариантом по умолчанию.

У десктопной Ubuntu LTS по умолчанию прилетает новое мажорное ядро этак раз в полгода.

fornlr ★★★★★ ()
Ответ на: комментарий от Lowes

Нет, там только исправления уязвимостей, обновление на новое ядро в Убунту по умолчанию невозможно, а в Дебиане для этого необходимо подключать репозиторий backports.

В не LTS убунте действительно может быть не LTS ядро, тогда патчи для него будут выпускаться пока не истечёт 9-тимесячная поддержка. Все ядра Debian и Ubuntu LTS поддерживаются всё время поддержки.

Vudod ★★★★★ ()
Ответ на: комментарий от Unicode4all

Еще трех часов не прошло, а уже налетели клоуны «Ко-ко-ко тестовый полигон! Ко-ко-ко красношапка! Кудах!»

И среди них-дебиановцы. У которых с пару недель назад были эпики с новой 9-кой. Хе-хе.

anonymous ()
Ответ на: комментарий от Vudod

Нет, там только исправления уязвимостей, обновление на новое ядро в Убунту по умолчанию невозможно, а в Дебиане для этого необходимо подключать репозиторий backports.

С разморозкой! https://wiki.ubuntu.com/Kernel/RollingLTSEnablementStack

Lowes ()
Ответ на: комментарий от anonymous

И зачем мне этот цирк, если есть уже собранное и настроенное готовое решение?

Из левых реп не нужно конечно же устанавливать. Собранное и настроенное Васяном? Там даже репами нельзя нормально пользоваться, того и глядишь, что что-то поломается. Все репы Russian Remix лучше держать disabled и обновляться с них только через dnf, чтобы видеть что происходит. А по большому счету там ничего стояшего и нет.

anonymous ()
Ответ на: комментарий от Vudod

Минт - это <CENSORED>. Там действительно что-то несколько по другому с апдейтами.

А в Ubuntu LTS поменяли с 16.04.2. Теперь HWE, в том числе ядро, на десктопах будут сами апгрейдится по умолчанию.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от anonymous

по большому счету там ничего стояшего и нет.

Ты не прав, мой анонимный друг. 1)Шрифты уже пропатченные с нормальным видом. 2) Дрова под мои вай-фай свистки «из-каробки». 3) Вся мультимедия в одной репе. Это только то, что мне нужно.

anonymous ()
Ответ на: комментарий от anonymous

Из левых реп не нужно конечно же устанавливать. Собранное и настроенное Васяном? Там даже репами нельзя нормально пользоваться, того и глядишь, что что-то поломается. Все репы Russian Remix лучше держать disabled и обновляться с них только через dnf, чтобы видеть что происходит. А по большому счету там ничего стояшего и нет.

Это беда федоры самой - в репозиториях свалка, за что и пересел на Debian/Ubuntu. Ибо надоело вручную вместо пакетного менеджера копировать файлы более свежей и совместимой версии. Ибо для этого есть слакварь и патрик!

Lowes ()
Ответ на: комментарий от anonymous

1)Шрифты уже пропатченные с нормальным видом.

А кому они нужны? У меня свои настройки шрифтов, как и сами шрифты.

2) Дрова под мои вай-фай свистки «из-каробки».

А сам ты не в сотоянии поставить нужный пакет? Лучше васяносборку и не париться, а что там Васян напихал, пофиг.

3) Вся мультимедия в одной репе.

Так и у меня есть rpmfusion.

anonymous ()
Ответ на: комментарий от anonymous

1) Мне нужны-на ноутах от дефолтно-федоровских глаза вытекают. 2) Я уже вырос из красноглазого возраста с пердолингом по любому чиху. Свободное время предпочитаю использовать по другому. 3) Тут уже дело вкуса.

anonymous ()
Ответ на: комментарий от anonymous

Что за свалка? И что за репозитории?

Центральный- апстримный. Например, есть пакет Light-theme-gnome, который так и застрял на 14.04.x, хотя уже вышла ветка 16.10.x, совместимая с GTK 3.20+

anonymous ()
Ответ на: комментарий от fornlr

Дело не в выдержке.

Fedora содержит свежий софт. Разумеется этот софт не имеет ещё подушки из stackoverflow-советов, видеоинструкций «как в пять кликов покрасить обоину рабочего стола» и «действительно ли вы этого хотите» предупреждений.

Для того чтобы пользоваться Fedora подход «да я всегда так делал» не работает. И если это единственный ваш источник знаний, то приходится тяжело.

А если не считать себя умнее других и не пытаться упорно «побеждать систему» вопреки здравому смыслу, а например почитать release notes и новости из пресс-релизов, освоить IRC и в случае чего по-человечески спросить у майнтейнера почему, например, пакет A не обновлен до версии x.y.z, или зачем по умолчанию ставится некоторый сервис и как его стоит правильно сконфигурировать, то жизнь станет гораздо проще и логичнее.

alpha ★★★★★ ()
Последнее исправление: alpha (всего исправлений: 1)