LINUX.ORG.RU

Вышел Blueman 1.10

 , ,


0

0

Blueman - это небольшая программа для настройки Bluetooth в Linux. Она позволяет легко настроить соединение с Internet через DUN, настроить подключение к PAN и подключиться по OBEX к смартфону. Основные изменения:

  • Переход к модульной структуре.
  • Добавлен плагин для PulseAudio.
  • Множество багфиксов.
Лицензия : GPLv3.

Репозитарий для Ubuntu

>>> Подробности

★★★★★

Проверено: hibou ()

Re: Вышел Blueman 1.10

GTK+... Не нужно :(.

Obey-Kun ★★★★★ ()
Ответ на: Re: Вышел Blueman 1.10 от Obey-Kun

Re: Вышел Blueman 1.10

>GTK+... Не нужно :(.

А что тогда ? Мега стабильный qt4.5 ?

Главное что Blueman нужно - усердно юзаю в гене.

unrealix ()

Re: Вышел Blueman 1.10

Когда его уже в офф.репозитории начнут включать? Очень дружелюбная мулька.

OperaSoftware ()

Re: Вышел Blueman 1.10

а как насчёт поднять DUN/PAN сервер? тоже может?

scaldov ★★ ()
Ответ на: Re: Вышел Blueman 1.10 от OperaSoftware

Re: Вышел Blueman 1.10

Новость оформлена, кстати, очень швах. Стоило добавить пару строк про переработанный интерфейс и еще много чего, т.к про 1.0.1 новостей тут не было, а ведь главное что оно под блюз4 сделано.

OperaSoftware ()

Re: Вышел Blueman 1.10

настрайки

ZogG ()
Ответ на: Re: Вышел Blueman 1.10 от OperaSoftware

Re: Вышел Blueman 1.10

>главное что оно под блюз4 сделано.

именно поэтому я не могу собрать pulseaudio с USE="bluetooth" - bluez4 и bluez3 жутко конфликтуют. Пульсятники сказали что четвероблюез не стабилен и закинули его в биореактор, хотя у меня bluez4 не разу не падал. Ах да, ещё и totem с USE="bluetooth" не собирается по тем же причинам

unrealix ()

Re: Вышел Blueman 1.10

Классная вещь, еще вчера перешел. Пока что две убийственные фичи ­-- возможность отключить адаптер через меню (ну не нравится мне, когда он мигает) и возможность назначить команду на кнопку гарнитуры. Интеграция с пульсом, опять же, большой плюс. Наконец-то гарнитура работает именно так, как мне нужно.

Erik_der_Zweite ()

Re: Вышел Blueman 1.10

Файлы передавать умеет? Гномовские библиотеки не тянет?

В принципе, это всё, что мне требуется. Надо будет попробовать эту программулину.

Flaming ★★ ()
Ответ на: Re: Вышел Blueman 1.10 от unrealix

Re: Вышел Blueman 1.10

>именно поэтому я не могу собрать pulseaudio с USE="bluetooth" - bluez4 и bluez3 жутко конфликтуют. Пульсятники сказали что четвероблюез не стабилен и закинули его в биореактор, хотя у меня bluez4 не разу не падал. Ах да, ещё и totem с USE="bluetooth" не собирается по тем же причинам

Я на них забил и отредактировал ебилды. Пульсятники, кстати, для нормальной интеграции bluez4 требуют.

Erik_der_Zweite ()

Re: Вышел Blueman 1.10

>Файлы передавать умеет? Гномовские библиотеки не тянет? Умеет, с флагом -gnome даже gconf не требует.

Erik_der_Zweite ()
Ответ на: Re: Вышел Blueman 1.10 от scaldov

Re: Вышел Blueman 1.10

> а как насчёт поднять DUN/PAN сервер? тоже может?

может

MJS ()
Ответ на: Re: Вышел Blueman 1.10 от MJS

Re: Вышел Blueman 1.10

>> а как насчёт поднять DUN/PAN сервер? тоже может?

>может

Так что у ГолубогоМужчины с потенцией всё нормально ибо он всё может.

unrealix ()

Re: Вышел Blueman 1.10

>плагин к PulseAudio

Значит ли это что можно использовать гарнитуру как аудиоустройство?

DNA_Seq ★★☆☆☆ ()

Re: Вышел Blueman 1.10

Сорри за оффтоп, но может кто подскажет, как гарнитуру со скайпом подружить?
$ cat ~/.asoundrc
pcm.bluetoothraw {
type bluetooth
device 00:1A:45:BD:C3:59
profile "auto"
}
pcm.bluetooth {
type plug
slave {
pcm bluetoothraw
}
}
Звук есть в течении 2-х секунд и скайп виснет. Приэтом mplayer нормально выводит звук. Гарнитура Jabra bt8040, bluez 4.30, alsa 1.0.19

Delay ★★ ()
Ответ на: Re: Вышел Blueman 1.10 от Delay

Re: Вышел Blueman 1.10

Я настраивал через стандартный гномовский блютус менеджер, все работает. Ubuntu 9.04

JB ★★★★★ ()
Ответ на: Re: Вышел Blueman 1.10 от DNA_Seq

Re: Вышел Blueman 1.10

> Значит ли это что можно использовать гарнитуру как аудиоустройство?

и раньше можно было, но напрямую через alsa, а теперь кошерно через pulseaudio

JB ★★★★★ ()
Ответ на: Re: Вышел Blueman 1.10 от scaldov

Re: Вышел Blueman 1.10

> а как насчёт поднять DUN/PAN сервер? тоже может?

было бы странно если бы не мог, ибо для поднятия оного достаточно его включить в bluez через dbus, а для этого и гуй не нужен

r0mik ()
Ответ на: Re: Вышел Blueman 1.10 от r0mik

Re: Вышел Blueman 1.10

Хмм, надо попробовать.

Вообще, работа с Bluetooth еще не совсем гладкая. Вот, недавно, мучался, подключая BT Mouse Logitech V470 под Убунтой. Нашлась, подключилась, но после перезаргузки или саспенда не всегда находится.

hcq ()

Re: Вышел Blueman 1.10

А оно до сих пор сильно завязано на гном?

Unnamed_Hero ★★★ ()
Ответ на: Re: Вышел Blueman 1.10 от Unnamed_Hero

Re: Вышел Blueman 1.10

>А оно до сих пор сильно завязано на гном?
Того кого до пены из-рта волнует привязка софта к каким либо ДЕ не должно очень напугать делать те же самые действия без этого софта, просто в консоли, да.

anotheranonymous ()
Ответ на: Re: Вышел Blueman 1.10 от Unnamed_Hero

Re: Вышел Blueman 1.10

> А оно до сих пор сильно завязано на гном?

не особо вроде, а раньше вроде сильно было...
вот к примеру 1.02:

CDEPEND="dev-libs/glib:2
        >=x11-libs/gtk+-2.12:2
        x11-libs/startup-notification
        >=dev-lang/python-2.5
        dev-python/pygobject
        dev-python/dbus-python
        dev-python/notify-python
        dev-python/pygtk
        net-wireless/bluez"
DEPEND="${CDEPEND}
        nls? ( dev-util/intltool sys-devel/gettext )
        dev-util/pkgconfig
        >=dev-python/pyrex-0.9.8"
RDEPEND="${CDEPEND}
        >=app-mobilephone/obex-data-server-0.4.4
        gnome-extra/policykit-gnome
        x11-misc/notification-daemon
        gnome? ( dev-python/gconf-python )
        sys-apps/dbus
        network? ( || ( net-dns/dnsmasq =net-misc/dhcp-3* ) )"


нахрена тут этот policykit-gnome не ясно. Убрали бы его и было бы мне счастье, а так ну его пока в топку

r0mik ()
Ответ на: Re: Вышел Blueman 1.10 от anotheranonymous

Re: Вышел Blueman 1.10

а вообще согласен с "другим анонимусом" - ну его вообще в топку

r0mik ()
Ответ на: Re: Вышел Blueman 1.10 от r0mik

Re: Вышел Blueman 1.10

У меня оно под кедами так и не заработало. Это нормально?

proDOOMman ★★ ()
Ответ на: Re: Вышел Blueman 1.10 от JB

Re: Вышел Blueman 1.10

>и раньше можно было, но напрямую через alsa, а теперь кошерно через pulseaudio

Более того, в пульсе 0.9.15 уже этот модуль блюмановский не требуется, гарнитура как аудиоустройство через hal подхватывается. Но пока еще не все так стабильно, как хотелось бы.

Erik_der_Zweite ()
Ответ на: Re: Вышел Blueman 1.10 от OperaSoftware

Re: Вышел Blueman 1.10

> Новость оформлена, кстати, очень швах.

А видели бы вы исходную версию... :)

shahid ★★★★★ ()
Ответ на: Re: Вышел Blueman 1.10 от anotheranonymous

Re: Вышел Blueman 1.10

> Того кого до пены из-рта волнует привязка софта к каким либо ДЕ не должно очень напугать делать те же самые действия без этого софта, просто в консоли, да.

Мне тоже было плевать на это, пока не познакомился с сабжем. Всё вроде как замечательно, но при желании открыть по obex свой смартфон начинаются проблемы: наутиус ну никак не хочет работать в четвертых кедах, а при принудительном запуске последнего внезапно оказывается, что рабочий стол четвертых кед заменился на гномий, а телефон всё равно не открывается.

shahid ★★★★★ ()
Ответ на: Re: Вышел Blueman 1.10 от shahid

Re: Вышел Blueman 1.10

ну раз пошла такая пьянка ... не могу найти рабочий индикатор заряда батарей способной висеть в доке ... // wm fluxbox

pascal ★★ ()
Ответ на: Re: Вышел Blueman 1.10 от Obey-Kun

Re: Вышел Blueman 1.10

Я не отношусь к ненавистникам GTK, но хочется на личном рабочем столе иметь некое единообразие. Посему спрошу - нет ли чего аналогичного под KDE3 или просто под qt?

hobbit ★★★★★ ()
Ответ на: Re: Вышел Blueman 1.10 от pascal

Re: Вышел Blueman 1.10

> ну раз пошла такая пьянка ... не могу найти рабочий индикатор заряда батарей способной висеть в доке ... // wm fluxbox

попробуй http://bavardage.awardspace.com/noteo/

JB ★★★★★ ()
Ответ на: Re: Вышел Blueman 1.10 от anotheranonymous

Re: Вышел Blueman 1.10

не надо так язвить. Этот пакет мне интересен, мне удобнее работать через графическую оболочку. Но я не смог поставить его предыдущую версию, так как пришлось ставить очень много зависимостей из gnome. А я пользуюсь голым xfce, и поэтому не хочу тащить пол-гнома в систему. Всё очень просто.

Unnamed_Hero ★★★ ()

Разве чего-то из этого не умеет менеджер Bluetooth для Gnome?

eugrus ★★★ ()
Ответ на: Re: Вышел Blueman 1.10 от r0mik

Re: Вышел Blueman 1.10

Полиси кит там, вроде, для регулировки прав на устройтва bluetooth. немного геморройно, согласен.

Unnamed_Hero ★★★ ()
Ответ на: Re: Вышел Blueman 1.10 от hobbit

Re: Вышел Blueman 1.10

>Я не отношусь к ненавистникам GTK, но хочет

kdebluetooth?

prizident ★★★★★ ()

Re: Разве чего-то из этого не умеет менеджер Bluetooth для Gnome?

> давно из анабиоза?

ну я это чудо программистской мысли видал только в ушлёпобунте-8.10 и нихрена там ниче не понял как файло отправить или список сервисов уст-ва глянуть. Пришлось юзать консоль

r0mik ()
Ответ на: Re: Вышел Blueman 1.10 от Azef

Re: Вышел Blueman 1.10

> kdebluetooth?

Спасибо, попробую.

Просто когда-то был куплен адаптер с блюсолейлем под винду. В технологии я как-то успел разочароваться. А теперь при очередном перетряхивании мусора я нашёл этот девайс, и захотелось попробовать, как он с современным софтом дружит.

hobbit ★★★★★ ()

Re: Вышел Blueman 1.10

Либо у меня телефон кривой, либо в blueman в этой версии сломали DUP в Ubuntu intrepid.
При подключении пишет:
"CDMA or GSM not supported
The device Z6 Project Evolution does not appear to support GSM/CDMA.
This connection will not work."
Покопавшись выяснил, что он теперь проверяет capabilities в HAL у rfcomm устройства (чтобы понять тип - gsm или cdma). Но у меня hal не давал такой информации и он писал ошибку.

Вот небольшой workaround, возможно кому-нибудь пригодится:
Открывайте файл /usr/share/pyshared/blueman/main/HalManager.py и после строчки 81 (перед if capabilities == None...) пишете (с правильным отступом):
capabilities = ["GSM-07.07", "GSM-07.05"]

snizovtsev ★★★ ()
Ответ на: Re: Вышел Blueman 1.10 от snizovtsev

Re: Вышел Blueman 1.10

Немного оффтоп, но вопрос знатокам HAL:
Почему правило 00-force-rfcomm-gsm-modem.fdi (помещал в information, policy, preprobe) никак не влияет на blueman (который смотрит capability)? hal-find-by-capability работает нормально.
<?xml version="1.0" encoding="UTF-8"?> <!-- -*- xml -*- -->
<deviceinfo version="0.2">
<device>
<match key="info.product" string="Bluetooth RFCOMM">
<append key="info.capabilities" type="strlist">GSM-07.07</append>
<append key="info.capabilities" type="strlist">GSM-07.05</append>
</match>
</device>
</deviceinfo>

snizovtsev ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.