LINUX.ORG.RU

Загадочное поведение pppd в Slackware 13.1 при попытке соединиться с интернетом через мобильник


0

0

Итак, я поставил Slackware 13.1. Тут обошлось без особых эксцессов, потому что я ставил поверх предыдущей версии с форматированием раздела без сохранения данных.

Одна из первых задач — это, конечно же, соединение с интернетом.
А я соединяюсь через мобильный телефон с bluetooth.
Тут Патрик расщедрился и положил в новую Слаку Blueman.
Он успешно распознал мобильный телефон, спаривание прошло, даже предложил установить соединение DUN, причем каким-то образом создал /dev/rfcomm0, хотя вроде был запущен от обычного юзера. Правда, почему-то созданный канал работал только на одну попытку соединения, поэтому я сделал то же самое, но уже через /etc/bluetooth/rfcomm.conf и добавление строки rfcomm bind all в /etc/rc.d/rc.bluetooth (почему там её не было? В предыдущих слаках была).
Я уже обрадовался что Slackware 13.1 станет первым дистрибутивом, где соединение с интернетом через мобильник можно устанавливать целиком через GUI. Но не тут-то было.
pppd стал ругаться:
pppd[4312]: By default the remote system is required to authenticate itself
pppd[4312]: (because this system has a default route to the internet)
pppd[4312]: but I couldn't find any suitable secret (password) for it to use to do so.
pppd[4312]: (None of the available passwords would let it use an IP address.)
При этом route del default почему-то не помогло. Хотя вообще-то это неправильно — я бы хотел иметь возможность пользоваться интернетом через локалку тоже, когда комп к ней подключен.
Потом я довольно долго по всякому шаманил, пробуя добавлять в /etc/ppp/options noauth через kppp и напрямую...
Добился того что он стал ругаться на что-то вроде serial link is not 8-bit clean
Потом я пробовал скрипт pppsetup, который сломал настройки ppp, дальше я удалил /etc/ppp/options и предсказуемо получил ошибку, о том что этого файла нет... создание пустого файла не помогло, всё равно выдавалась та же ошибка
pppd: Can't open options file /etc/ppp/options: No such file or directory
Я попробовал удалить /etc/ppp и взять его от старой слаки, где интернет настроен, потом попробовал переустановить пакет ppp (upgradepkg --reinstall), потом перезагрузиться и _всё равно_ выдается та же ошибка...

Что это может быть?

★★★★★

Я конечно ещё раз проверю, есть на месте это файл или нет, но всё-таки...

Xenius ★★★★★ ()

Ни в одной версии слаки после 12.1 нормально соединение с интернетом через мобильник и Bluetooth не работает.
В 12.2 я не понял, в чем дело, нагугленные манипуляции с конфигом HAL не помогли
В 13.0 кривой hcid, решилось костылем, использованием одного bluetooth-пин когда для всех устройств, иначе он зависал. Но всё равно это не годится, потому остался на 12.1
В 13.1 то что я описал, с bluetooth всё нормально, не считая того что blueman не умеет сам генерировать пин-код и соединение rfcomm, которое он создает работает только на одну попытку коннекта, но зато какой-то косяк с pppd или kppp...

Придется сидеть на 12.1, ожидая 13.2?

Xenius ★★★★★ ()

Кстати, KDE4 в 13.1 уже достаточно годный, хотя по некоторым фичам, в частности, konsole и удобству настройки, до KDE3.5 всё ещё не дотягивает.

Xenius ★★★★★ ()

> but I couldn't find any suitable secret (password) for it to use to do so

Путаница с файлом паролей. Не тот порядок логина, пароля и звёздочек.

У меня вообще стойкое ощущение, что опции ppp/pppd/pptp очень сильно разнятся вплоть до полной несовместимости не только в linux/*BSD, но и в разных дистрибутивах линукса и даже в разных версиях одного дистра.

pppd: Can't open options file /etc/ppp/options: No such file or directory

Добавь туда одну строку «noipparam», пусть подавится :)

tx ()

>потом перезагрузиться и _всё равно_ выдается та же ошибка...

перезагрузиться и _всё равно_

и _всё равно_


Перезагрузись три раза подряд - б-г (не Патрик) любит троицу :)

pppsetup и больше ничего не надо

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

> pppsetup и больше ничего не надо
Не помогает. Да и вообще, я хочу чтоб kppp мигал в трее когда байты передаются, ибо платный трафик.

Xenius ★★★★★ ()
Ответ на: комментарий от Xenius

Если через kppp, то единственное, что надо прописать так это DNS в /etc/resolv.conf, ЕМНИП. Остальное естественно через kppp.

amorpher ★★★★★ ()
Ответ на: комментарий от amorpher

DNS дает провайдер.
В том и проблема, что в слаке 12.1 это работало. В 13.0 после фикса hcid тоже, а в 13.1 — нет

Xenius ★★★★★ ()

Проблема частично решена

root@darkstar:~# cat /etc/ppp/peers/myprov
/dev/rfcomm0
connect '/usr/sbin/chat -v «» ATZ OK AT+CGDCONT=1,\\«IP\\»,\\«myprov.apn\\» OK ATDT*99# CONNECT'
lock
noproxyarp
noipdefault
crtscts
defaultroute
#replacedefaultroute
usepeerdns
noauth
user username
root@darkstar:~# cat /etc/resolv.conf
search example.net
nameserver 8.8.8.8
nameserver 8.8.4.4
root@darkstar:~# pppd call myprov
Решение взято из совета про убунту, но только с опцией, которую закомментировал, выдавало:
pppd: In file /etc/ppp/peers/myprov: unrecognized option 'replacedefaultroute'

Проблемы остались:
* Нет индикатора в трее, показывающего, когда трафик идет, а когда нет
* Не получает DNS от провайдера
* Устанавливать и убивать соединение довольно неудобно, так как требуется логиниться под рутом
* Если остался defaultroute от локалки, маршрут не заменяется

Теперь осталось понять, почему же KPPP не может соединиться, хотя, казалось бы, лог обмена IP-командами правильный. Настройку делал на другой машине, тоже со слакой 13.1.

Xenius ★★★★★ ()
Ответ на: Проблема частично решена от Xenius

Re: Проблема частично решена

> #replacedefaultroute
В Слаке используется ванильный pppd, потому и нету опции. В убунте, видимо, он не дефолтный

Не получает DNS от провайдера

Может и получает, но пишет, видимо, в /etc/ppp/resolv.conf
Надо над этим файлом делать mv в скрипте ip-up
(не проверил)

Мигалка в трее всё-таки нужна, есть план попробовать kppp с опцией dryrun чтоб посмотреть, что всё-таки не так

Xenius ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.