LINUX.ORG.RU

Ubuntu прекращает формирование пакетов для 32-разрядной архитектуры x86

 , , ,


0

3

Спустя два года с момента прекращения формирования 32-разрядных установочных образов для архитектуры x86 разработчики Ubuntu приняли решение о полном завершении жизненного цикла данной архитектуры в дистрибутиве. Начиная с осеннего выпуска Ubuntu 19.10 пакеты в репозитории для архитектуры i386 больше формироваться не будут.

Последней LTS-веткой для пользователей 32-разрядных систем x86 станет Ubuntu 18.04, поддержка которой продлится до апреля 2023 года (по платной подписке до 2028 года). Все официальные редакции проекта (Xubuntu, Kubuntu, Lubuntu и т.п.), а также производные дистрибутивы (Linux Mint, Pop_OS, Zorin и т.п.) будут лишены возможности поставки версий для 32-разрядной архитектуры x86, так как собираются из общей пакетной базы c Ubuntu (большинство редакций уже прекратили поставку установочных образов для i386).

Для обеспечения запуска существующих 32-разрядных приложений, которые невозможно пересобрать для 64-разрядных систем (например, многие игры в Steam остаются только в 32-разрядных сборках), в окружении Ubuntu 19.10 и более новых выпусках предлагается использовать отдельное окружение с Ubuntu 18.04, установленное в контейнере или chroot, или упаковать приложение в snap-пакет с runtime библиотеками core18 на базе Ubuntu 18.04.

В качестве причины прекращения поддержки архитектуры i386 упоминается невозможность сопровождения пакетов на уровне других поддерживаемых в Ubuntu архитектур из-за недостаточного уровня поддержки в ядре Linux, инструментарии и браузерах. В частности, последние наработки в области повышения безопасности и средства защиты от фундаментальных уязвимостей больше не разрабатываются своевременно для 32-разрядных систем x86 и становятся доступны только для 64-разрядной архитектуры.

Кроме того, поддержание пакетной базы для i386 требует больших ресурсов на разработку и контроль качества, которые не оправдывают себя из-за незначительной пользовательской базы, продолжающей применять устаревшее оборудование. Число систем i386 оценивается в 1% от общего числа установленных систем. Большинство ПК и ноутбуков с процессорами Intel и AMD, выпущенные за последние 10 лет, без проблем могут быть переведены на использование 64-разрядного режима. Оборудование, которое не поддерживает 64-разрядный режим, уже настолько устарело, что не обладает необходимыми вычислительными ресурсам для выполнения последних выпусков Ubuntu Desktop.

>>> Подробности

anonymous

Проверено: Shaman007 ()

Для обеспечения запуска существующих 32-разрядных приложений, которые невозможно пересобрать для 64-разрядных систем (например, многие игры в Steam остаются только в 32-разрядных сборках), в окружении Ubuntu 19.10 и более новых выпусках предлагается использовать отдельное окружение с Ubuntu 18.04, установленное в контейнере или chroot, или упаковать приложение в snap-пакет с runtime библиотеками core18 на базе Ubuntu 18.04.

Ну, туда им и дорога с такими предложениями.

aplay ★★★★ ()

Для обеспечения запуска существующих 32-разрядных приложений, которые невозможно пересобрать для 64-разрядных систем (например, многие игры в Steam остаются только в 32-разрядных сборках), в окружении Ubuntu 19.10 и более новых выпусках предлагается использовать отдельное окружение с Ubuntu 18.04, установленное в контейнере или chroot, или упаковать приложение в snap-пакет с runtime библиотеками core18 на базе Ubuntu 18.04.

А multilib уже сломали в ubuntu?

mandala ★★★★ ()
Ответ на: комментарий от aplay

Да вообще какая-то бредятина. Я не про прекращение формирования 32-х разрядных, а вот про это предложение. Чё не виртуалку сразу предложили с пробросом?

mandala ★★★★ ()
Ответ на: комментарий от mandala

Просто Ubuntu впереди поланеты всей, как обычно. Пока все прекращают поставку образов i386 системы, Каноникал решает прекратить поставку всех i386 пакетов.

aplay ★★★★ ()
Ответ на: комментарий от aplay

Каноникал решает прекратить поставку всех i386 пакетов

:D

А Стим уже нельзя ставить не из офф. репов (я правда хз)? Странный пример тогда.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)

Последней LTS-веткой для пользователей 32-разрядных систем x86 станет Ubuntu 18.04, поддержка которой продлится до апреля 2023 года (по платной подписке до 2028 года)

Это очень врядли будет касаться 32-битной архитекрутры.

fornlr ★★★★★ ()
Ответ на: комментарий от mandala

Сделают какой-нибудь лютый snap гигов на 10 со стимом внутри.

aplay ★★★★ ()
Ответ на: комментарий от aplay

Кстати сказать, это будет очень полезный snap — благодаря нему можно будет его легко ставить на дистрах, отличных от Ubuntu.

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от mandala

Ну мультилиб дебиана основан на том, что ты ставишь пакеты точно те же самые пакеты, что и от i386 дистрибутива. Если сравнить, то в Арче, например, вообще невозможно установить i386 пакет в систему, а вместо 32-битные библиотеки имеют префикс lib32 в названии.

Так что прекращение поддержки i386 равноценно прекращению поддержки мультилиба в Ubuntu.

a1batross ★★★★★ ()
Ответ на: комментарий от mandala

Стим можно поставить, и он притащит некоторые библиотеки с собой.

Но он не притащит, например, 32битный glibc и не притащит 32битные билды mesa или аналогичного куска для nvidia дров. И другой 32 битный софт тоже этого не сделает.

Для этого нужен multilib, который они делать не будут. Их решение - LXD контейнер, либо VM, или (как я понял из старой почтовой рассылки) снапы

Midael ★★★★★ ()
Последнее исправление: Midael (всего исправлений: 1)

Зная цену обещаний Canonical, дропнут они i386 ПОСЛЕ ТОГО, как дропнут все остальные. И уж точно не в 19.10, а позже, где-нибудь к 23.04. :)

Я конечно имею ввиду мультилиб. Сама по себе система в i386 не нужна.

a1batross ★★★★★ ()

inb4 какой-нибудь Red Hat делает то же самое, и все начинают говорить «правильно, давно нас надо было»

Midael ★★★★★ ()

Вся новость состоит из оправданий и отмазок.

unfo ★★★★★ ()

Что-то они там упоролись. Кому нужна убунта, где для стима надо строить свой велосипед и оборачивать его костылями?
Интересно, кстати, что теперь будет со SteamOS.

dogbert ★★★★★ ()

так много слов в оправдание, вместо всего двух «ради экономии»

powerguy ★★ ()

Ну и пусть. Не велика потеря. Есть же божественный Дебиан. А так, будет еще один повод всем говорить, что Ubuntu никому ненужный паразитариум.🍝

Odalist ★★★★★ ()
Ответ на: комментарий от dogbert

Ничего не будет, он же на дебиане основан.

По поводу темы: ко многим играх в зависимостях требуются 32-битные библиотеки, видимо steam runtime просто ещё чуть разбухнет.

energetix_user ()
Последнее исправление: energetix_user (всего исправлений: 1)

А как же wine? Там нужна i386 версия системы т.к 90% программ x86.

Skullnet ★★ ()
Ответ на: комментарий от dogbert

Кому нужна убунта, где для стима

Это ты типа приписал всем (или большинству) пользователям Ubuntu использование Steam? Лихо 🤣

fornlr ★★★★★ ()

стим, стим, стим

Труелинуксоиды будут ставить SteamOS дуалбутом 😉

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)

Какое же бредовое решение, учитывая, что перестанет работать 32-битный проприетарный софт, а также: Steam, игры с GOG, 32-битные приложения в Wine.

Кроме того, поддержание пакетной базы для i386 требует больших ресурсов на разработку и контроль качества

Большую часть репозитория можно удалить, но уж базовые multilib пакеты (glibc, видеодрайвера, gnutls, openal и прочие такие) почему бы не оставить? Их не так уж много.

Для обеспечения запуска существующих 32-разрядных приложений, которые невозможно пересобрать для 64-разрядных систем, в окружении Ubuntu 19.10 и более новых выпусках предлагается использовать отдельное окружение с Ubuntu 18.04, установленное в контейнере или chroot

Это вообще эпическое предложение. Так и вижу, как новичок, поставивший *buntu, настраивает отдельный контейнер для 32-битных приложений.

Kron4ek ★★★ ()
Последнее исправление: Kron4ek (всего исправлений: 1)
Ответ на: комментарий от dogbert

SteamOS на Debian 10. Дебианшики очень неохотно выбрасывают легаси и так, а уж если оно нужно их спонсорам...

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

на Debian 10.

В рассылке Дебиана, это уже обсуждается (я про поддержку 32-разрядной архитектуры x86 ). Оно будет поддерживаться как минимум и после выпуска Debian Bookworm😄

Odalist ★★★★★ ()

Большинство ПК и ноутбуков с процессорами Intel и AMD, выпущенные за последние 10 лет, без проблем могут быть переведены на использование 64-разрядного режима.

Они перед переводом без проблем понимают наличие amd64 в процессоре? Если так, охотно верю. Вот только для пристойной работы на 64 битах надо бы ещё хотя бы 4 гига ОЗУ, а здесь картина не столь радужная, если посмотреть на 6-7-летние системы.

hobbit ★★★★★ ()
Ответ на: комментарий от mandala

А multilib уже сломали в ubuntu?

Так не будет же мультилиба, потому что пакетов 32-битных не будет.

turtle_bazon ★★★★ ()

Начиная с осеннего выпуска Ubuntu 19.10 пакеты в репозитории для архитектуры i386 больше формироваться не будут.

Вот пользователи стима-то обрадуются... И 32-битного Wine - тоже.

DawnCaster ()
Последнее исправление: DawnCaster (всего исправлений: 1)

предлагается использовать отдельное окружение с Ubuntu 18.04, установленное в контейнере или chroot

А домашние и начинающие пользователи, для которых вроде как и позиционируется этот дистр, смогут такое сделать ?

DawnCaster ()
Ответ на: комментарий от Skullnet

Все игры года так с 2014 - 64бит онли.

anonymous ()
Ответ на: комментарий от hobbit

Для пристойной работы на чём угодно нужно восемь гиг озу, а четыре - это ловля проблем на своё седалище.

anonymous ()
Ответ на: комментарий от hobbit

6-7-летние системы

Да ладно? Вот 10-ти летние поверю. Но такой мусор давно пора выкинуть, ибо стремно. 6-7 летние тоже под замену пора. Это просто плюшкинизм какой-то некрофильский такое старье поддерживать. У московских бомжей уже наверное телефоны мощнее, чем вот такое вот все.

DrRulez ()
Ответ на: комментарий от DrRulez

Ну, например, на каком-нибудь Core 2 Due вполне себе можно ещё комфортно работать. И оно как раз лучше на 32-х битах себя чувствует.

DawnCaster ()
Ответ на: комментарий от DawnCaster

Вот пользователи стима-то обрадуются...

Эти вообще - страдать должны :) А если серьезно, то реально что напрягает, так это проблемы с вайном. Хотя есть надежда, что такой пинок под зад заставит их шевелиться с 64бит. Потому как давно пора, а там и не чесались особо.

DrRulez ()
Ответ на: комментарий от DawnCaster

Кор2дуо поддерживает вплоть до 8гигов памяти.

лучше на 32-х битах

Тормоза из-за отсутствия в коде новых инструкций и тд это такое себе «лучше».

anonymous ()
Ответ на: комментарий от DawnCaster

Ну, например, на каком-нибудь Core 2 Due вполне себе можно ещё комфортно работать.

В чем? Если использовать как терминал - то да, можно. Но проблема в надежности такой системы, даже как терминала. 7 лет, Карл! Что там сбойнет - фиг знает. Чинить это - уже себе дороже, это даже рабочее время не окупает.

DrRulez ()
Ответ на: комментарий от DawnCaster

Core 2 Due. И оно как раз лучше на 32-х битах себя чувствует.

Это ложь

anonymous ()
Ответ на: комментарий от hobbit

от только для пристойной работы на 64 битах надо бы ещё хотя бы 4 гига ОЗУ

2 ГБ ОЗУ достаточно, с ними уже одинаково плохо будет на 32 и 64 битах. Вот меньше уже да... Ну это уже совсем для «бомжей» как выше написали.

anonymous ()
Ответ на: комментарий от DrRulez

Эти вообще - страдать должны :)

Говорите за себя ) Я, например, являясь вполне себе опытным линуксоидом с опытом лет так 20 - очень даже играю в стиме, иногда. В основном, конечно, в разную индюшатину (остальное под линукс портируют редко), но, всё-таки, играю. И никто эти игры портировать на x64 не будет никогда.

С вайном тоже проблема. У меня приличное количество старого корпоративного софта, который требуется по работе и работает только на 32 битах. Его то уж точно никто не портирует.

Хотя есть надежда, что такой пинок под зад заставит их шевелиться с 64бит.

Заставит шевелиться кого ? Разработчиков вайна ? Им теперь придётся ещё делать какой-нибудь эмулятор для 32 бит, или что ?

Разработчиков стима ? Ну, они-то может и переведут свой клиент на 64 бита (давно уже ведут к этому), но разрабы игр даже не пошевелятся, пока поддержку 32-битных приложений не удалят из венды.

Да и даже в таком случае - на половину игр просто забьют. А другую половину попытаются впарить нам еще раз как «ремастер».

Или вы про разработчиков старого, но всё ещё нужного лигейси софта ? Ну дык, они-то точно ничего делать не будут.

DawnCaster ()
Последнее исправление: DawnCaster (всего исправлений: 1)
Ответ на: комментарий от DrRulez

Если использовать как терминал - то да

Как десктоп. Для разработки. Не всякой, конечно, но можно. В отличии от венды, линукс на нём просто летает.

Но проблема в надежности такой системы

Всё работает как часы. Всё что приходится чинить - это стандартные заменяемые компоненты. Которые точно также ломаются на современном железе и полностью совместимы со старым. И цена этих компонентов не зависит от поколения железа - они только постоянно дороже становятся из-за нашей «стабильности».

А процессор и память проработают ещё столько-же сколько уже отработали...

DawnCaster ()
Ответ на: комментарий от anonymous

и там много таких, которые кому-то нужны?

А вообще — не все с 2014 64бит онли, встречаются еще 32-битные (с 2018), как под винду, так и под линукс

anonymous ()
Ответ на: комментарий от anonymous

Ага. Аргументируйте, в каком месте там на 4 гигах ОЗУ, 64 бита - это лучше.

DawnCaster ()
Ответ на: комментарий от DrRulez

7 лет, Карл! Что там сбойнет - фиг знает

если это интел (а не гребаные старые амд, которые приходится скальпировать), материнки не на проблемных чипсетах и своевременно менять винты, то и 20 лет работает. железо времен кор2дуо вообще проблем не приносит.

tcler ()

как же теперь циннабоны и прочие ментосы будут существовать, бедные?)

darkenshvein ★★★★★ ()
Ответ на: комментарий от DawnCaster

Заставит шевелиться кого ? Разработчиков вайна ? Им теперь придётся ещё делать какой-нибудь эмулятор для 32 бит, или что ?

Да хотяб codeweavers, потому как сначала там, а уже потом для всех забесплатно. Таки их бизнес. И как раз и говорю, что это проблема, потому как у самого есть пара 32=бит приложений из-за которых и держится вайн. Не говоря уже про мс-офис, адекватной замены которому, как бы не вопили сторонник либры -нет.

но разрабы игр даже не пошевелятся, пока поддержку 32-битных приложений не удалят из венды.

Вот честно. Мое мнение, понятно, на тему игр такое себе, но как по мне, так хочешь нормально играть, или винду поставь в дуалбут, или консоль купи. Не хочешь за нее платить - поставь insider сборку из slow или RC канала и не плати совершенно официально.

DrRulez ()
Ответ на: комментарий от DawnCaster

Ага. Аргументируйте, в каком месте там на 4 гигах ОЗУ, 64 бита - это лучше.

Потому как адресация.

DrRulez ()
Ответ на: комментарий от DawnCaster

Все наборы инструкций включая SSE2 во всём коде по-умолчанию.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.