LINUX.ORG.RU

Firefox 52

 , ,


2

5

Доступен выпуск Firefox 52.

Основные изменения:

  • Удалена поддержка NPAPI-плагинов (Silverlight, Java, Unity, Gnome Shell Integration, Google Hangouts). Исключение сделано лишь для Flash. Поддержка плагинов сохранена (но отключена по умолчанию, для включения необходимо воспользоваться настройкой plugin.load_flash_only = false) в Firefox 52 ESR, который будет получать обновления безопасности до марта 2018 года. Кроме того, Firefox 52 и 52 ESR станут последними выпусками, поддерживающими процессоры без SSE2 (Pentium 3, Athlon XP, VIA C3), операционные системы Windows XP/Vista и 32-разрядные версии Mac OS X. Пользователи этих операционных систем будут автоматически пересажены на ESR-выпуск, чтобы не остаться без обновлений безопасности.
  • Если на http-странице содержится форма ввода пароля, то предупреждение о небезопасном вводе будет показано прямо возле соответствующего поля ввода, а автозаполнение будет отключено.
  • Добавлена возможность отправки открытой вкладки с одного устройства на другое через синхронизацию.
  • Улучшен интерфейс загрузок:
    • При неудаче выводится уведомление на панель инструментов.
    • Быстрый доступ к недавним загрузкам расширен с трёх до пяти элементов.
    • Увеличены кнопки отмены и перезапуска загрузки.
  • Реализована спецификация Strict Secure Cookies, запрещающая небезопасным (http:) сайтам установку кук с атрибутом «secure».
  • Включена поддержка чернового варианта спецификации TLS 1.3 (1310516).
  • Удалена поддержка Battery Status API (1313580). Предполагалось, что веб-приложения и сайты смогут при низком уровне заряда аккумулятора устройства отдавать облегчённую версию контента или экстренно сохранять данные. На практике этой возможностью пользуются лишь для отслеживания пользователей (уровень заряда служит одним из параметров, позволяющих точно идентифицировать клиента), а некоторые сервисы могут повышать расценки для пользователей, чей телефон вот-вот разрядится.
  • Движок обзавёлся поддержкой WebAssembly (эффективного низкоуровневого языка программирования, выполняющегося в браузере).
  • Совместный доступ к экрану теперь поддерживает предварительный просмотр и больше не требует присутствия домена в белом списке.
  • Прекращена поддержка SHA-1 сертификатов, выпущенных публичными удостоверяющими центрами. Кроме того, в Firefox 52 ESR отключена поддержка сервисных воркеров и пуш-уведомлений. Эти компоненты будут подвергнуты существенным изменениям, которые невозможно было бы портировать в ESR-выпуск, получающий лишь обновления безопасности.
  • Включено автоматическое обнаружение captive portal. При обнаружении сети, использующей эту технологию, браузер выдаст предупреждение и откроет страницу входа в новой вкладке.
  • Сервис отложенного чтения Pocket теперь полностью принадлежит корпорации Mozilla.
  • На платформе Windows улучшена совместимость со сторонними раскладками клавиатуры, не входящими в стандартную поставку Windows. Также, без объяснения причин удалена поддержка DRM-модуля Adobe Primetime CDM.
  • Устранены различные уязвимости.

Инструменты разработчика:

HTML:

  • Реализована поддержка rel="noopener" (1222516).

CSS:

  • Включена поддержка CSS Grid Layout.
  • Добавлен псевдокласс :focus-within (1176997).
  • Реализована поддержка display:flex/grid внутри элементов <button> (984869).
  • Реализована интерполяция между числовым значением цвета и currentcolor (1299741).
  • Реализована поддержка гибких блоков для justify-content: space-evenly, align-content: space-evenly (1235922) и для align|justify-self:baseline|last-baseline (1221524).
  • В CSS mask / clip-path добавлена поддержка субпиксельного сглаживания (1305259).
  • Реализована часть спецификации CSS Text 3 — Segment Break Transformation Rules (1081858).
  • Обрезка основных форм теперь может применяться к SVG-содержимому (1246741).
  • CSS Animations можно использовать для анимации неинтерполируемых свойств (1064937).
  • Мультиколоночные свойства избавлены от префиксов (1300895).
  • Реализована часть спецификации CSS Grid Layout Module Level 1 - Grid Container Baselines (1151204).
  • Из системы стилей удалена поддержка min-sizing у <flex> (1305244).
  • Начальные значения mask-position и mask-repeat изменены на 0% 0% (1308963).
  • Удалена поддержка медиатипов -moz-images-in-menus и -moz-images-in-buttons (1302157).
  • Удалена поддержка значения -moz-use-text-color. Вместо него следует использовать currentcolor (1306214).
  • Ряд изменений, связанных со значениями <color> (1295456):
    • rgba() и hsla() переопределены как ссылки на rgb() и hsl().
    • rgb() и hsl() принимают необязательное значение прозрачности.
    • функции цвета принимают параметры, разделённые пробелами вместо запятых.
    • значения прозрачности можно указывать не только в виде чисел, но и в процентах.
    • оттенок в hsl() можно указывать не только в виде числа, но и в градусах.

JavaScript:

DOM:

Сервисные воркеры и Fetch API:

  • Удалён метод Headers.getAll(); Headers.get() теперь получает все значения указанного заголовка, а не только первое (1278275).

Web Audio API:

  • Добавлен интерфейс ConstantSourceNode. Он представляет собой аудиоисточник, всегда передающий поток сэмплов, имеющих одинаковое значение. Статья с примерами того, как он может быть использован для упрощения сложных аудиопотоков.

WebRTC:

  • Теперь, если ICE-соединение временно повреждено, свойство RTCPeerConnection.iceConnectionState принимает значение «disconnected» (852665).
  • Добавлены обработчик событий MediaDevices.ondevicechange и событие devicechange.
  • Реализована поддержка свойства MediaStream.active, показывающего есть ли хоть один трек в воспроизводимом в данный момент потоке.
  • Метод MediaStreamTrack.stop() может останавливать воспроизведение не только лишь локальных треков.

Звук/видео:

  • Объекты MediaError, указанные в HTMLMediaElement.error при возникновении ошибки в обработке элемента <audio> или <video>, отныне включают свойство message, которое даёт конкретное описание случившейся ошибки.

Другие API:

HTTP:

SVG:

  • SVG документы теперь представлены не с помощью интерфейса SVGDocument, а с помощью XMLDocument, как того требует спецификация SVG 2.

>>> Примечания к выпуску для разработчиков

>>> Подробности

Ответ на: комментарий от i-rinat

PPAPI. Лол, нет. Если надо — делай сам. Они просто подождут, пока основные сайты перестанут использовать Flash и выбросят поддержу плагинов насовсем.

Не уверен. Вполне возможно, что на помойку выкинут pdf.js в пользу PDFium, а он на PPAPI

Widevine Content Decryption Module тоже PPAPI образную версию имеет.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от fornlr

Вполне возможно, что на помойку выкинут pdf.js в пользу PDFium, а он на PPAPI

На самом деле™, есть три «но». 1) PDFium не обязательно на PPAPI. Его можно и как NPAPI прикрутить, можно и каким-нибудь другим API на выбор. PPAPI сделали в Chromium, потому что им так удобнее. 2) Если выберут реализацию через PPAPI, достаточно реализовать достаточно маленькую часть, которая будет работать только с libpdf. 3) Планы были к концу 2016-го уже выкатить полурабочую версию, в которой уже можно смотреть pdf-ки, но нельзя в них искать, заполнять формы и отправлять на принтер. Но новостей нет с октября 2016, а уже март 2017. Проект снова заглох.

Widevine Content Decryption Module тоже PPAPI образную версию имеет.

Нет. PPAPI для него не нужен совсем.

i-rinat ★★★★★ ()

Также, без объяснения причин удалена поддержка DRM-модуля Adobe Primetime CDM.

Это тот, который запилили в одной из прошлых серий не так давно?

MuZHiK-2 ★★★★ ()
Ответ на: комментарий от te111011010

А Крипто-Про ЭЦП?

Любых, кроме Flash. Флеш закопают тоже, но когда-нибудь потом.

MozillaFirefox ★★ ()
Ответ на: комментарий от alozovskoy

Это в случае type=«password» или как оно будет определять?

Да, именно так.

MozillaFirefox ★★ ()
Последнее исправление: MozillaFirefox (всего исправлений: 1)
Ответ на: комментарий от kirill_rrr

Мне пока интересней, как его выключить.

Можно попробовать javascript.options.wasm = false

MozillaFirefox ★★ ()
Последнее исправление: MozillaFirefox (всего исправлений: 1)
Ответ на: комментарий от MozillaFirefox

Спасибо, пригодилось.
Зачем мне в браузере хрень, которую нельзя дебажить или даже посмотреть сорсы.

wxw ★★★★★ ()

Сижу на 45.7.0 ESR. Доволен как слон.

Odalist ★★★★★ ()
Ответ на: комментарий от wxw

Чёрт, а об этом я даже не подумал. Так это теперь надо создать отдельный сигнатурный антивирус под браузеры?

kirill_rrr ★★★★★ ()
Ответ на: комментарий от kirill_rrr

Антивирусы хорошо работают только для одного. И это совсем не отлов вирусов.
webassembly - дополнительная потенциальная дырень. К java-апплетам и flash пользователей научили относиться с подозрением, а webassembly подключается скрытно и методов контроля нет.

wxw ★★★★★ ()
Ответ на: комментарий от alozovskoy

Ну ёлки-иголки, опять flash не закопали.

Ну пусть сначала сделают аппаратное декодирование видео на ютубе хотя бы на интеловских встройках, а потом закапывают что хотят. Пока на ноуте ради этого флеш и держу.

dogbert ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

я где-то прочитала, что он теперь поддерживает jack. хотя бы это уже хорошо, если это так.

Iron_Bug ★★ ()
Последнее исправление: Iron_Bug (всего исправлений: 1)
Ответ на: комментарий от wxw

А есть ещё какой то способ проверки и контроля почти машинного и почти нативного кода? Сертификаты и цифровые подписи особо не работают, а в вебе вообще никак не работают.

kirill_rrr ★★★★★ ()
Ответ на: комментарий от Odalist

такая же фигня. пока не спешу переходить на непонятные обновления. там в безопасности дыр до чёрта. пусть годик это дело поварится, все баги соберут, потом будем посмотреть.

Iron_Bug ★★ ()
Ответ на: комментарий от alozovskoy

В данном случае - хорошо. Это же безопасность. Да и HTTP/2, только с https работает.

th3m3 ★★★★★ ()
Ответ на: комментарий от LynxChaus

Нужно просто использовать нормальное железо.

th3m3 ★★★★★ ()

А жрать ресурсы он когда перестанет? Я уже где-то спрашивал, но так и не выяснил: что это за новомодная фича в новых версиях - параллельно существует процесс Web Content, который жрёт немерено.

ZERG ★★★ ()
Ответ на: комментарий от ZERG

С новыми версиями FF, через минут 5-10 вся система виснет полностью, (вся) только ребут, перешел на мало мне нравившийся опера. У Firefox с потребой это не лечится, никогда не смотрела в эту сторону. Безопасность ? как было многим пол года назад из новости известно как у нее с безопасностью обстоят дела, досих пор судится со спецслужбами США что бы те открыли ее её дурку.

maldik ()

Отвалилась локализация. При запуске через apulse занимает звуковуху. Прогресс, чё.

macrohard ()

Мля, когда оно уже по дефолту будет 64-битное? Любая васяносборка от Seamonkey до Palemoon собрана под x86-64 с поддержкой инструкций современных процессоров, а ванильный фокс всё тормозит с этим. Делали бы отдельно рядом сборку 32 бита для всех блатных и нищих, а основную 64бита. Не понимаю.

yu-boot ()

Не понял, видеозвонки в google hangouts перестанут работать после обновления? silverlight/java в принципе и не жалко, в общем.

BattleCoder ★★★★★ ()
Ответ на: комментарий от yu-boot

Ориентировочно намечено на конец 2017 года:

  • предлагать по умолчанию 64-разрядную сборку
  • автоматически перевести пользователей 64-разрядных Windows, у которых установлен 32-разрядный браузер, на 64-разрядную сборку.
MozillaFirefox ★★ ()
Ответ на: комментарий от BattleCoder

Да голосовые и видеовызовы перестанут работать, поскольку они реализованы через NPAPI-плагин. Текстовые сообщения от него не зависят, они продолжат работать.

Google уже работает над проблемой.

Пока можно отключить настройку plugin.load_flash_only (до 53 выпуска, где она перестанет действовать), либо перейти на ESR-выпуски, где настройка будет действовать ещё год.

MozillaFirefox ★★ ()
Ответ на: комментарий от MozillaFirefox

Не, мне всё-таки интересно решение от гугла. Хотя вообще я этим практически не пользуюсь - google hangouts больше с телефона, может, в будущем и понадобится.

А NPAPI заменили ведь в пользу чего-то другого, более современного и безопасного?

BattleCoder ★★★★★ ()
Ответ на: комментарий от dogbert

Уже года два смотрю ютуб без каких либо проблем на интеловых интеграшках с пентиумами и целеронами вместо ЦПУ в моих ноутах. Флеша нет нигде, смотрю в firefox (iceweasel), все работает.

alozovskoy ★★★★★ ()
Ответ на: комментарий от th3m3

Тот уровень безопасности, который необходимо обеспечить, очень сильно зависит от ценности информации, безопасность которой необходимо обеспечить. Не вижу смысла городить https на вебморде моего роутера или на общедоступной в интрасети страничке с отчетами по выполненным работам, доступ к которой (сети) есть только через персональные vpn'ы.

Опять же никто не запрещает гов^Wразработчикам всяких мутных сайтов помечать поле ввода пароля как простой текст и маскировать символы тем же js'ом. За то пользователь думает что раз браузер не ругнулся значит все ОК, можно расслабиться.

По-этому вот эта вот принудиловка мне очень сильно не нравится. Сюда же и выпиливание npapi.

alozovskoy ★★★★★ ()

Нестандартный метод ArrayBuffer.slice() объявлен устаревшим и выдаёт предупреждение при использовании (1316913).

А что они предлагают использовать взамен?

mittorn ★★★★★ ()

И как быть со всякими iLo, DRAC, SiteScope +еще уоракла формочки на жабе? Разрабы мазилы о них не знают, значит они не существуют?

prizident ★★★★★ ()

алсу выпилили

за что алсу выпилили, ну нафига, ухожу на хром

anonymous ()
Ответ на: комментарий от ZenitharChampion

Наконец-то сделали PPAPI

Нет, только планируют

bohm ★★★★★ ()

Не пойму, куда подевались значки в меню? Версия gtk3.

anonymous ()

Как сделать, чтобы открывая в фоне (по колесу мышки) на ютюбе вкладки с видео, это видео не начинало в фоне проигрываться, И опера, и хром так умеют.

Aprel ()
Ответ на: комментарий от bohm

Наконец-то сделали PPAPI

Нет, только планируют

А что, были новости на эту тему?

i-rinat ★★★★★ ()
Ответ на: комментарий от alozovskoy

Шифрования много не бывает. Чем больше, тем лучше. Даже если это просто сайт к студенческим работам. Нефиг провайдеру видеть, что ты там за страницы смотришь. Их это не касается. А то понаставили себе ещё всяких DPI.

th3m3 ★★★★★ ()

Скажите главное! Тормозить тормозила будет все так же?!

Scampada ()
Ответ на: комментарий от th3m3

Нефиг провайдеру видеть, что ты там за страницы смотришь

Как будто они урлов не видят,лол.

WereFox ★★ ()

При просмотре ютуба нет звука. Просит установить pulseaudio. Приехали. :(

Jarvis ()
Ответ на: комментарий от Scampada

Ну так с VPN они и страниц не видят, нафига там HTTPS?

WereFox ★★ ()
Ответ на: комментарий от i-rinat

были новости на эту тему?

Как минимум дважды, почитай хотя бы о ff52 на опеннете.

bohm ★★★★★ ()
Ответ на: комментарий от bohm

На опеннете ссылка на старый анонс, по которому с октября ни слуху, ни духу. По задуманному расписанию сейчасиуже должен быть функционирующий libpdf. Но его как-то не видать.

i-rinat ★★★★★ ()
Ответ на: комментарий от anonymous

Ох, дай бог тебе здоровья! Спасибо, дружище!!!

Aprel ()
Ответ на: комментарий от WereFox

При https, максимум только url сайта, но не странички.

th3m3 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.