LINUX.ORG.RU

LXDE переносят на Qt, планируется совместимость с Wayland

 , , ,


2

2

В блоге LXDE появился отчет о работе по переносу компонент LXDE на Qt. Скриншот демонстрирует почти полное окружение, в том числе файловый менеджер PCManFM-Qt и панель lxpanel-qt. Автор сообщает, что потребление памяти несколько повышено по сравнению с версией на Gtk+2, но с Gtk+3 ситуация не лучше. Пока что разработка идет с использованием Qt4, переход на Qt5 планируется после выхода версии 5.1. Для полной совместимости с Wayland необходимо решить проблемы с зависимостью спецификаций freedesktop.org от X11, но автор рассчитывает, что это сделают разработчики KDE и Gnome. Кроме того, уделяется внимание совместимости с Razor-Qt.

>>> Подробности

Первое апреля вроде ещё не скоро. Вы это серьёзно¿

anonymous ()
Ответ на: комментарий от onon

ШТО, простите? Или это такая ирония? Хотя, в голой винде действительно нет приложений на Qt. ну, да в голой винде их ввбще почти нет.

anonymous ()
Ответ на: комментарий от h4tr3d

напрямую нельзя использовать std::string, std::vector и прочтие std::list - только через адаптеры типа QString::fromStdString() или QVector::toStdVector(), что требует дополнительных ресурсов на копирование.

Копирование кучи разных списков — это и есть чрезмерная связанность логики и интерфейса. В таких случаях можно уже всё писать на Qt без STL.

quiet_readonly ★★★★ ()
Ответ на: комментарий от pihter

Как только переходишь на ДЕ - нечинает скатываться в СГ.

Так вот кто виноват. А ну, держите его, ребята!

anonymous ()

Жаль, очень жаль. LXDE была очень быстрой средой. Понятное дело, что на Qt она уже быстрой не будет. Возможно будет легковесной KDE но тормоза будут такие же как в KDE.

anonymous ()

цирк какой-то. такими темпами придётся рано или поздно переходить на винду, т.к. линукс будет по горло засран всякими systemd и вялеными с монструозными qt, при этом насущные проблемы как были, так и остаются.

anonymous ()
Ответ на: комментарий от anonymous

Понятное дело, что говоришь ты прямиком из задницы. Как там, кстати, не тесно?

anonymous ()
Ответ на: комментарий от anonymous

Да переходи, родной, кто ж тебя держит то.

anonymous ()

Ох не просто так geekless все связи с LXDE порвал...

И мне интересно, они свой дисплейный сервер напишут или принудят автора openbox к поддержке вяленда?

Quasar ★★★★★ ()
Ответ на: комментарий от RedNikifor

а чего бояться если убогий с ТЗ пользователей тулкит заменят на гораздо более юзабельный? ну вот взять хотя бы файловый диалог.

thunar ★★★★★ ()

Вместо того, чтобы устраивать очередной холивар, лучше подскажите как делать стили для Qt, а то стандартные меня абсолютно не устраивают. Вот для gtk есть целая куча разнообразных стилей на любой вкус, от аскетично-минимальных вроде Mist до глянцево-гламурных Adwaita. А для стилей для Qt отдельно от KDE я не встречал.

lizard ★★ ()
Ответ на: комментарий от Reset

на самом деле, из действительно незаменяемых программ на GовноTK остался один гимп.

thunar ★★★★★ ()
Ответ на: комментарий от lizard

вот она разница. пользователям qt-софта нужно ехать, а пользователям gtk-софта нужны рюшечки.

thunar ★★★★★ ()
Ответ на: комментарий от shatsky

Кьютефобия?

Голый прагматизм. Код на С++ хрен сертифицируешь по НДВ выше 4 уровня.

Orlusha ★★★★ ()
Ответ на: комментарий от thunar

пользователям qt-софта нужно ехать

разработчикам qt-софта нужно ехать в пролёт мимо госов

Orlusha ★★★★ ()
Ответ на: комментарий от fragmentor

Очевидно, Вы не пишете софт под сертификацию.

Orlusha ★★★★ ()
Ответ на: комментарий от Orlusha

А на чём сертифицируешь? На BASIC или Java?

anonymous ()

оужс... Я потерял доверие к LXDE.

Amet13 ★★★★★ ()

Жаль geekless выпилился интересно было бы послушать о его планах насчет панельки.

J ★★★★ ()
Ответ на: комментарий от anonymous

А на чём сертифицируешь? На BASIC или Java?

На рагу из копчёно-варёных анонимусов.

Orlusha ★★★★ ()

А чего все печалятся то? Это же шикарно. Теперь возможно будет две рабочие ДЕ. Поставил недели две назад жене на ноут ХФСЕ, так оно тормознуло этот ноут так, как кедам даже не снилось. Теперь переносить обратно.

Однако, учитывая что они его даже на гтк до ума не довели...

LightDiver ★★★★★ ()
Ответ на: комментарий от Orlusha

Код на С++ хрен сертифицируешь по НДВ выше 4 уровня.

Подозреваю, что разрабов LXDE (и 99.99% аудитории ЛОР) это совершенно не волнует.

tailgunner ★★★★★ ()
Ответ на: комментарий от Orlusha

очевидно, что вы тоже. Софт на qt сертифицируют и еще как.

anonymous ()
Ответ на: комментарий от tailgunner

Подозреваю, что разрабов LXDE (и 99.99% аудитории ЛОР) это совершенно не волнует.

Увы, вынужден согласиться.

Orlusha ★★★★ ()
Ответ на: комментарий от anonymous

очевидно, что вы тоже.

После этой фразы очевидно, что Вы тоже. )))))

Софт на qt сертифицируют и еще как.

Известно как. По 4 уровню. Только в лёт. Как и 7-ю венду и вендософт. :devil:

С 3 уровнем это не прокатывает. Требования принципиально другие. Про 1-2 уровни уже не говорю.

Orlusha ★★★★ ()
Последнее исправление: Orlusha (всего исправлений: 2)

Qt как тулкит - хорош. А вот приложения на его основе страшны до ужаса. Надеюсь, LXDE не будет косить на KDE, а сохранит добрые традиции, и приличный(аскетичный) внешний вид.

lucentcode ★★★★★ ()
Последнее исправление: lucentcode (всего исправлений: 1)
Ответ на: комментарий от onon

в винде нет qt приложений.

Искаропки — странно было бы, если бы были.

А так, например, MuseScore есть.

Orlusha ★★★★ ()
Ответ на: комментарий от Orlusha

Почему так? И на чем должен быть код, чтобы можно было сертифицировать на более высоких уровнях?

BlackRaven86 ()
Ответ на: комментарий от Orlusha

После этой фразы очевидно, что Вы тоже. )))))

Разумеется нет, боже меня упаси. До недавнего времени я был по другую сторону этих проверок и знаю все это болото изнутри. Так что расскажи мне больше.

anonymous ()
Ответ на: комментарий от fragmentor

Не не вру. Поставил винду, ни одной программы на Qt нет. Честно. Идеал для тех кому не нравится этот набор библиотек.

onon ★★★ ()
Ответ на: комментарий от RedNikifor

это так важно, что рэдхетовцы уже рвут волосы на голове, чтобы найти способ и правдами и неправдами перетащить тебя на этот свой проклятый вэйланд.

ещё опасайся, что тебе systemd ночью втихоря пропихнут

anonymous ()

Жаль, пропал один из самых неприхотливых и удобных ДЕ. Нам его будет сильно не хватать.

AVL2 ★★★★★ ()

Объясните, почему львиная доля кутешных приложений так похожа на дельфи-поделки?

Shlyapa ★★ ()
Ответ на: комментарий от Shlyapa

потому что писали их бывшие делфи-адепты, которые считают, что умеют программировать. Очевидно же.

anonymous ()
Ответ на: комментарий от Shlyapa

Насколько я помню, отличительной особенностью Delphi-поделок является прибитый гвоздями UI. У Qt нет с проблем с резиновым интерфейсом.

pftBest ★★★★ ()
Ответ на: комментарий от pftBest

Я немного не про это. Просто у меня ощущение, что используемый тулкит у разработчика как будто режимы мозга переключает. Если КуТе - интерфейс на выходе получается винда-стайл, ГТК - закос под макось.

А в дельфи, насколько помню, какие-то средства придания интерфейсу резиновости все же были.

Shlyapa ★★ ()
Ответ на: комментарий от BlackRaven86

И на чем должен быть код, чтобы можно было сертифицировать на более высоких уровнях?

На языке, позволяющем «проследить поведение всех программных объектов, создаваемых при выполнении программы» (цитата из требования). Чистый С обычно проходит (если не увлекаться указателями на функции), интерпретируемые языки — нет. С++ — в зависимости от применяемого инструментария и стиля написания кода. Ассоциативные массивы вряд ли пройдут.

Orlusha ★★★★ ()
Ответ на: комментарий от anonymous

До недавнего времени я был по другую сторону этих проверок и знаю все это болото изнутри.

Аааа, так вы в атласе венду сертифицировали.

Так что расскажи мне больше.

Ну как, на квартирку с видом на кремль хватило?

Orlusha ★★★★ ()
Ответ на: комментарий от Orlusha

Чистый С обычно проходит (если не увлекаться указателями на функции), интерпретируемые языки — нет. С++ — в зависимости от применяемого инструментария и стиля написания кода. Ассоциативные массивы вряд ли пройдут.

Т.е. выше 4 уровня можно сертифицировать только микроконтроллеры.

tailgunner ★★★★★ ()

Значит LXDE фтопку. Жил он на ноуте более 2-х лет, но в эти выходные снесу к чертям.

anonymous ()
Ответ на: комментарий от tailgunner

Т.е. выше 4 уровня можно сертифицировать только микроконтроллеры.

Реально — немножко больше.

Orlusha ★★★★ ()
Ответ на: комментарий от Orlusha

А как же великая и ужасная МСВС, где половина софта на qt 4.6. И вся (!) эта требуха сертифицирована по 1/2.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.