<!DOCTYPE html>
<html lang=ru>
<head>
  <link href='https://fonts.googleapis.com/css?family=Open+Sans:600&amp;subset=latin,cyrillic' rel='stylesheet'
        type='text/css'>
  <link rel="stylesheet" type="text/css" href="/tango/combined.css?20170627-2112">

<link rel="yandex-tableau-widget" href="/manifest.json" />
<meta name="referrer" content="always">

<script type="text/javascript">
  /*!
  * $script.js Async loader & dependency manager
  * https://github.com/ded/script.js
  * (c) Dustin Diaz, Jacob Thornton 2011
  * License: MIT
  */
(function(e,d,f){typeof f.module!="undefined"&&f.module.exports?f.module.exports=d():typeof f.define!="undefined"&&f.define=="function"&&f.define.amd?define(e,d):f[e]=d()})("$script",function(){function y(f,e){for(var h=0,g=f.length;h<g;++h){if(!e(f[h])){return E}}return 1}function x(d,c){y(d,function(b){return !c(b)})}function w(p,k,h){function c(b){return b.call?b():K[b]}function q(){if(!--d){K[e]=1,f&&f();for(var b in I){y(b.split("|"),c)&&!x(I[b],c)&&(I[b]=[])}}}p=p[D]?p:[p];var g=k&&k.call,f=g?k:h,e=g?p.join(""):k,d=p.length;return setTimeout(function(){x(p,function(b){if(G[b]){return e&&(J[e]=1),G[b]==2&&q()}G[b]=1,e&&(J[e]=1),v(!L.test(b)&&H?H+b+".js":b,q)})},0),w}function v(h,g){var b=N.createElement("script"),a=E;b.onload=b.onerror=b[z]=function(){if(b[B]&&!/^c|loade/.test(b[B])||a){return}b.onload=b[z]=null,a=1,G[h]=2,g()},b.async=1,b.src=h,M.insertBefore(b,M.firstChild)}var N=document,M=N.getElementsByTagName("head")[0],L=/^https?:\/\//,K={},J={},I={},H,G={},F="string",E=!1,D="push",C="DOMContentLoaded",B="readyState",A="addEventListener",z="onreadystatechange";return !N[B]&&N[A]&&(N[A](C,function u(){N.removeEventListener(C,u,E),N[B]="complete"},E),N[B]="loading"),w.get=v,w.order=function(f,e,h){(function g(a){a=f.shift(),f.length?w(a,g):w(a,e,h)})()},w.path=function(b){H=b},w.ready=function(f,d,h){f=f[D]?f:[f];var g=[];return !x(f,function(b){K[b]||g[D](b)})&&y(f,function(b){return K[b]})?d():!function(b){I[b]=I[b]||[],I[b][D](d),h&&h(g)}(f.join("|")),w},w},this);</script>

<!--[if lt IE 9]>
  <script src="/webjars/html5shiv/3.7.2/html5shiv.min.js" type="text/javascript"></script>
<![endif]-->

<script type="text/javascript">
  $script('/webjars/jquery/1.12.3/jquery.min.js', 'jquery');

  $script.ready('jquery', function() {
    $script('/js/plugins.js?20170627-2112', 'plugins');
    $script('/js/lor.js?20170627-2112', 'lorjs');
  });

  $script('/js/highlight.pack.js', 'hljs', function() { hljs.initHighlightingOnLoad(); });
</script>
<title>Леннарт Поттеринг представил mkosi, инструмент для генерации образов ОС — Linux General — Новости</title>
<meta property="og:title" content="Леннарт Поттеринг представил mkosi, инструмент для генерации образов ОС" >

<meta property="og:image" content="https://www.linux.org.ru/img/good-penguin.png">
  <meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@wwwlinuxorgru">
<meta property="og:description" content="Следом за casync, Леннарт Поттеринг представил ещё один свой проект — mkosi (Make Operating System Image).    mkosi предназначен для генерации загрузочных образов операционных систем, представляющий собой обёртку над утилитами dnf --installroot, debo...">
<meta property="og:url" content="https://www.linux.org.ru/news/linux-general/13511594">

<link rel="canonical" href="https://www.linux.org.ru/news/linux-general/13511594">

<link rel="Previous" id="PrevLink" href="/news/games/13506589" title="Angband 4.1.0">
<link rel="alternate" title="Comments RSS" href="/news/linux-general/13511594?output=rss" type="application/rss+xml">
<script type="text/javascript">
  $script.ready('lorjs', function() { initNextPrevKeys(); });
  
    $script('/js/realtime.js', "realtime");
    $script.ready('realtime', function() {
        startRealtimeWS(13511594, "/news/linux-general/13511594", 13511817, "wss://www.linux.org.ru:9000/");
    });
  </script>
<link rel="search" title="Search L.O.R." href="/search.jsp">
<meta name="referrer" content="always">

<base href="https://www.linux.org.ru/">

<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon">
<meta name="viewport" content="initial-scale=1.0">
</head>
<body>
<div id="hd">
  <a id="sitetitle" href="/">LINUX.ORG.RU</a>

  <div class="menu">
    <div id="loginGreating">
      <div id="regmenu" class="head">
          <a href="https://www.linux.org.ru/register.jsp">Регистрация</a> -
          <a id="loginbutton" href="https://www.linux.org.ru/login.jsp">Вход</a>
        </div>

        <form method=POST action="https://www.linux.org.ru//ajax_login_process" style="display: none" id="regform">
          <input type="hidden" name="csrf" value="iqA2UKFJQNFj1plFLOIVMg==">
<label>Имя: <input type=text name=nick size=15 placeholder="nick или email" autocapitalize="off"></label>
          <label>Пароль: <input type=password name=passwd size=15></label>
          <input type=submit value="Вход">
          <input id="hide_loginbutton" type="button" value="Отмена">
        </form>
      </div>

    <ul>
      <li><a href="/news/">Новости</a></li>
      <li><a href="/gallery/">Галерея</a></li>

      <li><a href="/forum/">Форум</a></li>
      <li><a href="/tracker/">Трекер</a></li>
      <li><a href="/search.jsp">Поиск</a></li>
    </ul>
  </div>
</div>
<div style="clear: both"></div>
<div id="bd">
<div class=messages itemscope itemtype="http://schema.org/Article">

<article class=msg id="topic-13511594">
<header>
    <div class="msg-top-header">
    <span itemprop="articleSection">
      <a href="/news/">Новости</a> —
      <a href="/news/linux-general/">Linux General</a>
      </span>
      </span>
    </div>

    <h1 itemprop="headline">
      <a href="/news/linux-general/13511594">Леннарт Поттеринг представил mkosi, инструмент для генерации образов ОС</a>
      </h1>

    <p class="tags"><i class="icon-tag"></i>&nbsp;<a class=tag rel=tag href="/tag/%D0%BE%D0%B1%D1%80%D0%B0%D0%B7%D1%8B">образы</a>, <a class=tag rel=tag href="/tag/%D0%BF%D0%BE%D1%82%D1%82%D0%B5%D1%80%D0%B8%D0%BD%D0%B3">поттеринг</a></p></header>

  <div class="msg-container">

    <div class="fav-buttons">
        <a id="favs_button" href="#"><i class="icon-star"></i></a><br><span
              id="favs_count">0</span><br>
        <a id="memories_button" href="#"><i class="icon-eye"></i></a><br><span
              id="memories_count">1</span>
      </div>
    <div class="msg_body">
  <div itemprop="articleBody">
      <p>Следом за casync, Леннарт Поттеринг представил ещё один свой проект — mkosi (Make Operating System Image).<br><br>mkosi предназначен для генерации загрузочных образов операционных систем, представляющий собой обёртку над утилитами dnf --installroot, debootstrap, pacstrap и zypper.<br><br></p><div id="cut0"><p>Поддерживается создание образов на базе дистрибутивов Fedora, Debian, Ubuntu, Arch Linux, openSUSE. Созданный образ можно запустить из контейнера командой &#171;systemd-nspawn -b -i image.raw&#187;.<br><br>mkosi позиционируется как legacy-free, т. е. программа поддерживает только актуальные на сегодняшний день технологии. Это означает поддержку только таблиц разделов GPT (и отсутсвие поддержки MBR), возможность генерации образов, основанных только на systemd, и генерацию только для загрузки на системах с поддержкой EFI (не MBR/BIOS).<br><br>Проект написан на языке python, распространяется под лицензией LGPL-2.1.<br><br>Репозиторий на github — <a href="https://github.com/systemd/mkosi">https://github.com/systemd/mkosi</a>.</p></div><p>
          &gt;&gt;&gt; <a href="http://0pointer.net/blog/mkosi-a-tool-for-generating-os-images.html">Подробности</a></p>
      </div>
<footer>

<div class="userpic"><img class="photo" src="/photos/151512:1103990933.jpg" alt="" width=150 height=150 ></div><div class=sign >
  <a rel="author"itemprop="creator" href="/people/awesomelackware/profile">awesomelackware</a> <span class="stars"></span><br>
  <time datetime="2017-06-29T11:46:12.001+03:00" itemprop="dateCreated">29.06.2017 11:46:12</time><span class="sign_more">
  <br>Проверено: <a  href="/people/Shaman007/profile">Shaman007</a>
        (<time datetime="2017-06-29T12:09:07.016+03:00" itemprop="datePublished">29.06.2017 12:09:07</time>)
      </span>
</div>
</footer>

    <div class=reply>
          <div class="social-buttons">
            <a target="_blank" style="text-decoration: none"
               href="https://twitter.com/intent/tweet?text=%D0%9B%D0%B5%D0%BD%D0%BD%D0%B0%D1%80%D1%82+%D0%9F%D0%BE%D1%82%D1%82%D0%B5%D1%80%D0%B8%D0%BD%D0%B3+%D0%BF%D1%80%D0%B5%D0%B4%D1%81%D1%82%D0%B0%D0%B2%D0%B8%D0%BB+mkosi%2C+%D0%B8%D0%BD%D1%81%D1%82%D1%80%D1%83%D0%BC%D0%B5%D0%BD%D1%82+%D0%B4%D0%BB%D1%8F+%D0%B3%D0%B5%D0%BD%D0%B5%D1%80%D0%B0%D1%86%D0%B8%D0%B8+%D0%BE%D0%B1%D1%80%D0%B0%D0%B7%D0%BE%D0%B2+%D0%9E%D0%A1&amp;url=https%3A%2F%2Fwww.linux.org.ru%2Fnews%2Flinux-general%2F13511594&amp;hashtags=%D0%BB%D0%BE%D1%80">
              <img src="/img/twitter.png" width=16 height=16 alt="Share on Twitter" title="Share on Twitter">
            </a>
          </div>
          <ul id="topicMenu">
          <li><a href="comment-message.jsp?topic=13511594">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>
            <li><a href="/news/linux-general/13511594">Ссылка</a></li>
          </ul>
        </div>
      </div>
</div>
</article>

<script type="text/javascript">
  $script.ready('lorjs', function() {
    initStarPopovers();
  });
</script>
<div class="nav">
  <div class="grid-row">
    <div class="grid-3-1">
      <table>
        <tr valign=middle>
          <td style="padding-right: 5px">
              <a href="/news/games/13506589" rel=prev>←</a>
            </td>
            <td align=left valign=top class="hideon-phone">
              <a href="/news/games/13506589" rel=prev>
                Angband 4.1.0</a>
            </td>
          </tr>
      </table>
    </div>
    <div class="grid-3-2">
    </div>
    <div class="grid-3-3">
      </div>
  </div>
  </div><div class="comment" id="comments" style="padding-top: 0.5em">

<div style="text-align: center; margin-top: 0.5em; margin-bottom: 1em; height: 91px" id="interpage-adv">
  </div>
  <script type="text/javascript">
    $script.ready('lorjs', function () {
      var ads = [
        {
          type: 'img',
          src: '/adv/miran-e3.gif',
          href: 'https://miran.ru/services/dedicated/?utm_source=linux.org.ru&utm_medium=banner&utm_campaign=dedicated'
        }
      ];

      init_interpage_adv(ads);
    });
  </script>

<article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511652" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/img/p.gif" width="1" height="1"></div><div class="msg_body message-w-userpic"><blockquote><p>программа поддерживает только актуальные на сегодняшний день технологии<br></p></blockquote><blockquote><p>генерацию только для загрузки на системах с поддержкой EFI<br></p></blockquote><p>Выходит, что системы на C2D и подобные уже неактуальны? Кто-то зажрался.</p><div class="sign">anonymous <span class="stars"></span> (<time datetime="2017-06-29T12:07:26.679+03:00" itemprop="commentTime">29.06.2017 12:07:26</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511652">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511652">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511668" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="https://secure.gravatar.com/avatar/7e44e6ee5254fbed57ec9a227850bd2d?s=150&amp;r=g&amp;d=blank" width="150" height="150"></div><div class="msg_body message-w-userpic"><p>Уже начинаю бомбить</p><div class="sign"><a itemprop="creator" href="/people/mittorn/profile">mittorn</a> <span class="stars">★★★★★</span> (<time datetime="2017-06-29T12:12:17.223+03:00" itemprop="commentTime">29.06.2017 12:12:17</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511668">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511668">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511670" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/100226:1019313563.jpg" width="150" height="150"></div><div class="msg_body message-w-userpic"><p>Один файл на 2746 строк. Что с ним не так?</p><div class="sign"><a itemprop="creator" href="/people/Weres/profile">Weres</a> <span class="stars">★★★</span> (<time datetime="2017-06-29T12:12:25.210+03:00" itemprop="commentTime">29.06.2017 12:12:25</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511670">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511670">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511672" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/linux-general/13511594?cid=13511670">комментарий</a> от Weres <time datetime="2017-06-29T12:12:25.210+03:00" itemprop="false">29.06.2017 12:12:25</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="https://secure.gravatar.com/avatar/7e44e6ee5254fbed57ec9a227850bd2d?s=150&amp;r=g&amp;d=blank" width="150" height="150"></div><div class="msg_body message-w-userpic"><blockquote><p>mkosi позиционируется как legacy-free, т. е. программа поддерживает только актуальные на сегодняшний день технологии. Это означает поддержку только таблиц разделов GPT (и отсутсвие поддержки MBR), возможность генерации образов, основанных только на systemd, и генерацию только для загрузки на системах с поддержкой EFI (не MBR/BIOS).</p></blockquote><div class="sign"><a itemprop="creator" href="/people/mittorn/profile">mittorn</a> <span class="stars">★★★★★</span> (<time datetime="2017-06-29T12:13:22.926+03:00" itemprop="commentTime">29.06.2017 12:13:22</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511672">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511672">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511675" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/linux-general/13511594?cid=13511652">комментарий</a> от anonymous <time datetime="2017-06-29T12:07:26.679+03:00" itemprop="false">29.06.2017 12:07:26</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/151512:1103990933.jpg" width="150" height="150"></div><div class="msg_body message-w-userpic"><blockquote><p>only GPT disk labels (and no MBR disk labels) are supported, and only systemd based images may be generated. Moreover, for bootable images only EFI systems are supported (not plain MBR/BIOS).<br></p></blockquote><p>Может плохо ангельский знаю, но в оригинале вот так и написано.</p><div class="sign"><a itemprop="creator" href="/people/awesomelackware/profile">awesomelackware</a> <span class="stars"></span> (<time datetime="2017-06-29T12:13:59.909+03:00" itemprop="commentTime">29.06.2017 12:13:59</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511675">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511675">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511683" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/48269:-1031704999.jpg" width="101" height="150"></div><div class="msg_body message-w-userpic"><p>Нужность, конечно, сомнительна, но этот проект по крайней мере безобидный.</p><div class="code"><pre class="no-highlight"><code>if bytes &gt;= 1024*1024*1024:
    return &quot;{:0.1f}G&quot;.format(bytes / 1024**3)
</code></pre></div><blockquote><p> 1024*1024*1024<br></p></blockquote><blockquote><p> 1024**3<br></p></blockquote><p>Это специально, чтобы приостановиться секунд на 10 и подумать, почему написано один раз так, а другой так, мол раз так написали, значит зачем-то надо?</p><div class="code"><pre class="language-python"><code>return loopdev + &quot;p&quot; + str(partno)</code></pre></div><p>Расскажите ему про .format()</p><div class="code"><pre class="language-python"><code>def luks_format_home(args, loopdev, run_build_script, cached):

    if args.encrypt is None:
        return
    if args.home_partno is None:
        return
    if run_build_script:
        return
    if cached:
        return

    with complete_step(&quot;LUKS formatting home partition&quot;):
        luks_format(partition(loopdev, args.home_partno), args.passphrase)

def luks_format_srv(args, loopdev, run_build_script, cached):

    if args.encrypt is None:
        return
    if args.srv_partno is None:
        return
    if run_build_script:
        return
    if cached:
        return

    with complete_step(&quot;LUKS formatting server data partition&quot;):
luks_format(partition(loopdev, args.srv_partno), args.passphrase)
</code></pre></div><p>
А нельзя это &#171;home&#187; и home_partno просто как один из аргументов передавать было, смысл копипастить-то?</p><div class="code"><pre class="language-python"><code>def strip_suffixes(path):
    t = path
    while True:
        if t.endswith(&quot;.xz&quot;):
            t = t[:-3]
        elif t.endswith(&quot;.raw&quot;):
            t = t[:-4]
        elif t.endswith(&quot;.tar&quot;):
            t = t[:-4]
        else:
            break
    return t
</code></pre></div><p>
Да уж… А если потом решит ещё 50 форматов поддерживать, тоже каждому по elif и t = [t:-4] напишет? В чём проблема такого подхода:
<div class="code"><pre class="language-python"><code>def strip_suffixes(path):
    t, suffix = path.rsplit('.', 1)
    if suffix in (&quot;xz&quot;, &quot;raw&quot;, &quot;tar&quot;):
        return t
    return path
</code></pre></div></p><div class="sign"><a itemprop="creator" href="/people/Psych218/profile">Psych218</a> <span class="stars">★★★★★</span> (<time datetime="2017-06-29T12:15:22.576+03:00" itemprop="commentTime">29.06.2017 12:15:22</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511683">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511683">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511686" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/12202:2107260411.jpg" width="134" height="150"></div><div class="msg_body message-w-userpic"><p>Почему его никто не остановит ? Почему на github нет &#171;минусов&#187; ?</p><div class="sign"><a itemprop="creator" href="/people/robot12/profile">robot12</a> <span class="stars">★★★★★</span> (<time datetime="2017-06-29T12:16:05.911+03:00" itemprop="commentTime">29.06.2017 12:16:05</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511686">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511686">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511689" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/linux-general/13511594?cid=13511683">комментарий</a> от Psych218 <time datetime="2017-06-29T12:15:22.576+03:00" itemprop="false">29.06.2017 12:15:22</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/151512:1103990933.jpg" width="150" height="150"></div><div class="msg_body message-w-userpic"><p>Ого, в лучших традициях Леннарта.</p><div class="sign"><a itemprop="creator" href="/people/awesomelackware/profile">awesomelackware</a> <span class="stars"></span> (<time datetime="2017-06-29T12:16:39.677+03:00" itemprop="commentTime">29.06.2017 12:16:39</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511689">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511689">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511691" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/linux-general/13511594?cid=13511686">комментарий</a> от robot12 <time datetime="2017-06-29T12:16:05.911+03:00" itemprop="false">29.06.2017 12:16:05</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/128221:-1445121844.png" width="131" height="149"></div><div class="msg_body message-w-userpic"><p>Дислайки укрощают позитивную повестку, ну.</p><div class="sign"><a itemprop="creator" href="/people/nezamudich/profile">nezamudich</a> <span class="stars">★★</span> (<time datetime="2017-06-29T12:17:47.744+03:00" itemprop="commentTime">29.06.2017 12:17:47</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511691">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511691">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511700" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/68376:1858038799.png" width="62" height="99"></div><div class="msg_body message-w-userpic"><blockquote><p> представляющий собой обёртку над утилитами dnf --installroot, debootstrap, pacstrap и zypper.<br> Это означает поддержку только таблиц разделов GPT (и отсутсвие поддержки MBR), возможность генерации образов, основанных только на systemd, и генерацию только для загрузки на системах с поддержкой EFI (не MBR/BIOS).<br></p></blockquote><p>В общем суммируя - на хрен ненужный очередной костыль.</p><div class="sign"><a itemprop="creator" href="/people/cheez/profile">cheez</a> <span class="stars">★★</span> (<time datetime="2017-06-29T12:20:40.544+03:00" itemprop="commentTime">29.06.2017 12:20:40</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511700">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511700">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511704" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/linux-general/13511594?cid=13511672">комментарий</a> от mittorn <time datetime="2017-06-29T12:13:22.926+03:00" itemprop="false">29.06.2017 12:13:22</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/100226:1019313563.jpg" width="150" height="150"></div><div class="msg_body message-w-userpic"><p>Вот как раз это то ладно, в рамках проекта systemd делают, пусть поддерживают что хотят. Но можно же было на модули эту портянку распилить.</p><div class="sign"><a itemprop="creator" href="/people/Weres/profile">Weres</a> <span class="stars">★★★</span> (<time datetime="2017-06-29T12:21:57.370+03:00" itemprop="commentTime">29.06.2017 12:21:57</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511704">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511704">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511717" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/linux-general/13511594?cid=13511704">комментарий</a> от Weres <time datetime="2017-06-29T12:21:57.370+03:00" itemprop="false">29.06.2017 12:21:57</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/151512:1103990933.jpg" width="150" height="150"></div><div class="msg_body message-w-userpic"><p>systemd-mksosid</p><div class="sign"><a itemprop="creator" href="/people/awesomelackware/profile">awesomelackware</a> <span class="stars"></span> (<time datetime="2017-06-29T12:24:26.358+03:00" itemprop="commentTime">29.06.2017 12:24:26</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511717">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511717">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511728" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/linux-general/13511594?cid=13511683">комментарий</a> от Psych218 <time datetime="2017-06-29T12:15:22.576+03:00" itemprop="false">29.06.2017 12:15:22</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="https://secure.gravatar.com/avatar/4fb07ce0a586634542c2c279ebc2119a?s=150&amp;r=g&amp;d=blank" width="150" height="150"></div><div class="msg_body message-w-userpic"><p>Ну ладно багрепорты на ЛОРе писать, но код-ревью - это уже перебор, нет?</p><div class="sign"><a itemprop="creator" href="/people/vrutkovs/profile">vrutkovs</a> <span class="stars">★</span> (<time datetime="2017-06-29T12:26:59.519+03:00" itemprop="commentTime">29.06.2017 12:26:59</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511728">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511728">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511735" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="https://secure.gravatar.com/avatar/95a65bf052f820b0b92991cdbcd9ed16?s=150&amp;r=g&amp;d=blank" width="150" height="150"></div><div class="msg_body message-w-userpic"><p>Мне этот движ с корявыми микрософтинами напоминает поделки от suckless, только вместо suckless идет suckers.</p><div class="sign"><a itemprop="creator" href="/people/nihirash/profile">nihirash</a> <span class="stars"></span> (<time datetime="2017-06-29T12:29:06.841+03:00" itemprop="commentTime">29.06.2017 12:29:06</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511735">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511735">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511737" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/linux-general/13511594?cid=13511683">комментарий</a> от Psych218 <time datetime="2017-06-29T12:15:22.576+03:00" itemprop="false">29.06.2017 12:15:22</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/12202:2107260411.jpg" width="134" height="150"></div><div class="msg_body message-w-userpic"><p>Не будьте строгим, парень просто пидон изучает.</p><div class="sign"><a itemprop="creator" href="/people/robot12/profile">robot12</a> <span class="stars">★★★★★</span> (<time datetime="2017-06-29T12:29:36.831+03:00" itemprop="commentTime">29.06.2017 12:29:36</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511737">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511737">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511743" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/linux-general/13511594?cid=13511735">комментарий</a> от nihirash <time datetime="2017-06-29T12:29:06.841+03:00" itemprop="false">29.06.2017 12:29:06</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/151512:1103990933.jpg" width="150" height="150"></div><div class="msg_body message-w-userpic"><blockquote><p>suckmore<br>Software must suck</p></blockquote><div class="sign"><a itemprop="creator" href="/people/awesomelackware/profile">awesomelackware</a> <span class="stars"></span> (<time datetime="2017-06-29T12:31:13.481+03:00" itemprop="commentTime">29.06.2017 12:31:13</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511743">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511743">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511755" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/109572:199397400.jpg" width="138" height="138"></div><div class="msg_body message-w-userpic"><blockquote><p> возможность генерации образов, основанных только на systemd <br></p></blockquote><p>Наверно хочет вытеснить остальные утилиты, чтобы можно было генерить только линукса на systemd и остальные немногие совсем исчезли!</p><div class="sign"><a itemprop="creator" href="/people/SakuraKun/profile">SakuraKun</a> <span class="stars"></span> (<time datetime="2017-06-29T12:34:23.917+03:00" itemprop="commentTime">29.06.2017 12:34:23</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511755">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511755">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511769" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/linux-general/13511594?cid=13511683">комментарий</a> от Psych218 <time datetime="2017-06-29T12:15:22.576+03:00" itemprop="false">29.06.2017 12:15:22</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="/img/p.gif" width="1" height="1"></div><div class="msg_body message-w-userpic"><blockquote><p>Да уж… А если потом решит ещё 50 форматов поддерживать, тоже каждому по elif и t = [t:-4] напишет? В чём проблема такого подхода:<br></p></blockquote><p>проблема в том, что он учит питон и ещё не знает про os.path. а на системд он стало быть учил си, или на чём то поделие написано.</p><div class="code"><pre class="language-python"><code>path, ext = os.path.splitext(path)
</code></pre></div><p>не говоря уже о том, что strip_suffixes() не делает то, что заявлено и не отрезает расширение файла если это не .xz, .raw или .tar.</p><p>можете представить, что он понаписывал в системд, и прямо сейчас это барахло запущено на вашем железе.</p><div class="sign">anonymous <span class="stars"></span> (<time datetime="2017-06-29T12:38:32.584+03:00" itemprop="commentTime">29.06.2017 12:38:32</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511769">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511769">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511777" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="https://secure.gravatar.com/avatar/b985215ecdd713888ff4b7f2abd53140?s=150&amp;r=g&amp;d=blank" width="150" height="150"></div><div class="msg_body message-w-userpic"><p>очередное ненужное гавно от этого быдлокодера.</p><p>гори в огне поцеринг лучше.</p><div class="sign"><a itemprop="creator" href="/people/alwayslate/profile">alwayslate</a> <span class="stars">★</span> (<time datetime="2017-06-29T12:42:35.529+03:00" itemprop="commentTime">29.06.2017 12:42:35</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511777">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511777">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511781" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/linux-general/13511594?cid=13511769">комментарий</a> от anonymous <time datetime="2017-06-29T12:38:32.584+03:00" itemprop="false">29.06.2017 12:38:32</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/113773:-265967236.png" width="150" height="150"></div><div class="msg_body message-w-userpic"><blockquote><p>и прямо сейчас это барахло запущено на вашем железе<br></p></blockquote><p>Прошу, не обобщай.</p><div class="sign"><a itemprop="creator" href="/people/Meyer/profile">Meyer</a> <span class="stars">★★</span> (<time datetime="2017-06-29T12:43:21.938+03:00" itemprop="commentTime">29.06.2017 12:43:21</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511781">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511781">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511783" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/linux-general/13511594?cid=13511769">комментарий</a> от anonymous <time datetime="2017-06-29T12:38:32.584+03:00" itemprop="false">29.06.2017 12:38:32</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="https://secure.gravatar.com/avatar/b985215ecdd713888ff4b7f2abd53140?s=150&amp;r=g&amp;d=blank" width="150" height="150"></div><div class="msg_body message-w-userpic"><blockquote><p>можете представить, что он понаписывал в системд, и прямо сейчас это барахло запущено на вашем железе.<br></p></blockquote><p>зачем представлять, там и так все очевидно. говно. поэтому нормальные люди избегают этого поделия systemd</p><div class="sign"><a itemprop="creator" href="/people/alwayslate/profile">alwayslate</a> <span class="stars">★</span> (<time datetime="2017-06-29T12:44:10.512+03:00" itemprop="commentTime">29.06.2017 12:44:10</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511783">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511783">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511790" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/24081:-1968645623.png" width="64" height="64"></div><div class="msg_body message-w-userpic"><h2>Что из чего</h2><p>Я не понял, что у этого сценария на входе и что он выдаёт?</p><p>Из чего генерится образ? Из репозитерия пакетов? Из имеющейся установки ОС?</p><p>Результат работы можно только в контейнере запускать? Или можно запустить на железе? Если последнее, то почему это &#171;генератор образов&#187;, а не установщик?</p><div class="sign"><a itemprop="creator" href="/people/Camel/profile">Camel</a> <span class="stars">★★★★★</span> (<time datetime="2017-06-29T12:46:18.559+03:00" itemprop="commentTime">29.06.2017 12:46:18</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511790">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511790">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511796" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/58412:1240386028.jpg" width="150" height="112"></div><div class="msg_body message-w-userpic"><p>Надо давно поймать Поттеринга было. А то на следующем этапе он станет переписывать systemd на Питоне с использованием только греческих букв с диакритикою.</p><div class="sign"><a itemprop="creator" href="/people/Vudod/profile">Vudod</a> <span class="stars">★★★★★</span> (<time datetime="2017-06-29T12:49:40.330+03:00" itemprop="commentTime">29.06.2017 12:49:40</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511796">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511796">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511797" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/linux-general/13511594?cid=13511790">Что из чего</a> от Camel <time datetime="2017-06-29T12:46:18.559+03:00" itemprop="false">29.06.2017 12:46:18</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/151512:1103990933.jpg" width="150" height="150"></div><div class="msg_body message-w-userpic"><h2>Re: Что из чего</h2><blockquote><p>Из чего генерится образ? Из репозитерия пакетов? Из имеющейся установки ОС?<br>dnf --installroot, debootstrap, pacstrap and zypper<br></p></blockquote><p>Как вот эти пареньки генерят, так оно и должно.<br></p><blockquote><p>Результат работы можно только в контейнере запускать?<br>systemd-nspawn -bi image.raw<br></p></blockquote><p>Можно в контейнере.<br></p><blockquote><p>Или можно запустить на железе?<br>qemu-kvm -m 512 -smp 2 -bios /usr/share/edk2/ovmf/OVMF_CODE.fd -drive format=raw,file=image.raw<br></p></blockquote><p>Раз в qemu можно, то можно и на железе.<br>Да и не зря в новости про EFI.<br></p><blockquote><p>Если последнее, то почему это &#171;генератор образов&#187;, а не установщик?<br></p></blockquote><p>Потому что может генерить готовые образы, а не рутфс, не?</p><div class="sign"><a itemprop="creator" href="/people/awesomelackware/profile">awesomelackware</a> <span class="stars"></span> (<time datetime="2017-06-29T12:50:22.400+03:00" itemprop="commentTime">29.06.2017 12:50:22</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511797">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511797">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511801" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/114059:531897912.jpg" width="120" height="131"></div><div class="msg_body message-w-userpic"><p>Наконец-то! А то systemd-срачи надоели уже, хочется чего-то новенького</p><div class="sign"><a itemprop="creator" href="/people/Sunderland93/profile">Sunderland93</a> <span class="stars">★★★★★</span> (<time datetime="2017-06-29T12:52:58.240+03:00" itemprop="commentTime">29.06.2017 12:52:58</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511801">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511801">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511804" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/135215:-1090295902.png" width="149" height="149"></div><div class="msg_body message-w-userpic"><p>I'll break your OS Images.</p><div class="sign"><a itemprop="creator" href="/people/Skullnet/profile">Skullnet</a> <span class="stars">★</span> (<time datetime="2017-06-29T12:54:39.738+03:00" itemprop="commentTime">29.06.2017 12:54:39</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511804">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511804">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511808" class="msg"><div class="title">Ответ на: <a data-samepage="samePage" href="/news/linux-general/13511594?cid=13511735">комментарий</a> от nihirash <time datetime="2017-06-29T12:29:06.841+03:00" itemprop="false">29.06.2017 12:29:06</time></div><div class="msg-container"><div class="userpic"><img class="photo" src="/img/p.gif" width="1" height="1"></div><div class="msg_body message-w-userpic"><p>Где оное микрософтина?</p><div class="sign">anonymous <span class="stars"></span> (<time datetime="2017-06-29T12:56:30.192+03:00" itemprop="commentTime">29.06.2017 12:56:30</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511808">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511808">Ссылка</a></li></ul></div></div></div></article><article itemscope="itemscope" itemtype="http://schema.org/UserComments" itemprop="comment" id="comment-13511817" class="msg"><div class="title"></div><div class="msg-container"><div class="userpic"><img class="photo" src="/photos/129040:-2075522226.jpg" width="120" height="150"></div><div class="msg_body message-w-userpic"><p>Леннарт-весельчак. Леннарт-рукожоп.</p><div class="sign"><a itemprop="creator" href="/people/lochness/profile">lochness</a> <span class="stars"></span> (<time datetime="2017-06-29T13:00:14.362+03:00" itemprop="commentTime">29.06.2017 13:00:14</time>)</div><div class="reply"><ul><li><a itemprop="replyToUrl" href="add_comment.jsp?topic=13511594&amp;replyto=13511817">Ответить<span class="hideon-phone"> на это сообщение</span></a></li>   <li><a href="/news/linux-general/13511594?cid=13511817">Ссылка</a></li></ul></div></div></div></article></div>

<div id="realtime" style="display: none"></div>

<div class="nav">
  <div class="grid-row">
    <div class="grid-3-1">
      <table>
        <tr valign=middle>
          <td style="padding-right: 5px">
              <a href="/news/games/13506589" rel=prev>←</a>
            </td>
            <td align=left valign=top class="hideon-phone">
              <a href="/news/games/13506589" rel=prev>
                Angband 4.1.0</a>
            </td>
          </tr>
      </table>
    </div>
    <div class="grid-3-2">
      <a title="Новости - Linux General"
         href="/news/linux-general/">
          Linux General</a>
    </div>
    <div class="grid-3-3">
      </div>
  </div>
  </div></div>

<section id="related-topics">
    <h2>Похожие темы</h2>

    <div id="related-topics-list">
      <ul>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/talks/7929147">Леннарт Поттеринг анонсировал новый свободный загрузчик Gummiboot</a> (2012)
            </li>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/talks/10084057">Леннарт Поттеринг in motion</a> (2014)
            </li>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/talks/8697943">Интервью с Леннартом Поттерингом</a> (2013)
            </li>
          <li>
              <span class="group-label">Новости</span>
              <a href="/news/linux-general/11280962">Февральские тезисы о планах развития systemd</a> (2015)
            </li>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/talks/11227326">Леннарт Поттеринг дал большое интервью  LinuxVoice</a> (2015)
            </li>
          </ul>
      <ul>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/talks/8362286">Популярно про systemd и Леннарта Поттеринга</a> (2012)
            </li>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/development/10812246">Подскажите инструмент для генерации  данных</a> (2014)
            </li>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/general/2205588">создание образа ОС</a> (2007)
            </li>
          <li>
              <span class="group-label">Форум</span>
              <a href="/forum/talks/10914222">Леннарт Поттеринг: «Open Source community is full of assholes»</a> (2014)
            </li>
          <li>
              <span class="group-label">Новости</span>
              <a href="/news/opensource/7589105">Леннарт Поттеринг отказывается от OpenSource в пользу работы в Apple</a> (2012)
            </li>
          </ul>
      </div>
  </section>
</div>
<footer id="ft">

<p id="ft-info">
  <a href="/about">О Сервере</a> -
  <a href="/help/rules.md">Правила форума</a> -
  <a href="/help/lorcode.md">Правила разметки</a><br>
  <a href="https://www.linux.org.ru/">https://www.linux.org.ru/</a>
</p>

<script type="text/javascript">
  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-2184304-1']);
  _gaq.push(['_setCustomVar', 1, 'Authorized', 'false']);
  _gaq.push(['_setCustomVar', 2, 'Style', 'tango']);
  _gaq.push(['_setSiteSpeedSampleRate', 10]);
  _gaq.push(['_gat._forceSSL']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = 'https://ssl.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>

</footer>
</body></html>
