LINUX.ORG.RU

KDE Plasma 5.12 LTS

 , ,


1

1

6 февраля состоялся выпуск окружения рабочего стола KDE Plasma 5.12. Так как это релиз с расширенной поддержкой, основное внимание было уделено увеличению стабильности, оптимизации и проработке деталей.

Благодаря значительным усилиям по «облегчению» окружения сессия стала запускаться намного быстрее, а также использовать меньше оперативной памяти и ресурсов процессора.

Нововведения

  • Глобальное меню теперь включается автоматически при добавлении соответствующего виджета на панель или в заголовок окна.
  • KRunner теперь можно использовать с программами для чтения с экрана, такими как Orca.
  • Виджет иконки теперь поддерживает извлечение favicon при создании ссылки на веб-сайт.
  • Текст внутри уведомлений теперь можно выделять и копировать.
  • Улучшено меню Kickoff.
  • Виджет погоды теперь может показывать температуру рядом с иконкой на панели (скриншот).
  • В системный монитор добавлены графики нагрузки на ЦПУ для каждого процесса (скриншот).
  • Исправлен размер текста у виджета часов на горизонтальной панели (скриншот).
  • Тени окон выровнены по центру и по умолчанию сделаны более заметными (подробности).
  • Окно свойств теперь показывает метаданные файла.
  • Представлено множество усовершенствований в центре приложений Discover, в том числе повышение стабильности, доработка пользовательского интерфейса, а также улучшение поддержки Flatpak и Snap.

Wayland

В новой версии существенно доработана Wayland-сессия, на которую, в отличие от Plasma 5.8 LTS, теперь распространяется расширенная поддержка:

  • Добавлена функция Night Color, позволяющая изменять цветовую температуру дисплея (аналог Redshift).
  • С помощью KScreen теперь можно настраивать разрешение дисплеев, включать и отключать вывод и менять ориентацию экрана.
  • Реализована возможность автоматической смены ориентации на основе показаний соответствующего датчика.
  • Добавлена поддержка автоматической калибровки сенсорного экрана.
  • XWayland теперь запускается только при необходимости (см. также).
  • Wayland-окна теперь можно развернуть на весь экран.
  • KWin теперь выполняется в режиме реального времени для обеспечения отзывчивости ввода-вывода (подробности).
  • Поддерживаемый конкретной платформой метод композитинга теперь выбирается автоматически.
  • Добавлена начальная поддержка правил для окон.
  • Реализована поддержка протоколов xdg_shell_unstable_v6, xdg_foreign_unstable_v2, idle_inhibit_unstable_v1, server_decoration_palette, appmenu и wl_data_device_manager 3.

Также стоит отметить, что начиная с Plasma 5.13 в KWin не будут добавляться функции, специфичные для X11 (подробности).

>>> Список изменений

>>> Анонс

★★★★★

Проверено: leave ()

Интересно, что случится раньше: kwin_wayland начнёт работать на блобе nvidia, или в продажу поступят десктопные APU на базе Zen 2? А то, наверное, придётся уйти с nvidia.

anonymous ()
Ответ на: комментарий от anonymous

Ну, отсутствие нормальной поддержки Wayland — не единственная причина уйти с NVIDIA.

sudopacman ★★★★★ ()

А кто нибудь может мне объяснить почему wayland до сих пор не поддерживает nvidia карты?

Landgraf ★★★ ()
Ответ на: комментарий от Landgraf

nvidia запилила в драйвер eglstreams, тогда как в mesa и kwin запилили gbm, а это два разных стандарта реализации egl, и обе стороны упорно стоят на своём, хотя разраб kwin сказал «я пилить поддержку eglstreams не хочу и не буду, есть gbm - он и будет, но хер с вами, хотя бы eglstreams-патчи дайте, я их впилю в kwin», но nvidia тоже не спешит пилить эти патчи, вместо этого они начали пилить уже третий стандарт egl, карочи, цирк да и только

anonymous ()

Но.. Это была моя статья, почему меня даже не указали как автора..

jistake ()
Ответ на: комментарий от Landgraf

Зелёные решили в очередной раз, что все должны вокруг них танцевать, и добавили в свой драйвер поддержку Wayland через EGLStreams (все остальные драйверы используют GBM). Поэтому чтобы композитор работал с зелёным блобом, в него нужно добавлять специфичные для NVIDIA патчи. В GNOME их вроде даже добавили, но адекватные разработчики, естественно, сказали, что потакать прихотям Нвидии и разрабатывать отдельный бэкенд они не будут. Потом зелёные предложили запилить принципиально новую библиотеку, на которую все перейдут, выложили что-то на GitHub, но прогресса в этой области почти нет.

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

Зелёные решили в очередной раз, что все должны вокруг них танцевать

Не бери пример с лоровских икспердов, не будь таким ребёнком с одномерным мышлением. Реальный мир всегда сложнее.

Nvidia выбрала eglstreams потому, что он намного гибче и проще, чем gbm, плюс gbm гвоздями прибит к линуксу, тогда как нвидии надо делать драйвер и для винды, и для бсдей, и для соляры.

Аргументы нвидии в пользу eglstreams изложены здесь: https://devtalk.nvidia.com/default/topic/925605/linux/nvidia-364-12-release-v...

anonymous ()
Ответ на: комментарий от sudopacman

Т.е. как обычно — в гноме хоть как-то, но работает. А остальные просто кукарекают.

Это печально.

В любом случае единственное юзабельное DE после смерти юнити — это цина, и то только в составе минта благодаря куче удобного прикладного софта.

true_valman ()
Ответ на: комментарий от playX

Нельзя просто взять и поставить самую свежую версию ядра, не удостоверившись, что блоб на ней работает (плюс лишний геморрой с пересборкой модуля при каждом обновлении). Нет нормального разрешения в консоли (хоть это не катастрофически важно, но раздражает). Нет Gallium Nine и Gallium HUD.

Ну и, конечно, сам факт, что драйверы безнадёжно проприетарные, а в опенсорс компания выпускает только проекты, решающие ей же созданные проблемы (некоторые из них), — уже достаточный повод поддержать производителя, который не выпендривается и поддерживает открытые драйверы и общепринятые стандарты.

Fun fact:

2.1.1 Rights. Customer may install and use one copy of the SOFTWARE on a single computer, and except for making one back-up copy of the Software, may not otherwise copy the SOFTWARE. This LICENSE of SOFTWARE may not be shared or used concurrently on different computers.

sudopacman ★★★★★ ()
Ответ на: комментарий от anonymous

У EGLStreams тоже недостатки есть. Иначе зачем нужна новая библиотека? Я, конечно, за использование наилучшего программного решения, но почему NVIDIA не могла договориться со всеми раньше?

gbm гвоздями прибит к линуксу, тогда как нвидии надо делать драйвер и для винды, и для бсдей, и для соляры

AMD и Intel тоже надо. Кстати, в чём проблема со бсдями? Mesa же на них работает.

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

Нельзя просто взять и поставить самую свежую версию ядра, не удостоверившись, что блоб на ней работает (плюс лишний геморрой с пересборкой модуля при каждом обновлении)

Что за ерунда? Когда новая версия ядра ещё на стадии RC, под неё уже лежат дрова nvidia в репе. Собранные. То, что в некоторых говнодистрибутивах модуль приходится собирать самому - проблема этих говнодистрибутивов.

Нет Gallium Nine и Gallium HUD

А зачем оно?

anonymous ()
Ответ на: комментарий от sudopacman

У EGLStreams тоже недостатки есть

Ну ясен пень, идеального в мире ничего нет.

почему NVIDIA не могла договориться со всеми раньше?

Прежде всего, нужно уяснить, что Nvidia - корпорация, а там где корпорация, там бюрократия.

AMD и Intel тоже надо

У них дрова опенсорсные, ими сообщество, по большей части, занимается.

anonymous ()
Ответ на: комментарий от anonymous

Что за ерунда? Когда новая версия ядра ещё на стадии RC, под неё уже лежат дрова nvidia в репе. Собранные. То, что в некоторых говнодистрибутивах модуль приходится собирать самому - проблема этих говнодистрибутивов.

???

А зачем оно?

Глупый вопрос. Сходи да почитай.

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

По последней ссылке написано, что нужно сделать, чтобы не страдать из-за криворуких мантейнеров говнодистрибутивов:

Use Arch Linux....

Ровно об этом я и говорил. Когда в репы прилетает новое ядро, я просто обновляюсь, и у меня всё работает. Какое мне дело до каких-то пердоликов?

Сходи да почитай

Из этого можно сделать вывод, что это настолько аццки необходимые фичи, что я даже не знаю, зачем они))

Gallium Nine is an open-source implementation of DirectX 9

Пля, просто киллер-фича, кушать не могу без неё. С утра до ночи только и делаю, что виндовс-игры гоняю.

anonymous ()
Ответ на: комментарий от anonymous

У них дрова опенсорсные, ими сообщество, по большей части, занимается.

Во-первых, если бы производители не захотели, эти свободные драйверы не были бы официальными. Во-вторых, основной вклад в их разработку вносят как раз корпорации. Корпорациями, которым, несмотря на бюрократию, удаётся сотрудничать с сообществом.

sudopacman ★★★★★ ()
Последнее исправление: sudopacman (всего исправлений: 1)
Ответ на: комментарий от anonymous

По последней ссылке написано, что нужно сделать, чтобы не страдать из-за криворуких мантейнеров говнодистрибутивов:

Use Arch Linux....

Ровно об этом я и говорил. Когда в репы прилетает новое ядро, я просто обновляюсь, и у меня всё работает. Какое мне дело до каких-то пердоликов?

А если ты захочешь поставить нестандартное ядро, драйвер NVIDIA придётся пересобирать при помощи DKMS после каждого обновления. И не факт, что он с таким ядром вообще заработает. Зачем нужно нестандартное ядро? Ну, например, кому-то хочется звук с минимальными задержками записывать, а для этого надо установить linux-rt.

Из этого можно сделать вывод, что это настолько аццки необходимые фичи, что я даже не знаю, зачем они))
Пля, просто киллер-фича, кушать не могу без неё. С утра до ночи только и делаю, что виндовс-игры гоняю.

А кто-то про GNU/Linux за всю жизнь ни разу не слышал. Наверное, придётся смириться с фактом, что ОС, которой посвящён этот форум, не нужна…

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

Ну, например, кому-то хочется звук с минимальными задержками записывать, а для этого надо установить linux-rt.

Как хорошо, что мантейнеры моего дистрибутива собирают linux-rt вместе с дровами nvidia под него, и кладут это всё в репозиторий))

А кто-то про GNU/Linux за всю жизнь ни разу не слышал. Наверное, придётся смириться с фактом, что ОС, которой посвящён этот форум, не нужна…

Видишь ли, если ему нужны будут те качества, что имеет линукс, он начнёт искать по этим качествам, и рано или поздно узнает о линуксе.

anonymous ()
Ответ на: комментарий от anonymous

Как хорошо, что мантейнеры моего дистрибутива собирают linux-rt вместе с дровами nvidia под него, и кладут это всё в репозиторий))

Если это официальные пакеты, то что они делают в AUR и почему последнее обновление nvidia-rt было в августе?

Видишь ли, если ему нужны будут те качества, что имеет линукс, он начнёт искать по этим качествам, и рано или поздно узнает о линуксе.

Вряд ли я бы, например, пошёл бы искать, как включить копирование выделением и вставку колёсиком мыши, если бы не знал, что такая функция существует. А некоторые люди вообще умудряются жить, не зная о наличии контекстного поиска в программах типа браузера.

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

это официальные пакеты

Да: https://forum.manjaro.org/uploads/default/original/2X/f/f969dbacc2b439f59d44d...

почему последнее обновление nvidia-rt было в августе?

Я не в курсе ваших проблем, у меня в утилите руления ядрами последнее rt-ядро - версии 4.14.15-rt13-1

Вряд ли я бы, например, пошёл бы искать, как включить копирование выделением и вставку колёсиком мыши, если бы не знал, что такая функция существует

Это у тебя врождённое знание, понемаю.

anonymous ()
Ответ на: комментарий от anonymous

Я не в курсе ваших проблем, у меня в утилите руления ядрами последнее rt-ядро - версии 4.14.15-rt13-1

Во-первых, Manjaro ≠ Arch. Во-вторых, нужно смотреть версию nvidia-rt. В-третьих, такие пакеты есть только потому, что их поддерживает сторонний мейнтейнер, не связанный с NVIDIA; и ты от него зависишь. Нет гарантии, что все пакеты будут поддерживаться вечно и что все варианты ядра будут опакечены вместе с модулем NVIDIA.

Это у тебя врождённое знание, понемаю.

Ты о чём? Я про то, что пользователь очень часто решает, нужна ли ему какая-то функция, уже после того, как он узнал о её существовании.

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

Manjaro ≠ Arch

Да, это допиленный Арч.

Во-вторых, нужно смотреть версию nvidia-rt

https://github.com/manjaro/packages-community/tree/master/linux414-rt-extramo...

Нет гарантии, что все пакеты будут поддерживаться вечно и что все варианты ядра будут опакечены вместе с модулем NVIDIA.

Горе-то какое! Также нет гарантий, что завтра меня не собьёт автобус, поэтому я сижу в шкафу и не выхожу.

Ты о чём?

О том, что получение знания происходит из-за потребности в нём.

anonymous ()
Ответ на: комментарий от anonymous

https://github.com/manjaro/packages-community/tree/master/linux414-rt-extramo...

Там pkgver=384.111, когда для обычного ядра той же версии уже 390.25. Это как рас иллюстрирует то, что я хотел сказать. И не надо пытаться выехать на неуместных аналогиях.

О том, что получение знания происходит из-за потребности в нём.

А потребности меняются в зависимости от полученных знаний.

sudopacman ★★★★★ ()
Последнее исправление: sudopacman (всего исправлений: 1)
Ответ на: комментарий от sudopacman

Там pkgver=384.111, когда для обычного ядра той же версии уже 390.25

Фатальное отставание, посыпаю голову пеплом.

И не надо пытаться выехать на неуместных аналогиях

Аналогия более чем уместна: что там, что здесь - боязливое ожидание конца света негативных событий.

anonymous ()
Ответ на: комментарий от anonymous

Фатальное отставание, посыпаю голову пеплом.

Во-первых, важен сам факт отставания там, где его быть не должно; однажды этот пакет может повторить судьбу nvidia-rt из AUR. Во-вторых, оно действительно не такое уж и маленькое.

Аналогия более чем уместна: что там, что здесь - боязливое ожидание конца света негативных событий.

Корректная аналогия: «Нет гарантий, что меня не собьёт машина, поэтому я смотрю по сторонам, когда перехожу дорогу». Машина меня, кстати, ни разу не сбивала, а вот (полу)заброшенных пакетов я видел достаточно.

sudopacman ★★★★★ ()
Последнее исправление: sudopacman (всего исправлений: 1)
Ответ на: комментарий от sudopacman

важен сам факт отставания

Неважен, если отставание микроскопическое.

Кстати, и для обычного ядра тут предлагают 384.111, так что скорее всего, с новым драйвером не всё в порядке.

его быть не должно

Потому что ты так сказал?)

Корректная аналогия: «Нет гарантий, что меня не собьёт машина, поэтому я смотрю по сторонам, когда перехожу дорогу»

Нет, это некорректная аналогия. Ты предлагаешь не пользоваться дистрибутивом или видеокартой, потому вдруг пакет забросят ещё. Это равноценно сидению в шкафу.

anonymous ()
Ответ на: комментарий от anonymous

Неважен, если отставание микроскопическое.

Потому что ты так сказал?)

Кстати, и для обычного ядра тут предлагают 384.111,

https://github.com/manjaro/packages-extra/blob/master/linux414-extramodules/n...

Ты предлагаешь не пользоваться дистрибутивом или видеокартой, потому вдруг пакет забросят ещё.

Я не предлагаю не пользоваться дистрибутивом. А вот видеокартой я предлагаю не пользоваться в том числе потому, что драйверы для неё нужно приматывать скотчем к ядру; при этом к некоторым версиям ядра они не приматываются.

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

Потому что ты так сказал?)

Нет, потому что это логично - когда разница на одну версию, это некритично. По крайней мере, это не дебиан, где в репах лежат безнадёжно протухшие пакеты)

https://github.com/manjaro/packages-extra/blob/master/linux414-extramodules/n...

Чота странно. У меня до сих пор так:

# pacman -Q linux415-nvidia 
linux415-nvidia 1:384.111-0.14

причём на тестовой ветке. Может, это в unstable?

в том числе потому, что драйверы для неё нужно приматывать скотчем к ядру

А я говорю, что это вообще неважно, потому что скотчем орудуют мантейнеры, а ко мне приезжает уже всё готовенькое, нужно только мышкой клац-клац.

anonymous ()

Стабильность работы реально подтянули, молодцы. Пока тестил в лив-режиме, за полчаса ничего не упало и не взглюкнуло - это уже многое значит :) Потребление ОЗУ тоже уменьшилось. Теперь кеды жрут меньше чем XFCE. Это ли не чудо? :)

djoe ★★ ()
Ответ на: комментарий от anonymous

Нет, потому что это логично - когда разница на одну версию, это некритично.

Только отставание там не на одну версию.

Может, это в unstable?

Не знаю, но оба PKGBUILD'а из master-ветки, так что «соревнование» честное.

А я говорю, что это вообще неважно, потому что скотчем орудуют мантейнеры, а ко мне приезжает уже всё готовенькое, нужно только мышкой клац-клац.

А я говорю, что это важно, потому что не всегда можно полагаться на мейнтейнеров.

sudopacman ★★★★★ ()

Discover нихерово поправили, 261 изменение в ченджлоге.

anonymous ()
Ответ на: комментарий от sudopacman

Только отставание там не на одну версию.

А на сколько?

не всегда можно полагаться на мейнтейнеров

В Manjaro - всегда можно. Тем более, у меня желания нет играть в мантейнера.

anonymous ()
Ответ на: комментарий от anonymous

Кстати, к нам тут периодически захаживает один любитель несовершеннолетних девочек, он ещё в Казахстане живёт. Не знаешь такого?

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

Если к вам кто-то захаживает без спроса и трахает ваших девочек, то наймите швейцара, что ли.

anonymous ()
Ответ на: комментарий от anonymous

А на этом форуме есть несовершеннолетние девочки?

sudopacman ★★★★★ ()
Ответ на: комментарий от anonymous

А на сколько?

На две ветки.

В Manjaro - всегда можно.

А если ядро с нужными параметрами не опакечено?

Тем более, у меня желания нет играть в мантейнера.

Короче, ты мне на протяжении всего треда рассказываешь, что тебя устраивает стоковое ядро твоего дистрибутива, а всё остальное не нужно. Я тебя прекрасно понимаю. Давай сойдёмся на том, что причина «блоб доставляет неудобства при обновлении/установке ядра» релевантна не для всех пользователей.

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

Ладно. Лучше перейдём к девочкам!

anonymous ()
Ответ на: комментарий от anonymous

Как ты думаешь, какой дистрибутив больше всего подходит для девочек?

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

Тот, что ломается не чаще раза в месяц.

anonymous ()

В kubuntu backports уже прилетело. Полет нормальный.

Wens ()
Ответ на: комментарий от sudopacman

Фрактал не может не спалиться, да? :)

leave ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.