LINUX.ORG.RU

Корректирующий релиз драйвера NVIDIA 304.43

 ,


0

2

Серия драйверов NVIDIA 304.x Linux будет последней, в которой будут поддерживаться GeForce 7, GeForce 6 и более старые модели видеокарт.

Что нового в версии 304.43:

  • устранено зависание VDPAU при работе YouTube Flash Player;
  • исправлены ошибки с несогласованным изменением настроек nvidia-settings со стороны gnome-settings-daemon;
  • в nvidia-settings добавлена поддержка использования RandR для управления цветностью;
  • добавлена поддержка новых GPU GeForce GTX 660 Ti, Quadro K5000, Quadro K5000M, Quadro K4000M, Quadro K3000M и NVS 510;
  • решена проблема с крахом тестовой версии X.Org xserver 1.13 при запуске Firefox.

>>> Подробности на английском

★★★★★

Проверено: maxcom ()

Синих людей исправили?

anonymous ()

Да хоть после выхода каждой новой серии видеокарт прекращают поддержку драйверов. Это же не ATi/AMD, которые уже через несколько лет после выпуска не поддерживаются официальным драйвером, а NVIDIA, у которой поддерживаются старые версии драйверов для старых серий видеокарт. В них добавляется поддержка новых версий графического X-сервера и ядра Linux.

ZenitharChampion ★★★★★ ()

Серия драйверов NVIDIA 304.x Linux будет последней

Я аж испугался.

Paused ()
Ответ на: комментарий от ZenitharChampion

Я где-то скачивал пропатченную libvdpau, теперь все ок.

cipher ★★★★★ ()

Серия драйверов NVIDIA 304.x Linux будет последней, в которой будут поддерживаться GeForce 7, GeForce 6 и более старые модели видеокарт.

Серия драйверов NVIDIA 304.x Linux будет последней, в которой будут поддерживаться GeForce 7, GeForce 6 и более старые модели видеокарт.

мда, драйвера последние, а баги все столь же эпичные, что и в ранних альфах...

AVL2 ★★★★★ ()
Ответ на: комментарий от Paused

>> Серия драйверов NVIDIA 304.x Linux будет последней

> Я аж испугался.

Если серия драйверов NVIDIA 304.x Linux будет последней, перейду на FreeBSD.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Но если подумать, то всё равно, здесь итак ногаемс, зачем дрова нужны?

Paused ()
Ответ на: комментарий от cipher

Очень интересная информация! Раз так, то наверное можно устанавливать драйвер NVIDIA с ключом, который распакует библиотеку VDPAU. Несколько лет назад она перестала устанавливаться автоматически, потому что эту библиотеку приняли в репозитории большинства дистрибутивов. С официальной бинарной библиотекой бага может не оказаться.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)
Ответ на: комментарий от Paused

Да я в игры для Linux поиграть не успеваю! И каждый месяц около 5 новых появляется.

Во FreeBSD есть Wine.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)

решена проблема с крахом тестовой версии X.Org xserver 1.13 при запуске Firefox.

линукс для десктопа - готов!

pekmop1024 ★★★★★ ()
Ответ на: комментарий от AVL2

мда, драйвера последние, а баги все столь же эпичные, что и в ранних альфах...

Например?

AiFiLTr0 ★★★★★ ()
Ответ на: комментарий от pekmop1024

решена проблема с крахом тестовой версии X.Org xserver 1.13 при запуске Firefox.

тестовой

Они дрова тестируют с новыми иксами еще до выхода их, не то что ати/амд, со своим fglrx, кривая поддержка новых иксов только когда они успели уже протухнуть.

AiFiLTr0 ★★★★★ ()
Ответ на: комментарий от AiFiLTr0

Да к ним претензий ноль...
Вопрос к тому, что иксы принципиально способны валиться от запуска приложений.

pekmop1024 ★★★★★ ()
Ответ на: комментарий от AiFiLTr0

Для ati хоть открытые драйвера есть. Со своими плюсами и минусами.

kerneliq ★★★★★ ()
Ответ на: комментарий от pekmop1024

Скорее всего валятся иксы не от приложения, а от того, как приложение чо-то отрисоввывает из-за баге в драйвере. Это разные вещи.

AiFiLTr0 ★★★★★ ()
Ответ на: комментарий от onon

Мне Linux больше нравится, но если драйвера NVIDIA для него не будет, то лучше попробовать FreeBSD, чем возвращаться в Windows.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

У меня бага нет, и не было никогда. Сам недавно узнал, что он все таки есть у кого то. Странно конечно. Почему то меня уверяли, что проблема синих людей в драйвере. Но я, пользуясь самыми свежими драйверами, никогда такой ошибки не видел. Наверное вы правы в этом вопросе, и баг может проявляться только на некоторых дистрибутивах. Быть может у меня в дистрибутиве бинарная библиотека?

ivanlex ★★★★ ()

Оптимуса нет? Давай, до свидания!

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от kerneliq

Толку то в открытости, если они кривые и не рабочие. По мне, так пусть уж закрытые, зато рабочие.

ivanlex ★★★★ ()
Ответ на: комментарий от ivanlex

У тебя ускорение было включено? EnableLinuxHWVideoDecode? Лечилось отключением.

kerneliq ★★★★★ ()
Ответ на: комментарий от AiFiLTr0

Ну так когда падает драйвер даже в оффтопике, то падает драйвер, а не вся графическая система.

pekmop1024 ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Это же не ATi/AMD, которые уже через несколько лет после выпуска не поддерживаются официальным драйвером

Давно плоды трудов разработчиков свободного драйвера в AMD стали неофициальными?

В них добавляется поддержка новых версий графического X-сервера и ядра Linux.

Про Иксы см. следующее сообщение.
В дистрибутивах с новыми ядрами, пакеты fglrx пропатчены для поддержки новых ядер - сколько раз вам это нужно написать, чтобы вы запомнили?

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от AiFiLTr0

Они дрова тестируют с новыми иксами еще до выхода их

Ага, они уже второй раз переделали поддержку X.Org Server 1.13. Наверное очень важное и полезное дело, в то время как поддержка гибридной графики у AMD есть, а у nVidia - нет. Лучше бы nVidia делом занимались.

не то что ати/амд, со своим fglrx, кривая поддержка новых иксов только когда они успели уже протухнуть

X.Org Server 1.12 из Fedora 17 (первый не-роллинг дистр с X.Org Server 1.12) начали поддерживать спустя день после релиза Fedora 17. Сильно X.Org Server 1.12 за это время протух?

Со своими плюсами и минусами.

nouveau до radeon как подтипом членистоногих до крупнейшего экспортёра.

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

Скоро куплю 7770 для своего пассивного проекта и буду тебя зверски троллить этими говнодрайверами

pekmop1024 ★★★★★ ()
Ответ на: комментарий от AiFiLTr0

С плюсами у nouveau туговато, хотя иногда встречаются сносные сочетания версий ядра, иксового драйвера и модели видеокарты.

Homura_Akemi ()
Ответ на: комментарий от ivanlex

> Наверное вы правы в этом вопросе, и баг может проявляться только на некоторых дистрибутивах.

У меня тот же самый отзыв насчёт бага NVIDIA, когда вместо отображения виртуальных терминалов показывается «Экран переходит в энергосбережение», если с момента старта X-сервера прошло 10 минут. Потому что я наблюдаю его только в Debian, наверное всё дело в патчах, наложенных его мейнтейнерами! И именно поэтому разработчики драйвера не могут его вопроизвести.

Проблема синих людей на NVIDIA может проявляться в двух случаях:

1). Кодек H264, а не FLV. Например YouTube.

2). GeForce 8 и старше, потому что VDPAU работает только на нём.

Наверное у тебя GeForce 7, или ты не пользуешься YouTube. У меня вот есть встроенная в материнскую плату GeForce 7 и там всё отлично, а со вставленной в разъём PCI Express баг есть.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 2)
Ответ на: комментарий от pekmop1024

Скоро куплю 7770 для своего пассивного проекта и буду тебя зверски троллить этими говнодрайверами

Традиционно: без ссылок на багрепорты не интересно.

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

Открытый драйвер ati был неофициальным всегда. «Плоды трудов разработчиков» - хорошая фраза, только разработчики из AMD там появились уже после открытия спецификаций на видеокарты, насколько мне известно. fglrx для старых серий видеокарт стали обновлять для новых дистрибутивов Linux?

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Открытый драйвер ati был неофициальным всегда.

Дайте определение «официальности».

fglrx для старых серий видеокарт стали обновлять для новых дистрибутивов Linux?

Зачем?

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

Нет, не троллинг. Если не сможешь воспроизвести у себя, я тебе все нужные логи дам. :)

pekmop1024 ★★★★★ ()
Ответ на: комментарий от pekmop1024

Нет, не троллинг.

То есть второй вариант?

Если не сможешь воспроизвести у себя, я тебе все нужные логи дам. :)

Багтрекерофобия?

RussianNeuroMancer ★★★★★ ()

исправлены ошибки с несогласованным изменением настроек nvidia-settings со стороны gnome-settings-daemon

Это как это? Гном самовольно менял настройки графики?

alex-w ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

Ядробагзиллофобия.
Вообще, большая часть багтрекеров опенсорсных состоит из ответов разработчиков «УМВР, иди отсюда». Вот и будешь бороться с этими умвристами, а я устал.

pekmop1024 ★★★★★ ()
Ответ на: комментарий от pekmop1024

o'rly? Что-то у меня ни разу такого «успешного падения» не наблюдалось. Или это только в восьмерочке появилось?

AiFiLTr0 ★★★★★ ()
Ответ на: комментарий от AiFiLTr0

В семерочке. Возьми какую-нибудь относительно свежую жыфорсу, ферми или кеплер, переразгони и урони драйвер - увидишь

pekmop1024 ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

Раньше ATi/AMD не имела к драйверу xf86-video-ati никакого отношения. Я не застал тех времён и могу ошибаться. В настоящий момент AMD оплачивает работу над этим драйвером нескольких разработчиков.

Не обновляется fglrx для предыдущих версий видеокарт? ATi не нужен. А NVIDIA пусть хоть после выхода каждой новой серии видекарт прекращает поддержку предыдущей в драйвере, потому что (ну и далее - моё первое сообщение).

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от pekmop1024

Ядробагзиллофобия.
Вообще, большая часть багтрекеров опенсорсных состоит из ответов разработчиков «УМВР, иди отсюда». Вот и будешь бороться с этими умвристами, а я устал.

Причём тут опенсорсный драйвер, если для GCN он ещё не написан?

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Раньше ATi/AMD не имела к драйверу xf86-video-ati никакого отношения. Я не застал тех времён и могу ошибаться. В настоящий момент AMD оплачивает работу над этим драйвером нескольких разработчиков.

Так где определение «официальности» драйвера?

Не обновляется fglrx для предыдущих версий видеокарт? ATi не нужен.

Кому нужен fglrx для видеокарт ATi (эта фирма не существует шесть лет) кроме вендузятников?

RussianNeuroMancer ★★★★★ ()

Только недавно 304.37 поставил. Эти ставить пока не буду.

На носу свеженькая версия OpenSuse которую буду ставить с нуля.

И еще покупка новой видяхи 670, вот тогда и поставлю новые дровишки.

petyanamlt ★★★ ()
Ответ на: комментарий от RussianNeuroMancer

Причём тут опенсорсный драйвер, если для GCN он ещё не написан?

Люди-то те же...

pekmop1024 ★★★★★ ()
Ответ на: комментарий от petyanamlt

> Только недавно 304.37 поставил. Эти ставить пока не буду.

> На носу свеженькая версия OpenSuse которую буду ставить с нуля.

А тем временем в репозитории с драйверами NVIDIA для openSUSE обновили драйвер до последнего. Обычно в NVIDIA пропускали один или два релиза и не создавали RPM-пакетов, а тут вдруг выпустили пакеты с драйвером версии 304.43 сразу после выпуска пакетов с предыдущей версией драйвера. Это значит, что их намерения серьёзны, и это действительно последняя версия драйвера для видеокарт GeForce 6 и 7... Кроме того, NVIDIA сделала репоиторий для openSUSE 12.2.

ZenitharChampion ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.