LINUX.ORG.RU

Nvidia 270.41.06

 , , ,


0

0

20 апреля вышла первая стабильная версия проприетарного драйвера Nvidia из 270-ой ветки - 270.41.06
Исправленные ошибки:

  • Исправлена ошибка, вызывающая зависания X сервера каждые 49.7 дня на 32-битных платформах
  • Исправлена ошибка очереди представления VDPAU, вызывавшая «прерывания дисплея» VDPAU при рендеринге в очень маленькие окна или растровые изображения, а также окна или растровые изображения с нулевым размером.
  • Исправлена ошибка, из-за которой было невозможно использовать очередь представления VDPAU на основе оверлеев, возникавшая при выходе из приложения с нерасформированной очередью представления VDPAU.
  • Исправлена ошибка VDPAU, приводившая к тому, что оверлей не использовался, если при создании очереди представления целевое окно было перенаправлено при помощи расширения Composite.
  • Исправлен ряд ошибок, связанных с аппаратным ускорением градиентов, которые вызывали неверное отображение графики в некоторых темах Ubuntu GNOME по умолчанию.
  • Исправлена ошибка, из-за которой, некоторые графические процессоры переставали отвечать при запуске X-сервера. Наиболее часто встречалось на картах GF104 и GF106
  • Исправлена ошибка, приводившая к исключению в операциях с плавающей точкой(FPE)в некоторых приложениях(например gimp)на 32-битных платформах, если glibc собрана с omitfp, присутствующая во всей предыдущей ветке (260)

Новшества:

  • Добавлена поддержка xserver ABI 10 (xorg-server 1.10).
  • Добавлено уведомление о событии NV-CONTROL при смене статуса NV_CTRL_FRAMELOCK_SYNC_READY.
  • Добавлена новая опция X конфигурации «Interactive», по умолчанию она включена, ее можно отключить и позволить программам, использующим GPU-вычисления и требующим много времени на выполнение, работать одновременно с X
  • Добавлена новая библиотека совместного пользования: libnvidia-ml.so
  • Добавлена новая опция X конфигурации «3DVisionDisplayType», позволяющая указать тип дисплея при включенном NVIDIA 3D Vision на дисплее без поддержки 3D Vision.
  • Модифицированы обновления палитры, теперь они не синхронизируются в vblank. Благодаря этому приложения могут посылать запросы XStoreColor и XStoreColors быстрее частоты обновления экрана.

Так же добавлена поддержка новых карт:

  • GeForce GT 520
  • GeForce GT 525M
  • GeForce GT 520M
  • GeForce GT 445M
  • GeForce GT 530
  • GeForce 405
  • GeForce GTX 590
  • GeForce GTX 550 Ti
  • GeForce GTX 560 Ti
  • GeForce GT 420
  • GeForce GT 440
  • GeForce GTX 470M
  • GeForce GTX 485M
  • GeForce GT 550M
  • GeForce GT 555M
  • NVS 4200M
  • Quadro 1000M
  • Quadro 2000M
  • Quadro 2000 D
  • Quadro 400

>>> Подробности

★★★★

Проверено: JB ()

по поводу FPE официально инфы нет, но баг фикс есть ещё с бетки 270.30

megabaks ★★★★ ()

да - ебыдлы есть в оверлее stuff
для гентушнегов-торопышек :3

megabaks ★★★★ ()

Заметно пофикшен VDPAU, судя по всему.
Он меня на 260-270 просто заколебал уже - иногда машину приходится с кнопки ребутать, даже по ssh не зайти.

pekmop1024 ★★★★★ ()
Ответ на: комментарий от megabaks

Ну это же линукс - самая сложная и интересная MMORPG в мире :)

pekmop1024 ★★★★★ ()
Ответ на: комментарий от pekmop1024

>самая сложная и интересная MMORPG в мире :)
согласен :)

megabaks ★★★★ ()

>ошибка, вызывающая зависания X сервера каждые 49.7 дня

да, амд еще работать и работать

registrant ★★★★★ ()
Ответ на: комментарий от registrant

хз - у нвидии нет багтрекера
все багрепорты овер мыло
встречается на форуме, но редко
поищи, если не лень :)

megabaks ★★★★ ()

блоб не нужен, нуво пусть пилят активнее

Kompilainenn ★★★★★ ()
Ответ на: комментарий от Kompilainenn

ты всё перепутал
пока нуво даже не рядом
а если учесть, что ту же куду открывать никто не собирается...

megabaks ★★★★ ()

> Так же добавлена поддержка новых карт:

Интересно, а поддержку старых карт пофиксили? Или уже совсем забили? А то я так и не могу слезть со 173-ей версии из-за GIMP'а.

Впрочем, это могут быть и кривые руки GIMP'овцев, конечно... Выйдет 2.8 - посмотрим.

Cyril ★★ ()
Ответ на: комментарий от megabaks

Да, не рядом. Однако, с нуво иксы не падают при первой возможности в отличие от. А для большинства задач и нуво хватает. Так что пусть пилят нуво.

anonymous ()
Ответ на: комментарий от anonymous

у меня и на блобе с *недель аптайма иксы не падают ни при каких условиях
ЧЯДНТ?

megabaks ★★★★ ()
Ответ на: комментарий от Cyril

старые карты похоже тока в утиль или сидеть на недодровах типа нуво

megabaks ★★★★ ()

вот уже год я юзаю на соньковском ноуте карту nvidia через жопу (вручную подставляя edid слитый с винды), переключение в текстовую консоль не работает после того как зашел в иксы. карточка помойму 330m. не могу понять - неужели так тяжко эту багу исправить?

ioan ()
Ответ на: комментарий от ioan

может руки?
а вообще - что ты для этого сделал?
багрепорт отсылал?
ответ есть?
нет? так чо ноешь?

megabaks ★★★★ ()
Ответ на: комментарий от ioan

тот же FPE был пофикшен через...ты не поверишь - через сборку stage4 в терминах генты

megabaks ★★★★ ()
Ответ на: комментарий от anonymous

А как работать с использованием nouveau, если постоянно раз в ~10 секунд курсор на долю секунды тормозится?
P.S.: GTS 250.

carasin ★★★★★ ()
Ответ на: комментарий от megabaks

Не факт. Думаю, в скором времени просто прикрутят к 96.*, 173.* и 195.* поддержку ABI X'ов 1.10 и снова в путь =)

carasin ★★★★★ ()
Ответ на: комментарий от carasin

неа
гарантия 100%
ибо тот же FPE-fix присутствует только в 270-ой ветке
официальный ответ - все дрова кроме 270-ой ветки начиная с 270.30 идут нахер - ибо нех
таки дела
могу если что часть переписки показать
так что имхо никаких бэкпортов

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

Ну у меня не настолько старая. 270 её держат, по крайней мере. Ж;-)

Cyril ★★ ()

Мышам праздник

Проприетарный кактус стал еще вкуснее.

anarquista ★★★★★ ()
Ответ на: комментарий от megabaks

багрепорту этому сто лет. в феврале 2010 года в багрепорте нашел воркараунд, регулярно апдейчу дрова, но без вручную подсунутого edid-a всё также черный экран.

ioan ()
Ответ на: комментарий от megabaks

1) А при обновлении? Чуть какое обновление — всё валится.

2) Так было в openSUSE 11.3. В 11.4, вроде бы, пока нормально.

anonymous ()
Ответ на: комментарий от ioan

сто лет?
молодец
собирай новые данные - щли полноценный багрепорт с выхлопным файлом nvidia-bug-report.sh
и спами-спами-спами

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

Если это действительно так, то печально. Хоть уже полтора года и стоИт на балконе мой первый комп с GF2 MX400 64 MB в полуразобранном виде, но всё равно...
Но с другой стороны, железо семилетней давности, пожалуй, действительно устарело и на современных системах не канает, да.
В любом случае, это когда-нибудь должно было произойти =)

carasin ★★★★★ ()
Ответ на: комментарий от anonymous

малыш, я всегда сижу на самых распоследних дровах
будь то релиз или бетка - не важно
УМВР!
думай дальше - а вообще прозреваю, что ты когда-то нах^накосячил и теперь у тебя мусор от старых дров остался - есть такие «истории успеха» и на лоре в том числе

megabaks ★★★★ ()
Ответ на: комментарий от anonymous

я вот прям сейчас сижу тут с сабжем
что мне сделать чоб уронить иксы?

megabaks ★★★★ ()
Ответ на: комментарий от carasin

вот - про FPE нашёл:

Will the fix be available for 260 series, or only 270.29 and newer ?




The 260 branch will only be receiving minor updates from this point on,
so I don't think this fix will be backported to 260 series drivers.
Future 270 beta releases, and the eventual official releases of 270
should all contain the fix. If you want to use the NVIDIA driver with
omitfp glibc and userland, you'll need to use the 270 drivers, or older
drivers which didn't have this issue (or otherwise use any of the
workarounds that you had identified previously)

megabaks ★★★★ ()

Вот это

Исправлена ошибка, вызывающая зависания X сервера каждые 49.7 дня на 32-битных платформах

просто отлично! :)

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от megabaks

ну а чо тогда некрофильничаешь? о_О


1. Разъём - AGP (то есть, не выше 7950 - у меня 6200)
2. Производительность устраивает - менять комп нет смысла
3. И только GIMP, зараза, на драйверах старше 173 начинает жутко скрипеть инструментами

Пункт 3, вынуждающий меня использовать 173, можно и потерпеть - особенно после того, как они в последней подверсии 173-их подправили что-то и XvMC снова начал работать, а не падать.

Cyril ★★ ()
Ответ на: комментарий от megabaks
uptime 
 09:15:31 up 64 days, 13:55,  7 users,  load average: 0.09, 0.07, 0.06

Неделю назад было как раз ~50 дней с момента, когда я «падучий» модуль поставил, прихожу на работку, начинаю вводить пароль в xlock, жамкаю ввод - и кирдык-аул... Иксы весело схлопываются. Только начал заходить под рутом, чтобы посмотреть, в чем дело - они заново запустились. На ЛОРе узнал про этот «веселенький» прикол последних модулей.

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от megabaks

Как дети малые радуетесь этой кривой проприетарщине

int13h ★★★★★ ()
Ответ на: комментарий от megabaks

А я-то все не мог вспомнить, из какой темы я про это узнал :)

(до этого грешил на альфу четвертого огнелиса)

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от megabaks

Дык, я так понял, что разговор только о 260.* . То есть явно не сказано, что нельзя будет использовать те же 96.*, 173.* и 195.* . Говорится ведь, что в них просто не будет этого багфикса. А использовать - на здоровье, но со старыми лагами.
Или я что-то не так понял?

carasin ★★★★★ ()
Ответ на: комментарий от int13h

есть что-то лучше?
я не из числа тупоголовых фанатиков...хотя гентушнег, да :3
просто если что-то просто работает нахера себе вставлять в опу кляп с шипами?

megabaks ★★★★ ()
Ответ на: комментарий от carasin

правильно
но это своего рода пруф того, что новые багфиксы и фичи бэкпортировать никто не собираецо

megabaks ★★★★ ()
Ответ на: комментарий от int13h

Кактус жуют как раз те, кто покупает дорогущие видеокарты и используют кривущие свободные модули. В результате чего их карточка за 300 баксов работает не лучше дешевки за 30...

Где в свободных драйверах нормальное 3D, VDPAU, CUDA?

Eddy_Em ☆☆☆☆☆ ()
Ответ на: комментарий от Eddy_Em

сейчас тебе расскажут про тормоза в 2D, оха
хотя ни одна сука в теме про ресайз не отметилась
все эти заявления можно с тех пор считать сливом априори

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

сейчас тебе расскажут про тормоза в 2D

Я так понимаю, что подобные «рассказчики» никогда не видели живьем работу проприетарных модулей :)

Eddy_Em ☆☆☆☆☆ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.