LINUX.ORG.RU

Выпуск проприетарного драйвера для видеокарт Nvidia 295.40

 , ,


0

1

Сегодня произошло обновление стабильной ветки проприетарного драйвера для видеокарт Nvidia. Выпуск за номером 295.40 включает следующие изменения:

  • добавлена поддержка новых карт: GeForce GT 635M, GeForce 610M;
  • закрыта уязвимость, позволявшая злоумышленнику получить доступ к произвольной области системной памяти посредством изменения конфигурации видеоадаптера (подробнее);
  • исправлена ошибка, иногда приводившая к сбоям в работе устройств с интерфейсом DisplayPort после возвращения системы из ждущего режима;
  • добавлен параметр конфигурации X-сервера «AllowNon3DVisionModes», позволяющий использовать режимы, не оптимизированные для применения с технологией Nvidia 3D Vision, на мониторах с поддержкой 3D Vision.

>>> Подробности

★★★★★

Проверено: mono ()

Модераторам:
Если будете подтверждать, то сделайте в виде мини-новости.

carasin ★★★★★
() автор топика
Ответ на: комментарий от vvff

негодные в последнее время были дрова для нвидии. Вот раньше лучше было.

УМВР. А о драйверах AMD и говорить нечего. Так что остается только nvidia.

bsdfun ★★★★★
()

закрыта уязвимость, позволявшая злоумышленнику получить доступ к произвольной области системной памяти посредством изменения конфигурации видеоадаптера

Ждем выкриков «решето» :3

no-steam ★★
()
Ответ на: комментарий от carasin

Попробую твой. RPM для openSUSE всё ещё версии 290.10. А уже 295.x выходят, две (может быть три) версии драйвера в репозитории не появились.

ZenitharChampion ★★★★★
()
Ответ на: комментарий от Novell-ch

в сортах проприетарного гуано не разбираемся.

Фанатик?

bsdfun ★★★★★
()
Ответ на: комментарий от no-steam

>> закрыта уязвимость, позволявшая злоумышленнику получить доступ к произвольной области системной памяти посредством изменения конфигурации видеоадаптера

Ждем выкриков «решето» :3

У NVIDIA уязвимости только такие и закрываются. Что-то вроде «исправлена ошибка, проявляющаяся при запуске двух OpenGL-приложений на конфигурации с тремя видеокартами, если при этом переключиться на терминал и обратно. Ошибка заключается в графическом артефакте на терминале». А у AMD закрываются серьёзные проблемы.

ZenitharChampion ★★★★★
()
Ответ на: комментарий от carasin

>> Попробую твой. RPM для openSUSE всё ещё версии 290.10. А уже 295.x выходят, две (может быть три) версии драйвера в репозитории не появились.

А Вы уверены, что «мои» пакеты подойдут к Сюсе? 0_o

Нет, но попробовать-то можно. Я отпишусь.

ZenitharChampion ★★★★★
()
Ответ на: комментарий от ZenitharChampion

А у AMD закрываются серьёзные проблемы.

То то на fglrx до сих пор гном-шелл глючит. А они (AMD) только поддержку новых карточек добавляют, да версии бампают.

bsdfun ★★★★★
()
Ответ на: комментарий от ZenitharChampion

Не надо!
Там сборка модулей ядра завязана на akmods, т.е. нужен подключённый репозиторий RPM-Fusion, чтобы установить эту тулзу. Также akmods должен генерить пакеты с модулями ядра после обновления этого самого ядра.
Плюс для сборки ещё куча зависимостей (инструкцию я писАл для использования в т.ч. YUM'а).
Не торопились бы Вы экспериментировать!

carasin ★★★★★
() автор топика
Ответ на: комментарий от dm1024

Говоря про параноиков, я имел в виду тех, кто считает, что всё, что не из репов, содержит трояны, руткиты и бекторы.

carasin ★★★★★
() автор топика
Ответ на: комментарий от Novell-ch

Я собирал из *.src.rpm'ов из RPM-Fusion'а, там своя специфика.

carasin ★★★★★
() автор топика
Ответ на: комментарий от ZenitharChampion

Хорошо, что дров наломать не успели ;D

carasin ★★★★★
() автор топика
Ответ на: комментарий от vova7890

Думаю, что нет. Наверное, и не будут никогда.

carasin ★★★★★
() автор топика
Ответ на: комментарий от vova7890

закрыта уязвимость, позволявшая злоумышленнику получить доступ к произвольной области системной памяти посредством изменения конфигурации видеоадаптера

>>> Ждем выкриков «решето» :3

У NVIDIA уязвимости только такие и закрываются. Что-то вроде «исправлена ошибка, проявляющаяся при запуске двух OpenGL-приложений на конфигурации с тремя видеокартами, если при этом переключиться на терминал и обратно. Ошибка заключается в графическом артефакте на терминале». А у AMD закрываются серьёзные проблемы.

ага, «исправленна дата компиляции и некоторые синтаксические ошибки в комментариях» :D

Откуда это? Не увидел в новости.

ZenitharChampion ★★★★★
()
Ответ на: комментарий от ZenitharChampion

Это я про амд написал. У них в ченжлоге никогда ничего информативного не бывает...

vova7890 ★★★
()
Ответ на: комментарий от goingUp

Нет, это потому что минорное обновление.

carasin ★★★★★
() автор топика
Ответ на: комментарий от Urchin

Последний нормальный драйвер был 285.13 вроде...

Посмотрел на свой 195.36, позывов к обновлению не почувствовал.

aidaho ★★★★★
()
Ответ на: комментарий от x3qt

Не понимаю ни тех, ни других. Юзаю швабодку на hd5670, играю в xonotic и не ругаюсь на постоянные разборки между двумя мониторами и sdl/gl приложениями.

no-steam ★★
()
Ответ на: комментарий от aidaho

нормальный драйвер

Посмотрел на свой 195.36

И на хлам в системном блоке тоже :D?

anonymous
()
Ответ на: комментарий от tazhate

Я больше о том, что там вкусного есть кроме того, что написано в новости? :)


типо 47 пиксель слева стал ярче ?

есть несколько простых истин :
* Changelog: исправили старые баги, добавили новые
* работает ? Не трогай !
...

anTaRes ★★★★
()
Ответ на: комментарий от tazhate

А больше ничего и нет, разве что поддержка новых карт.

Xe0N
()

Периодически падает kwin и KDE-приложения, в бэктрейсах gdb указания на проприетарные библиотеки nvidia. GTX 550 Ti.

anonymous
()
Ответ на: комментарий от anonymous

падает kwin и KDE-приложения

Не удивительно.

Jayrome ★★★★★
()
Ответ на: комментарий от x3qt

Юзаю fglrx дабы играться в морровинд под вайном, ГШ 3.4 и УМВР.

а карта-то какая?:) А то у меня прямо тот же набор, но в ГШ фпсы режутся в 3 раза при игре в Ив-Онлайн через вайн.

petrosha ★★★★★
()

Кто в курсе - в Дебиане есть? Комп далеко с ним, проверить не могу.

dv76 ★★★★
()
Ответ на: комментарий от Urchin

Это версия в debian squeeze. С этой модой на безудержное наращивание версий разрыв выглядит забавно.

aidaho ★★★★★
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.