LINUX.ORG.RU

5 вольт - не влезай убьёт!

 , ,


0

1

Долго использовал старый нетбук в качестве домашнего сервера, точки доступа. Но стал барахлить и блок питания и аккумулятор и usb. Попробовал сделать замену из легендарного роутера tp-link mr3020 и уложиться в 5 вольт для питания нового сервера, т.к. именно пятивольтовые зарядки доступны везде и найти замену в случае выхода из строя не составит проблем.

Но, как оказалось, главная проблема - это подбор блока питания и вообще организация электропитания. Ещё влияет длина провода, сечение, качество соединения и прочее. Испортил дюжину зарядок, которые могут тянуть роутер с флешкой плюс adsl модем (~1-2A + 1A). Даже самые дешёвые могут пару дней/недель тянуть оба устройства, но потом начинаются сбои, появляется запах у блока питания, и странные волны, уже явно недостаточных милиампер. Подскажите что в них нужно менять, чтобы вернуть в работу.

На серваке последняя версия Openwrt 14.09 с поддержкой из коробки ipv6, pppoe. Т.е без задействования флешки можно поднять сеть pppoe с поддержкой ipv6 (провайдер даёт подсеть глобальную). Ещё на сервере ftp, samba, mini_http, transmission, p910 (принт-сервер с лазерным принтером). На всех домашних устройствах глобальный ipv6, что с учётом повсеместно серых ipv4 большой плюс. У кого-то даже виден сайт на серваке http://poshat.dhis.org (ipv6).

Openwrt 14.09 более стабильна и заточена под ipv6. Сложности были с поиском в путаном wiki нужных опций для ipv6.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'wan'
	option ifname 'eth0'
	option proto 'pppoe'
	option username '***'
	option password '***'
	option ipv6 '1'
	option mtu '1452'
	option accept_ra '1'
	option send_rs '1'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config interface 'wlan'
	option proto 'static'
	option ipaddr '192.168.1.11'
	option netmask '255.255.255.0'
	option ip6assign '64'

Стоит всё это чудо приблизительно в центре квартиры на шкафу, для наилучшего WiFi сигнала повсюду. Если стану уверен, что всё работает стабильно, то конечно буду думать как ещё загрузить сервачок ( вебкамера, DLNA, rsync и прочее).

>>> Просмотр (768x1365, 410 Kb)

★★

Проверено: JB ()

У кого-то даже виден сайт на серваке http://poshat.dhis.org (ipv6).

У «кого-то» — это в твоей локалке? Резолвится оно в какой-то странный адрес [fdcd:3c0c:3114:a87d:76b4:cb58:66ff:fbf1].

Deleted ()
Ответ на: комментарий от Deleted

Привет.

Салют, коллега! Там USB впаян?

У «кого-то» — это в твоей локалке? Резолвится оно в какой-то странный адрес [fdcd:3c0c:3114:a87d:76b4:cb58:66ff:fbf1].

Ещё не всё отладил. Из dmesg мало информации. Сайт сначала виден по ipv6, но через определенное время перестает, приходится перезапускать сеть:

/etc/init.d/network restart
ping6 poshat.dhis.org
PING poshat.dhis.org(2a00:1370:8000:da9:2459:a207:8874:b53) 56 data bytes
64 bytes from 2a00:1370:8000:da9:2459:a207:8874:b53: icmp_seq=1 ttl=59 time=70.0 ms
64 bytes from 2a00:1370:8000:da9:2459:a207:8874:b53: icmp_seq=2 ttl=59 time=68.7 ms
64 bytes from 2a00:1370:8000:da9:2459:a207:8874:b53: icmp_seq=3 ttl=59 time=67.4 ms
64 bytes from 2a00:1370:8000:da9:2459:a207:8874:b53: icmp_seq=4 ttl=59 time=76.4 ms

В 23:30 по Москве точно сайт открывается))) В предыдущей версии Openwrt всё работало несколько иным образом, с подключением сторонних модулей (dhcpv6, radvd), теперь вроде проще, но примеров рабочих нет пока, приходится самому выяснять.

poshat ★★ ()
Последнее исправление: poshat (всего исправлений: 1)

Имхо transmission на таком железе бесполезен. Собирал как-то мини-нас на Seagate GoFlex Home, так на нем transmission больше 2-3 MB/s не давал, а там ARM v5 1.2Ghz и SATA против 400Mhz MIPS и USB на TP-Link'е. В чем профит от такой торентокачалки? Или просто сам факт поднятия all-in-one на такой железке был целью?

ava1ar ()
Последнее исправление: ava1ar (всего исправлений: 1)
Ответ на: комментарий от Frost

Имхо transmission на таком железе бесполезен.

Да, именно transmission потребляет больше всех ресурсов. Но со свапом и нормальным блоком питания можно пользоваться и им, т.к. намного удобнее других клиентов и не нужны костыли. К тому же качаю не так часто. Для transmission даже софтинка есть для смартфона.

В чем профит от такой торентокачалки? Или просто сам факт поднятия all-in-one на такой железке был целью?

Да, это именно попытка создать решение all-in-one, которое может валяться на шкафу, делать свое дело и потреблять как usb. По ощущениям качество работы меняется с таким решением, хотя вроде бы ничего не изменилось, только проблем добавилось)))

а какой провайдер и в каком районе?

МГТС на севере Москвы. На версии Openwrt 12.09 «Attitude Adjustment» у меня ipv6 постоянно работал, а в данный момент почему-то каждый час пропадает.
Были настройки в /etc/config/network:

	option 'defaultroute' '1'
	option 'peerdns' '1'

Теперь наоборот пришлось их убрать. Всякие туннели настраивать не хочется, ведь и траф через туннели пойдет.

poshat ★★ ()
Последнее исправление: poshat (всего исправлений: 1)
Ответ на: 14.09 ... от dumauz

это ты как скомпилил 14.09? Или может 12.09?

BARRIER BREAKER (14.07, r42625) сорри, опечатался. Компилить пока ничего не потребовалось даже, всё встало «из коробки».

poshat ★★ ()

Openwrt 14.09
14.09

Последняя же пока 14.07.
А я себе АА 12.09.1 только собрал позавчера.

легендарного tp-link mr3020

Широко известный в узком кругу?

Испортил дюжину зарядок

А мог бы просто взять старый AT блок питания

что в них нужно менять, чтобы вернуть в работу

открой и посмотри

sehellion ★★★★★ ()
Ответ на: комментарий от poshat

Салют, коллега! Там USB впаян?

Нет, но в теории можно распаять с платы. Учитывая отвратительные характеристики этой коробки, смысла нет никакого.

Deleted ()
Ответ на: комментарий от sehellion

А мог бы просто взять старый AT блок питания

Это уже как-то ближе к 220, чем к 5. Хотя тоже вариант.

Широко известный в узком кругу?

По количеству возможных переделок, доделок, замен этот роутер очень известный. Мне кажется ни над каким другим так не издевались.

открой и посмотри

Открыл, смотрю https://yadi.sk/i/15uR5sP1dzMSu , ничего не пойму, но запах подозрительный. Конденсаторы поменять? Это даст что-то в долгосрочной перспективе?

poshat ★★ ()

я бы не стал так экспериментировать с китайскими зарядниками тем более в шкафу. они при превышении силы тока могут загореться и начать небольшой пожар. у меня был похожий блок который начал дымится и плавиться, повезло что я был рядом и заметил неладное. на твоем месте я бы купил нормальный фирменный блок на x+2 ампер и не рисковал.

pftBest ★★★★ ()

Подскажите что в них нужно менять, чтобы вернуть в работу.

Вероятно, перегрелся (и потерял ёмкость) конденсатор. А перегрел его, скорее всего, диод. Там ставят диод Шоттки из серии SR320-SR3100 или подобный. Заменять конденсатор на аналогичный (105C, можно чуть большей ёмкости, если помещается), диод на лучший (если хотеть не просто вернуть в работу, а получить стабильную работу при большем токе) - выбрать экземпляр с минимальным падением напряжения при токе в несколько ампер (купить сразу много на eBay/AliExpress и проверять; например, у меня из 20-ти SR5100 разброс по Vf до двух раз, хотя все в допустимых пределах по datasheet'у), либо дорогой диод сразу с хорошим заявленным Vf (что-то вроде 400 mV при нескольких амперах - очень хорошо). Из недорогих, можно попробовать 1N5822 и SR540 - у моих таких разброс Vf меньше, все «хорошие». (Меньше 40V лучше не рисковать, т.к. flyback.) Кстати, т.к. через упомянутый диод идет большой ток только часть времени (часть полупериода, т.е. меньше половины), а нагрузка работает постоянно, Vf лучше мерять/смотреть (для выбора диода) при в 2+ раза большем токе, чем планируемый ток нагрузки БП. Подобрать по параметрам можно тут: http://uk.farnell.com/diodes-rectifier а потом их искать в продаже...

И/или сразу купить на том же eBay/AliExpress питальник на 5V/3A - они там есть - хотя я не поручусь за их длительную работу при максимальном токе.

И да, 5V было не лучшим выбором.

solardiz ()
Ответ на: комментарий от sehellion

судя по фото его сразу в мусорку нужно, он не только может загореться но еще и людей поубивать током.
Кто знает английский, вот познавательное видео как отличить нормальный блок от параши: youtube

pftBest ★★★★ ()
Ответ на: комментарий от sehellion

Q2 - линейный стабилизатор?

Почти наверняка нет. Там есть 817, это опторазвязка - значит, идет обратная связь на высоковольтную часть схемы. Так что это импульсный БП. Скорее всего, перегрелся низковольтный конденсатор (тот, что на одной плате с диодом), или оба. Т.к. повреждений так сразу не видно, надо бы проверить их ёмкость тестером.

solardiz ()
Ответ на: комментарий от solardiz

Я думаю, что ведро все же будет более хорошим вариантом для этого блока. А для питания поискать что-то посолиднее

sehellion ★★★★★ ()
Ответ на: комментарий от sehellion

Понимаю. Проблема качества и экономии на всём есть и здесь отчетливо видна. Но 5V БП посолиднее, скорее всего, окажется не в предназначенном для конечного пользователя корпусе (или вообще без). Или нет?

solardiz ()
Ответ на: комментарий от solardiz

Да, так и есть. Я выше предлагат взять AT бп от компьютера. Как мне кажется, не худший выбор и не страшно оставить 24/7. Да, придется немножко потратить времени, чтобы отчистить его, внимательно осмотреть, возможно, заменить конденсаторы, перепаять провода на нужные. Зато потом быть спокойным

sehellion ★★★★★ ()

Очень часто в китайблоках завышают максимальный ток, процентов на 30-50. Советую купить 2А-3А БП. Провода тоже важно найти нормальные - большинство не соответствуют стандартам сечения(для USB 2.0) проводов по силовой линии. Мне приходилось покупать отдельно полноценный USB 2.0 кабель(и в нём толщина проводов питания вдвое толще даталиний) и паять самому.

miXel ()
Ответ на: комментарий от solardiz

Ещё высыхает мелкий конденсатор в питании микросхемы-задающего тактового генератора. Они обычно по 10-47 микрофарад и 50 вольт.

miXel ()

О, у меня такой же роутер. Хочу хаб купить и флешечку, поставить OpenWRT. Проблема в том, что стандартная прошивка не тянет мой usb-модем, надеюсь в OpenWRT удастся его запустить.

Deleted ()

проблемы блока питания решаются с помощью китайцев:

http://www.aliexpress.com/item/Voltage-Transformer-5A-25W-AC-100V-240V-to-DC-...

http://www.aliexpress.com/item/35W-5V-Ultra-thin-Single-Output-Switching-powe...

http://www.aliexpress.com/item/High-quality-1PCS-DC-5V-10A-LED-Power-Supply-F...

от себя могу сказать, что ни в одном из множества разобраных и отремонтированых зарядников, нормальной схемы и компонентов не было. лучше были фирменные самсунги и что-то от эппла. блоки питания по типу тех, на которые я дал ссылки, обычно и собраны качественнее и не горят как свечки. бери с запасом по току - возможно чуть позже захочешь присосать винчестер к данной конструкции. поэтому начинать нужно с цивилизованно выглядящего корпуса, куда всё аккуратно сложится, блока питания с запасом - это не проблема. и даже не сильно дорого. ну и аккуратного крепления всех компонентов внутри корпуса. именно крепления, а не сваливания в кучу и приклеивания жвачкой друг на друга. толщина проводов обычно не влияет так круто, как ты рассказал. возьми парный провод аналогичный тому, который идёт к настольной лампе и его хватит за глаза.

hawai ()
Ответ на: комментарий от sehellion

Да, так и есть. Я выше предлагат взять AT бп от компьютера. Как мне кажется, не худший выбор и не страшно оставить 24/7. Да, придется немножко потратить времени, чтобы отчистить его, внимательно осмотреть, возможно, заменить конденсаторы, перепаять провода на нужные. Зато потом быть спокойным

он большой и требует работающего вентилятора. плюс посмотрите где-то вроде на ixbt - они в своё время тестировали ATX блоки питания и объясняли рабочие параметры. вроде эти блоки питания имеют минимальную рабочую мощность. во всяком случае для меня, в старом ATX блоке питания, из плюсов только то, что он может валяться дома, потому будет бесплатно. 24/7 - под вопросом: если блок питания старый, или непонятного происхождения, там всем конденсаторам уже давно могли присниться пони и радуга. вероятность взрыва или горения уже не будет такой маленькой. хотя учитывая, что данная нагрузка для этого блока питания будет несущественной, можно быть оптимистом.

hawai ()
Ответ на: комментарий от poshat
pinkbyte@oas1 ~ $ nslookup -type=aaaa poshat.dhis.org | head -5
Server:         127.0.0.1
Address:        127.0.0.1#53

Non-authoritative answer:
poshat.dhis.org has AAAA address fd11:8bd8:7681:c43b:b2b3:673:fcbd:84f5

http://en.wikipedia.org/wiki/Unique_local_address:

In October 2005, RFC 4193 was published, reserving the address block fc00::/7 for use in private IPv6 networks and defining the associated term unique local addresses.

Если пользуешься динамическим DNS - кури почему он шлет link-local адрес вместо глобального

Pinkbyte ★★★★★ ()
Последнее исправление: Pinkbyte (всего исправлений: 1)

А белая коробочка с зелеными лампочками - это что? очень похожа на интернет-зонд, который у меня есть :)

bvn13 ★★★★★ ()
Ответ на: комментарий от AVL2

Яблодрочер детектед.

а вот и не угадал, я андроид разработчик и яблоки не люблю. но это не отменяет того что то видео полезно посмотреть с технической точки зрения.

pftBest ★★★★ ()
Ответ на: комментарий от hawai

проблемы блока питания решаются с помощью китайцев:

Посмотрел. Вижу часто в продаже такие блоки для светодиодных лент. Думаю, вполне логично было бы для подключения нескольких устройств на 5 вольт брать такие блоки. А последний на 10А для чего? Мне казалось, что больше 4 А - это уже перебор. Это чем-то чревато для устройств?

poshat ★★ ()
Ответ на: комментарий от bvn13

А белая коробочка с зелеными лампочками - это что? очень похожа на интернет-зонд, который у меня есть :)

Это и есть мини-роутер tp-link mr-3020 http://wiki.openwrt.org/ru/toh/tp-link/tl-mr3020. Есть ещё аналог TL-WR703N. Рядом, adsl модем D-LINK DSL-2500U, наверное единственный ADSL2+ модем с ethernet портом и питанием 5 вольт (1A).

poshat ★★ ()

столько гемора, пользую mini-itx и проблем не знаю кроме счета за электричество.

prizident ★★★★★ ()
Ответ на: комментарий от miXel

Мне приходилось покупать отдельно полноценный USB 2.0 кабель(и в нём толщина проводов питания вдвое толще даталиний) и паять самому.

Знакомо, сам долго не мог понять в чем дело, когда устройство с одним кабелем даже не включается, а с другим работает нормально.
Взял пока на авито такой https://yadi.sk/i/Rmg53MMOe3Xtd . Много новых продают без штекера, т.к. сами устройства от него используют в авто. Вроде тянет хорошо, но нужно ещё тестировать. Но, наверное, в будущем лучше что-то типа этого http://www.aliexpress.com/item/Voltage-Transformer-5A-25W-AC-100V-240V-to-DC-... использовать. К нему можно и ещё что-то подключить пятивольтовое.

poshat ★★ ()
Ответ на: комментарий от solardiz

Вероятно, перегрелся (и потерял ёмкость) конденсатор.

В электрике не силен, учюсь. Попробовал в одном блоке перепаять кондер самый большой (400v, 10mF) https://yadi.sk/i/cBAGyl-5e3Y7P , благо видео на эту тему много. Но всё равно свистит трелью (предохранитель уже потом сгорел, подключал без него). Буду разбираться.

poshat ★★ ()
Ответ на: комментарий от Pinkbyte

Если пользуешься динамическим DNS - кури почему он шлет link-local адрес вместо глобального

Уже устал разбираться. Сначала всё работает, но через 40-60 минут траф по ipv6 перестает ходить, приходится сеть перезапускать. Включил подробное логирование, но кроме

 32.910000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   33.960000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   58.830000] eth0: link up (100Mbps/Full duplex)
[   58.830000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   68.830000] eth0: link down
[   70.830000] eth0: link up (100Mbps/Full duplex)
[   74.380000] eth0: link down
[   74.380000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   74.830000] eth0: link up (100Mbps/Full duplex)
[   74.830000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   89.680000] eth0: link down
[   89.690000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   89.830000] eth0: link up (100Mbps/Full duplex)
[   89.830000] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

Ничего подозрительного не видно. Может проблема и не в настройках вовсе, сначала-то работает всё.

poshat ★★ ()
Ответ на: комментарий от poshat

Посмотрел. Вижу часто в продаже такие блоки для светодиодных лент. Думаю, вполне логично было бы для подключения нескольких устройств на 5 вольт брать такие блоки. А последний на 10А для чего? Мне казалось, что больше 4 А - это уже перебор. Это чем-то чревато для устройств?

чем больше мощность блока питания, тем более надёжные компоненты и более вменяемая схема. например в видео выложеном выше по треду, мужик кроет матом блок питания в котором вместо диодных мостов используются однополупериодные выпрямители на диодах. опять же легко выгорающий резистор на входе вместо термистора. такие уловки прокатывают при малых токах. когда мощность больше, так баловаться уже не получается. я не знаю реальных нагрузок в твоём случае, но у меня всегда хочется ещё-чуть чуть. ссылку на 10А давал, т.к. он в законченом ИЗОЛИРОВАННОМ корпусе. т.е. его можно сложить в ведро с остальным хламом и не бояться КЗ. два остальных - только для встраивания в какой корпус с принятием мер по предотвращению катастроф. трансформатор для светодиодов бывает со стабилизацией не напряжения (что нужно в данном случае), а тока (что не фатально, если готов перепаивать начинку). в случае моей ссылки, дядя ляо указал «100V-240V to DC 5V» и чуть ниже опять «Output voltage: DC 5V» что и даёт основание расчитывать на стабилизацию напряжения. два остальных блока - просто стабилизаторы на 5В и засады я там не жду.

если блок питания выдаёт ток больше, чем может потребить устройство, устройству не будет от этого никакого вреда. а блоку питания жизнь будет легче: запас по режимам работы у современных схем практически 0%. т.е. если блок питания должен отдать в нагрузку 5А, то диоды и стабилизаторы поставят на 5А, или чуть больше. любое отлонение параметров (а у многих компонентов +/- 10% величины - допустимая погрешность), может привести к тому, что на максимальной мощности данное устройство сгорит. но если забирать вместо 5А только 4А, то ты самостоятельно обеспечишь себе 20% запаса прочности.

hawai ()
Ответ на: комментарий от hawai

чем больше мощность блока питания, тем более надёжные компоненты

Сразу вспомнил зарядник для автомобильного аккумулятора, который гудит на всю квартиру.

tlx ★★★★★ ()
Ответ на: комментарий от tlx

Сразу вспомнил зарядник для автомобильного аккумулятора, который гудит на всю квартиру.

образец логики? =). моя мысль проста: рассчитывая на 100 ватт мощности, в схему придётся ставить компоненты, которые работают в таком режиме. использовать соответствующие схемные решения и архитектуру. а зарядники на пол-ватта, восточные друзья собирают из соплей и рисовой бумаги.

hawai ()
Ответ на: комментарий от tlx

Гудит он из-за того что херовый трансформатор на 50 Гц - либо плохо стянуты пластины, либо обмотка жужжит. С импульсными такого быть не может - там частоты начиная от 10 кГц.

miXel ()
Ответ на: комментарий от Pinkbyte

При чем здесь логи работы интерфейса? Кто ставит DNS-запись у тебя?

Запись ставится сама по крону каждые пять минут:

curl -6 "http://id:pass@is.dhis.org/"
OK poshat.dhis.org 2a00:1370:8000:1fc:4bf:de31:f6c1:6535 00007961CB246BAABB070B46B3A1DB529A5B64B4DB627519195B604DE890D09F

Но через некоторое время запрос перестает работать, что-то перестает роутиться

curl -6 "http://id:pass@is.dhis.org/"
curl: (7) Error
poshat ★★ ()
Последнее исправление: poshat (всего исправлений: 1)
Ответ на: комментарий от miXel

Гудит он из-за того что херовый трансформатор на 50 Гц - либо плохо стянуты пластины, либо обмотка жужжит. С импульсными такого быть не может - там частоты начиная от 10 кГц.

зато гудеть исправно он будет ещё лет 50 без проблем ))). частоты импульсников должны начинаться от 20 ... 25 КГц. 10 КГц - слышно без проблем, а даже самые дешёвые низкочастотные мощные биполярные транзисторы расчитаны на работу до 50 КГц. а дальше - чем выше частота, тем дешевле устройство. большей частью за счёт снижения стоимости трансформатора. стандарт современных импульсников: 100 - 150 КГц. Хотя те же TI делают интегральные преобразователи до 2.2 МГц.

hawai ()
Ответ на: комментарий от miXel

С импульсными такого быть не может

В этом плане радует инверторная сварка весом пару килограмм. Раньше трансформатор вдвоём таскали.

tlx ★★★★★ ()
Ответ на: комментарий от poshat

Но через некоторое время запрос перестает работать, что-то перестает роутиться

Какой DHCP-клиент используется у тебя для получения IPv6-адреса?

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Pinkbyte

Какой DHCP-клиент используется у тебя для получения IPv6-адреса?

odhcp6c за получение ipv6 отвечает. По всей видимости у провайдера есть какие-то спец. настройки для ipv6 (по ipv6 вообще не консультируют), при которых ipv6 сбрасывается каждые ~40 минут или требуют активности. Модем в режиме моста работает, т.е. при его перезагрузке соединение само даже не восстанавливается, возможно это как-то влияет. Нашел тему похожую, попробую там ещё спросить. Спасибо!

poshat ★★ ()
Последнее исправление: poshat (всего исправлений: 1)
Ответ на: комментарий от Pinkbyte


Кажется просто пропадает маршрут по-умолчанию для ipv6, помогает его обновление.

 
route -A inet6 add default dev IFACE

Видимо надо дальше курить мануалы про ipv6 (настройки SLAAC и прочее).

poshat ★★ ()
Ответ на: комментарий от hawai

Да, без сомнения - 50Гц трансформаторы - сама надёжность, стоит его в лаке пропитать и ещё гудеть не будет.

Однако большинство китайцев делают на 20-40кГц. Насчёт повышения частоты - палка о двух концах, сечение сердечника нужно меньшее, но его качество должно быть выше, следовательно он дороже. Хотя на меди же тоже можно выйграть? Витков на вольт меньше становится?

miXel ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.