LINUX.ORG.RU

BusyBox v1.19.4 OpenWrt

 ,


0

1

config interface 'lan0'
        option ifname 'lan0'
        option proto 'none'
        option macaddr 'ac:9a:96:00:01:00'

config interface 'lan1'
        option ifname 'lan1'
        option proto 'none'
        option macaddr 'ac:9a:96:00:00:00'

config interface 'lct'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option proto 'static'
        option ifname 'lan1'
        option gateway '192.168.1.1'

config interface 'wan'
        option ifname 'wan'
        option proto 'static'
        option ipaddr '0.0.0.0'
        option netmask '255.255.255.0'
        option macaddr 'ac:9a:96:00:02:00'

root@SFP:~# uci set network.wan.macaddr="a8:f9:4b:1c:xx:xx"
root@SFP:~# uci commit network
uci: I/O error
root@SFP:~#```

подскажите , как переписать правильно mac адрес?

Ответ на: комментарий от krasnh

root@SFP:~# /etc/config/network
        batch
        export     [<config>]
        import     [<config>]
        changes    [<config>]
        commit     [<config>]
        add        <config> <section-type>
        add_list   <config>.<section>.<option>=<string>
        del_list   <config>.<section>.<option>=<string>
        show       [<config>[.<section>[.<option>]]]
        get        <config>.<section>[.<option>]
        set        <config>.<section>[.<option>]=<value>
        delete     <config>[.<section>[[.<option>][=<id>]]]
        rename     <config>.<section>[.<option>]=<name>
        revert     <config>[.<section>[.<option>]]
        reorder    <config>.<section>=<position>

root@SFP:~# /etc/config/network
/etc/config/network: line 2: config: Permission denied
/etc/config/network: line 3: option: not found
/etc/config/network: line 4: option: not found
/etc/config/network: line 5: option: not found
/etc/config/network: line 7: config: Permission denied
/etc/config/network: line 8: option: not found
/etc/config/network: line 9: option: not found
/etc/config/network: line 10: option: not found
/etc/config/network: line 12: config: Permission denied
/etc/config/network: line 13: option: not found
/etc/config/network: line 14: option: not found
/etc/config/network: line 15: option: not found
/etc/config/network: line 16: option: not found
/etc/config/network: line 17: option: not found
/etc/config/network: line 19: config: Permission denied
/etc/config/network: line 20: option: not found
/etc/config/network: line 21: option: not found
/etc/config/network: line 22: option: not found
/etc/config/network: line 23: option: not found
/etc/config/network: line 24: option: not found```

Strell
() автор топика
Ответ на: комментарий от Strell

root@OpenWrt:~# cd /etc/config/
root@OpenWrt:/etc/config# ls
dhcp dropbear firewall  network  system  ubootenv  wireless


Далее вводишь vi network и правишь.
Только сначала прочитай vim для самых маленьких . Это не совсем простой редактор, часто юзера из него выйти не могут. :)

krasnh ★★★
()
Ответ на: комментарий от Strell

проблема в том , что точно не известно где менять. стик от элтекс, но прошивка у него от ZISA.OP151S https://disk.yandex.ru/i/wp22xGV5YbaJOQ в тоже время он же есть под другими марками Halny HL-GSFP D-LINK DPN-100-Rev-A2 T&W TW2362H-CDEL

Strell
() автор топика
Ответ на: комментарий от Strell

Кирпич ты всяко не получишь - при неправильных настройках и незагрузке, делается или «жесткий резет» и все сбрасывается, как было, или более мягкие способы точечного исправления.

Отказоустойчивый режим, сброс к заводским настройкам и режим восстановления

krasnh ★★★
()
Последнее исправление: krasnh (всего исправлений: 1)
Ответ на: комментарий от krasnh

там похоже защита от таких как я стоит. надо отредактировать ifconfig , когда пишу vim или vi ifconfig то просто идет в столбик ~. vim ifconfig wan hw ether A8:F9:4B:1C:65:30 хотел так, но не могу сохранить командой . опять появляется ~

Strell
() автор топика
Ответ на: комментарий от Strell

ifconfig это команда, не надо ее пытаться править.

Скажи, чем тебе mac адрес не угодил, что ты его хочешь менять? Есть хорошая присказка, «работает - не трожь».

krasnh ★★★
()
Последнее исправление: krasnh (всего исправлений: 3)
Ответ на: комментарий от mky
rootfs / rootfs rw 0 0
/dev/root / squashfs ro,noatime 0 0
proc /proc proc rw,noatime 0 0
sysfs /sys sysfs rw,noatime 0 0
tmpfs /tmp tmpfs rw,nosuid,nodev,noatime 0 0
tmpfs /dev tmpfs rw,noatime,size=512k,mode=755 0 0
devpts /dev/pts devpts rw,noatime,mode=600 0 0
/dev/root /mnt squashfs ro,relatime 0 0
/dev/root /mnt squashfs ro,relatime 0 0
root /tmp/root tmpfs rw,noatime,mode=755 0 0
/dev/root /mnt squashfs ro,relatime 0 0
root /mnt tmpfs rw,noatime,mode=755 0 0
/dev/mtdblock4 /tmp/config jffs2 rw,relatime 0 0
debugfs /sys/kernel/debug debugfs rw,relatime 0 0
root@SFP:/#```
я еще не знаю где он, ищу)
Strell
() автор топика
Ответ на: комментарий от Strell

/etc — это каталог или ссылка? /etc/config/ — это каталог или ссылка? Если и то и другое каталоги, что они получаются на / (/dev/root), которая squashfs, которая ro по определению.

Ну можно попробовать ″df /etc/config/network″, там должно вывести на каком устройстве ФС с этим файлом.

То есть squashfs нужно распаковать, изменить файлы, запаковать обратно. Но, неведомо куда её нужно сложить на вашем устройстве, и нет ли там какой защиты, например проверки контрольной суммы.

mky ★★★★★
()
Ответ на: комментарий от mky

То есть squashfs нужно распаковать

Это что, рубрика вредных советов? :)

На OpenWrt прошивках, принцип LiveCD с возможностью записи - система упакована в squashfs с ro. А изменения rw пишутся на постоянную флеш-память слоем выше (наверно спецы придерутся к такой вольной интерпретации).

Для примера, на моем стареньком роуте (правда у меня прошивка посвежей, чем у ТС):

root@OpenWrt:~# cat /proc/mounts
/dev/root /rom squashfs ro,relatime 0 0
proc /proc proc rw,nosuid,nodev,noexec,noatime 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,noatime 0 0
tmpfs /tmp tmpfs rw,nosuid,nodev,noatime 0 0
/dev/mtdblock4 /overlay jffs2 rw,noatime 0 0
overlayfs:/overlay / overlay rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work 0 0
tmpfs /dev tmpfs rw,nosuid,relatime,size=512k,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,mode=600,ptmxmode=000 0 0
debugfs /sys/kernel/debug debugfs rw,noatime 0 0

krasnh ★★★
()
Последнее исправление: krasnh (всего исправлений: 3)

/mnt

Учитывая странные точки монтирования у ТС (сравниваю со своими), и коммент выше:

У тебя походу rootfs в r/o.

Может действительно включен какой-то режим, что не дает записывать. ‘Шаловливые умелые’ ) ручки ТС потыкали, где надо и не надо. Имхо.

krasnh ★★★
()
Ответ на: комментарий от krasnh

я права доступа не менял. и не переписывал ничего) ибо прошивок от этой фирмы не достать. есть только китайческие.(хотя и это тоже китаец) мне всего надо переписать 6 символов. я нашел человека который менял мак в директории manufactory , но он это делал в 2018 году и не помнит как.

Strell
() автор топика
Ответ на: комментарий от Strell

Давай сначала.

У тебя в шапке поста выложен конфиг, это результат команды vi /etc/config/network? Если да, то что происходит когда ты его правишь?
То что ты написал здесь BusyBox v1.19.4 OpenWrt (комментарий), я не понял причем тут ifconfig, его никто не просил править.

И да, когда выкладываешь результат команды, делай так, чтобы и сама команда попадала в него. Чтобы вопросов, подобных моему, не возникало.

krasnh ★★★
()
Последнее исправление: krasnh (всего исправлений: 1)
Ответ на: комментарий от krasnh
config interface 'lan0'
        option ifname 'lan0'
        option proto 'none'
        option macaddr 'ac:9a:96:00:01:00'

config interface 'lan1'
        option ifname 'lan1'
        option proto 'none'
        option macaddr 'ac:9a:96:00:00:00'

config interface 'lct'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option proto 'static'
        option ifname 'lan1'
        option gateway '192.168.1.1'

config interface 'wan'
        option ifname 'wan'
        option proto 'static'
        option ipaddr '0.0.0.0'
        option netmask '255.255.255.0'
        option macaddr 'ac:9a:96:00:02:00'


~
- /etc/config/network [Readonly] 1/25 4%```

этот вроде правится. но тут нету того мак адреса который надо поменять, или он тут просто по другому пишется, а в ifconfig я вижу именно тот который надо поменять.
https://disk.yandex.ru/i/luW-8LKVABateA
wan4094 на нем висит.

Strell
() автор топика
Ответ на: комментарий от krasnh

на постоянную флеш-память слоем выше

Что там придираться? Разве что «постоянная флеш-память» вызывает смех. Так, у вас есть overlayfs, а ТС его нет. Я вобще пытался понять, что у ТС в /etc/config, но это никому не интерестно.

рубрика вредных советов

Не вреднее, чем совет запустить vi неведомо на что. Просто так ТС бы не смог ни распаковать, ни запаковать squashfs, тем более я сразу предупредил, что это скорее всего не получится.

Пока вобще не понятно, зачем ТС править конфиг, если:

что роутер привязан у оператора по маку.

то почему нельзя просто на ходу командой ip/ifconfig поменять MAC и проверить, есть ли привязка или нет.

mky ★★★★★
()
Ответ на: комментарий от mky

root@SFP:/etc/config# ls dropbear gpon network omci sfp_pins ucitrack goi_config luci ntpclient sfp_eeprom system root@SFP:/etc/config# root@SFP:~# df /etc/config/network Filesystem 1K-blocks Used Available Use% Mounted on rootfs 2304 2304 0 100% / root@SFP:~# командой ip/ifconfig поменять MAC нельзя.

Strell
() автор топика
Ответ на: комментарий от Strell

Для того, чтобы понять, каталог или ссылка, нужно смотреть ″ls -l -d″. То есть, если в командах ″ls -l -d /etc″ и ″ls -l -d /etc/config″ будет выводится просто имя каталога, без стрелочки (->), значит /etc/config/network лежит на squashfs и не редактируется.

/etc/config/network [Readonly] 1/25 4%```

этот вроде правится

Прикалываетесь? Readonly для кого написано?

Вобще, у вас вывод ifconfig вобще не соответствует /etc/config/network, там, например, для ″lan0″ написано ″proto 'none'″, что означает совсем не поднимать этот интерфейс, а в выводе ifconfig он поднят и на него назначен ip-адрес. Значит файл /etc/config/networt левый и не используется при конфигурации интерфейсов. Вам же никто не обещал, что openwrt в железяке ванильный, запросто какие-нибудь скрипты поправлены.

командой ip/ifconfig поменять MAC нельзя

Что ip, что netifd, который читает /etc/config/network, используют одинаковые запросы к ядру, если ip не может поменять MAC-адрес, значит и netifd не сможет его поменять. Не все устройства позволяют менять mac, или не для всех устройств драйвер в ядре позволяет менять mac...

mky ★★★★★
()
Ответ на: комментарий от mky

https://disk.yandex.ru/i/qSEN-BWcIHQzpg три разных варианта посмотреть ip устройства. 2 и 3 верные ip, который надо поменять, первый вариант неизвестно откуда.

https://disk.yandex.ru/i/iZco9GWBtsu0NA ″ls -l -d /etc″ и ″ls -l -d /etc/config″

Strell
() автор топика