LINUX.ORG.RU

OpenWRT не выдает глобальный IPv6

 , , ,


0

1

Всем привет!

Мой провайдер стал выдавать IPv6 с префиксом /64, но роутер, на котором крутится OpenWRT 17.01.6, выдает устройствам только link-local IPv6, а хочется глобальный. Решения в Интернете не нашел. Может кто знает, как настроить правильно DHCPv6?

# cat /etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde0:f49e:ffe1::/48'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '64'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option reqaddress 'force'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'

Провайдер какой? У него самого инструкция есть? В логах шевеление dhcpv6 видно?

На моём всё сразу через luci заработало на прошлых openwrt. Только надо было запросить у провайдера включение ipv6 с их стороны.

Кстати, посмотрел. Через wan6 прошло 85% от общего трафика.

boowai ★★★★ ()
Ответ на: комментарий от ukr_unix_user

если коротко, /64 не годится для раздачи.

Если плюнуть на RFC, и правила приличия в целом, то годится. Правда не уверен, что openwrt так просто позволит с собой такое сделать.

Khnazile ★★★★★ ()

А у провайдера работает prefix delegation? Ты запрашиваешь и получаешь делегированный префикс? На wan6 назначается глобальный адрес?

ivlad ★★★★★ ()
Последнее исправление: ivlad (всего исправлений: 1 )
Ответ на: комментарий от mizuchi

То есть, нет делегированного префикса или он не назначается на внутреннем интерфейсе. Проверь, запрашивает ли твой роутер PD и получает ли его. Можно, например поснифать dhcpv6 пакеты. Или логи посмотри.

ivlad ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.